Создание базы данных в Access

Создание базы данных в Access

В этой статье описана обычная процедура запуска приложения Access и создания базы данных, которая будет использоваться на настольном компьютере, но не в Интернете. В статье рассказано о том, как создать базу данных для настольных компьютеров на основе шаблона или с нуля с собственными таблицами, формами, отчетами и другими объектами базы данных. Кроме того, в статье рассмотрены способы импорта имеющихся данных в новую базу данных.

В этой статье

Общие сведения

Создание базы данных на основе шаблона

Создание базы данных без использования шаблона

Копирование данных из другого источника в таблицу Access

Импорт, добавление или связывание данных из другого источника

Добавление части приложения

Открытие существующей базы данных Access

Общие сведения

При первом запуске приложения Access, а также при закрытии базы данных без завершения работы Access отображается представление Microsoft Office Backstage.

Представление Backstage является отправным пунктом для создания новых и открытия существующих баз данных, просмотра релевантных статей на сайте Office.com и т. д., то есть для выполнения любых операций с файлом базы данных или вне базы данных, но не внутри ее.

Создание базы данных

При открытии приложения Access в представлении Backstage отображается вкладка Создание. На вкладке Создание доступны команды создания базы данных.

  • Новая база данных.    Создать базу данных можно с нуля. Это хороший вариант, если к структуре базы данных предъявляются очень специфичные требования или имеются данные, которые необходимо поместить или встроить в базу данных.

  • Шаблон, устанавливаемый вместе с Access.    Шаблон можно использовать, если нужно быстро начать новый проект. В Access по умолчанию установлено несколько шаблонов.

  • Шаблон с сайта Office.com.    В дополнение к шаблонам, поставляемым с Access, много других шаблонов доступно на сайте Office.com. Для их использования даже не нужно открывать браузер, потому что эти шаблоны доступны на вкладке Создание.

Добавление к базе данных

При работе с базой данных в нее можно добавлять поля, таблицы и части приложений.

Части приложений — это элементы, позволяющие использовать несколько связанных объектов базы данных как один объект. Например, часть приложения может состоять из таблицы и формы, основанной на таблице. С помощью части приложения можно одновременно добавить в базу данных таблицу и форму.

Также можно создавать запросы, формы, отчеты, макросы — любые объекты базы данных, необходимые для работы.

Создание базы данных с помощью шаблона

Access поставляется с разнообразными шаблонами, которые можно использовать как есть или в качестве начальной точки. Шаблон — это готовая к использованию база данных, содержащая все таблицы, запросы, формы, макросы и отчеты, необходимые для выполнения определенной задачи. Например, имеются шаблоны, которые можно использовать для отслеживания вопросов, управления контактами или учета расходов. Некоторые шаблоны содержат несколько примеров записей, демонстрирующих их использование.

Если один из этих шаблонов точно соответствует потребностям, с его помощью обычно проще и быстрее всего создать необходимую базу данных. Однако если необходимо импортировать в Access данные из другой программы, возможно, будет проще создать базу данных без использования шаблона. Так как в шаблонах уже определена структура данных, на изменение существующих данных в соответствии с этой структурой может потребоваться много времени.

  1. Если база данных открыта, нажмите на вкладке Файл кнопку Закрыть. В представлении Backstage откроется вкладка Создание.

  2. На вкладке Создание доступно несколько наборов шаблонов; некоторые из них встроены в Access. Другие шаблоны можно загрузить с сайта Office.com. Дополнительные сведения см. в следующем разделе.

  3. Выберите шаблон, который необходимо использовать.

  4. В поле Имя файла будет предложено имя файла для базы данных — при необходимости его можно изменить. Чтобы сохранить базу данных в другой папке, нажмите кнопку Изображение кнопки , откройте папку, в которой необходимо сохранить базу данных, и нажмите кнопку ОК. При необходимости можно связать базу данных с сайтом SharePoint.

    Примечание : База данных для настольных компьютеров, связанная с сайтом SharePoint, не эквивалентна веб-базе данных, использующей службы Access, хотя обе они используют SharePoint. Чтобы можно было использовать базу данных для настольных компьютеров, необходимо приложение Access, а с веб-базой данных можно работать в браузере.

  5. Нажмите кнопку Создать.

    Access создаст базу данных на основе выбранного шаблона, а затем откроет ее. Для многих шаблонов при этом отображается форма, в которую можно начать вводить данные. Если шаблон содержит примеры данных, можно удалить каждую из этих записей, щелкнув область маркировки записи (затененное поле или полосу слева от записи) и выполнив действия, указанные ниже.

    На вкладке Главная в группе Записи нажмите кнопку Удалить  Изображение кнопки .

  6. Щелкните первую пустую ячейку в форме и начинайте ввод данных. Для перехода к другим нужным формам или отчетам используйте Область навигации. Некоторые шаблоны содержат форму навигации для перемещения между разными объектами базы данных.

Дополнительные сведения о работе с шаблонами см. в статье Создание базы данных Access на компьютере с помощью шаблона.

К началу страницы

Создание базы данных без использования шаблона

Если использовать шаблон не имеет смысла, можно создать базу данных с нуля. Для этого нужно создать таблицы, формы, отчеты и другие объекты базы данных. В большинстве случаев для этого необходимо выполнить одно или оба указанных ниже действия.

  • Ввод, вставка или импорт данных в таблицу, которая создана при создании новой базы данных, и последующее повторение этой процедуры для новых таблиц, которые создаются с помощью команды Таблица, расположенной на вкладке Создать.

  • Импорт данных из других источников и создание новых таблиц в этом процессе.

Создание пустой базы данных

  1. На вкладке Файл нажмите кнопку Создать и выберите пункт Новая база данных.

  2. В поле Имя файла введите имя файла. Чтобы сохранить файл в другой папке, отличной от используемой по умолчанию, нажмите кнопку Поиск расположения для размещения базы данных  Изображение кнопки (рядом с полем Имя файла), откройте нужную папку и нажмите кнопку ОК.

  3. Нажмите кнопку Создать.

    Приложение Access создаст базу данных с пустой таблицей "Таблица1" и откроет эту таблицу в режиме таблицы. Курсор будет помещен в первую пустую ячейку столбца Щелкните, чтобы добавить.

  4. Чтобы добавить данные, начните вводить их или вставьте данные из другого источника (см. раздел Копирование данных из другого источника в таблицу Microsoft Access).

Ввод данных в режиме таблицы очень похож на работу с листом Excel. Структура таблицы создается при вводе данных: при добавлении каждого нового столбца в таблицу определяется новое поле. Приложение Access автоматически определяет тип данных каждого поля на основе введенных данных.

Если на этом этапе вводить данные в таблицу "Таблица1" не нужно, нажмите кнопку Закрыть Изображение кнопки . Если таблица была изменена, будет предложено сохранить изменения. Нажмите кнопку Да, чтобы сохранить изменения, кнопку Нет, чтобы не сохранять их, или кнопку Отмена, чтобы оставить таблицу открытой.

Совет :  Access ищет файл с именем Blank.accdb в папке [диск установки]:\Program Files\Microsoft Office\Templates\1033\Access\. Если он существует, Blank.accdb используется как шаблон для всех новых пустых баз данных, за исключением веб-баз данных. Все новые базы данных наследуют содержимое этого файла. Это отличный способ распространения содержимого по умолчанию, например номеров компонентов или заявлений об отказе от ответственности и политик компании. Следует помнить, что файл Blank.accdb не влияет на создание новых пустых веб-баз данных.

Важно : Если хотя бы один раз закрыть таблицу "Таблица1" без сохранения, она будет удалена полностью, даже если в нее введены данные.

Добавление таблицы

Добавление таблиц к существующей базе данных осуществляется командами группы Таблицы на вкладке Создать.

Изображение ленты Access

Создание таблицы в режиме таблицы    В режиме таблицы можно начать ввод данных сразу, структура таблицы при этом будет создаваться автоматически. Полям присваиваются имена с последовательными номерами ("Поле1", "Поле2" и т. д.). Приложение Access автоматически задает тип данных для каждого поля в зависимости от вводимых данных.

  1. На вкладке Создание в группе Таблицы нажмите кнопку Таблица  Изображение кнопки .

    Приложение Access создаст таблицу и выделит первую пустую ячейку в столбце Щелкните, чтобы добавить.

  2. На вкладке Поля в группе Добавление и удаление выберите тип поля, которое требуется добавить. Если необходимый тип поля отсутствует, нажмите кнопку Другие поля Изображение кнопки .

  3. В Access откроется список часто используемых типов полей. Выберите необходимый тип поля, и приложение Access добавит в таблицу новое поле в позиции курсора.

    Поле можно переместить в другое место путем перетаскивания. При перетаскивании поля в таблице появляется вертикальная полоса вставки, указывающая место, где будет расположено поле.

  4. Чтобы добавить данные, начните вводить их в первую пустую ячейку или вставьте данные из другого источника (см. раздел Копирование данных из другого источника в таблицу Microsoft Access).

  5. Для переименования столбца (поля) дважды щелкните заголовок столбца и введите новое имя.

    Присвойте полям значимые имена, чтобы при просмотре области Список полей было понятно, что содержится в каждом поле.

  6. Чтобы переместить столбец, щелкните его заголовок для выделения столбца и перетащите столбец в нужное место. Можно выделить несколько смежных столбцов и перетащить их одновременно. Чтобы выделить несколько смежных столбцов, щелкните заголовок первого столбца, а затем, удерживая нажатой клавишу SHIFT, щелкните заголовок последнего столбца.

Создание таблицы в режиме конструктора    В режиме конструктора сначала следует создать структуру таблицы. Затем можно переключиться в режим таблицы для ввода данных или ввести данные, используя другой способ, например вставить данные из буфера обмена или импортировать их.

  1. На вкладке Создание в группе Таблицы нажмите кнопку Конструктор таблиц. Изображение кнопки

  2. Для каждого поля в таблице введите имя в столбце Имя поля, а затем в списке Тип данных выберите тип данных.

  3. При желании можно ввести описание для каждого поля в столбце Описание. Это описание будет отображаться в строке состояния, когда в режиме таблицы курсор будет находиться в данном поле. Это описание также отображается в строке состояния для любых элементов управления в форме или отчете, которые создаются путем перетаскивания этого поля из области списка полей, и любых элементов управления, которые создаются для этого поля при использовании мастера отчетов или мастера форм.

  4. Когда все необходимые поля будут добавлены, сохраните таблицу:

    • Нажмите на вкладке Файл кнопку Сохранить.

  5. Чтобы добавить данные, переключитесь в режим таблицы и начните их вводить, щелкнув первую пустую ячейку. Данные также можно вставить из другого источника (см. раздел Копирование данных из другого источника в таблицу Microsoft Access).

Задание свойств полей в режиме конструктора    Независимо от способа создания таблицы рекомендуется проверить и установить свойства поля. Хотя некоторые свойства доступны в режиме таблицы, другие свойства можно установить только в режиме конструктора. Чтобы перейти в режим конструктора, в области навигации щелкните таблицу правой кнопкой мыши и выберите пункт Конструктор. Чтобы отобразить свойства поля, щелкните поле в сетке конструктора. Свойства отображаются под сеткой конструктора в области Свойства поля.

Щелкните свойство поля для просмотра его описания в поле, расположенном рядом со списком свойств в области Свойства поля. Более подробные сведения можно получить, нажав кнопку "Справка".

В следующей таблице описаны некоторые наиболее часто изменяемые свойства полей.

Свойство

Описание

Размер поля

Для текстовых полей это свойство указывает максимально допустимое количество знаков, сохраняемых в этом поле. Максимальное значение — 255. Для числовых полей это свойство указывает тип сохраняемых чисел ("Длинное целое", "Двойное с плавающей точкой" и т. д.). Для более рационального хранения данных рекомендуется выделять для хранения данных наименьший необходимый размер памяти. Если потребуется, это значение позже можно изменить.

Формат

Это свойство определяет формат отображения данных. Оно не влияет на фактические данные, сохраняемые в этом поле. Можно выбрать встроенный формат или задать пользовательский формат.

Маска ввода

Это свойство используется для определения общего шаблона для ввода любых данных в это поле. Это позволяет обеспечить правильный ввод и нужное количество знаков для всех данных. Для получения справки по созданию маски ввода нажмите кнопку Кнопка "Построитель" справа от поля свойства.

Значение по умолчанию

Это свойство используется для задания значения по умолчанию, которое будет отображаться в этом поле при каждом добавлении новой записи. Например, для поля "Дата/время", в котором необходимо записывать дату добавления каждой записи, в качестве значения по умолчанию можно ввести "Date()" (без кавычек).

Обязательное поле

Это свойство указывает, обязательно ли вводить значение в это поле. Если для этого свойства задано значение Да, невозможно будет добавить новую запись, если в это поле не введено значение.

К началу страницы

Копирование данных из другого источника в таблицу Access

Если данные хранятся в другой программе, например Excel, их можно скопировать и вставить в таблицу Access. Как правило, этот метод работает лучше всего, если данные уже разделены на столбцы, как в таблице Excel. Если данные находятся в текстовом редакторе, перед копированием рекомендуется разделить столбцы данных с помощью табуляции или преобразовать данные в таблицу в текстовом редакторе. Если необходимо изменить данные или выполнить другие операции (например, разделить полное имя на имя и фамилию), рекомендуется сделать это перед копированием данных, особенно при отсутствии опыта работы с Access.

При вставке данных в пустую таблицу приложение Access задает тип данных для каждого поля в зависимости от того, какие данные находятся в этом поле. Например, если во вставляемом поле содержатся только значения даты, для этого поля используется тип данных "Дата/время". Если вставляемое поле содержит только слова "Да" и "Нет", для этого поля выбирается тип данных "Логический".

В приложении Access поля именуются в зависимости от данных, содержащейся в первой строке вставленных данных. Если в первой строке вставленных данных находятся данные такого же типа, как и в последующих строках, то в приложении Access эта строка используется как часть данных, а полям присваиваются общие имена (F1, F2 и т. д.). Если первая строка вставляемых данных отличается от следующих строк, ее содержимое используется только как имена полей и не включается в данные.

В приложении Access имена присваиваются полям автоматически, поэтому во избежание путаницы данные поля следует переименовать. Для этого выполните следующие действия.

  1. Нажмите клавиши CTRL+S, чтобы сохранить таблицу.

  2. В режиме таблицы дважды щелкните заголовок каждого столбца и введите описательное имя поля для каждого столбца.

  3. Еще раз сохраните таблицу.

Примечание : Кроме того, для изменения имен полей можно переключиться в режим конструктора и переименовать поля в этом режиме. Для переключения в режим конструктора щелкните правой кнопкой мыши таблицу в области навигации и выберите команду Конструктор. Чтобы вернуться в режим таблицы, дважды щелкните таблицу в области навигации.

К началу страницы

Импорт, добавление или связывание данных из другого источника

В Access можно импортировать данные из другой программы и поместить эти данные в новую таблицу или добавить в существующую. При совместной работе с пользователями, которые хранят данные в других программах, их данные тоже можно использовать в Access, установив связи. В обоих случаях работа с данными из других источников в Access не представляет сложности. Импортировать данные можно из листа Excel, таблицы в другой базе данных Access, списка SharePoint и других источников. Процесс импорта для разных источников немного различается, однако всегда начинается с приведенной ниже процедуры.

  1. В приложении Access на вкладке Внешние данные в группе Импорт и связи выберите команду для типа файла, который необходимо импортировать.

    Группа "Импорт и связывание" на вкладке "Внешние данные"

    Например, чтобы импортировать данные из таблицы Excel, нажмите кнопку Excel. Если нужного типа программы в группе нет, нажмите кнопку Дополнительно.

    Примечание : Если не удается найти нужный тип формата в группе Импорт и связи, может потребоваться запустить программу, в которой созданы эти данные, а затем сохранить в этой программе данные в файле общего формата (например, в текстовый файл с разделителями) перед импортом данных в Access.

  2. В диалоговом окне Внешние данные нажмите кнопку Обзор, чтобы найти файл данных источника, или введите в поле Имя файла полный путь к файлу данных источника.

  3. Выберите нужный параметр в разделе Укажите, когда и где сохранять данные в текущей базе данных (все программы позволяют импортировать данные, а некоторые поддерживают также добавление и связывание данных). Можно использовать импортируемые данные для создания новой таблицы или добавить их (в некоторых программах) в существующую таблицу. Также можно создать связанную таблицу, содержащую ссылку на данные в исходной программе.

  4. Если будет запущен мастер, следуйте инструкциям на экране. На последней странице нажмите кнопку Готово.

    При импорте объектов или связывании таблиц из базы данных Access открывается диалоговое окно Импорт объектов или Связь с таблицами. Выберите нужные элементы и нажмите кнопку ОК.

    Точная последовательность действий зависит от выбранного способа обработки данных: импорт, добавление или связывание.

  5. Появится предложение сохранить сведения о только что завершенной операции импорта. Если эту операцию импорта в будущем планируется выполнять снова, нажмите кнопку Сохранить шаги импорта и введите подробные сведения. Позже для повторения этой операции достаточно будет нажать кнопку Сохраненные операции импорта Изображение кнопки на вкладке Внешние данные в группе Импорт и связи. Если сохранять сведения об операции не нужно, нажмите кнопку Закрыть.

Если импортируется таблица, программа Access импортирует данные в новую таблицу и отображает эту таблицу в группе Таблицы в области навигации. Если выбрано добавление данных к существующей таблице, данные добавляются к этой таблице. Если выбрано связывание данных, в группе Таблицы в области навигации создается связанная таблица.

К началу страницы

Добавление части приложения

Части приложений можно использовать для расширения функциональности существующих баз данных. Часть приложения может быть просто отдельной таблицей, а может включать несколько связанных объектов, таких как таблицы и связанные формы.

Например, часть приложения "Примечания" состоит из таблицы с полем идентификатора, имеющим тип "Счетчик", поля даты и поля MEMO. Эту часть приложения можно добавить в базу данных и использовать как есть или с минимальными изменениями.

  1. Откройте базу данных, к которой необходимо добавить часть приложения.

  2. Откройте вкладку Создание.

  3. В группе Шаблоны нажмите кнопку Части приложения. Отобразится список доступных частей.

  4. Выберите часть приложения, которую необходимо добавить.

К началу страницы

Открытие существующей базы данных Access

  1. На вкладке Файл нажмите кнопку Открыть.

  2. В диалоговом окне Открытие файла базы данных найдите базу данных, которую нужно открыть.

  3. Выполните одно из следующих действий.

    • Чтобы открыть базу данных в режиме по умолчанию, дважды щелкните ее (режим по умолчанию может быть указан в диалоговом окне Параметры Access или установлен административной политикой).

    • Нажмите кнопку Открыть, чтобы открыть базу данных для общего доступа в многопользовательской среде и предоставить другим пользователям возможность выполнять чтение и запись в базу данных.

    • Нажмите кнопку со стрелкой рядом с кнопкой Открыть и выберите вариант Открыть для чтения, чтобы открыть базу данных только для чтения, т.е. для просмотра без возможности внесения изменений. При этом другие пользователи могут осуществлять чтение и запись в базу данных.

    • Нажмите кнопку со стрелкой рядом с кнопкой Открыть и выберите вариант Монопольный доступ, чтобы открыть базу данных в монопольном режиме. Если база данных открыта в монопольном режиме, при попытке ее открытия другим пользователем будет выведено сообщение "Файл уже используется".

    • Нажмите кнопку со стрелкой рядом с кнопкой Открыть и выберите вариант Монопольно для чтения, чтобы открыть базу данных только для чтения. Другие пользователи при этом могут открывать базу данных только для чтения.

Примечание : Можно открывать напрямую файлы данных внешних форматов, например dBASE, Microsoft Exchange или Excel. Кроме того, можно открывать напрямую любые источники данных ODBC, такие как Microsoft SQL Server. Приложение Access автоматически создает новую базу данных Access в одной папке с файлом данных и добавляет ссылки на все таблицы внешней базы данных.

Советы

  • Чтобы открыть одну из недавно использовавшихся баз данных, нажмите на вкладке Файл кнопку Последние и выберите имя файла базы данных. Приложение Access откроет базу данных, используя параметры, которые применялись при ее открытии в прошлый раз. Если список последних использовавшихся файлов не отображается, нажмите на вкладке Файл кнопку Параметры. В диалоговом окне Параметры Access нажмите кнопку Параметры клиента. В разделе Вывод на экран введите количество документов, которые необходимо отобразить в списке "Последние документы" (не больше 50).

    Также можно вывести список недавно использовавшихся баз данных в области навигации в представлении Backstage. Для этого потребуется два щелчка мышью: 1) откройте вкладку Файл; 2) выберите необходимую базу данных. В нижней части вкладки Последние установите флажок Быстрый доступ к недавно использовавшимся базам данных и укажите количество отображаемых баз данных.

  • При открытии базы данных с помощью команды Открыть на вкладке Файл можно просмотреть список ярлыков недавно открывавшихся баз данных, нажав в диалоговом окне Открыть кнопку Мои последние документы.

К началу страницы

В этой статье

Изучение страницы "Приступая к работе с Microsoft Office Access"

Создание базы данных на основе шаблона

Создание базы данных без использования шаблона

Копирование данных из другого источника в таблицу Access

Импорт, добавление или связывание данных из другого источника

Открытие существующей базы данных Access

Создание пустого пользовательского шаблона

Изучение страницы "Приступая к работе с Microsoft Office Access"

При первом запуске программы Access или закрытии базы данных без выхода из Access отображается окно Приступая к работе с Microsoft Office Access.

Страница "Приступая к работе с Microsoft Office Access"

Это отправной пункт, из которого можно создать новые базы данных, открыть существующую базу данных или ознакомиться с информацией на веб-узле Microsoft Office Online.

Создание базы данных с помощью шаблона

В приложении Access предусмотрены разнообразные шаблоны, с помощью которых можно быстро создать базу данных. Шаблон – это уже готовая к использованию база данных, включающая все необходимые таблицы, запросы, формы и отчеты для выполнения определенной задачи. Например, предусмотрены шаблоны, которые можно использовать для отслеживания вопросов, управления контактами или учета расходов. Некоторые шаблоны содержат несколько примеров записей, позволяющих продемонстрировать их использование. Шаблоны баз данных можно использовать без изменений или настроить в соответствии с конкретными потребностями.

Если один из этих шаблонов точно соответствует потребностям, с его помощью обычно проще и быстрее всего создать необходимую базу данных. Однако если необходимо импортировать в Access данные из другой программы, возможно, будет проще создать базу данных без использования шаблона. Так как в шаблонах уже определена структура данных, на изменение существующих данных в соответствии с этой структурой может потребоваться много времени.

  1. Если база данных открыта, нажмите кнопку Microsoft Office Изображение кнопки Office , а затем нажмите кнопку Закрыть базу данных Изображение кнопки , чтобы отобразить страницу Приступая к работе с Microsoft Office Access.

  2. В средней части страницы Приступая к работе с Microsoft Office Access отобразится несколько шаблонов. Щелкните ссылки в области Категории шаблонов, чтобы отобразить другие шаблоны. Кроме того, дополнительные шаблоны можно загрузить с веб-узла Office Online. Для получения дополнительных сведений см. далее этот раздел.

  3. Выберите шаблон, который необходимо использовать.

  4. В поле Имя файла будет предложено имя файла для базы данных — при необходимости его можно изменить. Чтобы сохранить базу данных в другой папке, нажмите кнопку Изображение кнопки , откройте папку, в которой необходимо сохранить базу данных, и нажмите кнопку ОК. При необходимости можно связать базу данных с сайтом SharePoint.

  5. Нажмите кнопку Создать (или Загрузить— для загрузки шаблона Office Online).

    Приложение Access создаст или загрузит, а затем откроет базу данных. Отображается форма, в которой можно начать ввод данных. Если шаблон содержит примеры данных, можно удалить каждую из записей, щелкнув область выделения записи (затененное поле или полосу слева от записи) и выполнив следующие действия.

    На вкладке Главная в группе Записи нажмите кнопку Удалить  Изображение кнопки .

  6. Щелкните первую пустую ячейку в форме и приступайте к вводу данных. Используйте область переходов для перехода к другим необходимым формам или отчетам.

Загрузка шаблона с узла Office Online

Если на странице Приступая к работе с приложением Microsoft Office Access, не удается найти нужный шаблон, то при наличия подключения к Интернету можно найти на веб-узле Office Online другие шаблоны.

  1. На странице Приступая к работе с Microsoft Office Access в разделе Дополнительно на веб-узле Office Online щелкните пункт Шаблоны.

    В окне обозревателя отобразится главная страница "Шаблоны" на веб-узле Microsoft Office Online.

  2. Используйте средства поиска и перехода Microsoft Office Online для поиска нужного шаблона приложения Access, а затем следуйте инструкциям для его загрузки. При загрузке шаблона файл базы данных загружается на компьютер, а затем открывается в новом окне приложения Access. В большинстве случаев шаблоны разрабатываются таким образом, чтобы сразу открывалась форма ввода данных и можно было немедленно приступить к их вводу.

Дополнительные сведения о работе с шаблонами см. в статье Руководство по шаблонам Access 2007.

К началу страницы

Создание базы данных без использования шаблона

Если использовать шаблон не имеет смысла, можно создать базу данных с нуля. Для этого нужно создать таблицы, формы, отчеты и другие объекты базы данных. В большинстве случаев необходимо выполнить одно или оба следующих действия:

  • Ввод, вставка или импорт данных в таблицу, которая создана при создании новой базы данных, и последующее повторение этой процедуры для новых таблиц, которые создаются с помощью команды Таблица, расположенной на вкладке Создать.

  • Импорт данных из других источников и создание новых таблиц в этом процессе.

Создание пустой базы данных
  1. На странице Приступая к работе с Microsoft Office Access в разделе Новая пустая база данных выберите команду Новая база данных.

    Кнопка "Новая база данных"

  2. В области Новая база данных в поле Имя файла введите имя файла. Если имя файла указано без расширения, расширение будет добавлено автоматически. Чтобы сохранить файл в другой папке, отличной от используемой по умолчанию, нажмите кнопку Открыть Изображение кнопки (рядом с полем Имя файла), перейдите к нужной папке и нажмите кнопку ОК.

  3. Нажмите кнопку Создать.

    Приложение Access создаст базу данных с пустой таблицей с именем "Таблица1" и откроет эту таблицу в режиме таблицы. Курсор находится в первой пустой ячейке столбца Добавить поле.

  4. Чтобы добавить данные, начните их вводить или вставьте данные из другого источника (описание см. в разделе Копирование данных из другого источника в таблицу Microsoft Access).

Ввод данных в режиме таблицы очень похож на работу в электронной таблице Microsoft Office Excel 2007. Структура таблицы создается при вводе данных — при каждом добавлении нового столбца в таблицу определяется новое поле. Приложение Access автоматически задает тип данных для каждого поля на основе введенных данных.

Если на этом этапе вводить данные в таблицу "Таблица1" не нужно, нажмите кнопку Закрыть Изображение кнопки . Если таблица была изменена, то появится запрос на сохранение изменений в таблице. Нажмите кнопку Да, чтобы сохранить изменения, кнопку Нет, чтобы отменить изменения, или кнопку Отменить, чтобы оставить таблицу открытой.

Важно : Если хотя бы один раз закрыть таблицу "Таблица1" без сохранения, она будет удалена полностью, даже если в нее введены данные.

Добавление таблицы

Добавление таблиц к существующей базе данных осуществляется командами группы Таблицы на вкладке Создать.

Изображение ленты Access

Создание таблицы в режиме таблицы    В режиме таблицы можно начать ввод данных сразу, структура таблицы при этом будет создаваться автоматически. Полям присваиваются имена с последовательными номерами ("Поле1", "Поле2" и т. д.). Приложение Access автоматически задает тип данных для каждого поля в зависимости от вводимых данных.

  1. На вкладке Создание в группе Таблицы нажмите кнопку Таблица  Изображение кнопки .

    Приложение Access создаст базу данных с пустой таблицей с именем "Таблица1" и откроет эту таблицу в режиме таблицы. При этом будет выделена первая пустая ячейка столбца Добавить поле.

    Примечание : Если столбец Добавить поле не отображается, возможно, вместо режима таблицы выбран режим конструктора. Чтобы переключиться в режим таблицы, в области переходов дважды щелкните таблицу. В приложении Access появится предложение сохранить новую таблицу, а затем произойдет переключение в режим таблицы.

  2. На вкладке Таблица в группе Поля и столбцы нажмите кнопку Создать поле  Изображение кнопки .

    В приложении Access будет отображена панель Шаблоны полей, которая содержит список наиболее часто используемых типов полей. При двойном щелчке или перетаскивании одного из этих полей на лист в приложении Access добавляется поле с этим именем, а его свойствам присваиваются значения, соответствующие выбранному типу поля. Эти свойства можно изменить позднее. Поле необходимо перетащить в область листа, содержащую данные: при этом появится вертикальная линия вставки, показывающая расположение поля.

  3. Чтобы добавить данные, начните их вводить в первую пустую ячейку или вставьте данные из другого источника (описание см. в разделе Копирование данных из другого источника в таблицу Microsoft Access).

  4. Для переименования столбца (поля) дважды щелкните заголовок столбца и введите новое имя.

    Рекомендуется присваивать полям значимые имена, чтобы при просмотре области списка полей было понятно, что содержится в каждом поле.

  5. Для перемещения столбца сначала щелкните его заголовок, чтобы выделить столбец, а затем перетащите столбец в нужное место.

    Кроме того, можно выбрать сразу несколько смежных столбцов, а затем одновременно перетащить их в новое место. Чтобы выбрать несколько последовательно расположенных столбцов, щелкните заголовок первого столбца, а затем, удерживая нажатой клавишу SHIFT, щелкните заголовок последнего столбца.

Создание таблицы в режиме конструктора     В режиме конструктора сначала создается структура новой таблицы. Затем можно переключиться в режим таблицы для ввода данных или ввести данные, используя другой метод, например вставку или импорт.

  1. На вкладке Создание в группе Таблицы нажмите кнопку Конструктор таблиц. Изображение кнопки

  2. Для каждого поля в таблице введите имя в столбце Имя поля, а затем в списке Тип данных выберите тип данных.

    Примечание : Если столбцы Имя поля и Тип данных не отображаются, возможно, вместо режима конструктора выбран режим таблицы. Чтобы переключиться в режим конструктора, в области переходов щелкните таблицу правой кнопкой мыши, а затем выберите команду Режим конструктора Изображение кнопки . Будет предложено ввести имя для новой таблицы, а затем произойдет переключение в режим конструктора.

  3. При желании можно ввести описание для каждого поля в столбце Описание. Это описание будет отображаться в строке состояния, когда в режиме таблицы курсор будет находиться в данном поле. Это описание также отображается в строке состояния для любых элементов управления в форме или отчете, которые создаются путем перетаскивания этого поля из области списка полей, и любых элементов управления, которые создаются для этого поля при использовании мастера отчетов или мастера форм.

  4. Когда все необходимые поля будут добавлены, сохраните таблицу:

    • Нажмите кнопку Microsoft Office Изображение кнопки Office и выберите Сохранить или нажмите клавиши CTRL+S Изображение кнопки .

  5. Чтобы добавить данные, переключитесь в режим таблицы и начните их вводить, щелкнув первую пустую ячейку. Данные также можно вставить из другого источника (см. раздел Копирование данных из другого источника в таблицу Microsoft Access).

Создание таблицы на основе шаблона     В приложении Access имеются шаблоны для часто используемых типов таблиц. Одним щелчком мыши можно создать полную, сконфигурированную и готовую к использованию структуру таблицы. Чтобы привести таблицу в соответствие со своими запросами пользователь может добавлять или удалять поля.

  1. На вкладке Создание в группе Таблицы щелкните Шаблоны таблиц и выберите из списка один из доступных шаблонов.

  2. Чтобы добавить данные, начните их вводить в первую пустую ячейку или вставьте данные из другого источника (описание см. в разделе Копирование данных из другого источника в таблицу Access).

    • Удаление столбца    

      1. Щелкните заголовок столбца правой кнопкой мыши, а затем выберите команду Удалить столбец  Изображение кнопки .

    • Добавление столбца    

      1. На вкладке Таблица в группе Поля и столбцы нажмите кнопку Создать поле  Изображение кнопки .

      2. В приложении Access будет отображена панель Шаблоны полей, которая содержит список наиболее часто используемых типов полей. При двойном щелчке или перетаскивании одного из этих полей на лист в приложении Access добавляется поле с этим именем, а его свойствам присваиваются значения, соответствующие выбранному типу поля. Эти свойства можно изменить позднее. Поле необходимо перетащить в область листа, содержащую данные: при этом появится вертикальная линия вставки, показывающая расположение поля.

  3. Сохранение таблицы.

    • Нажмите кнопку Microsoft Office Изображение кнопки Office и выберите Сохранить или нажмите клавиши CTRL+S Изображение кнопки .

Задание свойств полей в режиме конструктора    При создании таблицы в режиме таблицы или конструктора рекомендуется проверить и задать свойства полей. Это можно сделать только в режиме конструктора. Для перехода в режим конструктора в области переходов щелкните таблицу правой кнопкой мыши, а затем выберите команду Режим конструктора. Для отображения свойств полей щелкните поле на сетке конструктора. Свойства отображаются под сеткой конструктора в области Свойства поля.

Щелкните свойство поля для просмотра его описания в поле, расположенном рядом со списком свойств в области Свойства поля. Дополнительную информацию можно получить, нажав клавишу F1.

В следующей таблице описаны некоторые наиболее часто изменяемые свойства полей.

Свойство

Описание

Размер поля

Для текстовых полей это свойство указывает максимально допустимое количество знаков, сохраняемых в этом поле. Максимальное значение — 255. Для числовых полей это свойство указывает тип сохраняемых чисел ("Длинное целое", "Двойное с плавающей точкой" и т. д.). Для более рационального хранения данных рекомендуется выделять для хранения данных наименьший необходимый размер памяти. Если потребуется, это значение позже можно изменить.

Формат

Это свойство определяет формат отображения данных. Оно не влияет на фактические данные, сохраняемые в этом поле. Можно выбрать встроенный формат или задать пользовательский формат.

Маска ввода

Это свойство используется для определения общего шаблона для ввода любых данных в это поле. Это позволяет обеспечить правильный ввод и нужное количество знаков для всех данных. Для получения справки по созданию маски ввода нажмите кнопку Кнопка "Построитель" справа от поля свойства.

Значение по умолчанию

Это свойство используется для задания значения по умолчанию, которое будет отображаться в этом поле при каждом добавлении новой записи. Например, для поля "Дата/время", в котором необходимо записывать дату добавления каждой записи, в качестве значения по умолчанию можно ввести "Date()" (без кавычек).

Обязательное поле

Это свойство указывает, обязательно ли вводить значение в это поле. Если для этого свойства задано значение Да, невозможно будет добавить новую запись, если в это поле не введено значение.

К началу страницы

Копирование данных из другого источника в таблицу Access

Если данные хранятся в другой программе, например Office Excel 2007, их можно скопировать и вставить в таблицу Access. Этот метод работает лучше всего, если данные уже разделены по столбцам, как это сделано в таблице Excel. Если это данные из текстового редактора, перед копированием рекомендуется разделить столбцы данных с помощью табуляции или преобразовать эти данные в таблицу в текстовом редакторе. Если необходимо изменить данные или выполнить другие операции (например, разделить полное имя на имя и фамилию), рекомендуется это сделать перед копированием данных, особенно при отсутствии опыта работы с Access.

При вставке данных в пустую таблицу приложение Access задает тип данных для каждого поля в зависимости от того, какие данные находятся в этом поле. Например, если во вставляемом поле содержатся только значения даты, для этого поля используется тип данных "Дата/время". Если вставляемое поле содержит только слова "Да" и "Нет", для этого поля выбирается тип данных "Логический".

В приложении Access поля называются в зависимости от информации, содержащейся в первой строке вставленных данных. Если в первой строке вставляемых данных находятся данные такого же типа, как и в последующих строках, то в приложении Microsoft Access эта строка используется в качестве строки данных, а полям присваиваются общие имена (F1, F2 и так далее). Если первая строка вставляемых данных отличается от следующих строк, ее содержимое используется только в качестве имен поля и не включается в данные.

В приложении Access имена присваиваются полям автоматически, поэтому во избежание путаницы данные поля следует переименовать. Для этого выполните следующие действия.

  1. Сохраните таблицу.

    • Нажмите кнопку Microsoft Office Изображение кнопки Office и выберите Сохранить или нажмите клавиши CTRL+S Изображение кнопки .

  2. В режиме таблицы дважды щелкните заголовок каждого столбца и введите допустимое имя поля для каждого столбца. Может показаться, что при этом происходит замена данных, однако в строке заголовка столбца содержатся имена полей, а не данные.

  3. Еще раз сохраните таблицу.

Примечание : Кроме того, для изменения имен полей можно переключиться в режим конструктора и переименовать поля в этом режиме. Для переключения в режим конструктора щелкните правой кнопкой мыши таблицу в области навигации и выберите команду Конструктор. Чтобы вернуться в режим таблицы, дважды щелкните таблицу в области навигации.

К началу страницы

Импорт, добавление или связывание данных из другого источника

В Access можно импортировать данные из другой программы и поместить эти данные в новую таблицу или добавить в существующую. При совместной работе с пользователями, которые хранят данные в других программах, их данные тоже можно использовать в Access, установив связи. В обоих случаях работа с данными из других источников в Access не представляет сложности. Импортировать данные можно из листа Excel, таблицы в другой базе данных Access, списка SharePoint и других источников. Процесс импорта для разных источников немного различается, однако всегда начинается с приведенной ниже процедуры.

  1. В группе Внешние данные на вкладке Внешние данные в Access выберите команду для типа файла, который необходимо импортировать.

    Изображение ленты Access

    Например, чтобы импортировать данные из таблицы Excel, нажмите кнопку Excel. Если нужного типа программы в группе нет, нажмите кнопку Дополнительно.

    Примечание : Если не удается найти нужный тип формата в группе Внешние данные, следует запустить программу, в которой первоначально созданы эти данные, а затем использовать эту программу для сохранения данных в общем формате данных (например, текстовый файл с разделителями) перед импортом этих данных в Access.

  2. В диалоговом окне Внешние данные нажмите кнопку Обзор, чтобы найти файл данных источника, или введите в поле Имя файла полный путь к файлу данных источника.

  3. Выберите нужный параметр в разделе Укажите, когда и где сохранять данные в текущей базе данных. (все программы допускают импорт данных, а некоторые поддерживают также добавление или связывание данных). Имеется возможность использовать импортируемые данные для создания новой таблицы или (для некоторых программ) добавить их в существующую таблицу или создать связанную таблицу, содержащую ссылку на данные в исходной программе.

  4. Если будет запущен мастер, следуйте инструкциям на экране. На последней странице нажмите кнопку Готово.

    Если осуществляется импорт объектов или привязка таблиц из базы данных Access, появляется диалоговое окно Импорт объектов или Связь с таблицами. Выберите нужные элементы и нажмите кнопку ОК.

    Точная последовательность действий зависит от выбранного способа обработки данных: импорт, добавление или связывание.

  5. Откроется диалоговое окно с запросом на сохранение сведений только что завершенной операции импорта. Если эту операцию импорта в будущем планируется выполнять снова, нажмите кнопку Сохранить шаги импорта и введите подробные сведения. Позже для повторения этой операции достаточно нажать кнопку Сохраненные операции импорта Изображение кнопки в группе Импорт на вкладке Внешние данные. Если сохранять сведения этой операции не нужно, нажмите кнопку Закрыть.

Если импортируется таблица, программа Access импортирует данные в новую таблицу и отображает эту таблицу в группе Таблицы в области навигации. Если выбрано добавление данных к существующей таблице, данные добавляются к этой таблице. Если выбрано связывание данных, в группе Таблицы в области навигации создается связанная таблица.

К началу страницы

Открытие существующей базы данных Access
  1. Нажмите кнопку Microsoft Office Изображение кнопки Office и выберите Открыть.

  2. В диалоговом окне Открытие файла базы данных найдите базу данных, которую нужно открыть.

  3. Выполните одно из следующих действий.

    • Чтобы открыть базу данных в режиме по умолчанию, дважды щелкните ее (Режим по умолчанию может быть указан в диалоговом окне Параметры Access или установлен административной политикой).

    • Нажмите кнопку Открыть, чтобы в многопользовательской среде открыть базу данных для совместного доступа с возможностью чтения и записи в базу данных для всех пользователей.

    • Нажмите кнопку со стрелкой рядом с кнопкой Открыть и выберите вариант Открыть для чтения, чтобы открыть базу данных только для чтения, т.е. для просмотра без возможности внесения изменений. При этом другие пользователи могут осуществлять чтение и запись в базу данных.

    • Чтобы открыть базу данных с монопольным доступом, щелкните стрелку рядом с кнопкой Открыть и выберите команду Монопольный доступ.

    • Нажмите кнопку со стрелкой рядом с кнопкой Открыть и выберите вариант Монопольно для чтения, чтобы открыть базу данных только для чтения. Другие пользователи при этом могут открывать базу данных только для чтения.

Если не удается найти базу данных, которую вы хотите открыть   

  1. Щелкните значок Мой компьютер в диалоговом окне Открытие файла базы данных или выберите Мой компьютер в раскрывающемся списке Папка.

  2. В списке дисков щелкните правой кнопкой мыши диск, на котором может находиться база данных, и выберите команду Найти.

  3. Введите условие поиска в диалоговом окне Результаты поиска и нажмите кнопку Поиск для поиска этой базы данных.

  4. Если база данных найдена, дважды щелкните эту базу данных для ее открытия.

  5. Чтобы база данных открылась, необходимо нажать кнопку Отменить в диалоговом окне Открытие файла базы данных. Затем закройте диалоговое окно Результаты поиска.

Примечание : Можно открывать непосредственно файлы данных внешних форматов, например dBASE, Paradox, Microsoft Exchange или Excel. Кроме того, можно открывать непосредственно любые источник данных ODBC, такие как Microsoft SQL Server или Microsoft FoxPro. Приложение Access автоматически создает новую базу данных Access в одной папке с файлом данных и добавляет ссылки на все таблицы внешней базы данных.

Советы
  • Для открытия одной из баз данных, которые открывались недавно, щелкните имя файла этой базы данных в списке Открыть последнюю базу данных в области Приступая к работе с Microsoft Office Access. Программа Access откроет базу данных, используя параметры, которые применялись при ее последнем открытии. Если список последних открывавшихся файлов не отображается, нажмите кнопку Microsoft Office Изображение кнопки Office , а затем выберите команду Параметры Access. В диалоговом окне Параметры Access щелкните элемент Дополнительно. В разделе Вывод на экран введите количество файлов, отображаемых в этом списке (максимум девять).

  • Если база данных открывается с помощью нажатия кнопки Microsoft Office Изображение кнопки Office и последующего выбора команды Открыть, то, чтобы просмотреть список ярлыков для недавно используемых баз данных, выберите папку Мои последние документы в диалоговом окне Открытие файла базы данных.

К началу страницы

Создание пустого пользовательского шаблона

При создании новой пустой базы данных в программе Access автоматически открывается новая таблица, в которую можно ввести данные. Никаких других объектов в этой базе данных не создается. Если во всех вновь создаваемых базах данных должны быть и другие объекты, например формы, отчеты, макросы или дополнительные таблицы, можно создать пользовательский пустой шаблон, содержащий эти объекты. В этом случае каждая создаваемая база данных будет содержать объекты, определенные в этом шаблоне. Кроме этих объектов в шаблон можно включить таблицы, предварительно заполненные данными, а также любые требуемые настройки конфигурации, свойства, ссылки или код, который должен присутствовать во всех новых базах данных.

Пусть, например, имеется набор макросов, которые должны использоваться во всех проектах. Если создать пустой шаблон с этими макросами, они будут автоматически добавляться во все создаваемые в программе Access базы данных.

Пустые шаблоны можно создать в виде файлов следующих форматов: Office Access 2007, Access 2002-2003 или Access 2000. Шаблон должен называться Пустая.accdb в случае использования файлов формата Office Access 2007 и Пустая.mdb для форматов файлов предыдущих версий.

  • Если в качестве используемого по умолчанию задан формат Access 2000 или Access 2002-2003, файл пустого шаблона получит имя Пустая.mdb. Новая база данных будет создана в том же формате, что и файл Пустая.mdb. Например, если по умолчанию используется формат Access 2000 и шаблон с именем Пустая.mdb имеет формат файла Access 2002-2003, все новые базы данных будут создаваться в формате Access 2002-2003.

  • Если в качестве используемого по умолчанию выбран формат Access 2007, файл пустого шаблона получит имя Пустая.accdb.

Как изменить используемый по умолчанию формат файлов?

  1. Нажмите кнопку Microsoft Office  Изображение кнопки Office , а затем — кнопку Параметры Access.

  2. В диалоговом окне Параметры Access щелкните пункт Основные.

  3. В группе Создание баз данных в раскрывающемся списке Формат файла по умолчанию выберите нужный формат.

Чтобы создать пустой шаблон, выполните одно из следующих действий.

  • Создайте пустую базу данных (назовите ее "Пустая" или дайте ей любое временное имя), а затем импортируйте или создайте объекты, которые должны быть в шаблоне.

  • Создайте копию существующей базы данных, в которой имеются нужные для шаблона объекты, а затем удалите лишние объекты.

Когда нужные для шаблона объекты будут готовы, сохраните базу данных в нужном месте.

  1. Нажмите кнопку Microsoft Office  Изображение кнопки Office и выберите команду Сохранить как.

  2. В группе Сохранение базы данных в другом формате выберите файловый формат для шаблона.

  3. В диалоговом окне Сохранить как откройте одну из следующих двух папок.

    • Системная папка для шаблонов    , например C:\Program Files\Microsoft Office\Templates\1049\Access

    • Папка для пользовательских шаблонов    , например:

      • в Windows Vista   : C:\Users\имя_пользователя\AppData\Roaming\Microsoft\Templates

      • в Microsoft Windows Server 2003 или Microsoft Windows XP   : C:\Documents and Settings\имя_пользователя\Application Data\Microsoft\Templates

        Примечание : Пустой шаблон в системной папке переопределяет пустые шаблоны в любых пользовательских папках.

  4. В поле Имя файла введите Пустая.accdb (или Пустая.mdb, если создается шаблон одной из предыдущих версий), а затем нажмите кнопку Сохранить.

Новый шаблон готов к использованию. Теперь при создании новой пустой базы данных объекты из шаблона включаются во все создаваемые базы данных по умолчанию. В программе Access по-прежнему будет открываться новая таблица в режиме таблицы, как это было при создании новой пустой базы данных без использования шаблона.

Чтобы прекратить использование пустого шаблона, удалите или переименуйте файл Пустая.accdb (или файл Пустая.mdb, если используется одна из предыдущих версий программы Access).

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×