Сложение значений в один или несколько столбцов повторяющейся таблицы или раздела

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

В этой статье

Общие сведения

Добавление одного столбца значений в повторяющуюся таблицу или повторяющийся раздел

Добавление нескольких столбцов значений в повторяющуюся таблицу или повторяющийся раздел

Обзор

Повторяющихся таблиц и разделов часто содержит числовые значения, которые вы хотите добавить в нижней части раздела. Например возможно, повторяющаяся таблица, содержащая сведения о заказе, включающую отпускная цена каждого элемента. В нижней части таблицы можно отобразить общий итог, как показано на приведенном ниже рисунке.

Сумма в строке нижнего колонтитула повторяющейся таблицы

В этой статье описаны способы добавления значений в один или несколько столбцов повторяющейся таблицы или раздела.

Добавление одного столбца значений в повторяющуюся таблицу или повторяющийся раздел

При добавлении столбца в повторяющейся таблице, можно поместить элемент управления с итогами за пределами таблицы или размещение его в нижний колонтитул таблицы, как показано на рисунке. Чтобы достичь этого результата, если нижний колонтитул не отображается, выполните следующие действия для отображения нижнего колонтитула в повторяющуюся таблицу.

  1. В режиме конструктора щелкните правой кнопкой мыши строку заголовка повторяющейся таблицы и нажмите кнопку Свойства повторяющейся таблицы.

  2. Откройте вкладку Отображение.

  3. Установите флажок Включить нижний колонтитул и нажмите кнопку ОК.

Если требуется отображать результаты вычислений и не хотите использовать в других вычислениях результаты вычисления, используйте поле выражения для выполнения вычислений. Поле выражения отображаются только данные; она не сохранять в форме. Если вы хотите использовать результаты вычислений другого вычисления, используйте текстовое поле.

Чтобы добавить столбец значений с помощью поле выражения

  1. Нажмите кнопку, где нужно вставить поле выражения.

  2. В меню Вставка выберите пункт Другие элементы.

  3. В области задач элементы управления в группе Дополнительно выберите Поле выражения.

  4. В диалоговом окне Вставка поля выражения нажмите кнопку Изменить формулу Значок кнопки рядом с полем XPath.

  5. В диалоговом окне Вставка формулы нажмите кнопку Вставить функцию.

  6. В списке категорий в диалоговом окне Вставка функции выберите математические.

  7. В списке функции выберите сумму и нажмите кнопку ОК.

  8. В поле Формула в диалоговом окне Вставка формулы дважды щелкните текст в скобках.

  9. В списке источник данных в диалоговом окне Выбор поля или группы щелкните поле, значения которых вы хотите добавить. Поля должен быть привязан к столбцу, и он должен быть повторяющегося поля или часть повторяющейся группы.

  10. Нажмите кнопку ОК два раза.

Чтобы добавить столбец значений с помощью текстового поля

  1. Нажмите кнопку, которую вы хотите вставить надпись.

  2. В меню Вставить выберите пункт Текстовое поле.

  3. Дважды щелкните текстовое поле, которое вы только что добавили.

  4. Откройте вкладку Данные.

  5. В разделе Значение по умолчанию нажмите кнопку Изменить формулу Значок кнопки .

  6. В диалоговом окне Вставка формулы нажмите кнопку Вставить функцию.

  7. В списке категорий в диалоговом окне Вставка функции выберите математические.

  8. В списке функции выберите сумму и нажмите кнопку ОК.

  9. В поле Формула в диалоговом окне Вставка формулы дважды щелкните текст в скобках.

  10. В списке источник данных в диалоговом окне Выбор поля или группы щелкните поле, значения которых вы хотите добавить. Поля должен быть привязан к столбцу, и он должен быть повторяющегося поля или часть повторяющейся группы.

К началу страницы

Добавление нескольких столбцов значений в повторяющуюся таблицу или повторяющийся раздел

Предположим, что у вас есть несколько столбцов, которые требуется сложить. В приложении InfoPath можно использовать оператор объединения (|) для этого, независимо от того, содержатся ли столбцы в одной Повторяющаяся таблица или повторяющийся раздел, или если они распределены через несколько повторяющихся таблиц или разделы. Например возможно, один Повторяющаяся таблица, содержащая сведения о заказе, а другой Повторяющаяся таблица, содержащая элементы упорядочены назад. Чтобы добавить элемент управления формы, который добавляет Общая сумма заказа между двумя таблицами можно использовать эту процедуру.

Если требуется отображать результаты вычислений и не хотите использовать в других вычислениях результаты вычисления, используйте поле выражения для выполнения вычислений. Поле выражения только отображает данные и не хранить. Если вы хотите использовать результаты вычислений другого вычисления, используйте текстовое поле.

Поле выражения можно использовать для добавления нескольких столбцов

  1. Нажмите кнопку, где нужно вставить поле выражения.

  2. В меню Вставка выберите пункт Другие элементы.

  3. В области задач элементы управления в группе Дополнительно выберите Поле выражения.

  4. В диалоговом окне Вставка поля выражения нажмите кнопку Изменить формулу Значок кнопки рядом с полем XPath.

  5. В диалоговом окне Вставка формулы нажмите кнопку Вставить функцию.

  6. В списке категорий в диалоговом окне Вставка функции выберите математические.

  7. В списке функции выберите сумму и нажмите кнопку ОК.

  8. В поле Формула в диалоговом окне Вставка формулы дважды щелкните текст в скобках.

  9. В списке источник данных в диалоговом окне Выбор поля или группы дважды щелкните первое поле, значения которых вы хотите добавить.

  10. В поле Формула введите оператор объединения (|) сразу после только что вставленную поля.

  11. Нажмите кнопку Вставка поля или группы.

  12. В списке источник данных в диалоговом окне Выбор поля или группы дважды щелкните поле next, значения которых вы хотите добавить. Поля должен быть привязан к столбцу, и он должен быть повторяющегося поля или часть повторяющейся группы. Формула должна выглядеть следующим образом:

SUM(field16 | field17)

  1. Повторите шаги 10 – 12 для любые дополнительные столбцы, которые вы хотите добавить.

Чтобы добавить несколько столбцов с помощью текстового поля

  1. Нажмите кнопку, которую вы хотите вставить надпись.

  2. В меню Вставить выберите пункт Текстовое поле.

  3. Дважды щелкните текстовое поле, которое вы только что добавили.

  4. Откройте вкладку Данные.

  5. В разделе Значение по умолчанию нажмите кнопку Изменить формулу Значок кнопки .

  6. В диалоговом окне Вставка формулы нажмите кнопку Вставить функцию.

  7. В списке категорий в диалоговом окне Вставка функции выберите математические.

  8. В списке функции выберите сумму и нажмите кнопку ОК.

  9. В поле Формула в диалоговом окне Вставка формулы дважды щелкните текст в скобках.

  10. В списке источник данных в диалоговом окне Выбор поля или группы дважды щелкните первое поле, значения которых вы хотите добавить. Поля должен быть привязан к столбцу, и он должен быть повторяющегося поля или часть повторяющейся группы.

  11. В поле Формула введите оператор объединения (|) сразу после только что вставленную поля.

  12. Нажмите кнопку Вставка поля или группы.

  13. В списке источник данных в диалоговом окне Выбор поля или группы дважды щелкните поле next, значения которых вы хотите добавить. Поля должен быть привязан к столбцу, и он должен быть повторяющегося поля или часть повторяющейся группы. Формула должна выглядеть следующим образом:

SUM(field16 | field17)

  1. Повторите шаги 10 – 12 для любые дополнительные столбцы, которые вы хотите добавить.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×