Связывание проектов для создания главного проекта

Связывание проектов для создания главного проекта

Чтобы улучшить организацию больших проектов, вы можете связать несколько файлов проектов, создав систему из главного проекта и подпроектов (внешние зависимости). Например, главный проект по строительству может включать файлы подпроектов по водопроводным, электромонтажным и столярным работам.

Эти инструкции относятся к Microsoft Project 2016, 2013 и 2010.

Связывание файлов в Project

  1. Создайте в Project отдельные файлы для каждого подпроекта, а затем откройте или создайте проект, который нужно сделать главным.

  2. В главном проекте нажмите Вид > Диаграмма Ганта.

  3. В поле Название задачи нажмите на строку, под которой нужно вставить подпроект. Его можно вставить в любой строке списка задач главного проекта.

  4. Выберите Проект > Подпроект.

    Вкладка ленты "Проект", на которой отображается команда "Вставить подпроект".

  5. В окне Вставка проекта выберите подпроект, который нужно вставить.

    • Чтобы вставить несколько подпроектов, нажмите и удерживайте клавишу CTRL и нажимайте подпроекты в нужном порядке.

    • В большинстве случаев флажок для параметра Связать с проектом должен быть установленным, чтобы изменения в подпроекте отображались в главном проекте и наоборот. Но если вы хотите просто скопировать подпроект в главный проект, не устанавливая между файлами динамическую связь, снимите этот флажок.

  6. Нажмите кнопку Вставить или, чтобы вставить проект в формате только для чтения, нажмите на стрелку на кнопке Вставить, а затем выберите команду Вставить только для чтения. При вставке проекта в таком формате будет создана связь между двумя проектами, но обновление подпроекта в главном проекте выполняться не будет. При этом в случае обновления непосредственно файла подпроекта внесенные изменения будут отображены в главном проекте. Параметр Вставить только для чтения доступен только после установки флажка Связать с проектом.

Как избежать дублирования имен ресурсов в связанных проектах

Если связать проекты, в которых используются ресурсы с одинаковыми именами, вы создадите их копии, что может привести к ошибкам. Чтобы избежать этого, в диалоговом окне Вставка проекта снимите флажок Связать с проектом. Таким образом вы гарантируете использование сведений о ресурсах (например, ставок оплаты и календарей ресурсов) из главного проекта в подпроекте.

Примечание : При обновлении несвязанного подпроекта в главном проекте внесенные изменения не будут отображаться в исходном файле подпроекта.

Эти инструкции относятся к Microsoft Project 2007.

Когда следует использовать перекрестные связи между проектами, а не зависимости?

Если в вашем проекте есть задача, зависящая от задачи из другого проекта, используйте перекрестные связи, чтобы связать даты этих задач. Если впоследствии сроки задачи из другого проекта сместятся, эти изменения отразятся на вашей задаче. Если ваш проект зависит от какого-либо аспекта другого проекта, и эта зависимость не связана с определенной задачей, используйте зависимости между проектами, чтобы точно определить, в чем заключается вклад каждого проекта в связь.

  1. Откройте проекты с задачами, которые вы хотите связать.

    В одном из проектов откройте меню Окно и выберите Упорядочить все.

  2. Выберите задачу, для которой хотите создать зависимость с внешним предшественником.

  3. Выберите Сведения о задаче Изображение кнопки и откройте вкладку Предшественники.

  4. В столбце Ид. введите через обратную косую черту имя проекта и идентификатор задачи для внешнего предшественника. Например, введите Проект1\1, если файл называется "Проект1", а идентификатор задачи — "1".

По умолчанию при изменениях в проекте с внешними связями отображается уведомление. Если открыть такой проект, отобразятся внешние предшественники и последователи, а также влияния на ваш календарный план. Вы можете принять все изменения или только какие-либо из них.

  • Для установления связи с внешней задачей оба проекта следует предварительно сохранить.

  • Если вы связываете задачи из проектов, хранящихся на сервере Microsoft Office Project Server, следует правильно отформатировать идентификатор задачи для предшественника. В диалоговом окне Сведения о задаче на вкладке Предшественники в столбце Ид. идентификатор задачи должен быть указан в следующем формате: "<>\проект1\42". В этом примере "проект1" — имя проекта с предшественником, а "42" — идентификатор задачи для предшественника.

  • Задачи с внешними связями отображаются затененными в списке задач. Дважды щелкнув задачу с внешним предшественником или последователем, вы откроете проект, содержащий внешнюю задачу (если он доступен).

Задачи из разных проектов связаны, но данные отличаются

Если в меню Правка открыть диалоговое окно Специальная вставка и выбрать пункт Связать для создания связи между задачами, произойдет связывание и внедрение объектов (OLE). При этом будут связаны только выбранные поля. Однако для задач могут использоваться другие поля со сведениями, связанные с их календарным планом. Если проекты отображаются с разделением экрана по вертикали, эти поля могут быть скрыты.

При необходимости создать зависимость между задачами из разных проектов, для соблюдения календарного плана следует создать внешние зависимости, а не связи.

Если вы выбрали пункт Связать, выделите отдельные поля, а не целые строки, и создайте связь только для нужных сведений, чтобы избежать конфликтов в календарном плане.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×