Связывание или внедрение данных в Office для Mac

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

При работе с пакетом Office доступны несколько способов обмена данными между приложениями. Один из способов — копирование и вставка данных, однако их можно также связать с источником, чтобы они обновлялись автоматически, или внедрить, чтобы обновлять данные только вручную путем открытия файла. Кроме того, использование связанного объекта позволяет создать связь с частью файла, например с несколькими ячейками на листе Excel.

Преимущества и недостатки связывания и внедрения

Связывание

Внедрение

Автоматическое обновление данных

Простое открытие приложения, в котором были созданы внедренные данные

Небольшой размер файлов

Размер файлов больше, чем при связывании данных

Для просмотра данных должны быть доступны оба файла

Оба файла должны быть доступны для обновления данных; для просмотра это не нужно

Не подходит, если требуется распространить файл в сети

Подходит в случаях, когда файл нужно распространить в сети, поскольку все данные сохраняются в одном файле

Word

Если данные находятся в файле Excel, а связанные сведения — в файле Word, можно связать их, чтобы упростить обновление. Например, предположим, что последние сведения о доходах от продаж нужно связать с ежемесячным отчетом о состоянии. Отчет представляет собой документ Word, а данные о доходах от продаж находятся на листе Excel. После связывания документа и листа данные в отчете о состоянии будут автоматически обновляться при изменении сведений о доходах от продаж. Возможна также ситуация, когда инструкции из документа Word необходимо вставить в несколько файлов Excel. Если использовать связывание данных, изменения в инструкциях будут автоматически отражаться во всех файлах Excel.

  1. Щелкните то место, куда нужно вставить связь.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Найдите и щелкните файл, который нужно создать ссылку, а затем нажмите кнопку Параметры.

  4. Установите флажок связать с файлом

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  5. Если используется приложение Word нажмите кнопку Вставить, или нажмите кнопку ОК, если используется приложение Excel.

  1. В меню Правка выберите команду Связи.

    Если команда Связи недоступна, это означает, что в файле нет связанных данных.

  2. В разделе Исходный файл выберите нужный файл и нажмите кнопку Открыть источник.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Сохранить, чтобы сохранить изменения, и закройте приложение.

    Помните, что изменения содержатся в файле со связью.

Если требуется сохранить связь между двумя файлами, причем основной файл не должен обновляться при изменении другого, данные можно внедрить. Например, данные можно внедрить в тех случаях, когда не нужно, чтобы отчет о состоянии обновлялся при внесении изменений на листе Excel, или не требуется, чтобы на листе Excel отражались изменения в инструкциях. Поскольку все сведения хранятся в одном файле, внедрение данных оказывается удобным в ситуациях, когда сетевую версию файла нужно отправить пользователям, не имеющим доступа к внедренному файлу.

  1. Щелкните место, куда требуется внедрить файл.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Выберите нужный файл и нажмите кнопку Параметры.

    Если нужно внедрить лист Excel, он должен быть первым в книге.

  4. Снимите флажок связать с файлом.

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  5. Если используется приложение Word нажмите кнопку Вставить, или нажмите кнопку ОК, если используется приложение Excel.

  1. Дважды щелкните внедренный объект.

  2. Внесите изменения и сохраните их.

  3. В меню Файл выберите команду Закрыть и вернуться к [имя файла].

    Обратите внимание, что изменения сохраняются во внедренном файле.

Вы можете связать часть файла. Например в ежемесячный отчет о состоянии, может потребоваться создать ссылку в определенном диапазоне ячеек на листе Excel, а не весь лист. Например вы хотите связать с инструкциями из документа Word, а не весь документ.

  1. Выделите данные, которые нужно вставить (например, диапазон ячеек на листе Excel).

  2. В меню Правка выберите команду Копировать.

  3. Перейдите в другой файл и щелкните место, куда нужно вставить скопированные данные.

  4. В меню Правка выберите команду Специальная вставка, а затем — пункт Вставить связь.

  5. В поле Как выберите тип объекта, например Лист Microsoft Excel, и нажмите кнопку ОК.

PowerPoint

Если требуется сохранить связь между двумя файлами, причем основной файл не должен обновляться при изменении другого, данные можно внедрить. Например, предположим, что последние сведения о доходах от продаж нужно внедрить в ежемесячный отчет о состоянии. Отчет представляет собой презентацию PowerPoint, а данные о доходах от продаж находятся на листе Excel. После внедрения листа в презентацию файлы остаются связанными.

  1. Щелкните место, куда требуется внедрить файл.

  2. В меню Вставка выберите пункт объект и выберите команду из файла.

  3. Найдите и выберите файл, который нужно внедрить.

    Если нужно внедрить лист Excel, он должен быть первым в книге.

  4. Нажмите кнопку Вставить, а затем кнопку ОК.

    Если данные из встроенного файла не отображаются, перетаскивайте маркер изменения размера, пока не появится содержимое файла.

  1. Дважды щелкните внедренный файл.

  2. Внесите необходимые изменения.

  3. Выберите файл и нажмите кнопку Обновить.

  4. В меню Файл выберите команду Закрыть и вернуться к [имя файла].

    Обратите внимание, что изменения сохраняются во внедренном файле.

Можно встроить только часть файла. Например, в ежемесячный отчет о состоянии, может потребоваться внедрить не весь лист Excel, а только определенный диапазон ячеек на нем.

  1. Выделите данные, которые нужно вставить (например, диапазон ячеек на листе Excel).

  2. В меню Правка выберите команду Копировать.

  3. Перейдите в другой файл и щелкните место, куда нужно вставить скопированные данные.

  4. В меню Правка выберите команду Специальная вставка.

  5. В поле Вставить как выберите тип объекта, например Лист Microsoft Excel, и нажмите кнопку ОК.

Excel

Если данные находятся в файле Excel, а связанные сведения — в файле Word, можно связать их, чтобы упростить обновление. Например, предположим, что последние сведения о доходах от продаж нужно связать с ежемесячным отчетом о состоянии. Отчет представляет собой документ Word, а данные о доходах от продаж находятся на листе Excel. После связывания документа и листа данные в отчете о состоянии будут автоматически обновляться при изменении сведений о доходах от продаж. Возможна также ситуация, когда инструкции из документа Word необходимо вставить в несколько файлов Excel. Если использовать связывание данных, изменения в инструкциях будут автоматически отражаться во всех файлах Excel.

  1. Щелкните то место, куда нужно вставить связь.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Выберите файл, который нужно создать ссылку, а затем нажмите кнопку Параметры.

  4. Установите флажок связать с файлом

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  5. Если используется приложение Word нажмите кнопку Вставить, или нажмите кнопку ОК, если используется приложение Excel.

  1. В меню данные выберите команду Изменить связи.

    Если команда Изменить связи недоступна, файл не содержит связанных данных.

  2. В разделе Исходный файл выберите нужный файл и нажмите кнопку Открыть источник.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Сохранить, чтобы сохранить изменения, и закройте приложение.

  5. Выберите нужный файл. Обратите внимание на то, что файл содержит нужные изменения.

Если требуется сохранить связь между двумя файлами, причем основной файл не должен обновляться при изменении другого, данные можно внедрить. Например, данные можно внедрить в тех случаях, когда не нужно, чтобы отчет о состоянии обновлялся при внесении изменений на листе Excel, или не требуется, чтобы на листе Excel отражались изменения в инструкциях. Поскольку все сведения хранятся в одном файле, внедрение данных оказывается удобным в ситуациях, когда сетевую версию файла нужно отправить пользователям, не имеющим доступа к внедренному файлу.

  1. Щелкните место, куда требуется внедрить файл.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Выберите файл, который вы хотите внедрить и нажмите кнопку Параметры.

    Если нужно внедрить лист Excel, он должен быть первым в книге.

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  4. Снимите флажок Связать с файлом и нажмите кнопку Вставить, если используется приложение Word, или кнопку ОК, если используется приложение Excel.

  1. Дважды щелкните внедренный файл.

  2. Внесите необходимые изменения.

  3. В меню файл нажмите кнопку Обновить.

    Обратите внимание, что изменения сохраняются во внедренном файле.

Можно создать связь с частью файла. Например, может потребоваться создать связь не со всем листом Excel, а только с определенным диапазоном ячеек на нем.

  1. Выделите данные, которые нужно вставить (например, несколько предложений в документе Word).

  2. В меню Правка выберите команду Копировать.

  3. Перейдите в другой файл и щелкните место, куда нужно вставить скопированные данные.

  4. В меню Правка выберите команду Специальная вставка, а затем — пункт Вставить связь.

  5. В поле Как выберите тип объекта, например Документ Microsoft Word, и нажмите кнопку ОК.

Word

Если данные находятся в файле Excel, а связанные сведения — в файле Word, можно связать их, чтобы упростить обновление. Например, предположим, что последние сведения о доходах от продаж нужно связать с ежемесячным отчетом о состоянии. Отчет представляет собой документ Word, а данные о доходах от продаж находятся на листе Excel. После связывания документа и листа данные в отчете о состоянии будут автоматически обновляться при изменении сведений о доходах от продаж. Возможна также ситуация, когда инструкции из документа Word необходимо вставить в несколько файлов Excel. Если использовать связывание данных, изменения в инструкциях будут автоматически отражаться во всех файлах Excel.

  1. Щелкните то место, куда нужно вставить связь.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Найдите файл, с которым нужно установить связь, и щелкните его имя.

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  4. Установите флажок Связать с файлом и нажмите кнопку Вставить, если используется приложение Word, или кнопку ОК, если используется приложение Excel.

  1. В меню Правка выберите команду Связи.

    Если команда Связи недоступна, это означает, что в файле нет связанных данных.

  2. В разделе Исходный файл выберите нужный файл и нажмите кнопку Открыть источник.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Сохранить, чтобы сохранить изменения, и закройте приложение.

    Помните, что изменения содержатся в файле со связью.

Если требуется сохранить связь между двумя файлами, причем основной файл не должен обновляться при изменении другого, данные можно внедрить. Например, данные можно внедрить в тех случаях, когда не нужно, чтобы отчет о состоянии обновлялся при внесении изменений на листе Excel, или не требуется, чтобы на листе Excel отражались изменения в инструкциях. Поскольку все сведения хранятся в одном файле, внедрение данных оказывается удобным в ситуациях, когда сетевую версию файла нужно отправить пользователям, не имеющим доступа к внедренному файлу.

  1. Щелкните место, куда требуется внедрить файл.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Найдите и выберите файл, который нужно внедрить.

    Если нужно внедрить лист Excel, он должен быть первым в книге.

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  4. Снимите флажок Связать с файлом и нажмите кнопку Вставить, если используется приложение Word, или кнопку ОК, если используется приложение Excel.

  1. Щелкните внедренный файл.

  2. В меню Правка наведите указатель мыши на пункт Объект [тип объекта], например Лист, и нажмите кнопку Изменить.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Закрыть и вернуться к [имя файла].

    Обратите внимание, что изменения сохраняются во внедренном файле.

Вы можете связать часть файла. Например в ежемесячный отчет о состоянии, может потребоваться создать ссылку в определенном диапазоне ячеек на листе Excel, а не весь лист. Например вы хотите связать с инструкциями из документа Word, а не весь документ.

  1. Выделите данные, которые нужно вставить (например, диапазон ячеек на листе Excel).

  2. В меню Правка выберите команду Копировать.

  3. Перейдите в другой файл и щелкните место, куда нужно вставить скопированные данные.

  4. В меню Правка выберите команду Специальная вставка, а затем — пункт Вставить связь.

  5. В поле Как выберите тип объекта, например Лист Microsoft Excel, и нажмите кнопку ОК.

PowerPoint

Если требуется сохранить связь между двумя файлами, причем основной файл не должен обновляться при изменении другого, данные можно внедрить. Например, предположим, что последние сведения о доходах от продаж нужно внедрить в ежемесячный отчет о состоянии. Отчет представляет собой презентацию PowerPoint, а данные о доходах от продаж находятся на листе Excel. После внедрения листа в презентацию файлы остаются связанными.

  1. Щелкните место, куда требуется внедрить файл.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Создать из файла.

  3. Найдите и выберите файл, который нужно внедрить.

    Если нужно внедрить лист Excel, он должен быть первым в книге.

  4. Нажмите кнопку Вставить, а затем кнопку ОК.

    Если данные из встроенного файла не отображаются, перетаскивайте маркер изменения размера, пока не появится содержимое файла.

  1. Щелкните внедренный файл.

  2. В меню Правка наведите указатель мыши на пункт Объект [тип объекта], например Лист, и нажмите кнопку Изменить.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Закрыть и вернуться к [имя файла].

    Обратите внимание, что изменения сохраняются во внедренном файле.

Можно встроить только часть файла. Например, в ежемесячный отчет о состоянии, может потребоваться внедрить не весь лист Excel, а только определенный диапазон ячеек на нем.

  1. Выделите данные, которые нужно вставить (например, диапазон ячеек на листе Excel).

  2. В меню Правка выберите команду Копировать.

  3. Перейдите в другой файл и щелкните место, куда нужно вставить скопированные данные.

  4. В меню Правка выберите команду Специальная вставка.

  5. В поле Вставить как выберите тип объекта, например Лист Microsoft Excel, и нажмите кнопку ОК.

Excel

Если данные находятся в файле Excel, а связанные сведения — в файле Word, можно связать их, чтобы упростить обновление. Например, предположим, что последние сведения о доходах от продаж нужно связать с ежемесячным отчетом о состоянии. Отчет представляет собой документ Word, а данные о доходах от продаж находятся на листе Excel. После связывания документа и листа данные в отчете о состоянии будут автоматически обновляться при изменении сведений о доходах от продаж. Возможна также ситуация, когда инструкции из документа Word необходимо вставить в несколько файлов Excel. Если использовать связывание данных, изменения в инструкциях будут автоматически отражаться во всех файлах Excel.

  1. Щелкните то место, куда нужно вставить связь.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Найдите файл, с которым нужно установить связь, и щелкните его имя.

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  4. Установите флажок Связать с файлом и нажмите кнопку Вставить, если используется приложение Word, или кнопку ОК, если используется приложение Excel.

  1. В меню Правка выберите команду Связи.

    Если команда Связи недоступна, это означает, что в файле нет связанных данных.

  2. В разделе Исходный файл выберите нужный файл и нажмите кнопку Открыть источник.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Сохранить, чтобы сохранить изменения, и закройте приложение.

    Помните, что изменения содержатся в файле со связью.

Если требуется сохранить связь между двумя файлами, причем основной файл не должен обновляться при изменении другого, данные можно внедрить. Например, данные можно внедрить в тех случаях, когда не нужно, чтобы отчет о состоянии обновлялся при внесении изменений на листе Excel, или не требуется, чтобы на листе Excel отражались изменения в инструкциях. Поскольку все сведения хранятся в одном файле, внедрение данных оказывается удобным в ситуациях, когда сетевую версию файла нужно отправить пользователям, не имеющим доступа к внедренному файлу.

  1. Щелкните место, куда требуется внедрить файл.

  2. В меню Вставка щелкните пункт Объект и выберите вариант Из файла.

  3. Найдите и выберите файл, который нужно внедрить.

    Если нужно внедрить лист Excel, он должен быть первым в книге.

    Совет : Если требуется, чтобы отображался только значок, который можно щелкнуть для просмотра сведений, установите флажок В виде значка.

  4. Снимите флажок Связать с файлом и нажмите кнопку Вставить, если используется приложение Word, или кнопку ОК, если используется приложение Excel.

  1. Щелкните внедренный файл.

  2. В меню Правка наведите указатель мыши на пункт Объект [тип объекта], например Лист, и нажмите кнопку Изменить.

  3. Внесите необходимые изменения.

  4. В меню Файл выберите команду Закрыть и вернуться к [имя файла].

    Обратите внимание, что изменения сохраняются во внедренном файле.

Можно создать связь с частью файла. Например, может потребоваться создать связь не со всем листом Excel, а только с определенным диапазоном ячеек на нем.

  1. Выделите данные, которые нужно вставить (например, несколько предложений в документе Word).

  2. В меню Правка выберите команду Копировать.

  3. Перейдите в другой файл и щелкните место, куда нужно вставить скопированные данные.

  4. В меню Правка выберите команду Специальная вставка, а затем — пункт Вставить связь.

  5. В поле Как выберите тип объекта, например Документ Microsoft Word, и нажмите кнопку ОК.

Дополнительные материалы

Создание, изменение и удаление гиперссылок

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×