СЧЁТЕСЛИ (функция СЧЁТЕСЛИ)

СЧЁТЕСЛИ (функция СЧЁТЕСЛИ)

С помощью статистической функции СЧЁТЕСЛИ можно подсчитать количество ячеек, отвечающих определенному условию (например, число клиентов в списке из определенного города).

Самая простая функция СЧЁТЕСЛИ означает следующее:

  • =СЧЁТЕСЛИ(где нужно искать;что нужно найти)

Например:

  • =COUNTIF(A2:A5;"Лондон")

  • =СЧЁТЕСЛИ(A2:A5;A4)

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

СЧЁТЕСЛИ(диапазон;критерий)

Имя аргумента

Описание

диапазон    (обязательный)

Группа ячеек, для которых нужно выполнить подсчет. Диапазон может содержать числа, массивы, именованный диапазон или ссылки на числа. Пустые и текстовые значения игнорируются.

Узнайте, как выбирать диапазоны на листе.

критерий    (обязательный)

Число, выражение, ссылка на ячейку или текстовая строка, которая определяет, какие ячейки нужно подсчитать.

Например, критерий может быть выражен как 32, ">32", В4, "яблоки" или "32".

В функции СЧЁТЕСЛИ используется только один критерий. Чтобы провести подсчет по нескольким условиям, воспользуйтесь функцией СЧЁТЕСЛИМН.

Примеры

Чтобы использовать эти примеры в Excel, скопируйте данные из приведенной ниже таблицы и вставьте их на новый лист в ячейку A1.

Данные

Данные

яблоки

32

апельсины

54

персики

75

яблоки

86

Формула

Описание

=СЧЁТЕСЛИ(A2:A5;"яблоки")

Количество ячеек, содержащих текст "яблоки" в ячейках А2–А5. Результат — 2.

=СЧЁТЕСЛИ(A2:A5;A4)

Количество ячеек, содержащих текст "персики" (значение ячейки A4) в ячейках А2–А5. Результат — 1.

=СЧЁТЕСЛИ(A2:A5;A2)+СЧЁТЕСЛИ(A2:A5;A3)

Количество ячеек, содержащих текст "яблоки" (значение ячейки A2) и "апельсины" (значение ячейки A3) в ячейках А2–А5. Результат — 3. В этой формуле для указания нескольких критериев, по одному критерию на выражение, функция СЧЁТЕСЛИ используется дважды. Также можно использовать функцию СЧЁТЕСЛИМН.

=СЧЁТЕСЛИ(B2:B5;">55")

Количество ячеек со значением больше 55 в ячейках В2–В5. Результат — 2.

=СЧЁТЕСЛИ(B2:B5;"<>"&B4)

Количество ячеек со значением, не равным 75, в ячейках В2–В5. Знак амперсанда (&) объединяет оператор сравнения "<>" (не равно) и значение в ячейке B4, в результате чего получается формула =СЧЁТЕСЛИ(B2:B5;"<>75"). Результат — 3.

=СЧЁТЕСЛИ(B2:B5;">=32")-СЧЁТЕСЛИ(B2:B5;">85")

Количество ячеек со значением, большим или равным 32 и меньшим или равным 85, в ячейках В2–В5. Результат — 3.

=СЧЁТЕСЛИ(A2:A5;"*")

Количество ячеек, содержащих любой текст, в ячейках А2–А5. Подстановочный знак "*" обозначает любое количество любых символов. Результат — 4.

=СЧЁТЕСЛИ(A2:A5;"????ки")

Количество ячеек, строка в которых содержит ровно 7 знаков и заканчивается буквами "ки", в диапазоне A2–A5. Подставочный знак "?" обозначает отдельный символ. Результат — 2.

Распространенные неполадки

Проблема

Возможная причина

Для длинных строк возвращается неправильное значение.

Функция СЧЁТЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов.

Для работы с такими строками используйте функцию СЦЕПИТЬ или оператор сцепления &. Пример: =СЧЁТЕСЛИ(A2:A5;"длинная строка"&"еще одна длинная строка").

Функция должна вернуть значение, но ничего не возвращает.

Аргумент критерий должен быть заключен в кавычки.

Когда формула СЧЁТЕСЛИ ссылается на другую книгу, появляется ошибка #ЗНАЧ!.

Эта ошибка возникает при вычислении ячеек, когда в формуле содержится функция, которая ссылается на ячейки или диапазон в закрытой книге. Для работы этой функции необходимо, чтобы другая книга была открыта.

Рекомендации

Действие

Результат

Помните о том, что функция СЧЁТЕСЛИ не учитывает регистр символов в текстовых строках.

Критерий не чувствителен к регистру. Например, строкам "яблоки" и "ЯБЛОКИ" будут соответствовать одни и те же ячейки.

Использование подстановочных знаков

В критерии можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*). Вопросительный знак соответствует одному любому символу, а звездочка — любой последовательности знаков. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак тильды (~).

Например, =СЧЁТЕСЛИ(A2:A5;"яблок?") возвращает все вхождения слова "яблок" с любой буквой в конце.

Убедитесь, что данные не содержат ошибочных символов.

При подсчете текстовых значений убедитесь в том, что данные не содержат начальных или конечных пробелов, недопустимых прямых и изогнутых кавычек или непечатаемых символов. В этих случаях функция СЧЁТЕСЛИ может вернуть непредвиденное значение.

Попробуйте воспользоваться функцией ПЕЧСИМВ или функцией СЖПРОБЕЛЫ.

Для удобства используйте именованные диапазоны.

Функция СЧЁТЕСЛИ поддерживает именованные диапазоны в формулах (например, =СЧЁТЕСЛИ(фрукты;">=32")-СЧЁТЕСЛИ(фрукты;">85"). Именованный диапазон может располагаться на текущем листе, другом листе этой же книги или листе другой книги. Чтобы одна книга могла ссылаться на другую, они обе должны быть открыты.

Примечание : С помощью функции СЧЁТЕСЛИ нельзя подсчитать количество ячеек с определенным фоном или цветом шрифта. Однако Excel поддерживает пользовательские функции, в которых используются операции VBA (Visual Basic для приложений) над ячейками, выполняемые в зависимости от фона или цвета шрифта. Вот пример подсчета количества ячеек определенного цвета с использованием VBA.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Для подсчета непустых ячеек используйте функцию СЧЁТЗ

Для подсчета ячеек на основании нескольких критериев используйте функцию СЧЁТЕСЛИМН

Просмотрите видео об использовании функции СЧЁТЕСЛИ

Функция СУММЕСЛИ суммирует значения, соответствующие одному критерию

Функция СУММЕСЛИМН суммирует только те значения, которые соответствуют нескольким критериям

Функция УСЛОВИЯ (Office 365, Excel 2016 и более поздней версии)

Функция СЖПРОБЕЛЫ удаляет из ячеек начальные и конечные пробелы

Функция ПЕЧСИМВ удаляет из ячеек непечатаемые символы

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Статистические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Использование функций СУММЕСЛИ, СЧЁТЕСЛИ и связанных с ними функций для экспресс-анализа данных (бесплатное ознакомительное видео)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×