Реконструирование существующей базы данных в модель базы данных

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью мастера реконструирования в выпусках Visio Pro для Office 365, Microsoft Visio профессиональный и Microsoft Visio Premium можно создать модель базы данных из существующей базы данных или из книги Microsoft Excel. Модель базы данных — это графическое представление ее структуры. Оно позволяет увидеть, как связаны между собой элементы базы данных, например таблицы и представления, без отображения фактических данных. Это может облегчить создание новой или изучение структуры уже имеющейся базы данных.

В этой статье:

Местонахождение функций моделирования баз данных в Visio Pro для Office 365

Элементы, извлекаемые мастером реконструирования

Подготовка к запуску мастера

Реконструирование существующей базы данных

Местонахождение функций моделирования баз данных в Visio Pro для Office 365

Создать модель базы данных из существующей базы данных можно с помощью надстройки Visio для моделирования баз данных. Эта надстройка работает только в Visio Pro для Office 365. Если вы не знаете, какую версию Visio используете, на вкладке Файл выберите Учетная запись > О программе Visio. Дополнительные сведения о версии Visio, которая предоставляется по подписке, см. на странице продукта Visio Pro для Office 365.

Скачивание надстройки Visio для моделирования баз данных

  1. Скачайте надстройку отсюда.

  2. На странице загрузки выберите нужный язык и нажмите кнопку Скачать.

  3. Выберите 64-разрядную (x64) или 32-разрядную (x86) версию надстройки (в зависимости от установленной версии Visio Pro для Office 365). Вы также можете скачать PDF-файл с инструкциями по установке. Нажмите кнопку Далее, чтобы скачать файлы на свой компьютер или устройство.

  4. Если программа Visio открыта, закройте ее перед следующим шагом.

  5. Найдите файл установки (с расширением MSI), который вы скачали, и дважды щелкните его, чтобы начать установку. Когда появится запрос, нажмите Установить, а затем следуйте инструкциям на экране, чтобы установить надстройку.

  6. Теперь схема модели базы данных доступна для использования в приложении Visio Pro для Office 365, предоставляемом по подписке.

Элементы, извлекаемые мастером реконструирования

Элементы определения схемы, которые может извлечь мастер, зависят от сочетания различных факторов, например от возможностей системы управления базами данных (СУБД) и драйвера ODBC. Во время работы мастера вы увидите, какие элементы доступны для извлечения, и сможете выбрать нужные. Например, можно выбрать только пять таблиц из 10 и два представления из четырех.

В мастере можно задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

Извлечь можно такие элементы (при условии, что они доступны в целевой СУБД):

  • таблицы;

  • представления;

  • первичные ключи;

  • внешние ключи;

  • индексы;

  • триггеры (включая код);

  • предложения проверки (включая код);

  • хранимые процедуры (включая код).

Подготовка к запуску мастера

Если вы выполняете реконструирование книги Excel, то перед запуском мастера нужно открыть ее и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. Если вы хотите использовать несколько листов, просто присвойте имя группе ячеек с заголовками столбцов на каждом из них. Мастер интерпретирует эти диапазоны как таблицы. Дополнительные сведения о том, как присвоить имя диапазону ячеек, см. в справке Microsoft Office Excel.

Чтобы добиться наилучших результатов, перед запуском мастера реконструирования настройте драйвер по умолчанию для целевой базы данных. Это гарантирует, что мастер правильно сопоставит собственные типы данных, а весь код, извлеченный мастером, будет правильно отображаться в окне "Код".

  1. На вкладке Файл выберите Создать > Шаблоны > Программы и базы данных и дважды щелкните элемент Схема модели базы данных.

  2. На вкладке База данных в группе Управление щелкните Драйверы баз данных.

  3. На вкладке Драйверы выберите доступный в Visio драйвер для конкретной СУБД. Например, если вы проектируете базу данных Access, нужно выбрать драйвер Microsoft Access.

    Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

  4. Нажмите кнопку Настройка.

  5. На вкладке Драйверы ODBC установите флажок рядом с нужным драйвером для вашей СУБД. Например, если вы проектируете базу данных Access, нужно установить флажок Драйвер Microsoft Access (*.mdb, *.accdb).

  6. В каждом диалоговом окне нажмите кнопку ОК.

32-разрядный драйвер ODBC должен входить в состав пакета ODBC Data Access Pack более поздней версии, чем 2.0, и быть совместимым с уровнем 1 (или выше) стандарта ODBC. Поставщик OLE DB должен соответствовать спецификации OLE DB 1.0 или более поздней версии.

К началу страницы

Реконструирование существующей базы данных

  1. В схеме модели базы данных на вкладке База данных щелкните Реконструировать.

  2. На первом экране мастера реконструирования выполните указанные ниже действия.

    1. Выберите драйвер базы данных Microsoft Visio для своей системы управления базами данных (СУБД). Если вы еще не связали драйвер базы данных Visio с конкретным источником данных ODBC, нажмите кнопку Настройка, чтобы сделать это сейчас.

      Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

    2. Выбор источник данных для базы данных, которую вы хотите обновить. Если вы еще не создали источник данных для существующей базы данных, нажмите кнопку Создать, чтобы сделать это сейчас.

      Когда новый источник будет создан, его имя появится в списке Источники данных.

    3. Завершив настройку параметров, нажмите кнопку Далее.

    4. Следуйте инструкциям в диалоговых окнах для конкретного драйвера. Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК. Если источник данных не защищен паролем, нажмите кнопку ОК.

  3. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите кнопку Далее.

    Некоторые элементы могут быть затенены, т. е. недоступны, потому что не каждая система поддерживает все типы элементов, которые может извлечь мастер.

  4. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

    Если вы выполняете реконструирование листа Excel, а этот список пуст, скорее всего, нужно присвоить имя диапазону ячеек, которые содержат заголовки столбцов на листе.

  5. Если на шаге 3 вы установили флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или щелкните Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

  6. Укажите, нужно ли автоматически добавлять реконструируемые элементы на текущую страницу.

    Вы можете задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

  7. Просмотрите выбранные параметры, чтобы убедиться в том, что будут извлечены все необходимые данные, и нажмите кнопку Готово.

Если используется универсальный драйвер ODBC, иногда появляется сообщение об ошибке, которое означает, что реконструированная информация может быть неполной. В большинстве случаев это не указывает на реальную проблему, так что можно нажать кнопку ОК, чтобы продолжить работу мастера.

Мастер извлекает выбранные данные и отображает замечания о процедуре извлечения в окне вывода.

К началу страницы

В Visio 2013 мастер реконструирования не поддерживается.

Обратный структурную недоступен в Visio профессиональный 2013 или Visio стандартный 2013. Чтобы использовать возможности моделирования баз данных, рассмотрите возможность обновления до Visio Pro для Office 365.

Попробуйте новую версию Outlook

В этой статье:

Элементы, извлекаемые мастером реконструирования

Подготовка к запуску мастера

Реконструирование существующей базы данных

Элементы, извлекаемые мастером реконструирования

Элементы определения схемы, которые может извлечь мастер, зависят от сочетания различных факторов, например от возможностей системы управления базами данных (СУБД) и драйвера ODBC. Во время работы мастера вы увидите, какие элементы доступны для извлечения, и сможете выбрать нужные. Например, можно выбрать только пять таблиц из 10 и два представления из четырех.

В мастере можно задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

Извлечь можно такие элементы (при условии, что они доступны в целевой СУБД):

  • таблицы;

  • представления;

  • первичные ключи;

  • внешние ключи;

  • индексы;

  • триггеры (включая код);

  • предложения проверки (включая код);

  • хранимые процедуры (включая код).

К началу страницы

Подготовка к запуску мастера

Если вы выполняете реконструирование книги Excel, то перед запуском мастера нужно открыть ее и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. Если вы хотите использовать несколько листов, просто присвойте имя группе ячеек с заголовками столбцов на каждом из них. Мастер интерпретирует эти диапазоны как таблицы. Дополнительные сведения о том, как присвоить имя диапазону ячеек, см. в справке Microsoft Office Excel.

Чтобы добиться наилучших результатов, перед запуском мастера реконструирования настройте драйвер по умолчанию для целевой базы данных. Это гарантирует, что мастер правильно сопоставит собственные типы данных, а весь код, извлеченный мастером, будет правильно отображаться в окне "Код".

  1. На вкладке Файл выберите Создать > Программы и базы данных и дважды щелкните элемент Схема модели базы данных.

  2. На вкладке База данных в группе Управление щелкните Драйверы баз данных.

  3. На вкладке Драйверы выберите доступный в Visio драйвер для конкретной СУБД. Например, если вы проектируете базу данных Access, нужно выбрать драйвер Microsoft Access.

    Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

  4. Нажмите кнопку Настройка.

  5. На вкладке Драйверы ODBC установите флажок рядом с нужным драйвером для вашей СУБД. Например, если вы проектируете базу данных Access, нужно установить флажок Драйвер Microsoft Access (*.mdb).

  6. В каждом диалоговом окне нажмите кнопку ОК.

32-разрядный драйвер ODBC должен входить в состав пакета ODBC Data Access Pack более поздней версии, чем 2.0, и быть совместимым с уровнем 1 (или выше) стандарта ODBC. Поставщик OLE DB должен соответствовать спецификации OLE DB 1.0 или более поздней версии.

К началу страницы

Реконструирование существующей базы данных

  1. В схеме модели базы данных на вкладке База данных щелкните Реконструировать.

  2. На первом экране мастера реконструирования выполните указанные ниже действия.

    1. Выберите драйвер базы данных Microsoft Visio для своей системы управления базами данных (СУБД). Если вы еще не связали драйвер базы данных Visio с конкретным источником данных ODBC, нажмите кнопку Настройка, чтобы сделать это сейчас.

      Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

    2. Выбор источник данных для базы данных, которую вы хотите обновить. Если вы еще не создали источник данных для существующей базы данных, нажмите кнопку Создать, чтобы сделать это сейчас.

      Когда новый источник будет создан, его имя появится в списке Источники данных.

    3. Завершив настройку параметров, нажмите кнопку Далее.

    4. Следуйте инструкциям в диалоговых окнах для конкретного драйвера. Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК. Если источник данных не защищен паролем, нажмите кнопку ОК.

  3. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите кнопку Далее.

    Некоторые элементы могут быть затенены, т. е. недоступны, потому что не каждая система поддерживает все типы элементов, которые может извлечь мастер.

  4. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

    Если вы выполняете реконструирование листа Excel, а этот список пуст, скорее всего, нужно присвоить имя диапазону ячеек, которые содержат заголовки столбцов на листе.

  5. Если на шаге 3 вы установили флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или щелкните Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

  6. Укажите, нужно ли автоматически добавлять реконструируемые элементы на текущую страницу.

    Вы можете задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

  7. Просмотрите выбранные параметры, чтобы убедиться в том, что будут извлечены все необходимые данные, и нажмите кнопку Готово.

Если используется универсальный драйвер ODBC, иногда появляется сообщение об ошибке, которое означает, что реконструированная информация может быть неполной. В большинстве случаев это не указывает на реальную проблему, так что можно нажать кнопку ОК, чтобы продолжить работу мастера.

Мастер извлекает выбранные данные и отображает замечания о процедуре извлечения в окне вывода.

К началу страницы

В этой статье

Элементы, извлекаемые мастером реконструирования

Подготовка к запуску мастера

Реконструирование существующей базы данных

Не удается найти функции моделирования баз данных?

Вероятно, эти возможности отсутствуют в вашем выпуске Visio. Чтобы узнать, какой выпуск Visio у вас установлен, в меню Справка щелкните О программе Microsoft Office Visio. Название выпуска указано в верхней строке текста в диалоговом окне.

  • В выпуске Microsoft Office Visio Стандартный отсутствует шаблон "Схема модели базы данных".

  • В выпуске Microsoft Office Visio Профессиональный поддерживаются функции реконструирования для шаблона "Схема модели базы данных" (т. е. создание модели в Visio из существующей базы данных), но функции прямой разработки (т. е. создание кода SQL на основе модели базы данных в Visio) отсутствуют.

  • Полный набор функций для моделирования баз данных, включая возможности реконструирования и прямой разработки, доступен в выпуске Visio for Enterprise Architects. Visio for Enterprise Architects входит в подписку MSDN Premium, которая предлагается вместе с продуктом Visual Studio Professional и ролевыми выпусками системы Visual Studio Team System.

Элементы, извлекаемые мастером реконструирования

Элементы определения схемы, которые может извлечь мастер, зависят от сочетания различных факторов, например от возможностей системы управления базами данных (СУБД) и драйвера ODBC. Во время работы мастера вы увидите, какие элементы доступны для извлечения, и сможете выбрать нужные. Например, можно выбрать только пять таблиц из 10 и два представления из четырех.

В мастере можно задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

Извлечь можно такие элементы (при условии, что они доступны в целевой СУБД):

  • таблицы;

  • представления;

  • первичные ключи;

  • внешние ключи;

  • индексы;

  • триггеры (включая код);

  • предложения проверки (включая код);

  • хранимые процедуры (включая код).

К началу страницы

Подготовка к запуску мастера

Если вы выполняете реконструирование книги Excel, то перед запуском мастера нужно открыть ее и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. Если вы хотите использовать несколько листов, просто присвойте имя группе ячеек с заголовками столбцов на каждом из них. Мастер интерпретирует эти диапазоны как таблицы. Дополнительные сведения о том, как присвоить имя диапазону ячеек, см. в статье справки Microsoft Office Excel, посвященной определению именованных ссылок на ячейки и диапазонов ячеек.

Чтобы добиться наилучших результатов, перед запуском мастера реконструирования настройте драйвер по умолчанию для целевой базы данных. Это гарантирует, что мастер правильно сопоставит собственные типы данных, а весь код, извлеченный мастером, будет правильно отображаться в окне "Код".

  1. В меню База данных наведите указатель мыши на пункт Параметры и выберите пункт Драйверы.

  2. На вкладке Драйверы выберите доступный в Visio драйвер для конкретной СУБД. Например, если вы проектируете базу данных Access, нужно выбрать драйвер Microsoft Access.

    Примечание : Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

  3. Нажмите кнопку Настройка.

  4. На вкладке Драйверы ODBC установите флажок рядом с нужным драйвером для вашей СУБД. Например, если вы проектируете базу данных Access, нужно установить флажок Драйвер Microsoft Access (*.mdb).

  5. В каждом диалоговом окне нажмите кнопку ОК.

Примечание : 32-разрядный драйвер ODBC должен входить в состав пакета ODBC Data Access Pack более поздней версии, чем 2.0, и быть совместимым с уровнем 1 (или выше) стандарта ODBC. Поставщик OLE DB должен соответствовать спецификации OLE DB 1.0 или более поздней версии.

К началу страницы

Реконструирование существующей базы данных

  1. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

  2. В меню База данных выберите команду Реконструировать.

  3. На первом экране мастера реконструирования выполните указанные ниже действия.

    • Выберите драйвер базы данных Microsoft Office Visio для своей системы управления базами данных (СУБД). Если вы еще не связали драйвер базы данных Visio с конкретным источником данных ODBC, нажмите кнопку Настройка, чтобы сделать это сейчас.

      Примечание : Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

    • Выбор источник данных для базы данных, которую вы хотите обновить. Если вы еще не создали источник данных для существующей базы данных, нажмите кнопку Создать, чтобы сделать это сейчас.

      Когда новый источник будет создан, его имя появится в списке Источники данных.

    • Завершив настройку параметров, нажмите кнопку Далее.

    • Следуйте инструкциям в диалоговых окнах для конкретного драйвера. Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК. Если источник данных не защищен паролем, нажмите кнопку ОК.

  4. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите кнопку Далее.

    Примечание : Некоторые элементы могут быть затенены, т. е. недоступны, потому что не каждая СУБД поддерживает все типы элементов, которые может извлечь мастер.

  5. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

    Примечание : Если вы выполняете реконструирование листа Excel, а этот список пуст, скорее всего, нужно присвоить имя диапазону ячеек, которые содержат заголовки столбцов на листе.

  6. Если на шаге 3 вы установили флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или щелкните Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

  7. Укажите, нужно ли автоматически добавлять реконструируемые элементы на текущую страницу.

    Примечание : Вы можете задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

  8. Просмотрите выбранные параметры, чтобы убедиться в том, что будут извлечены все необходимые данные, и нажмите кнопку Готово.

Примечание : Если используется универсальный драйвер ODBC, иногда появляется сообщение об ошибке, которое означает, что реконструированная информация может быть неполной. В большинстве случаев это не указывает на реальную проблему, так что можно нажать кнопку ОК, чтобы продолжить работу мастера.

Мастер извлекает выбранные данные и отображает замечания о процедуре извлечения в окне вывода.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×