Рекомендации, позволяющие избежать появления неработающих формул

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Когда формулы возвращают неожиданные результаты или ошибки, это может сильно раздражать, особенно если непонятно, что делать дальше.

Причин может быть множество. Например, это может быть несоответствие количества скобок, опечатки или ссылки на данные в диапазонах, которые не существуют. В этой статье описаны рекомендации, позволяющие избежать или устранить распространенные ошибки при построении или исправлении формул.

Рекомендации

Распространенная ошибка

Начинайте каждую формулу со знака равенства (=)

Если запись начинается не со знака равенства, она не считается формулой и не вычисляется (распространенная ошибка, которую легко допустить).

Например, если ввести СУММ(A1:A10), Excel Online отобразит текстовую строку СУММ(A1:A10) вместо результата формулы. Если ввести 11/2, отобразится дата (например, "11.фев" или "11.02.2009") вместо результата деления 11 на 2.

Чтобы избежать подобных неожиданных результатов, всегда начинайте формулу со знака равенства. Например, введите =СУММ(A1:A10) и =11/2

Следите за соответствием открывающих и закрывающих скобок

Убедитесь, что у каждой скобки есть соответствующая пара. Если в формуле используется функция, для ее правильной работы важно, чтобы каждой открывающей скобке соответствовала закрывающая.

Например, формула =ЕСЛИ(B5<0);"Недопустимый";B5*1,05) не будет работать, поскольку в ней две закрывающие скобки и только одна открывающая.

Правильный вариант этой формулы выглядит следующим образом: =ЕСЛИ(B5<0;"Недопустимый";B5*1,05).

Вводите все обязательные аргументы

Большинство функций имеют обязательные аргументы — значения, которые необходимо указать, чтобы функция работала. Без аргументов работает лишь небольшое количество функций (например, ПИ или СЕГОДНЯ). Проверьте синтаксис формулы, который отображается при вводе знака равенства с именем функции, чтобы убедиться, что указаны все обязательные аргументы (нет ни лишних, ни недостающих).

Например, функция ПРОПИСН принимает в качестве аргумента только одну текстовую строку или ссылку на ячейку: =ПРОПИСН("привет") или =ПРОПИСН(C2).

Кроме того, некоторые функции, такие как СУММ, позволяют использовать только числовые аргументы, а другие, такие как ЗАМЕНИТЬ, требуют, чтобы хотя бы один аргумент был текстовым. Если использовать неправильный тип данных, некоторые функции могут вернуть неожиданные результаты или ошибку #ЗНАЧ!.

Используйте в формулах неформатированные числа

Не вводите в формулах числа со знаком доллара ($) или разделителем (;), поскольку знаки доллара используются для обозначения абсолютных ссылок, а точка с запятой — в качестве разделителя аргументов. Форматированные числа не используются при вычислении формул. Вместо $1,000 в формуле необходимо ввести 1000.

Если в качестве аргументов использовать форматированные числа, функция может вернуть неожиданные результаты вычисления или ошибку #ЧИСЛО!. Например, если ввести формулу =ABS(-2.134), чтобы найти абсолютное значение числа -2134, Excel Online отобразит ошибку #ЧИСЛО!, поскольку функция ABS принимает только один аргумент.

Результат формулы можно отформатировать с использованием десятичных разделителей и обозначений денежных единиц после ввода формулы с неформатированными числами, применив числовой формат.

Используйте правильный тип данных в ячейке

Формула может не возвратить ожидаемые результаты, если тип данных ячейки не подходит для вычислений.

Например, если ввести простую формулу =2+3 в ячейке, которая имеет текстовый формат, Excel Online не сможет вычислить введенные данные. В ячейке будет отображаться строка =2+3.

Чтобы исправить эту ошибку, измените тип данных ячейки с Текстовый на Общий, как описано ниже.

  1. Выделите ячейку.

  2. На вкладке Главная в раскрывающемся списке Числовой формат выберите пункт Общий.

  3. Нажмите клавишу F2, чтобы перевести ячейку в режим редактирования, а затем нажмите клавишу ВВОД, чтобы подтвердить формулу.

Если ввести дату в ячейку, которая имеет числовой тип данных, она может быть отображена как числовое значение, а не как дата. Чтобы это число отображалось в виде даты, в раскрывающемся списке Числовой формат выберите формат Дата.

Для умножения чисел используйте символ *

В качестве оператора умножения в формуле иногда используют крестик (x), однако вместо него необходимо использовать звездочку (*).

Если в формуле используется крестик (x), Excel Online не сможет вычислить результат и вместо него отобразит в ячейке формулу, а саму ячейку выделит с помощью пунктирной красной рамки, свидетельствующей об ошибке в формуле.

Текст в формулах необходимо заключать в кавычки

Если в формуле содержится текст, его нужно заключить в кавычки.

Например, формула ="Сегодня " & ТЕКСТ(СЕГОДНЯ();"дддд, дд.ММ") объединяет текстовую строку "Сегодня " с результатами функций ТЕКСТ и СЕГОДНЯ и возвращает в ячейке следующий результат: Сегодня понедельник, 30.05.

В формуле строка "Сегодня " содержит пробел перед закрывающей кавычкой, который соответствует пробелу между словами Сегодня и понедельник, 30 мая. Если бы текст не был заключен в кавычки, формула могла бы вернуть ошибку #ИМЯ?.

Не используйте в формуле больше 64 вложенных функций

Формула может содержать не более 64 уровней вложенности функций.

Например, формула =ЕСЛИ(КОРЕНЬ(ПИ())<2;"Меньше двух!";"Больше двух!") содержит три уровня вложенности функций: функция ПИ вложена в функцию КОРЕНЬ, которая, в свою очередь, вложена в функцию ЕСЛИ.

Не делите числовые значения на ноль

При делении одной ячейки на другую, содержащую ноль (0) или пустое значение, возвращается ошибка #ДЕЛ/0!.

Чтобы избежать этой ошибки, вложите операцию деления в функцию ЕСЛИОШИБКА. Например, введите две указанных ниже формулы в ячейки на листе.

=ЕСЛИОШИБКА(3/0;0)

=ЕСЛИОШИБКА(3/7;0)

Первая формула вернет значение 0, поскольку функция ЕСЛИОШИБКА распознает, что деление на ноль приводит к ошибке. Вторая формула вернет результат деления 3/7, который не содержит ошибку, поскольку деление на ноль не выполняется.

Чтобы вам было проще создавать формулы, также ознакомьтесь со статьей Советы и рекомендации по работе с формулами.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×