Работа с гиперссылками в Excel

Для быстрого перехода к связанным данным в другом файле или на веб-странице можно вставить гиперссылка в ячейку листа. Кроме того, гиперссылки можно вставлять в определенные элементы диаграмм.

Примечание : Большинство представленных в этой статье снимков экрана создано в Excel 2016. Если вы используете другую версию, то в ней может быть немного другой интерфейс, однако, если не указано иное, функции будут такими же.

Гиперссылка представляет собой ссылку в документе, по щелчку которой открывается другая страница или файл. Обычно ссылка указывает на другую веб-страницу, но она также может указывать на рисунок, адрес электронной почты или программу. В документе гиперссылка может быть представлена текстом или рисунком.

Когда пользователь веб-сайта щелкает гиперссылку, целевой объект отображается в веб-браузер, открывается или запускается (в зависимости от его типа). Например, гиперссылка на страницу отображает страницу в веб-браузере, а гиперссылка на AVI-файл открывает файл в проигрывателе Windows Media.

Применение гиперссылок

Гиперссылки можно использовать для следующих действий:

  • переход к файлу или веб-странице в локальной сети, интрасети или Интернете;

  • переход к файлу или веб-странице, которые предполагается создать в будущем;

  • отправка сообщения электронной почты;

  • запуск передачи файла, например его загрузки или процесса FTP.

При наведении указателя на текст или рисунок, который содержит гиперссылку, он принимает форму руки Указатель в форме руки , означающую, что выбранный объект можно щелкнуть.

Что такое URL-адрес, и как он действует

При создании гиперссылки объект, на который она указывает, обозначается адресом URL (uniform resource locator — универсальный указатель ресурсов), например

http://example.microsoft.com/news.htm

file://ИмяКомпьютера/ОбщаяПапка/ИмяФайла.htm

URL-адрес включает протокол, такой как HTTP, FTP или FILE, веб-сервер или сетевую папку, путь к файлу и его имя. Компоненты URL-адреса показаны на рисунке.

Четыре компонента URL-адреса

1. Используемый протокол (http, ftp, file)

2. Веб-сервер или расположение в сети

3. Путь

4. Имя файла

Абсолютные и относительные гиперссылки

Абсолютная ссылка содержит полный адрес, включая протокол, веб-сервер, путь к файлу и его имя.

В относительном URL-адресе отсутствуют один или несколько компонентов. Недостающие сведения содержатся на странице, содержащей URL-адрес. Например, если не указаны протокол и имя веб-сервера, в веб-браузере используются протокол и домен, например .com, .org или .edu, текущей страницы.

На страницах в Интернете часто используются относительные URL-адреса, содержащие только часть пути и имя файла. В случае перемещения файлов на другой сервер все гиперссылки продолжают работать, поскольку относительное расположение страниц при этом сохраняется. Например, пусть гиперссылка на странице Products.htm указывает на страницу apple.htm в папке Food. Если обе страницы будут перемещены в папку Food на другом сервере, URL-адрес, указанный в гиперссылке, останется правильным.

В книге Microsoft Office Excel в гиперссылках вместо пропущенных путей по умолчанию подставляется путь к активной книге. Можно задать другой адрес для использования в гиперссылках по умолчанию. После этого в диалоговом окне Вставка гиперссылки вместо полного пути нужно будет указывать только имя файла.

  1. Щелкните ячейку на листе, в которой нужно создать гиперссылку.

    Можно также выбрать объект, представляющий гиперссылку, например рисунок или элемент диаграммы.

    1. На вкладке Вставка в группе Связи нажмите кнопку Гиперссылка  Кнопка "Гиперссылка" .

    Можно также щелкнуть правой кнопкой мыши ячейку или рисунок, а затем в контекстном меню выбрать команду Гиперссылка, или нажать клавиши CTRL+K.

  2. В разделе Связать с выберите вариант новым документом.

  3. Введите имя нового файла в поле Имя нового документа.

    Совет : Для задания расположения, отличного о указанного в группе Путь, укажите его в поле Имя нового документа или нажмите кнопку Изменить для выбора нужного расположения, а затем нажмите кнопку ОК.

  4. В разделе Когда вносить правку в новый документ щелкните позже или сейчас, чтобы указать, когда нужно открыть новый файл для редактирования.

  5. В поле Текст введите текст, который будет представлять собой гиперссылку.

  6. Чтобы создать подсказку, которая будет появляться при наведении указателя на гиперссылку, нажмите кнопку Подсказка, введите нужный текст в поле Текст подсказки и нажмите кнопку ОК.

  1. Щелкните ячейку на листе, в которой нужно создать гиперссылку.

    Можно также выбрать объект, представляющий гиперссылку, например рисунок или элемент диаграммы.

    1. На вкладке Вставка в группе Связи нажмите кнопку Гиперссылка  Кнопка "Гиперссылка" .

    Можно также щелкнуть правой кнопкой мыши ячейку или рисунок, а затем в контекстном меню выбрать команду Гиперссылка, или нажать клавиши CTRL+K.

  2. В разделе Связать с выберите файлом, веб-страницей.

  3. Выполните одно из следующих действий.

    • Чтобы выбрать файл, нажмите текущая папка, а затем щелкните нужный файл.

      Можно изменить текущую папку, выбрав другую из списка Папка.

    • Чтобы выбрать веб-страницу, нажмите просмотренные страницы, а затем щелкните нужную веб-страницу.

    • Чтобы выбрать недавно использовавшийся файл, нажмите последние файлы, а затем щелкните нужный файл.

    • Можно ввести имя и расположение известного файла или веб-страницы, на которые должна указывать ссылка, в поле Адрес.

    • Для выбора веб-страницы нажмите кнопку Интернет Кнопка "Интернет" , откройте веб-страницу, на которую должна указывать ссылка, а затем вернитесь в приложение Excel, не закрывая веб-обозреватель.

  4. Если нужно создать гиперссылку на определенное место в файле или на веб-странице, нажмите кнопку Закладка, а затем дважды щелкните нужную закладка.

    Примечание : В файле или на веб-странице, на которые создается ссылка, должна быть хотя бы одна закладка.

  5. В поле Текст введите текст, который будет представлять собой гиперссылку.

  6. Чтобы создать подсказку, которая будет появляться при наведении указателя на гиперссылку, нажмите кнопку Подсказка, введите нужный текст в поле Текст подсказки и нажмите кнопку ОК.

Чтобы указать место в текущей или другой книге, можно определить имя для конечных ячеек или использовать ссылку на ячейку.

  1. Чтобы можно было использовать имя, его необходимо присвоить конечным ячейкам в нужной книге.

    Присвоение имени ячейке и диапазону ячеек

    1. Выделите ячейку, диапазон ячеек или несмежный диапазон, которому требуется присвоить имя.

    2. Щелкните поле Имя, расположенное у левого края строки формул Изображение кнопки .

      Поле "Имя"

      Изображение кнопки Поле "Имя"

    3. В поле Имя введите имя для этих ячеек, а затем нажмите клавишу ВВОД.

      Примечание : Имя не должно содержать пробелов и должно начинаться с буквы.

  2. На листе исходной книги щелкните ячейку, в которой нужно создать гиперссылку.

    Можно также выбрать объект, представляющий гиперссылку, например рисунок или элемент диаграммы.

    1. На вкладке Вставка в группе Связи нажмите кнопку Гиперссылка  Кнопка "Гиперссылка" .

    Также можно щелкнуть правой кнопкой мыши ячейку или объект, а затем в контекстном меню выбрать пункт Гиперссылка, или нажать клавиши CTRL+K.

  3. В группе Связать с выполните одно из следующих действий.

    • Чтобы создать ссылку на место в текущей книге, щелкните пункт местом в документе.

    • Для указания места в другой книге щелкните пункт файлом, веб-страницей, найдите и выберите книгу, на которую должна указывать ссылка, а затем нажмите кнопку Закладка.

  4. Выполните одно из следующих действий.

    • В поле Или выберите место в документе в разделе Ссылка на ячейку щелкните лист, на который будет указывать ссылка, введите ссылку на ячейку в поле Введите адрес ячейки, а затем нажмите кнопку ОК.

    • В списке Определенные имена щелкните имя, представляющее ячейки, на которые будет указывать ссылка, а затем нажмите кнопку ОК.

  5. В поле Текст введите текст, который будет представлять собой гиперссылку.

  6. Чтобы создать подсказку, которая будет появляться при наведении указателя на гиперссылку, нажмите кнопку Подсказка, введите нужный текст в поле Текст подсказки и нажмите кнопку ОК.

С помощью функции ГИПЕРССЫЛКА можно создать гиперссылку, которая открывает документ, расположенный на сетевом сервере, в интрасеть или Интернете. Если щелкнуть ячейку, содержащую функцию ГИПЕРССЫЛКА, приложение Excel откроет файл, расположенный в указанном ссылкой месте.

Синтаксис

ГИПЕРССЫЛКА(адрес;имя)

Адрес    — это путь и имя файла для открываемого документа. Аргумент представляет собой текст. Адрес может ссылаться на место в документе, например на определенную ячейку или именованный интервал на листе книги Microsoft Excel или на закладку в документе Microsoft Word. Путь может представлять собой путь к файлу, записанному на жестком диске, а также может быть адресом сервера в формате UNC (в Microsoft Excel для Windows) или URL-адресом в Интернете или интрасети.

  • Аргумент "адрес" может быть заключенной в кавычки текстовой строкой или ячейкой, содержащей адрес ссылки в виде текстовой строки.

  • Если определенный аргументом адрес ссылки не существует или переход не может быть выполнен, выбор соответствующей ячейки приводит к появлению сообщения об ошибке.

Имя    — текст ссылки или числовое значение, отображаемое в ячейке. Имя отображается синим цветом и с линией подчеркивания. Если аргумент опущен, в ячейке в качестве текста ссылки отображается аргумент "адрес".

  • Аргумент "имя" может быть представлен значением, текстовой строкой, именем или ячейкой, содержащей текст или значение для перехода.

  • Если аргумент "имя" возвращает значение ошибки (например, #ЗНАЧ!), вместо адреса перехода в ячейке отображается значение ошибки.

Примеры

В следующем примере открывается лист Budget Report.xls, который хранится в Интернете по адресу example.microsoft.com/report, и отображается текст "Щелкните, чтобы открыть отчет":

=HYPERLINK("http://example.microsoft.com/report/budget report.xls", "Click for report")

В следующем примере создается гиперссылка на ячейку F10 листа "Годовой" книги Budget Report.xls, адрес которой в Интернете — example.microsoft.com/report. В ячейке листа, содержащей гиперссылку, в качестве адреса перехода отображается содержимое ячейки D1:

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]Annual!F10", D1)

В следующем примере создается гиперссылка на интервал "Итоги_по_отделу" на листе "Первый квартал" книги Budget Report.xls, адрес которой в Интернете — example.microsoft.com/report. В ячейке листа, содержащей гиперссылку, отображается текст "Щелкните, чтобы просмотреть итоги по отделу за первый квартал":

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]First Quarter!DeptTotal", "Click to see First Quarter Department Total")

Чтобы создать гиперссылку на определенное место документа Microsoft Word, необходимо сначала с помощью закладки обозначить это место в документе. В следующем примере создается гиперссылка на закладку КвартПриб в документе Annual Report.doc, находящемся по адресу example.microsoft.com:

=HYPERLINK("[http://example.microsoft.com/Annual Report.doc]QrtlyProfits", "Quarterly Profit Report")

Следующий пример демонстрирует вывод в Microsoft Excel для Windows содержимого ячейки D5 как текста перехода и открытие файла 1stqtr.xls, расположенного на сервере FINANCE в каталоге общего доступа Statements. Данный пример использует адрес в формате UNC:

=HYPERLINK("\\FINANCE\Statements\1stqtr.xls", D5)

В приведенном ниже примере в Microsoft Excel для Windows открывается файл 1stqtr.xls, который находится в каталоге Finance на жестком диске D, после чего выводится число, которое содержится в ячейке H10:

=HYPERLINK("D:\FINANCE\1stqtr.xls", H10)

В следующем примере в Excel для Windows создается гиперссылка на область "Итоги" в другой (внешней) книге Mybook.xls:

=HYPERLINK("[C:\My Documents\Mybook.xls]Totals")

В следующем примере Microsoft Excel для компьютеров "Макинтош" отображает в ячейке надпись "Щелкните здесь" и открывает файл First Quarter из папки Budget Reports на жестком диске "Macintosh HD":

=HYPERLINK("Macintosh HD:Budget Reports:First Quarter", "Click here")

Гиперссылки можно создавать внутри листа для перехода от одной ячейки к другой. Например, если в книге Budget имя активного листа "Июнь", следующая формула создаст гиперссылку на ячейку E56. Текст перехода — это значение в ячейке E56.

=HYPERLINK("[Budget]June!E56", E56)

Для перехода на другой лист в той же книге измените имя листа в ссылке. В предыдущем примере для создания ссылки на ячейку E56 на листе "Сентябрь" замените слово "Июнь" на слово "Сентябрь".

Если на компьютере установлена почтовая программа, она автоматически запускается по щелчку гиперссылки на адрес электронной почты и создается новое сообщение с соответствующим адресом в поле Кому.

  1. Щелкните ячейку на листе, в которой нужно создать гиперссылку.

    Можно также выбрать объект, представляющий гиперссылку, например рисунок или элемент диаграммы.

    1. На вкладке Вставка в группе Связи нажмите кнопку Гиперссылка  Кнопка "Гиперссылка" .

    Можно также щелкнуть ячейку или объект правой кнопкой мыши, а затем в контекстном меню выбрать команду Гиперссылка, или нажать клавиши CTRL+K.

  2. В разделе Связать с выберите вариант электронной почтой.

  3. В поле Адрес эл. почты введите нужный адрес электронной почты.

  4. В поле Тема введите тему сообщения.

    Примечание : Строка темы может не распознаваться некоторыми браузерами и почтовыми программами.

  5. В поле Текст введите текст, который будет представлять собой гиперссылку.

  6. Чтобы создать подсказку, которая будет появляться при наведении указателя на гиперссылку, нажмите кнопку Подсказка, введите нужный текст в поле Текст подсказки и нажмите кнопку ОК.

    Можно создать гиперссылку на адрес электронной почты, указав его непосредственно в ячейке. Например, если ввести proverka@example.com, гиперссылка будет создана автоматически.

Можно вставить одну или несколько внешних ссылок из книги на другую книгу, расположенную в интрасеть или в Интернете. Книга должна быть сохранена как HTML.

  1. Откройте исходную книгу и выберите диапазон ячеек, которые необходимо скопировать.

  2. На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать.

    Кнопки копирования и вставки на вкладке "Главная"
  3. Перейдите к листу, на котором нужно поместить данные, и щелкните ячейку, в которой требуется их расположить.

  4. На вкладке Главная в группе Буфер обмена нажмите кнопку Специальная вставка.

  5. Выберите параметр Связать.

    Приложение Excel создаст внешнюю ссылку на ячейку или на каждую из ячеек диапазона.

Примечание : Возможно, вам будет удобнее создавать внешние ссылки, не открывая книгу в Интернете. Для каждой ячейки в целевой книге, с которой необходимо создать связь, сделайте следующее: щелкните ячейку, а затем введите знак равенства (=), URL-адрес и расположение в книге. Например:

='http://www.someones.homepage/[Файл.xls]Лист1!A1

='ftp.server.somewhere/Файл.xls'!ИменованныеЯчейки

Чтобы выбрать гиперссылка, но не переходить на назначение, выполните одно из указанных ниже действий:

  • Щелкните ячейку, содержащую гиперссылку, и удерживайте нажатой кнопку мыши, пока указатель не примет вид креста Курсор выделения Microsoft Excel . После этого отпустите кнопку мыши.

  • Выделите ячейку, содержащую ссылку, с помощью клавиш со стрелками.

  • Если ссылка является графическим объектом, нажмите клавишу CTRL и, удерживая ее нажатой, щелкните ссылку.

У существующей в книге гиперссылки можно изменить назначение, вид, текст или рисунок, представляющий гиперссылку.

Изменение адреса назначения гиперссылки

  1. Выделите ячейку или рисунок, содержащие гиперссылку, которую нужно изменить.

    Совет : Для выделения ячейки, содержащей гиперссылку, не переходя по этой ссылке, щелкните ячейку и удерживайте кнопку мыши до тех пор, пока указатель не примет форму креста Курсор выделения Microsoft Excel , а затем отпустите кнопку мыши. Для выделения ячейки можно также воспользоваться клавишами со стрелками. Для выделения рисунка щелкните его, нажав и удерживая клавишу CTRL.

    1. На вкладке Вставка в группе Связи нажмите кнопку Гиперссылка  Кнопка "Гиперссылка" .

    Можно также щелкнуть правой кнопкой мыши ячейку или рисунок, а затем в контекстном меню выбрать команду Изменить гиперссылку, или нажать клавиши CTRL+K.

  2. В диалоговом окне Изменение гиперссылки внесите нужные изменения.

    Примечание : Если гиперссылка была создана с помощью функции ГИПЕРССЫЛКА, для изменения адреса назначения необходимо отредактировать формулу. Выделите ячейку с гиперссылкой, щелкните строку формул, а затем отредактируйте формулу.

Вид текста гиперссылки в текущей книге можно изменить, изменив стиль ячеек с гиперссылками.

  1. На вкладке Главная в группе Стили нажмите кнопку Стили ячеек.

  2. В группе Данные и модель выполните указанные ниже действия.

    • Для изменения внешнего вида гиперссылок, по которым ни разу не переходили, щелкните правой кнопкой мыши пункт Гиперссылка, а затем нажмите кнопку Изменить.

    • Для изменения внешнего вида гиперссылок, по которым осуществлялся переход, щелкните правой кнопкой мыши пункт Открывавшаяся гиперссылка, а затем нажмите кнопку Изменить.

      Примечание : Стиль ячеек Гиперссылка доступен только в случае, если в книге содержится хотя бы одна гиперссылка. Стиль ячеек Открывавшаяся гиперссылка доступен только в случае, если в книге содержится хотя бы одна гиперссылка, по которой осуществлялся переход.

  3. В диалоговом окне Стиль нажмите кнопку Формат.

  4. На вкладках Шрифт и Заливка выберите нужные параметры форматирования, а затем нажмите кнопку ОК.

    Примечания : 

    • Параметры, выбранные в диалоговом окне Формат ячеек, будут выбраны и в группе Стиль включает диалогового окна Стиль. Флажки для тех параметров, которые устанавливать не нужно, можно снять.

    • Изменения в стилях ячеек Гиперссылка и Открывавшаяся гиперссылка применяются ко всем гиперссылкам текущей книги. Внешний вид отдельных гиперссылок изменить нельзя.

  1. Выделите ячейку или рисунок, содержащие гиперссылку, которую нужно изменить.

    Совет : Для выделения ячейки, содержащей гиперссылку, не переходя по этой ссылке, щелкните ячейку и удерживайте кнопку мыши до тех пор, пока указатель не примет форму креста Курсор выделения Microsoft Excel , а затем отпустите кнопку мыши. Для выделения ячейки можно также воспользоваться клавишами со стрелками. Для выделения рисунка щелкните его, нажав и удерживая клавишу CTRL.

  2. Выполните одно или несколько следующих действий.

    • Для изменения текста ссылки щелкните строка формул, а затем отредактируйте текст.

    • Для изменения формата рисунка щелкните его правой кнопкой мыши, а затем в контекстном меню выберите нужный вариант изменения формата.

    • Чтобы изменить текст в рисунке, дважды щелкните выделенный рисунок и внесите необходимые изменения.

    • Если нужно изменить рисунок, представляющий гиперссылку, добавьте новый рисунок, сделайте его гиперссылкой с тем же адресом назначения, а затем удалите старые рисунок и гиперссылку.

  1. Щелкните правой кнопкой мыши гиперссылку, которую нужно скопировать или переместить, а затем в контекстном меню выберите команду Копировать или Вырезать.

  2. Правой кнопкой мыши щелкните ячейку, в которую нужно скопировать или переместить гиперссылку, а затем в контекстном меню выберите команду Вставить.

По умолчанию пропущенные пути в гиперссылках на файлы назначения считаются относительными по отношению к расположению активной книги. Данная процедура позволяет установить требуемый путь по умолчанию. В этом случае при создании гиперссылки на файл в диалоговом окне Вставка гиперссылки необходимо будет ввести только имя файла (без указания полного пути).

Выполните одно из указанных ниже действий в зависимости от того, какая у вас версия Excel.

  • В Excel 2016, Excel 2013 и Excel 2010

    1. Откройте вкладку Файл.

    2. Нажмите кнопку Сведения.

    3. Нажмите кнопку Свойства, а затем — кнопку Дополнительные свойства.

      Дополнительные свойства
    4. На вкладке Сводка в поле База гиперссылки введите путь, который нужно использовать.

      Примечание : Базовый адрес гиперссылки можно переопределить для отдельной гиперссылки, указав полный, или абсолютный, адрес в диалоговом окне Добавление гиперссылки.

  • В Excel 2007

    1. Нажмите кнопку Microsoft Office Изображение кнопки Office , выберите пункт Подготовить, а затем нажмите кнопку Свойства.

    2. В области сведений о документе нажмите кнопку Свойства, а затем выберите пункт Дополнительные свойства.

      Дополнительные свойства
    3. Перейдите на вкладку Документ.

    4. В поле База гиперссылки введите путь, который требуется использовать.

    Примечание : Базовый адрес гиперссылки можно переопределить для отдельной гиперссылки путем использования полного, или абсолютного, адреса в диалоговом окне Добавление гиперссылки.

Чтобы удалить гиперссылку, выполните одно из следующих действий.

  • Чтобы удалить гиперссылку и текст, который ее представляет, щелкните правой кнопкой мыши ячейку, содержащую гиперссылку, а затем в контекстном меню выберите команду Очистить содержимое.

  • Чтобы удалить гиперссылку и рисунок, который ее представляет, нажав и удерживая клавишу CTRL, щелкните рисунок, а затем нажмите клавишу DELETE.

  • Чтобы удалить отдельную гиперссылку, щелкните ее правой кнопкой мыши, а затем в контекстном меню выберите команду Удалить гиперссылку.

  • Чтобы отключить несколько гиперссылок, выполните следующие действия:

    1. В пустой ячейке введите число 1.

    2. Щелкните эту ячейку правой кнопкой мыши и выберите в контекстном меню команду Копировать.

    3. Нажав и удерживая клавишу CTRL, выделите все гиперссылки, которые нужно отключить.

      Совет : Чтобы выделить ячейку, содержащую гиперссылку, не переходя по этой ссылке, щелкните эту ячейку и удерживайте кнопку мыши, пока указатель не примет вид креста Курсор выделения Microsoft Excel . После этого отпустите кнопку мыши.

    4. На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставитьи выберите пункт Специальная вставка 
      .

      Кнопки копирования и вставки на вкладке "Главная"
    5. В группе Операция выберите параметр умножить и нажмите кнопку ОК.

    6. На вкладке Главная в группе Стили нажмите кнопку Стили ячеек.

    7. В поле Хороший, плохой и нейтральный выберите значение Обычный.

См. также

Удаление и отключение гиперссылок

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×