Приступая к работе с модулем "Скачать и преобразовать" в Excel 2016

Приступая к работе с модулем "Скачать и преобразовать" в Excel 2016

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью модуля Скачать и преобразовать в Excel 2016 вы можете искать источники данных, создавать подключения, а затем формировать данные (например, удалить столбец, изменить тип данных или объединить таблицы) в соответствии со своими потребностями. Когда данные сформированы, вы можете поделиться своими выводами или использовать запрос для создания отчетов.

Шаги Power Query часто

Если рассматривать эти шаги по порядку, часто это выглядит так:

  • Подключение — создание подключений к данным, которые хранятся в облаке, в какой-либо службе или на локальном компьютере.

  • Преобразование — формирование данных в соответствии со своими потребностями (данные в источнике остаются без изменений).

  • Объединение — создание модели данных из нескольких источников данных и получение уникальных представлений данных.

  • Предоставление общего доступа — после выполнения запроса вы можете сохранить его, поделиться им или использовать его для отчетов.

На каждом этапе — при подключении к данным, их преобразовании или объединении с другими источниками данных — редактор запросов модуля Скачать и преобразовать записывает все ваши действия и позволяет изменять их. Кроме того, редактор запросов позволяет отменять и повторять шаги, менять их порядок и корректировать любой шаг. В результате вы можете создать такое представление подключенных данных, которое отвечает всем вашим пожеланиям.

С помощью модуля Скачать и преобразовать можно создавать запросы — как простые, так и сложные. Когда вы добавляете шаги в запрос, редактор запросов автоматически создает набор отдельных инструкции для выполнения ваших команд. Инструкции создаются на языке M. Пользователи, которым нравится использовать широкие и гибкие возможности сценариев, могут вручную создавать (или настраивать) запросы на языке M с помощью расширенного редактора. Все эти мощные и гибкие возможности автоматической настройки и создания сценариев вручную предлагаются в наборе функций Скачать и преобразовать в Excel 2016. Редактор запросов и расширенный редактор описаны более подробно далее в этой статье.

Чтобы создать запрос, нажмите кнопку Создать запрос на ленте Скачать и преобразовать в Excel 2016.

Кнопка "Создание запроса" в Excel 2016

Примечание : Эта технология также доступна для предыдущих версий Excel в виде надстройки Power Query, которую можно скачать, а также в составе Power BI. Чтобы узнать, как работает Power Query в предыдущих версиях Excel, ознакомьтесь со статьей Начало работы с Power Query.

Подключение

Используя запрос, вы можете подключиться к одному источнику данных, такому как база данных Access, либо к нескольким файлам, базам данных, каналам OData или веб-сайтам. С помощью модуля Скачать и преобразовать вы сможете объединить все эти источники, создавая уникальные сочетания, и выявить закономерности, которые в противном случае остались бы незамеченными.

При нажатии кнопки Создать запрос в разделе Скачать и преобразовать на вкладке Данные в меню указываются доступные источники данных. Существует большое количество источников данных, включая файлы, например книги Excel или CSV-файлы, базы данные, такие как Access, SQL Server, Oracle и MySQL, службы Azure, например HDInsight или Хранилище больших двоичных объектов, а также другие разнообразные источники, такие как Интернете, Списки SharePoint,, Файлы Hadoop, Facebook, Salesforce и т. д.

Примечание : Некоторые источники данных доступны только при наличии лицензии на выпуск "Профессиональный" или "Профессиональный плюс".

Источники данных для запроса

При подключении к источнику данных модуль Скачать и преобразовать выводит окно Навигатор, которое позволяет редактировать данные из источника. При нажатии кнопки Изменить в окне Навигатор модуль Скачать и преобразовать запускает редактор запросов — специальное окно, в котором отображаются подключения к данным и можно легко выполнять преобразования. В следующем разделе (Преобразование) вы найдете более подробные сведения о редакторе запросов.

Преобразование

С помощью модуля Скачать и преобразовать вы можете преобразовать данные из источников таким образом, чтобы было удобно их анализировать. Преобразование данных означает их изменение в соответствии с вашими потребностями. Например, вы можете удалить столбец, изменить тип данных или объединить таблицы. Все эти действия относятся к преобразованию данных. В результате преобразования данные принимают вид, необходимый вам для дальнейшего анализа. Процесс применения преобразований к одному или нескольким наборам данных часто называется формированием данных.

Для упрощения преобразования данных и отображения получаемых результатов в Excel используется специальное окно — редактор запросов. При нажатии кнопки Создать запрос в разделе Скачать и преобразовать на вкладке Данные и выборе источника данных (например, книги или базы данных), выводится окно Навигатор, в котором вы можете выбрать таблицу (или таблицы) для запроса. При выборе таблицы в правой части окна Навигатор отображается часть ее данных.

Навигатор по запросам

Если нажать кнопку Загрузить, источник данных будет перенесен непосредственно в Excel. В данном случае мы нажали кнопку Изменить, чтобы запустить редактор запросов.

Редактор запросов

Редактор запросов отслеживает все ваши действия с данными. Онзаписывает и помечает каждое преобразование (шаг), которое вы применяете к данным. Независимо от вида преобразования (подключение к данным, т. е. к источнику данных, удаление столбца, слияние данных или изменение типа данных), редактор запросов отслеживает каждую операцию в разделе ПРИМЕНЕННЫЕ ШАГИ области Параметры запроса.

Преобразования, примененные вами к подключениям к данным, в совокупности образуют ваш запрос.

Очень важно (и полезно) понимать, что действия, определенные в редакторе запросов, не изменяют исходный источник данных. Вместо этого Excel фиксирует каждый шаг, выполняемый вами при подключении к данным и их преобразовании, так что если вы закончили формировать данные, он использует моментальный снимок уточненного набора данных и загружает его в книгу.

Существует множество преобразований, которые вы можете применить к данным. Вы можете также создать собственные преобразования на языке M (с его помощью редактор запросов записывает шаги в фоновом режиме), используя расширенный редактор, доступный в редакторе запросов. Расширенный редактор можно открыть на вкладке Вид редактора запросов. В нем вы можете изменять шаги, записанные на языке M и связанные с существующим запросом. Кроме того, используя расширенный редактор, можно создавать запросы с нуля.

Расширенный редактор запросов

Создав запрос, можно нажать кнопку Закрыть и загрузить на вкладке Главная, после чего результаты запроса будут загружены в Excel и появятся на новой вкладке книги.

Дополнительные сведения об этапе преобразования:

Предоставление общего доступа

При сохранении книги Excel, содержащей запрос, он также автоматически сохраняется. Вы можете просмотреть все запросы в книге Excel, выбрав команду Показать запросы в разделе Скачать и преобразовать на вкладке Данные.

Показать запросы

В области Запросы книги отображаются все запросы, которые содержит книга.

Область "Запросы книги" в Excel 2016

Но стоит ли на этом останавливаться? С помощью каталога данных Power BI вы можете поделиться своими запросами с любым пользователем в организации. Кроме того, можно создать запрос, который вы планируете часто применять, а затем использовать его в нескольких книгах, тем самым избегая лишней работы. Вместо того чтобы сохранять книги Excel и отправлять их по электронной почте (при этом пытаясь установить, какая версия является исходной, что изменилось и не устарели ли данные), сохраните запрос в каталоге данных, и вам не придется иметь дело с бесчисленным количеством неконтролируемых версий книги, заполонивших почтовые ящики. Просто щелкните правой кнопкой мыши запрос в области Запросы книги, и откроется меню с разнообразными командами, в том числе Отправить в каталог данных.

Пункт "Отправить в каталог данных"

Обратите внимание и на другие пункты контекстного меню. С помощью команды Создать дубликат можно создать дубликат запроса, что позволяет изменить некоторые или все элементы запроса, не редактируя исходный запрос. Это похоже на создание шаблона запроса, который затем можно изменять, чтобы получать специализированные наборы данных (например, один набор данных для розничных продаж, другой — для оптовой торговли, а третий — для складских запасов), причем все они будут основаны на одном и том же подключении к данным.

Вы можете также превращать запросы в стандартные блоки для повторного использования с помощью команд Слияние и Добавить.

Вы также можете опубликовать книгу в Power BI и создавать веб-отчеты, которые можно отправлять группе, уточнять и автоматически обновлять. Чтобы опубликовать книгу в Power BI, выберите Файл > Опубликовать > Опубликовать в Power BI. Пункт "Опубликовать в Power BI"

Примечание : Для публикации в Power BI книга должна быть сохранена в OneDrive для бизнеса.

Готовый запрос можно использовать для создания отчетов в Excel или Power BI. В следующем разделе вы найдете ссылки на статьи, посвященные созданию отчетов. Ознакомьтесь с ними, чтобы узнать, как наилучшим образом воспользоваться результатами проделанной вами работы по формированию данных в модуле Скачать и преобразовать.

Дополнительные сведения о предоставлении общего доступа:

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×