Преобразование печатного бюллетеня для использования в Интернете

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

В приложении Publisher создается печатный бюллетень. Но как можно использовать эту же публикацию в Интернете? Есть два варианта:

  • Из печатного бюллетеня можно создать веб-узел.

  • Можно изменить файл печатного бюллетеня в формате PDF или XPS-файл и затем опубликовать его на веб-сайт, созданный в Publisher.

Отправка по электронной почте сообщения, содержащего ссылку на веб-бюллетень, позволяет снизить почтовые расходы и охватить широкую аудиторию.

Предполагаемое действие:

Создание веб-сайта на основе печатного бюллетеня

Преобразование печати публикации в файлы формата PDF или XPS для публикации в Интернете

Публикация файлов в Интернете

Создание веб-узла из печатного бюллетеня

Перед преобразованием бюллетеня

Важно : Внесите все необходимые изменения в печатный бюллетень перед его преобразованием в веб-публикацию. После начала преобразования печатного бюллетеня некоторые параметры редактирования становятся недоступны. (Например, после использования для преобразования печатного бюллетеня в веб-публикацию мастера Преобразовать в веб-публикацию параметр Столбцы в области задач Параметры страницы становится недоступен).

Может понадобиться внесение некоторых изменений в печатный бюллетень, чтобы сделать его более удобным для чтения в веб-обозревателе. Перед преобразованием печатного бюллетеня в веб-публикацию решите, нужно ли выполнить следующие преобразования:

  • Если полный текст статьи не находится на одной странице, рассмотрите возможность помещения статьи на одну страницу для облегчения чтения. Или же можно после преобразования публикации использовать взаимные гиперссылки разделов статьи друг на друга.

  • Если последняя страница печатного бюллетеня содержит замещающий текст почтового адреса клиента и контактных сведений компании, возможно понадобиться удалить страницу, изменить сведения или переместить контактные сведения на другие страницы.

  • Текст в одной колонке на веб-страницах воспринимается легче, чем его многоколоночный вариант, поэтому рассмотрите возможность изменения многоколоночного бюллетеня в одноколоночную веб-публикацию с помощью параметров в группе Столбцы области задач Параметры страницы.

    Примечание : Изменение выбора колонок должно выполняться для каждой страницы публикации отдельно.

  • У печатного бюллетеня есть особенности, которые характерны для печатного издания и не нужны для Интернета. Номера страниц в оглавлении и на каждой странице публикации, а также сведения о почтовом адресе для сообщений клиентов являются примерами элементов, характерных для печатных изданий и которые может понадобиться удалить.

Преобразование печатного бюллетеня в веб-публикацию

После внесения необходимых изменений в печатную публикацию можно переходить к ее преобразованию.

Преобразование печатного бюллетеня на веб-бюллетень

  1. Запустите приложение Publisher.

  2. В списке Последние публикации выберите файл печатного бюллетеня. (Или нажмите кнопку Из файла, найдите и выберите файл существующего бюллетеня, а затем откройте его).

  3. Внесите все необходимые изменения в содержимое или макет бюллетеня (например, переместите многостраничную статью на одну страницу, измените многоколоночный макет на одноколоночную публикацию, удалите область почтовых адресов для сообщений клиентов или удалите элементы макета, характерные для печатных изданий).

  4. В меню Файл выберите команду Преобразовать в веб-публикацию.

  5. В группе Сохранение текущей веб-публикации выполните одно из следующих действий:

    • Для сохранения измененной версии печатного бюллетеня перед его преобразованием щелкните Да.

      Или по завершении работы мастера можно сохранить преобразованную публикацию под новым именем, если в меню Файл выбрать команду Сохранить как, а затем ввести новое имя файла.

      Примечание : При выборе того же имени файла, которое использовалось для исходной публикации, будет выполнена перезапись исходной публикации.

    • Для преобразования бюллетеня без сохранения измененной версии печатного бюллетеня щелкните Нет.

  6. Нажмите кнопку Далее.

  7. В группе Добавление панели навигации выполните выполните одно из следующих действий:

    • Чтобы добавить панель навигации в преобразованную веб-публикацию, щелкните Да.

    • Чтобы не добавлять панель навигации в преобразованную веб-публикацию, щелкните Нет.

      Важно : Когда панели навигации отсутствуют, посетители веб-узла не смогут получить доступ к другим страницам веб-публикации. Однако панель навигации можно добавить даже после преобразования бюллетеня.

  8. Нажмите кнопку Готово.

  9. Если на шаге 5 был выбран вариант сохранения измененной версии печатного бюллетеня, в диалоговом окне Сохранить как предоставляется новое имя файла для измененной версии печатного бюллетеня. Сохраните измененную печатную публикацию с новым описательным именем файла, например, «Июль2008Изменен», изменив предложенное имя в поле Имя файла, а затем в списке Тип файла выберите Веб-страница в одном файле или Веб-страница с фильтром.

    Важно : Если сохранить печатную публикацию под именем, предложенным по умолчанию, печатная публикация будет перезаписана.

    Примечание : Используя имя файла, отличное от имени исходной печатной публикации, можно гарантировать неизменность исходной печатной публикации бюллетеня.

  10. Внесите необходимые изменения в преобразованную веб-публикацию. (Например, можно изменить положение панели навигации).

  11. Сохраните новую веб-публикацию, введя описательное имя файла, например, «Июль2008Интернет».

Настройка панели навигации

Если панель навигации была добавлена при преобразовании публикации, может понадобиться настроить положение панели навигации таким образом, чтобы она располагалась в одном и том же месте на каждой странице. Хорошее место для размещения представляет собой верхнее поле каждой страницы, особенно если создана горизонтальная панель навигации для эффективного использования пространства экрана.

Добавление новой панели навигации

Если при преобразовании бюллетеня панель навигации не была добавлена, ее можно добавить позже, выполнив следующую процедуру:

  1. В меню Вставка выберите пункт Панель переходов, а затем — команду Создать.

  2. В диалоговом окне Библиотека макетов выберите нужный макет и параметры панели навигации.

    Примечание : Для создания ссылок, имеющих как состояние невыбранной (отображается цвет по умолчанию), так и состояние выбранной (при щелчке этой ссылки отображается другой цвет), установите флажок Отображать выделенное состояние.

  3. В группе Автоматическое обновление выполните одно из следующих действий:

    • Для обновления панели навигации путем добавления ссылки на каждую существующую страницу публикации установите флажок Обновить панель навигации ссылками на существующие страницы в публикации.

    • Для указания вручную страниц, на которые должны быть ссылки на панели навигации, снимите флажок Обновить панель навигации ссылками на существующие страницы в публикации, а затем задайте страницы, на которые необходимы ссылки, используя варианты в диалоговом окне Свойства панели навигации.

  4. Нажмите кнопку Добавить объект.

Изменение текста на панели навигации

  1. Выберите панель навигации на любой странице.

  2. Выберите текст, который необходимо изменить, а затем введите новый текст, которым нужно заменить исходный.

    Текст изменится на панели навигации на каждой странице.

Автоматическое добавление ссылок на панель навигации

Если добавить страницы в веб-бюллетень, в существующую навигационную панель могут быть автоматически добавлены ссылки на эти страницы.

  1. Выберите навигационную панель на любой странице.

  2. В меню Формат выберите пункт Свойства панели навигации.

  3. В диалоговом окне Свойства панели навигации установите флажок Добавить на эту панель навигации ссылки на новые страницы, добавленные в эту публикацию.

Добавление ссылок в навигационную панель вручную

  1. В преобразованной публикации нажмите кнопку на панели навигации и нажмите кнопку Мастер кнопка «Мастер» .

  2. В диалоговом окне Свойства панели навигации нажмите кнопку Добавить ссылку.

  3. В диалоговом окне Добавление ссылки в группе Связать с выберите команду Местом в документе.

  4. В группе Выберите место в документе выберите страницу, на которую должен выполняться переход по ссылке из панели навигации.

  5. В поле Текст введите нужный текст ссылки, который будет отображаться на панели навигации, а затем нажмите кнопку ОК.

  6. В диалоговом окне Свойства панели навигации нажмите кнопку ОК.

Преобразование оглавления печатного бюллетеня в оглавление веб-публикации

Если в печатном бюллетене содержалось оглавление с указанием всех статей и их номеров страниц, это оглавление может стать панелью навигации, содержащей ссылки на все страницы веб-публикации.

На первую страницу публикации можно поместить сокращенное оглавление со ссылками на определенные статьи. Удалите номера страниц и отформатируйте названия статей в виде гиперссылок на соответствующие статьи.

Форматирование названия статей в виде гиперссылки

  1. Выделите название статьи в оглавлении.

  2. В меню Вставка выберите пункт Гиперссылка.

  3. В списке Связать с выберите команду Местом в документе.

  4. В группе Выберите место в документе выберите страницу, которую нужно связать с названием, а затем нажмите кнопкуОК.

Другие настройки для веб-сайта

Свойства форматирования печатных публикаций, которые некорректно отображаются в веб-обозревателях, недоступны в режиме «Веб». После преобразования приложением Publisher печатной публикации в веб-публикацию необходимо выполнить дополнительные настройки форматирования публикации, чтобы подготовить ее для размещения в Интернете.

После преобразования текст больше не обтекает автоматически вокруг рамок рисунков. Если рамка рисунка находится сверху текстовой рамки, текст будет скрыт. Можно либо переместить или изменить размер текстовой рамки, либо переместить рамку рисунка так, чтобы эти рамки не перекрывались.

Обычно пустые поля между текстовыми рамками и краями публикации больше, чем необходимо на веб-узле. Текстовые рамки и рамки рисунков можно настраивать для оптимального заполнения пустого пространства.

Шрифтовые схемы, доступные для веб-публикаций, отличаются от шрифтовых схем, применяемых в печатных публикациях. Шрифты, использовавшиеся в печатном бюллетене, не преобразуются автоматически в шрифты, которые оптимальны для Интернета. Рекомендуется все шрифты в преобразованном бюллетене заменить на веб-шрифты, чтобы сделать их более удобными для чтения в веб-обозревателях.

Выбор схемы веб-шрифтов

  1. Выделите часть текста в публикации.

  2. В меню Формат выберите пункт Шрифт.

  3. Убедитесь, что в диалоговом окне Шрифт в группе Общие установлен флажок Отображать только веб-шрифты.

  4. В меню Формат выберите пункт Шрифтовые схемы.

  5. Выберите один из шрифтов в списке Применить шрифтовую схему.

    Шрифтовая схема для всей публикации преобразуется в шрифты, которые удобны для просмотра веб-публикации.

Изменение размера страницы при преобразовании

Можно заметить, что после преобразования печатной публикации в веб-публикацию размер страницы изменяется. Дополнительное пространство внизу страницы позволяет перемещать текстовые рамки и рамки рисунков с других страниц на одну страницу для упрощения веб-узла.

Проверка графики

Просмотрите форматы файлов всех графических изображений в бюллетене. Если в исходном бюллетене содержались фотографии или иллюстрации высокого разрешения, воспользуйтесь программой редактирования изображений, например, Microsoft Picture It! или Microsoft Digital Image Pro, для изменения размеров графики и ее повторного сохранения в формате, подходящем для Интернета. Это приведет к уменьшению времени загрузки файла.

В меню Сервис выберите пункт Диспетчер графики для быстрого просмотра всех рисунков в публикации.

Возвращение к исходной публикации

Примечание : Если бюллетень был преобразован в веб-публикацию, а затем требуется вернуться к исходному бюллетеню, нет необходимости использовать команду Преобразовать в печатную публикацию в меню Файл. Данная команда преобразует уже преобразованный файл и изменяет исходную публикацию. Вместо этого в меню Файл нужно выбрать команду Открыть, а затем найти исходную публикацию бюллетеня.

Предварительный просмотр веб-узла

  1. В меню Файл выберите команду Просмотр веб-страницы.

  2. Веб-узел откроется в окне веб-обозревателя. С помощью гиперссылок в публикации и ссылок на панелях веб-навигации, можно переходить со страницы на страницу.

Публикация бюллетеня как веб-узла в Интернете

Завершив редактирование, вы будете готовы создать фактические веб-файлами. Следуйте инструкциям, предоставленный поставщиком услуг Интернета (ISP) для публикации веб-сайта и прочтите раздел файлы на веб-узел публикации этой статьи.

Найдите краткий обзор публикация файлы в файлы на веб-узел публикациив Интернете ниже.

К началу страницы

Преобразование печати публикации в файлы формата PDF или XPS для публикации в Интернете

Перед публикацией файлов Publisher в Интернете следует преобразовать их в файлы формата PDF или XPS.

Примечание : Сохранить файл в формате PDF или XPS из программы выпуск 2007 системы Microsoft Office можно только после установки надстройки. Дополнительные сведения см. в статье Включение поддержки других форматов файлов, таких как PDF и XPS.

Ссылки на сведения о сохранении файлов Publisher в форматах, доступных для просмотра другими пользователями, см. в разделе См. также.

Сохранение файлов Publisher как PDF или XPS-файлы

Чтобы сохранить публикацию в формате PDF

Этот параметр используется для сохранения публикации в формате, который распространен, легко доступен для всех и используется многими типографиями.

  1. В приложении Publisher откройте публикацию, которую должны просматривать другие пользователи.

  2. В меню Файл выберите пункт Опубликовать как PDF или XPS.

  3. В списке Тип файла диалогового окна Опубликовать как PDF или XPS выберите PDF, а затем нажмите кнопку Сохранить.

    Публикация сохраняется по умолчанию как имя публикацииPDF-файл в папке Мои документы на вашем компьютере. Нажмите кнопку Изменить и выберите пункт стандартный или минимальный размер в диалоговом окне Параметры публикации. Эти параметры предназначены для просмотра в браузере.

Можно также сохранить публикацию в формате PDF с помощью диалогового окна Сохранить как.

Чтобы сохранить публикацию в формате XPS

Этот параметр используется, если публикацию необходимо сохранить с большим уровнем сжатия, чем при сохранении в формате PDF, и одновременно высокого качества печати файла для настольного принтера.

  1. В приложении Publisher откройте публикацию, которую должны просматривать другие пользователи.

  2. В меню Файл выберите пункт Опубликовать как PDF или XPS.

  3. В списке Тип файла в диалоговом окне Опубликовать как PDF или XPS выберите Документ XPS, а затем нажмите кнопку Сохранить.

    Публикация сохраняется по умолчанию как имя публикациирасширением XPS в папке Мои документы на вашем компьютере. Публикация будет оптимизированные для высокое качество печати, но может быть изменено в более низкое значение, нажав кнопку Изменить.

Можно также сохранить публикацию в формате XPS с помощью диалогового окна Сохранить как.

К началу страницы

Публикация файлов на веб-узле

Можно опубликовать на веб-сайт веб-сервер, на сетевом сервере, сервер передачи файлов (FTP) или в папку на своем компьютере.

Публикация веб-сайта в расположение в Интернете или в сети

Чтобы опубликовать на веб-сайт на World Wide Web (WWW), необходимо подписаться на поставщиком услуг размещения веб-узла. На веб-серверах поставщиком услуг размещения веб-узел предоставляет Internet access и место для хранения. Прежде чем публиковать на веб-сайт, обратитесь в ваш поставщик услуг Интернета (ISP) или системному администратору, чтобы получить сведения, которые вам нужно опубликовать унифицированный указатель ресурсов (URL) веб-сайт, где вы можете сохранять файлы.

  1. В меню Файл выберите пункт Поместить на веб-узел.

  2. В поле Имя файла диалогового окна Опубликовать на веб-узле введите URL-адрес сетевого или веб-сервера, на котором нужно сохранить веб-узел — например, http://www.northwindtraders.com — а затем нажмите кнопку Сохранить.

  3. Если потребуется, введите имя пользователя и пароль, а затем нажмите кнопку ОК.

    Каталог, связанный с адресом URL, появится в диалоговом окне Опубликовать на веб-узле.

  4. Щелкните два раза ту папку, в которую требуется сохранить веб-узел.

  5. В поле Имя файла выберите index в качестве стандартного имени домашней страницы, а затем нажмите кнопку Сохранить.

  6. В ответ на запрос нажмите кнопку ОК.

Публикация веб-сайта с помощью FTP

Перед выполнением данной процедуры свяжитесь с поставщиком услуг Интернета или системным администратором для получения сведений, необходимых для публикации на FTP-узле. Понадобится также создать FTP-узел в папке Адреса FTP.

Инструкции

  1. В меню Файл выберите команду Поместить на веб-узел.

  2. В списке Папка выберите Адреса FTP.

  3. Дважды щелкните пункт Добавить/изменить адреса FTP.

  4. Введите информацию, полученную у поставщика услуг Интернета, и нажмите кнопку ОК.

  5. Нажмите кнопку Отмена.

  1. В меню Файл выберите пункт Поместить на веб-узел.

  2. В списке Папка выберите Адреса FTP.

  3. В списке FTP-узлов дважды щелкните нужный узел, а затем дважды щелкните папку, в которой необходимо опубликовать этот веб-узел.

    Примечание : Если поставщик услуг Интернета требует использования специальной программы для загрузки веб-узла или если веб-узел публикуется в корпоративной сети, может потребоваться сохранить версию веб-узла в специальном формате HTML-файла и выполнить другую процедуру публикации веб-узла. Обратитесь к поставщику услуг Интернета или системному администратору для получения сведений о порядке сохранения и публикации веб-узла.

Сохранение веб-сайта в папку на компьютере

  1. В меню Файл выберите пункт Поместить на веб-узел.

  2. В списке Папка диалогового окна Опубликовать на веб-узле выберите дисковод или папку, где нужно опубликовать веб-узел, например, папку Мои документы.

    Если веб-узел необходимо добавить в новую папку, щелкните правой кнопкой мыши то место, куда нужно добавить новую папку, выберите команду Создать, щелкните вариант Папку для создания новой папки, а затем введите имя новой папки в поле Имя.

  3. В поле Имя файла введите имя файла для домашней страницы.

  4. Нажмите кнопку Сохранить.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×