Представление данных на кольцевой диаграмме

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью Microsoft Excel, можно быстро включить данные в кольцевая диаграмма и затем с помощью новых функций форматирования легче читать, кольцевая диаграмма. Например путем добавления условных обозначений, метки данных и текстовые поля, которые определяют каждого звонить кольцевая диаграмма представляет, можно быстро понять данных, построенные на диаграмме.

Форматированная кольцевая диаграмма

После создания кольцевой диаграммы вы можете повернуть секторы, чтобы представить данные в различных перспективах, акцентировать внимание на определенных секторах, отделив их от диаграммы, или изменить размер отверстия, чтобы увеличить или уменьшить секторы.

Примечание : Начиная с Office 2016, будут удалены кольцевые диаграммы оно учитывало звезда диаграммы.

Выберите нужное действие

Дополнительные сведения о представлении данных в виде кольцевой диаграммы

Создание сложной кольцевой диаграммы

Поворот секторов на кольцевой диаграмме

Отделение секторов на кольцевой диаграмме

Изменение размера отверстия в кольцевой диаграмме

Сохранение диаграммы в качестве шаблона

Дополнительные сведения о представлении данных в виде кольцевой диаграммы

Данные, которые находятся на листе только в столбцах или строках, можно представить в виде кольцевой диаграммы. Как и круговая диаграмма, кольцевая диаграмма показывает отношение частей к целому, но она может включать более чем один ряд данных. Каждый ряд данных, нанесенный на кольцевую диаграмму, добавляет к ней кольцо. Первый ряд данных отображается в центре диаграммы.

Из-за их циклической природы кольцевые диаграммы, не удобные для восприятия, особенно если отобразить несколько рядов данных. Пропорции кольца внешние и внутренние кольца не объем данных, точно представляют — точек данных на внешнее кольца может отображаться больше, чем точек данных на внутреннее кольца во время их фактических значений может быть меньше. Отображение значений и процентов в подписи данных очень полезна на кольцевой диаграмме, но если требуется сравнить рядом друг с другом точек данных, следует использовать гистограмма с накоплением или Нормированная линейчатая диаграмма вместо.

Кольцевые диаграммы рекомендуется использовать, если:

  • Требуется отобразить один или несколько рядов данных.

  • Все значения, которые требуется отобразить, неотрицательны.

  • Среди значений, которые вы хотите отобразить, нет нулей (0).

  • Имеется не более семи категорий на каждый ряд данных.

  • Категории соответствуют частям целого в каждом кольце кольцевой диаграммы.

При создании кольцевой диаграммы вы можете выбрать один из следующих подтипов:

  • Кольцевая.    Этот тип диаграммы показывает данные в виде колец, каждое из которых представляет набор данных. Если в подписях данных отображаются проценты, каждое кольцо в сумме должно давать 100%.

    Кольцевая диаграмма

  • Разрезанная кольцевая диаграмма.    Подобно разрезанным круговым диаграммам, разрезанные кольцевые диаграммы отображают вклад каждого значения в общее, одновременно выделяя отдельные значения, но они могут содержать более одного ряда данных.

    Разрезанная кольцевая диаграмма

Кольцевые диаграммы и разрезанные кольцевые диаграммы недоступны в трехмерном варианте, но вы можно использовать объемное форматирование, чтобы сделать их похожими на трехмерные.

К началу страницы

Создание сложной кольцевой диаграммы

Форматированная кольцевая диаграмма

Итак, как была создана эта кольцевая диаграмма? Следующая процедура поможет вам создать аналогичную кольцевую диаграмму. Для этой диаграммы мы использовали данные из листа примера. Вы можете скопировать эти данные на свой лист или использовать собственные.

  1. Откройте лист, содержащий данные, которые вы хотите отобразить в виде кольцевой диаграммы, или скопируйте данные примера в пустой лист.

    Копирование данных листа примера

    1. Создайте пустую книгу или лист.

    2. Выделите пример в разделе справки.

      Примечание : Не выделяйте заголовки строк или столбцов.

      Выделение примера в справке
      Выделение примера в справке
    3. Нажмите клавиши CTRL+C.

    4. Выделите на листе ячейку A1 и нажмите клавиши CTRL+V.

    1

    2

    3

    4

    A

    B

    C

    2005

    2006

    Европа

    12 704 714,00 $

    17 987 034,00 $

    Азия

    8 774 099,00 $

    12 214 447,00 $

    США

    12 094 215,00 $

    10 873 099,00 $

  2. Выделите данные, которые вы хотите отобразить на кольцевой диаграмме.

  3. На вкладке Вставка в группе Диаграммы нажмите кнопку Другие диаграммы.

    Изображение ленты Excel

  4. В группе Кольцевая выберите Кольцевая.

  5. Щелкните область построения кольцевой диаграммы.

    Откроется панель Работа с диаграммами с дополнительными вкладками Конструктор, Макет и Формат.

  6. На вкладке Конструктор в группе Макеты диаграммы щелкните макет диаграммы, который вы хотите использовать.

    Изображение ленты Excel

    Для нашей кольцевой диаграммы использовался Макет 6.

    Макет 6 включает легенду. Если у диаграммы слишком много записей легенды или их трудно различить, вы можете добавить метки данных к точкам данных вместо отображения легенды (вкладка Макет, группа Подписи, кнопка Подписи данных).

  7. На вкладке Конструктор в группе Стили диаграмм выберите стиль, который требуется использовать.

    Изображение ленты Excel

    Для нашей кольцевой диаграммы использовался Стиль 26.

  8. Чтобы изменить размер диаграммы, сделайте следующее:

    1. Щелкните диаграмму.

    2. На вкладке Формат в группе Размер введите нужный размер в поля Высота фигуры и Ширина фигуры.

      В данном примере для кольцевой диаграммы была задана высота 10 см и ширина 14 см.

  9. Чтобы изменить размер отверстия, сделайте следующее:

    1. Щелкните ряд данных или выберите его из списка элементов диаграммы (вкладка Формат, группа Текущий фрагмент, поле Элементы диаграммы).

      Изображение ленты Excel

    2. На вкладке Формат в группе Текущий фрагмент нажмите кнопку Формат выделенного.

    3. Нажмите кнопку Параметры ряда, а затем в поле Диаметр отверстия перетащите ползунок до требуемого размера или введите значение в процентах (от 10 до 90) в поле Процент.

      Для этой кольцевой диаграммы мы использовали 20%.

  10. Чтобы метки данных были лучше видны, сделайте следующее:

    1. Щелкните один раз метку данных, чтобы выделить метки данных для всего ряда, или выберите метки из списка элементов диаграммы (вкладка Формат, группа Текущий фрагмент, поле Элементы диаграммы).

    2. На вкладке Формат в группе Стили фигур нажмите кнопку Дополнительно Изображение кнопки и щелкните стиль фигуры.

      Стили фигур на ленте Excel

      Для нашей кольцевой диаграммы использовался Слабый эффект — Темный 1.

    3. Повторите эти действия для форматирования меток данных для всех рядов данных на своей кольцевой диаграмме.

  11. Чтобы изменить и отформатировать название диаграммы, сделайте следующее:

    1. Щелкните название диаграммы или выберите его из списка элементов диаграммы (вкладка Формат, группа Текущий фрагмент, поле Элементы диаграммы).

    2. Введите нужный текст и нажмите клавишу ВВОД.

    3. На вкладке Формат в группе Стили фигур нажмите кнопку Дополнительно Изображение кнопки и щелкните стиль фигуры.

      Для нашей кольцевой диаграммы использовался Средний эффект — Акцент 1.

    4. Чтобы изменить расположение названия, перетащите его в нужное место.

  12. Чтобы изменить формат легенды, щелкните ее, а затем выберите необходимый стиль в поле Стили фигур (вкладка Формат в группе Стили фигур, кнопка Дополнительно Изображение кнопки ).

  13. Чтобы добавить текстовые подписи со стрелками, указывающими на кольца диаграммы, сделайте следующее:

    1. На вкладке Макет в группе Вставка нажмите кнопку Надпись.

    2. Щелкните место на диаграмме, куда вы хотите поместить надпись, введите требуемый текст, а затем нажмите клавишу ВВОД.

    3. Выделите текстовое поле, а затем на вкладке Формат в группе Стили фигур нажмите кнопку вызова диалогового окна Изображение кнопки .

    4. Щелкните Надпись, а затем в группе Автоподбор установите флажок Подгонять размер фигуры под текст и нажмите кнопку ОК.

    5. В группе Стили фигур выберите стиль, который вы хотите использовать.

    6. На вкладке Макет в группе Вставка нажмите кнопку Фигуры.

    7. В разделе Линии щелкните элемент Стрелка.

    8. На диаграмме нарисуйте стрелку от угла надписи до того кольца диаграммы, на которое она должна указывать.

    9. Чтобы изменить формат надписей, щелкните надпись, а затем выберите необходимый стиль в группе Стили фигур (вкладка Формат, группа Стили фигур).

      Повторите эти шаги для всех колец на кольцевой диаграмме.

  14. Чтобы изменить фон диаграммы, сделайте следующее:

    1. Щелкните область диаграммы или выберите ее из списка элементов диаграммы (вкладка Формат, группа Текущий фрагмент, поле Элементы диаграммы).

    2. На вкладке Формат в группе Стили фигур нажмите кнопку Дополнительно Изображение кнопки и щелкните стиль фигуры.

      Для нашей кольцевой диаграммы использовался Слабый эффект — Акцент 3.

  15. Чтобы скруглить углы фона диаграммы, сделайте следующее:

    1. На вкладке Формат в группе Стили фигур щелкните кнопку вызова диалогового окна Изображение кнопки .

    2. Щелкните Стили границ и установите флажок Скругленные углы.

  16. Если вы не хотите использовать цвета темы, которая по умолчанию применяется к книге, сделайте следующее:

    1. На вкладке Разметка страницы в группе Темы нажмите кнопку Темы.

      Изображение ленты Excel

    2. В группе Встроенные выберите тему, которую вы хотите использовать.

      Для нашей кольцевой диаграммы использовалась тема Апекс.

К началу страницы

Поворот секторов на кольцевой диаграмме

Последовательность, в которой ряд данных отображаются на кольцевой диаграмме Office Excel 2007, определяется их порядком на листе. Для получения другой перспективы вы можете повернуть секторы диаграммы в пределах 360 градусов.

Повернутая кольцевая диаграмма

  1. Щелкните на кольцевой диаграмме ряд или точку данных или выберите их из списка элементов диаграммы, выполнив следующие действия:

    1. Щелкните диаграмму.

      Откроется панель Работа с диаграммами с дополнительными вкладками Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный ряд данных или точку данных.

      Изображение ленты Excel

  2. На вкладке Формат в группе Текущий фрагмент нажмите кнопку Формат выделенного.

  3. В поле Угол поворота первого сектора перетащите ползунок до требуемого угла поворота или введите число от 0 до 360, чтобы задать угол, определяющий положение первого сектора.

К началу страницы

Отделение секторов на кольцевой диаграмме

Чтобы выделить отдельные секторы на кольцевой диаграмме, можно при ее создании использовать тип разрезанной кольцевой диаграммы. Этот тип диаграммы показывает вклад каждого значения в общую сумму, выделяя отдельные значения. Вы можете изменить настройки разреза кольцевой диаграммы для всех или для отдельных секторов.

Разрезанная кольцевая диаграмма

Вы также можете отделять сектора вручную.

Кольцевая диаграмма с отделенным сектором

Изменение настроек секторов для разрезанной кольцевой диаграммы

  1. Щелкните на разрезанной кольцевой диаграмме ряд или точку данных или выберите ряд данных из списка элементов диаграммы, выполнив следующие действия:

    1. Щелкните диаграмму.

      Откроется панель Работа с диаграммами с дополнительными вкладками Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите ряд данных.

      Изображение ленты Excel

  2. На вкладке Формат в группе Текущий фрагмент нажмите кнопку Формат выделенного.

  3. В поле Разрезанная кольцевая диаграмма перетащите ползунок, чтобы увеличить или уменьшить процент разделения, или введите требуемое значение в поле Процент.

Отделение секторов на кольцевой диаграмме вручную

Щелкните кольцевую диаграмму, а затем выполните одно из следующих действий:

  • Чтобы отделить друг от друга все секторы в кольцевой диаграмме, перетащите их от центра диаграммы.

  • Чтобы отделить определенный сектор кольцевой диаграммы, выберите его и перетащите его от центра диаграммы.

К началу страницы

Изменение размера отверстия в кольцевой диаграмме

Увеличивая или уменьшая размер отверстия на кольцевой диаграмме, можно изменять ширину колец. Например, вам может потребоваться сделать кольца более широкими, чтобы на них помещались подписи данных, содержащие длинные имена рядов или категорий либо сочетание имен, значений и процентов.

  1. Щелкните на кольцевой диаграмме ряд данных или выберите его из списка элементов диаграммы, выполнив следующие действия:

    1. Щелкните диаграмму.

      Откроется панель Работа с диаграммами с дополнительными вкладками Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите ряд данных.

      Изображение ленты Excel

  2. На вкладке Формат в группе Текущий фрагмент нажмите кнопку Формат выделенного.

  3. В поле Диаметр отверстия перетащите ползунок до требуемого размера или введите значение в процентах (от 10 до 90) в поле Процент.

К началу страницы

Сохранение диаграммы в качестве шаблона

Если вы хотите создавать аналогичные диаграммы на основе созданной диаграммы, можно сохранить ее в качестве шаблона.

  1. Щелкните диаграмму, которую требуется сохранить как шаблон.

  2. На вкладке Конструктор в группе Тип нажмите кнопку Сохранить как шаблон.

    Изображение ленты Excel

  3. В поле Имя файла введите имя шаблона.

    Совет : Если не задана другая папка, CRTX-файл шаблона сохраняется в папку Диаграммы. При этом шаблон становится доступен в разделе Шаблоны как в диалоговом окне Вставка диаграммы (вкладка Вставка, группа Диаграммы, кнопка вызова диалогового окна Изображение кнопки ), так и в диалоговом окне Изменение типа диаграммы (вкладка Конструктор, группа Тип, Изменить тип диаграммы).

    Дополнительные сведения о том, как применение шаблона диаграммы Сохранение диаграммы как шаблонасм.

Примечание : Шаблон диаграммы содержит форматирование диаграммы и сохраняет цветов, которые используются при сохранении диаграммы в качестве шаблона. При использовании шаблона диаграммы, чтобы создать диаграмму в другой книге, новой диаграммы используются цвета шаблона диаграммы — не цветов темы документа, примененную к книге. Использование цвета темы документа вместо цвета шаблона диаграммы, щелкните правой кнопкой мыши в области диаграммы и в контекстном меню выберите команду Сброс совпадение стиль.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×