Получение данных из служб Analysis Services

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Службы Analysis Services предоставляют многомерные данные, которые хорошо подходят для просмотра в сводных таблицах и отчетах Power View. Вы можете получить данные Analysis Services из следующих источников:

  • кубы OLAP на многомерном сервере служб Analysis Services;

  • табличные модели служб Analysis Services на табличном сервере;

  • Книги на SharePoint 2010 или более поздней версии, Excel, если книга содержит модель данных.

Вы можете анализировать данные из внешнего источника данных Analysis Services с помощью сетевого подключения. При сведении, фильтрации отчетов или создании в них срезов приложение Excel запрашивает нужные данные в службах Analysis Services. Для такого анализа данных требуется сетевое подключение к источнику данных.

Кроме того, поддерживается автономный режим. Для работы в автономном режиме нужно импортировать данные в книгу, чтобы данные и визуализации отчетов были самодостаточными и полностью содержались в одном файле. Помните, что для импорта данных требуются надстройка Power Pivot, знание многомерных выражений и место на диске для хранения больших книг. В этой статье объясняется, как импортировать данные из различных источников служб Analysis Services.

Книги Excel, сохранить в SharePoint или Office 365 регулируемых Максимальный размер файла. С помощью мастера импорта таблиц в надстройке Power Pivot, выборочно Импорт таблиц, столбцов и строк, чтобы уменьшить общий размер файла. Если книга слишком большая, чтобы просмотреть в Excel Online, вы можно открыть в в Microsoft Excel.

Office 365 запрещает обновление данных из внешних источников, в том числе из служб Analysis Services, которые работают на серверах в сети. Если вам требуется обновлять данные, выберите SharePoint или используйте сетевой файловый ресурс.

В этой статье

Необходимые условия

Подключение к кубу, табличной модели или модели данных Power Pivot

Импорт данных из куба

Импорт данных из табличной модели

Импорт данных из модели данных книги на SharePoint

Обновление данных из внешней базы данных Analysis Services

Необходимые условия

Кубы служб Analysis Services должны иметь версию SQL Server 2005 или более поздней версии.

Табличная модель базы данных Analysis Services, только в SQL Server 2012 или более поздней версии.

Вы должны знать, как подключаться к базе данных Analysis Services. Обратитесь к администратору базы данных Analysis Services, чтобы получить имена сервера и базы данных, а также учетные данные.

Для импорта данных в модель данных требуются надстройка Power Pivot, которая входит в состав Office профессиональный плюс. Также может потребоваться знать, как написать запрос многомерных выражений, который извлекает нужные данные. Вместо написания запроса многомерных выражений можно выбрать нужные меры, атрибуты измерения и иерархии в построителе запросов.

Для подключения к сводной таблице или сводной диаграмме в интерактивном режиме через Excel знание многомерных выражений не требуется. Excel подключается ко всему кубу OLAP или табличной модели.

Размер файла, вероятно, будет больше того, к чему вы привыкли. Например, книга, использующая подключение к данным, часто может быть меньше 100 килобайт, тогда как эта же книга с импортированными данными будет в десять раз больше. Если на диске мало места, вам нужно освободить его для больших файлов.

Power Pivot книги, которые можно использовать в качестве источников данных могут быть опубликованы в SharePoint 2010 или более поздней версии. Сайт SharePoint должен быть запущен на другом компьютере, который используется для создания отчета. Просмотр разрешений необходимо иметь на сайте SharePoint в отчет для книг в SharePoint.

Подключение к кубу, табличной модели или модели данных Power Pivot

Самым простым способом анализа данных в кубе или модели Analysis Services является подключение к внешней базе данных. В сводной таблице или отчете будет динамическое подключение к источнику данных. Каждый раз при перетаскивании поля в область "Значения", "Строки", "Столбцы" или "Фильтр" списка полей фильтра приложение Excel строит запрос и отправляет его в службы Analysis Services.

Динамическое подключение к анализируемым данным имеет свои преимущества. Вы можете анализировать данные так, как вам угодно. Добавьте любое поле в сводную таблицы или отчет, и службы Analysis Services вернут требуемые данные. Список полей, подключенных к службам Analysis Services, включает все объекты в кубе или модели, поэтому вам не придется писать многомерные выражения для получения нужных данных.

Недостатки заключаются в зависимости от подключения к серверу. Если сервер отключается или вы работаете в автономном режиме, взаимодействие с данными полностью останавливается.

К началу страницы

Импорт данных из куба

Любые данные, которые содержатся в базе данных SQL Server Analysis Services, можно скопировать в модель данных в Excel. Вы можете извлечь все измерения или их часть, получить срезы и агрегаты из куба, например суммы продаж по месяцам за текущий год.

Ниже показано, как использовать надстройку и многомерные выражения для получения подмножества данных из обычного куба в экземпляре служб Analysis Services. Многомерные выражения всегда используются при построении запроса с помощью надстройки Power Pivot.

В этой процедуре импорт подмножества куба рассматривается на примере базы данных Adventure Works DW Multidimensional 2012. Если у вас есть доступ к серверу Analysis Services, на котором расположен пример базы данных Adventure Works DW Multidimensional 2012, выполните эти инструкции для знакомства с импортом данных из служб Analysis Services.

  1. В окне Power Pivot выберите Получение внешних данных > Из базы данных > Из служб Analysis Services или Power Pivot.

  2. В окне Подключение к службам Microsoft SQL Server Analysis Services в поле Имя сервера или файла введите имя компьютера, на котором выполняются службы Analysis Services.

  3. Щелкните стрелку вниз с правой стороны от списка Имя базы данных и выберите базу данных служб Analysis Services. Например, если имеется доступ к образцу базы данных Adventure Works DW Multidimensional 2012, необходимо выбрать Adventure Works DW Multidimensional 2012.

  4. Нажмите кнопку Проверить соединение для проверки доступности сервера служб Analysis Services.

  5. Нажмите кнопку Далее.

  6. На странице Задание запроса многомерных выражений нажмите кнопку Конструктор, чтобы открыть построитель запросов MDX.

    На этом шаге необходимо перетащить в большую область конструирования запросов все меры, атрибуты измерения, иерархии и вычисляемые элементы, которые будут импортированы.

    Выберите по крайней мере одну меру и одно или несколько измерений.

    Если вы хотите использовать существующую инструкцию многомерных выражений, вставьте ее в текстовое поле и нажмите кнопку Проверить, чтобы убедиться в ее работоспособности. Дополнительные сведения об использовании конструктора см. в статье Конструктор запросов многомерных выражений служб Analysis Services (Power Pivot).

    В этой процедуре, используя в качестве примера куб Adventure Works, выполните следующее.

    1. На панели Метаданные разверните элемент Меры, а затем — элемент Sales Summary (Сводка продаж).

    2. Перетащите Average Sales Amount (Средний объем продаж) на большую панель конструктора.

    3. На панели Метаданные разверните измерение Product (Товар).

    4. Перетащите Product Categories (Категории товаров) налево от элемента Average Sales Amount на большой панели конструктора.

    5. На панели Метаданные разверните измерение Date (Дата), а затем — элемент Calendar (Календарь).

    6. Перетащите Date.Calendar Year (Дата.Календарный год) налево от элемента Category (Категория) на большой панели конструктора.

    7. Кроме того, можно использовать фильтр для импорта подмножества данных. В области в правом верхнем углу конструктора для элемента Измерение перетащите элемент Date в поле измерения. На вкладке Иерархия выберите Date.Calendar Year; для элемента Оператор выберите Не равно; для элемента Критерий фильтра щелкните стрелку вниз и выберите CY 2009 и CY 2010.

      В результате создается фильтр для куба, исключающий значения за 2009 год.

  7. Нажмите кнопку ОК и проверьте запрос MDX, который был создан с помощью конструктора запросов.

  8. Введите понятное имя для набора данных. Это имя будет использоваться в качестве имени таблицы в модели данных. Если не назначить новое имя, по умолчанию результаты запроса сохраняются в новую таблицу с именем "Запрос".

  9. Нажмите кнопку Готово.

  10. После завершения загрузки данных нажмите кнопку Закрыть.

Все данные, которые импортируются из базы данных куба, имеют плоский формат. В вашей модели данные отображаются в виде одной таблицы, содержащей все столбцы, которые вы указали в запросе. Если вы определили запрос, который получает меры с несколькими измерениями, данные будут импортированы для каждого измерения в отдельном столбце.

После импорта данных в модель данных желательно проверить тип столбцов, в которых содержатся числовые и финансовые данные. При обнаружении пустых значений Power Pivot изменяет тип данных на "Текст". Чтобы проверить и изменить тип данных, выберите столбец и просмотрите значение Тип данных в группе Форматирование на ленте. Если числовые или финансовые данные имеют неверный тип, для его исправления можно использовать поле "Тип данных".

Чтобы использовать данные в сводной таблице, переключитесь обратно в Excel:

  1. Выберите Вставка > Таблицы > Сводная таблица.

  2. Щелкните Использовать внешний источник данных и Выбрать подключение.

  3. Щелкните Таблицы.

  4. В поле Модель данных этой книги выберите таблицу, которую вы только что импортировали.

К началу страницы

Импорт данных из табличной модели

Ниже на примере табличной базы данных объясняется, как импортировать данные. Вы можете использовать пример Adventure Works Tabular Model SQL 2012 на табличном сервере Analysis Services.

  1. Убедитесь, что табличная база данных содержит по крайней мере одну меру. Импорт завершится ошибкой, если в базе данных нет мер. Если вы используете пример, он включает в себя меры.

  2. В окне Power Pivot выберите Получение внешних данных > Из базы данных > Из служб Analysis Services или Power Pivot.

  3. В окне Подключение к службам Microsoft SQL Server Analysis Services в поле Имя сервера или файла введите имя компьютера, на котором выполняются службы Analysis Services.

  4. Щелкните стрелку вниз справа от списка Имя базы данных и выберите базу данных Analysis Services. Например, если у вас есть доступ к примеру базы данных AW Internet Sales Tabular Model, выберите Adventure Works Tabular Model SQL 2012.

  5. Нажмите кнопку Проверить соединение для проверки доступности сервера служб Analysis Services.

  6. Нажмите кнопку Далее.

  7. На странице Задание запроса многомерных выражений нажмите кнопку Конструктор, чтобы открыть построитель запросов MDX.

    На этом шаге необходимо перетащить в большую область конструирования запросов все меры, столбцы и иерархии, которые вы хотите импортировать.

    Если вы хотите использовать существующую инструкцию многомерных выражений, вставьте ее в текстовое поле и нажмите кнопку Проверить, чтобы убедиться в ее работоспособности. Дополнительные сведения об использовании конструктора см. в статье Конструктор запросов многомерных выражений служб Analysis Services (Power Pivot).

    В этой процедуре, используя пример модели, выполните следующее.

    1. В области Метаданные разверните элемент Меры, а затем — Internet Sales (Продажи через Интернет).

    2. Перетащите Internet Total Sales (Общие продажи через Интернет) на большую панель конструктора.

    3. Разверните таблицу Product (Товар).

    4. Прокрутите список вниз и перетащите поле Category так, чтобы оно выводилось слева от Internet Total Sales в большой области конструирования. Это иерархия, поэтому она будет возвращать все поля в иерархии.

    5. Разверните таблицу Date (Дата).

    6. Перетащите поле Calendar Year (Календарный год) так, чтобы оно выводилось слева от Category на большой панели конструктора.

    7. Разверните элемент Sales Territory (Территория продаж).

    8. Перетащите элемент Sales Territory Region (Регион территории продаж) в область фильтра в верхней части конструктора. В качестве выражения фильтра выберите Australia (Австралия).

      Запрос многомерных выражений для примера табличной базы данных

  8. Нажмите кнопку ОК и проверьте запрос MDX, который был создан с помощью конструктора запросов.

  9. Введите понятное имя для набора данных. Это имя будет использоваться в качестве имени таблицы в модели данных. Если не назначить новое имя, по умолчанию результаты запроса сохраняются в новую таблицу с именем "Запрос".

  10. Нажмите кнопку Готово.

  11. После завершения загрузки данных нажмите кнопку Закрыть.

После импорта данных в модель данных желательно проверить тип столбцов, в которых содержатся числовые и финансовые данные. При обнаружении пустых значений Power Pivot изменяет тип данных на "Текст". Чтобы проверить и изменить тип данных, выберите столбец и просмотрите значение Тип данных в группе Форматирование на ленте. Если числовые или финансовые данные имеют неверный тип, для его исправления можно использовать поле "Тип данных".

Чтобы использовать данные в сводной таблице, переключитесь обратно в Excel:

  1. Выберите Вставка > Таблицы > Сводная таблица.

  2. Щелкните Использовать внешний источник данных и Выбрать подключение.

  3. Щелкните Таблицы.

  4. В поле Модель данных этой книги выберите таблицу, которую вы только что импортировали.

К началу страницы

Импорт данных из модели данных книги на SharePoint

SharePoint может потребоваться дополнительное программное обеспечение для загрузки данных. Если вы используете SharePoint 2010, необходимо иметь Power Pivot для SharePoint 2010. В отличие от SharePoint 2013 или более поздняя версия включает встроенную функцию для загрузки и запросы модели данных. Если вы используете SharePoint, обратитесь к администратору SharePoint включить и настроить для рабочих нагрузок BI службы Excel.

  1. В окне Power Pivot выберите Получение внешних данных > Из базы данных > Из служб Analysis Services или Power Pivot.

  2. На вкладке Соединение со службами Microsoft SQL Server Analysis Services в поле Понятное имя соединения введите описательное имя для подключения к данным. Использование описательных имен для соединения поможет не забыть, как используется данное соединение.

  3. В поле Имя сервера или файла введите URL-адрес опубликованного XLSX-файла, например: http://Contoso-srv/Shared Documents/ContosoSales.xlsx.

    Примечание : Локальную книгу Excel использовать в качестве источника данных нельзя. Книга должна быть опубликована на сайте SharePoint.

  4. Нажмите кнопку Проверить соединение для проверки доступности книги в SharePoint.

  5. Нажмите кнопку Далее.

  6. Нажмите Конструирование.

  7. Постройте запрос, перетащив меры, атрибуты измерений или иерархии в большую область конструирования. Можно также использовать панель фильтров в верхнем правом углу для выбора импортируемого подмножества данных.

  8. Нажмите кнопку ОК.

  9. Нажмите кнопку Проверить.

  10. Нажмите кнопку Готово.

Данные Power Pivot копируются в модель данных и сохраняются в сжатом формате. После импорта данных подключение к книге закрывается. Чтобы выполнить повторный запрос исходных данных, обновите книгу в Excel.

К началу страницы

Обновление данных из внешней базы данных Analysis Services

В Excel на вкладке Данные в группе Подключения нажмите кнопку Обновить все, чтобы повторно подключиться к базе данных Analysis Services и обновить данные в книге.

При этом обновляются отдельные ячейки и добавляются строки, появившиеся во внешней базе данных с момента последнего импорта. Обновляются только строки и существующие столбцы. Если вы хотите добавить в модель новый столбец, вам необходимо импортировать его, выполнив действия, описанные выше в этой статье.

При обновлении повторно выполняется запрос, который применялся для импорта данных. Если источник данных был перемещен либо если таблицы или столбцы были удалены или переименованы, выполнить обновление не удастся, но ранее импортированные данные останутся. Чтобы просмотреть запрос, используемый при обновлении данных, на вкладке Power Pivot нажмите кнопку Управление. Откроется окно Power Pivot. Затем на вкладке Конструктор нажмите кнопку Свойства таблицы.

Службы Analysis Services используют вашу учетную запись пользователя Windows для чтения данных из баз данных. Чтобы вы могли импортировать данные, администратор базы данных должен предоставить вашей учетной записи пользователя Windows разрешения на чтение для базы данных. Эти же разрешения используются для обновления данных. Если другим пользователям необходимо обновлять данные, им также нужны разрешения на чтение базы данных.

Помните, что как общий доступ к книге определяет, может возникнуть ли обновления данных. В Office 365 невозможно обновить данные в книге, которая хранится в Office 365. На сервере SharePoint Server 2013 или более поздней версии вы можете планировать обновления автоматической данных на сервере, но при этом требуется, Power Pivot для SharePoint установлены и настроены в среде SharePoint. Обратитесь к своему администратору SharePoint, чтобы выяснить, доступен ли запланированное обновление данных.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×