Подсчет числа или даты, по условию

Подсчет числа или даты, которые соответствуют одного условия (например, равно, больше, чем меньше, чем больше или равно или меньше или равно), используйте функцию СЧЁТЕСЛИ . Для подсчета числа или даты, которые входят в определенный диапазон (например, больше чем 9000 на том же время и меньше, чем 22500), можно использовать функцию СЧЁТЕСЛИМН . Кроме того можно использовать функцию СУММПРОИЗВ слишком.

Пример

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

A

B

Продавец

Счет

Егоров

15 000

Егоров

9 000

Гладких

8 000

Гладких

20 000

Егоров

5 000

Туманов

22 500

Формула

Описание (результат)

=СЧЁТЕСЛИ(B2:B7;">9000")

Функция СЧЁТЕСЛИ подсчитывает число ячеек в диапазоне B2:B7, значения которых больше 9000 (4).

=СЧЁТЕСЛИ(B2:B7;"<=9000")

Функция СЧЁТЕСЛИ подсчитывает число ячеек в диапазоне B2:B7, значения которых меньше 9000 (4).

=СЧЁТЕСЛИМН(B2:B7;">=9000";B2:B7;"<=22500")

Функция СЧЁТЕСЛИМН (доступна в Excel 2007 и более поздних версиях приложения) подсчитывает число ячеек в диапазоне B2:B7, значения которых больше или равны 9000 и меньше или равны 22500 (4).

=СУММПРОИЗВ((B2:B7>=9000)*(B2:B7<=22500))

Функция СУММПРОИЗВ подсчитывает число ячеек в диапазоне B2:B7, значения которых больше или равны 9000 и меньше или равны 22500 (4). Эту функцию можно использовать в Excel 2003 и более ранних версиях, в которых функция СЧЁТЕСЛИМН не поддерживается.

Дата

11.03.2011

01.01.2010

31.12.2010

30.06.2010

Формула

Описание (результат)

=СЧЁТЕСЛИ(B14:B17;">01.03.2010")

Подсчитывает число ячеек в диапазоне B14:B17, в которых указана дата после 01.03.2010 (3).

=СЧЁТЕСЛИ(B14:B17;"31.12.2010")

Подсчитывает число ячеек в диапазоне B14:B17 с датой 31.12.2010 (1). Знак равенства в условии не обязателен и поэтому не указывается (формула будет работать и со знаком равенства ("=31.12.2010").

=СЧЁТЕСЛИМН(B14:B17;">=01.01.2010";B14:B17;"<=31.12.2010")

Подсчитывает число ячеек в диапазоне B14:B17 с датами в интервале от 01.01.2010 до 31.12.2010 включительно (3).

=СУММПРОИЗВ((B14:B17>=ДАТАЗНАЧ("01.01.2010"))*(B14:B17<=ДАТАЗНАЧ("31.12.2010")))

Подсчитывает число ячеек в диапазоне B14:B17 с датами в интервале от 01.01.2010 до 31.12.2010 включительно (3). В данном примере показано, как обойтись без функции СЧЁТЕСЛИМН, которая впервые появилась в Excel 2007. Функция ДАТАЗНАЧ преобразует даты в числовые значения, с которыми может работать функция СУММПРОИЗВ.

Примечания : 

  • Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

  • Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала. Вместе с другими участниками сообщества Майкрософт вы можете улучшить эту статью с помощью Community Translation Framework (CTF). Просто наведите указатель мыши на предложение в статье и выберите команду "УЛУЧШИТЬ ПЕРЕВОД" в мини-приложении CTF. Для получения дополнительных сведений о CTF щелкните здесь. Используя CTF, вы соглашаетесь с нашими условиями предоставления услуг.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×