Подсчет символов в ячейках

Если вам нужно подсчитать символы в ячейках, используйте функцию ДЛСТР. Она вычисляет количество букв, цифр, символов и всех пробелов. Например, длина фразы "На улице сегодня 25 градусов, я пойду купаться" (не учитывая кавычки) составляет 46 символов: 36 букв, 2 цифры, 7 пробелов и запятая.

  • Чтобы использовать эту функцию, введите =ДЛСТР(ячейка) в строку формул и нажмите клавишу ВВОД. В этих примерах ячейка — это ячейка, количество символов в которой нужно подсчитать, например B1.

  • Чтобы подсчитать символы в нескольких ячейках, введите формулу и протяните маркер заполнения через необходимый диапазон ячеек.

Ввод нескольких функций ДЛСТР на листе

  • Чтобы посчитать общее количество символов в нескольких ячейках, используйте функцию СУММ вместе с функцией ДЛСТР. Например, =СУММ((ДЛСТР(ячейка1);ДЛСТР(ячейка2);(ДЛСТР(ячейка3)))). В этом примере функция ДЛСТР считает символы в каждой ячейке, а функция СУММ слагает результаты.

Попробуйте попрактиковаться

Используйте примеры из следующей книги, чтобы увидеть, как работает функция ДЛСТР.

Скопируйте таблицу ниже и вставьте ее на лист Excel, начиная с ячейки A1. Перетащите формулу из ячейки B2 в диапазон ячеек B3:B4, чтобы увидеть длину текста в ячейках столбца A.

Текстовые строки

Формулы

Съешь же еще этих мягких

=ДЛСТР(A2)

Съешь же еще этих мягких французских булок

Съешь же еще этих мягких французских булок, да выпей чаю.

Подсчет символов в одной ячейке

  1. На Листе1 этой книги с примерами щелкните ячейку B2.

  2. Введите в ячейку формулу =ДЛСТР(A2) и нажмите клавишу ВВОД.

Формула подсчитает количество символов в ячейке А2. Их 24, включая пробелы. Если после конечной точки есть пробелы, они тоже учитываются.

Подсчет символов в нескольких ячейках

  1. В книге с примерами щелкните ячейку В2.

  2. Введите в ячейке =ДЛСТР(A2).

  3. Нажмите клавиши CTRL+C, чтобы скопировать содержимое ячейки B2, а затем CTRL+V, чтобы вставить формулу из нее в диапазон ячеек B3:B4.

Так формула копируется в ячейки B3 и B4, и функция подсчитывает символы в каждой ячейке (24, 42 и 57).

Подсчет общего количества символов

  1. В книге с примерами щелкните ячейку В6.

  2. Введите в ячейке формулу =СУММ(ДЛСТР(A2);ДЛСТР(A3);ДЛСТР(A4)) и нажмите клавишу ВВОД.

Так подсчитывается количество символов в каждой из трех ячеек, а затем значения суммируются (123).

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×