Подсчет символов в ячейках в Excel 2016 для Mac

Если вам нужно подсчитать символы в ячейках, используйте функцию ДЛСТР. Она вычисляет количество букв, цифр, символов и всех пробелов. Например, длина фразы "На улице сегодня 25 градусов, я пойду купаться" (не учитывая кавычки) составляет 46 символов: 36 букв, 2 цифры, 7 пробелов и запятая.

  • Чтобы использовать эту функцию, введите =ДЛСТР(ячейка) в строку формул и нажмите клавишу ВВОД. В этих примерах ячейка — это ячейка, количество символов в которой нужно подсчитать, например B1.

  • Чтобы подсчитать символы в нескольких ячейках, введите формулу, а затем скопируйте и вставьте ее в другие ячейки.

  • Чтобы посчитать общее количество символов в нескольких ячейках, используйте функцию СУММ вместе с функцией ДЛСТР. Например, =СУММ((ДЛСТР(ячейка1);ДЛСТР(ячейка2);(ДЛСТР(ячейка3)))). В этом примере функция ДЛСТР считает символы в каждой ячейке, а функция СУММ слагает результаты.

  • Для подсчета определенных, конкретных символов в ячейках используйте функцию ДЛСТР в сочетании с функцией ПОДСТАВИТЬ. Например, если вы хотите узнать, сколько строчных букв "ъ" находится в ячейке, воспользуйтесь такой формулой: =ДЛСТР(ячейка1)-ДЛСТР(ПОДСТАВИТЬ(ячейка1;"ъ";""))

Попробуйте попрактиковаться

Введите приведенные ниже данные на новый лист Excel. Начните с ячейки A1.

Текстовые строки

Формулы

Съешь же еще этих мягких

Съешь же еще этих мягких французских булок

Съешь же еще этих мягких французских булок, да выпей чаю

Подсчет символов в одной ячейке

  1. Щелкните ячейку B2.

  2. Введите в ячейку формулу =ДЛСТР(A2) и нажмите клавишу ВВОД.

Формула подсчитает количество символов в ячейке А2. Их 24, включая пробелы. Если после конечной точки есть пробелы, они тоже учитываются.

Подсчет символов в нескольких ячейках

  1. Нажмите клавиши CONTROL+C, чтобы скопировать ячейку B2.

  2. Нажмите клавиши CONTROL+V, чтобы вставить формулу из нее в ячейки B3:B4.

Формула будет скопирована в ячейки B3 и B4, а функция подсчитает символы в каждой ячейке (42 и 56).

Подсчет общего количества символов

  1. Щелкните ячейку B6.

  2. Введите в ячейке формулу =СУММ(ДЛСТР(A2);ДЛСТР(A3);ДЛСТР(A4)) и нажмите клавишу ВВОД.

Эта формула подсчитывает количество символов в каждой из трех ячеек, а затем значения суммируются (122).

Подсчет количества определенных символов в ячейках

  1. Щелкните ячейку C4.

  2. Введите в ячейку формулу =ДЛСТР(A4)-ДЛСТР(ПОДСТАВИТЬ(A4;"ъ";"")) и нажмите клавишу ВВОД.

Эта формула подсчитывает количество строчных букв "ъ" в ячейке A4 (1).

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×