Подсчет количества уникальных значений среди повторяющихся

Предположим, что вы хотите узнать, сколько уникальных текстовых и числовых значений в диапазоне есть. Например, если столбец содержит текст значения Руслан "," Сергей "," Сергей, Сергей, имеется два уникальных значения — Руслан и Сергей. Если диапазон содержит числа 5, 6, 7, 6, уникальные значения — 5, 6 и 7.

Чтобы подсчитать только уникальные значения, используйте следующие функции:

  • Используйте функции Если для присвоения значения 1 каждому истинному условию.

  • Используется функция сумм для сложения уникальных значений.

  • Функция частота позволяет выполнить подсчет количества уникальных значений. Эта функция игнорирует текстовые и нулевые значения. Первое вхождение конкретное значение она возвращает число равно количество вхождений значения. Для каждого случая того же значения после первого эта функция возвращает значение 0.

  • Функция ПОИСКПОЗ используется для возврата позиции текстового значения в диапазоне. Функция частота использует результирующее значение рассчитывается соответствующих текстовых значений.

  • Функция LEN используется для поиска пустых ячеек. Пустые ячейки иметь длину 0 (количество символов).

Пример

Скопируйте таблицу в ячейку A1 на пустом листе в Excel для работы с примерами формул, использующих функции.

Данные

Данные

986

Руслан

Дмитрий

563

67

789

235

Руслан

Дмитрий

689

789

Дмитрий

143

56

237

67

235

Формула

Описание (результат)

=СУММ(ЕСЛИ(ЧАСТОТА(A2:A10,A2:A10)>0,1))

Подсчет количества уникальных числовых значений в диапазоне A2:A10 без учета пустых ячеек и текстовых значений (4)

=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B10,B2:B10,0),ПОИСКПОЗ(B2:B10,B2:B10,0))>0,1))

Подсчет количества уникальных текстовых и числовых значений в диапазоне B2:B10, который не должен содержать пустые ячейки (7)

=СУММ(ЕСЛИ(ЧАСТОТА(ЕСЛИ(ДЛСТР(A2:A10)>0,ПОИСКПОЗ(A2:A10,A2:A10,0),""),ЕСЛИ(ДЛСТР(A2:A10)>0,ПОИСКПОЗ(A2:A10,A2:A10,0),""))>0,1))

Подсчет количества уникальных текстовых и числовых значений в диапазоне A2:A10 без учета пустых ячеек и текстовых значений (6)

Примечания : 

  • В формулах в этом примере должны быть введены как формулы массива. Выделите все ячейки, содержащие формулы, нажмите клавишу F2 и нажмите клавиши Ctrl + Shift + Ввод.

  • Чтобы просмотреть процесс вычисления функции по шагам, выделите ячейку с формулой, а затем на вкладке Формулы в группе Зависимости формул нажмите кнопку Вычисление формулы.

Примечания : 

  • Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

  • Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала. Вместе с другими участниками сообщества Майкрософт вы можете улучшить эту статью с помощью Community Translation Framework (CTF). Просто наведите указатель мыши на предложение в статье и выберите команду "УЛУЧШИТЬ ПЕРЕВОД" в мини-приложении CTF. Для получения дополнительных сведений о CTF щелкните здесь. Используя CTF, вы соглашаетесь с нашими условиями предоставления услуг.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×