Подсчет количества вхождений значения

Некоторые функции листа могут помочь узнать, сколько раз встречается определенный текст или число в диапазоне ячеек. Например, с помощью функции СЧЁТЕСЛИ можно посчитать, сколько раз встречается одно значение (см. пример ниже).

Пример

Продавец

Счет

Грачев

15 000

Грачев

9 000

Шашков

8 000

Шашков

20 000

Грачев

5 000

Нагайчук

22 500

Формула

Описание

Результат

=СЧЁТЕСЛИ(A2:A7,"Грачев")

Количество вхождений фамилии Грачев (3)

3

=СЧЁТЕСЛИ(A2:A7,A4)

Количество вхождений фамилии Шашков (2)

2

=СЧЁТЕСЛИ(B2:B7,"< 20000")

Число счетов с суммой, меньшей 20 000 (4)

4

=СЧЁТЕСЛИ(B2:B7,">="&B5)

Число счетов с суммой, большей или равной 20 000 (2)

2

Подсчет значений на основе нескольких условий с помощью функции СЧЁТЕСЛИМН

Функция СЧЁТЕСЛИМН аналогична функции СЧЁТЕСЛИ с одним важным исключением: СЧЁТЕСЛИМН позволяет применить условия к ячейкам в нескольких диапазонах и подсчитывает число соответствий каждому условию. С функцией СЧЁТЕСЛИМН можно использовать до 127 пар диапазонов и условий. Синтаксис функции имеет следующий вид:

СЧЁТЕСЛИМН(диапазон_условия1; условие1; [диапазон_условия2; условие2]; …)

Пример

Код сотрудника

Номер региона

Отдел

20552

2

Продажи

21268

2

Финансы

23949

1

Администратор

24522

4

Администратор

28010

3

ИТ

29546

4

Продажи

31634

3

ИТ

32131

1

ИТ

35106

4

Финансы

40499

1

Управление персоналом

42051

1

Продажи

43068

2

Управление персоналом

45382

2

Финансы

47971

1

ИТ

Формула

Описание

Результат

=СЧЁТЕСЛИМН(B2:B15,"2",C2:C15,"Финансы")

Количество сотрудников в регионе 2 и в отделе финансов

2

Первый диапазон условий — это номера регионов, а второй — названия отделов. В первом диапазоне применяются условия со значением "2", а во втором — условия со значением "Финансы". Функция СЧЁТЕСЛИМН проверяет соответствие обоим условиям.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×