Office

Подготовка источника данных Excel к слиянию в Word

Вы создали список контактов и других данных, который хотите использовать для слияния в Word. Если в качестве источника данных используется таблица Excel, то достаточно подготовить данные для слияния. Но если источником данных является файл со значениями, разделенными табуляциями (TXT) или запятыми (CSV), сначала следует импортировать данные в Excel, а затем подготовить их для слияния.

Шаг 1. Настройка источника данных в Excel

Если вы используете электронную таблицу Excel в качестве источника данных для слияния в Word, пропустите этот шаг. Если источником данных является TXT- или CSV-файл, мастер импорта текста поможет вам отформатировать данные в Excel.

После импорта TXT- или CSV-файла перейдите к шагу 2.

  1. Откройте Excel.

  2. Щелкните Данные > Из текстового/CSV-файла.

    Выбор текстового или CSV-файла на вкладке "Данные"

  3. Выберите нужный TXT- или CSV-файл и нажмите кнопку Импорт.

  4. В окне предварительного просмотра нажмите кнопкуПреобразование данных.

  5. Выберите столбец, содержащий почтовые индексы, или другой столбец, который нужно отформатировать.

  6. Выберите Преобразование > Тип данных: > Текст.

    Окно Power Query с выделенным элементом "Текст"

  7. Нажмите кнопку Заменить текущий.

  8. При необходимости повторите шаги 5–7.

  9. Выберите Закрыть и загрузить.

  10. Выберите Файл > Сохранить как и сохраните файл с другим именем.

  1. Откройте Excel.

  2. Excel 2016    Выберите Данные > Получение внешних данных > Из текста.

    На вкладке "Данные" выделен параметр "Из текста".

  3. Выберите нужный TXT- или CSV-файл и нажмите кнопку Импорт.

  4. В мастере импорта текста в области Формат исходных данных выберите С разделителями.

    Получение внешних данных из текста, мастер импорта текста, шаг 1 из 3

  5. При необходимости выберите элемент Мои данные содержат заголовки над областью Предварительный просмотр, а затем нажмите кнопку Далее.

  6. В области Разделители установите нужный флажок (например, "знак табуляции" или "запятая") и нажмите кнопку Далее.

    Параметры разделителей выделены в мастере импорта текста.

  7. В области Образец разбора данных выберите столбец, содержащий почтовые индексы, а затем в списке Формат данных столбца выберите Текстовый.

    В мастере импорта текста выделен параметр "Текст" в разделе "Формат данных столбца".

    Примечание: Каждый раз, когда вы применяете формат ("общий", "текстовый" или "дата") к столбцу, в его заголовке отображается имя формата.

  8. При необходимости повторите действие 7, выбрав столбец, который вы хотите изменить, и нужный формат данных.

  9. Нажмите кнопку Finish (Готово).

  10. В диалоговом окне Импорт данных примите значение по умолчанию (имеющийся лист), а затем нажмите кнопку ОК.

    В диалоговом окне "Импорт данных" укажите, нужно ли добавить данные в существующую книгу (значение по умолчанию) или на новый лист.

    Внимание: В диалоговом окне Импорт данных указывается адрес выбранной ячейки. Данные импортируются, начиная с этой ячейки.

  11. Сохраните электронную таблицу с новым именем файла.

Шаг 2. Подготовка источника данных

В источнике данных Excel, который вы хотите использовать в качестве списка рассылки в Word, проверьте правильность форматирования столбцов с числовыми данными. Например, примените нужный формат, такой как денежный.

При выборе процентного формата помните, что значения в ячейках будут умножены на 100. Если вы хотите избежать этого, отформатируйте столбец с процентными значениями как текст.

Отформатируйте значения почтовых индексов как текст, чтобы сохранить данные во время слияния. Если вы не сделали этого при импорте, выполните форматирование сейчас. Начальные нули, например в индексе 000399, удаляются при слиянии, если значения не отформатированы как текст.

  1. Выберите столбец, содержащий почтовые индексы или другие данные, которые нужно отформатировать.

  2. На вкладке Главная в группе Число щелкните стрелку раскрывающегося списка Числовой формат и выберите нужное значение (например, "Текст").

    На вкладке "Главная" Excel в группе "Число" в щелкните стрелку раскрывающегося списка "Общий" и выберите нужное значение.

Не забудьте добавить нужный символ перед полем слияния или после него. Например, вот как будут выглядеть денежные и процентные значения, если опустить символы:

Результаты слияния: "ваш взнос в размере 50" и "предложить вам скидку 20".

Если добавить символы, числа будут иметь смысл.

Результаты слияния: "ваш взнос в размере 50 ₽" и "предложить вам скидку 20%".

В документе слияния можно добавить символы до и после поля слияния следующим образом:

Пример документа слияния, в котором после поля "Пожертвования" стоит знак рубля, а после поля "Процент" — знак процента.

См. также

Важным шагом при настройке слияния в Word является подготовка источника данных. Вы можете использовать существующий источник данных Excel или создать новый, импортировав файл, разделенный табуляциями (TXT) или запятыми (CSV). После настройки и подготовки источника данных можно выполнить слияние почты с помощью динамический обмен данными (DDE) с мастером слияния или вручную.

Если у вас нет источника данных Excel для слияния, вы можете использовать список контактов или адресную книгу в TXT- или CSV-файле. Мастер импорта текста поможет вам извлечь данные из файла в Excel.

  1. Откройте Excel.

  2. На вкладке Данные выберите элемент Из тестового/CSV-файла.

  3. Выберите нужный TXT- или CSV-файл и нажмите кнопку Импорт.

  4. В мастере импорта текста в области Тип исходных данных выберите С разделителями.

    Получение внешних данных из текста, мастер импорта текста, шаг 1 из 3

  5. При необходимости установите флажок Мои данные содержат заголовки над областью Предварительный просмотр файла, а затем нажмите кнопку Далее.

  6. В разделе Разделители установите нужный флажок (например, "знак табуляции" или "запятая") и нажмите кнопку Далее.

    Параметры разделителей выделены в мастере импорта текста.

    Совет: В области Образец разбора данных вы можете увидеть, как результаты будут выглядеть в виде таблицы.

  7. В области Образец разбора данных выберите столбец, содержащий почтовые индексы, а затем в списке Формат данных столбца выберите Текстовый.

    В мастере импорта текста выделен параметр "Текст" в разделе "Формат данных столбца".

    Примечания: 

    • Доступны форматы Общий, Текстовый и Дата. Каждый раз, когда вы применяете формат данных к столбцу, в его заголовке отображается имя формата.

    • Столбец, содержащий числовые данные, например процентные или денежные значения, можно отформатировать только после импорта файла. См. раздел "Форматирование числовых данных в Excel" ниже.

  8. При необходимости повторите действие 7, выбрав столбец, который вы хотите изменить, и нужный формат данных.

  9. Нажмите кнопку Finish (Готово).

  10. В диалоговом окне Импорт данных примите значение по умолчанию (имеющийся лист), а затем нажмите кнопку ОК.

    В диалоговом окне "Импорт данных" укажите, нужно ли добавить данные в существующую книгу (значение по умолчанию) или на новый лист.

    Внимание: В диалоговом окне Импорт данных указывается адрес выбранной ячейки. Данные импортируются, начиная с этой ячейки.

  11. Добавив данные, сохраните источник с новым именем файла.

Форматирование числовых данных в Excel

Отформатируйте все числовые данные, например процентные или денежные значения, в новых и существующих источниках данных Excel, которые предполагается использовать при слиянии в Word. Чтобы сохранить числовые данные, которые вы отформатировали как процентные или денежные значения, при слиянии, следуйте инструкциям в разделе "Шаг 2. Слияние с помощью динамического обмена данными (DDE)".

В источнике данных Excel, который вы хотите использовать в качестве списка рассылки в Word, проверьте правильность форматирования столбцов с числовыми данными. Например, примените нужный формат, такой как денежный.

  1. Откройте источник данных Excel.

  2. Выберите столбец, который вы хотите отформатировать.

  3. На вкладке Главная в группе Число в щелкните стрелку раскрывающегося списка Числовой формат (Общий) и выберите нужное значение.

    На вкладке "Главная" Excel в группе "Число" в щелкните стрелку раскрывающегося списка "Общий" и выберите нужное значение.

  4. При необходимости повторите шаги 2 и 3.

  5. После завершения нажмите кнопку Сохранить.

Если в источнике данных Excel есть числа, отформатированные как процентные или денежные значения, они могут потерять форматирование во время слияния. Чтобы получить необходимый результат при слиянии и сохранить формат числовых данных в Excel, используйте DDE.

Формат данных Excel в сравнении с полем слияния при использовании DDE и без него

Примечание: Если вы решили не использовать DDE, выполните инструкции в статье Использование слияния для массовой рассылки сообщений электронной почты.

  1. Откройте Word и выберите Файл > Параметры > Дополнительно.

  2. В разделе Общие установите флажок Подтверждать преобразование формата файла при открытии.

    Параметр ''Подтверждать преобразование формата файла при открытии''

  3. Нажмите кнопку ОК.

  4. На вкладке Рассылки щелкните Начать слияние > Пошаговый мастер слияния.

    В Word на вкладке "Рассылки" щелкните "Начать слияние" и выберите "Пошаговый мастер слияния".

  5. В области Слияние в разделе Выбор получателей щелкните Использовать существующий список.

    При выборе мастера слияния в группе "Слияние" в Word открывается область задач "Слияние".

  6. В разделе Использовать существующий список нажмите кнопку Обзор и откройте отформатированную электронную таблицу.

  7. В диалоговом окне Преобразование источника данных установите флажок Отобразить все, а затем выберите элемент Листы MS Excel с помощью DDE (*.xls) и нажмите кнопку ОК.

    Диалоговое окно ''Преобразование источника данных''

  8. В диалоговом окне Microsoft Excel выберите Весь лист и нажмите кнопку ОК.

    Диалоговое окно Microsoft Excel в Word

  9. В диалоговом окне Получатели слияния нажмите кнопку ОК.

    Диалоговое окно "Получатели слияния", в котором показана электронная таблица Excel, используемая в качестве источника данных для списка рассылки

  10. Выполните слияние для создания писем, сообщений электронной почты, наклеек или конвертов.

Совет: Можно сделать так, чтобы при каждом открытии файла данных в Word не выводились запросы. После подключения к списку рассылки выберите Файл > Параметры > Дополнительно. В разделе Общие снимите флажок Подтверждать преобразование формата файла при открытии.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×