Перемещение опубликованного шаблона формы в новую библиотеку SharePoint

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

В этой статье

Общие сведения

Перед началом работы

Получение рабочую копию шаблона формы

Шаг 1: Публикация шаблона формы для новой библиотеки документов

Шаг 2: Копирование и связать существующие формы

Обзор

После публикации шаблона формы для заполнения пользователями в библиотеке документов, возможно, потребуется переместить этот шаблон формы в другую библиотеку документов. Например может потребоваться переместить шаблона формы на сервере с дополнительный объем таким образом, чтобы другие пользователи смогут заполнять формы одновременно. Некоторые пользователи могут уже заполнили форм, основанных на шаблоне формы, хранящиеся в библиотеке исходного документа. При перемещении шаблона формы в новую библиотеку документов нужно переместить слишком всех существующих форм. Вы также хотите убедитесь в том, что всех существующих форм будут работать в новая библиотека документов, перед тем как архивация или удаление старых библиотеки документов.

Совет: Прежде чем перейти шаблоны опубликованную форму новую библиотеку документов, создайте план, который включает в себя пользователей о том, что свои формы были перемещены в новую библиотеку документов. Вы хотите своим пользователям использовать новую библиотеку документов для хранения новых форм или измените существующие формы. План должен также включают в себя процесс Архивация или удаление исходного библиотеки документов.

Для перемещения шаблона формы и существующих форм в новую библиотеку документов, сначала необходимо опубликовать рабочую копию шаблона формы в новую библиотеку документов. Рабочая копия является версию, которая хранится на вашем компьютере или в программе управления версии, таких как Microsoft Visual SourceSafe.

Совет: Если у вас рабочую копию шаблона формы, можно сохранить копию шаблона формы из исходной библиотеки документов со своим компьютером для использования в качестве рабочей копии.

После публикации рабочей копии новая библиотека документов, следует копирование всех форм из старой библиотеки документов в новую библиотеку документов, а затем связать формы в библиотеке документов недавно опубликованный шаблон формы.

Если необходимо внести необходимые изменения, являющееся результатом перемещение шаблона формы внести эти изменения перед публикацией шаблона формы. Например расположение внешние источники данных, используемые с помощью форм, основанных на этом шаблоне формы также могут измениться после наведения шаблона формы. В этом случае необходимо изменить подключения к данным в шаблоне формы в новое место внешние источники данных, перед публикацией шаблона формы. Вы найдете ссылки на дополнительные сведения об изменении подключений к данным в разделе Дополнительные сведения.

Примечание: Публикация шаблона формы не совпадает с сохранением шаблона формы. При публикации шаблона формы, мастер публикации добавляет команды обработки в шаблон формы, чтобы пользователи могут открыть форм, основанных на этом шаблоне формы и расположения для публикации. При сохранении шаблона формы требуется сохранить копию в шаблоне формы, как и при сохранении файла с компьютером. Если вы хотите сделать доступным для пользователей для заполнения шаблона формы всегда следует использовать мастер публикации.

К началу страницы

Подготовка

Прежде чем перемещать шаблона формы и всех существующих форм, основанных на шаблоне формы в новую библиотеку документов, нужно будет следующее:

  • Рабочую копию шаблона формы    Это копию шаблона формы, которая будет изменить, а затем повторно опубликовать новая библиотека документов. Рабочая копия может быть сохранен на компьютере или в программе управления версии, например Visual SourceSafe.

  • Расположение новой внешним источникам данных    Если внешние источники данных, которые были изменены с помощью форм, основанных на шаблоне формы, вам нужно будет новое расположение к внешним источникам данных. К своему администратору проверить, правильно ли вы и ваши пользователи соответствующие разрешения на использование внешних источников данных. Если шаблон формы использует параметры в файле подключения к данным для подключения к внешнему источнику данных, убедитесь, что файл подключения к данным был обновлен с новое расположение источника внешних данных.

  • Права на сервере Windows SharePoint Services 3.0    Вам нужно будет соответствующие права на сервере для публикации шаблона формы и копирование всех существующих форм, старая библиотека документов на новую библиотеку документов. Обратитесь к администратору сервера, чтобы убедиться, что у вас есть эти права.

К началу страницы

Получение рабочую копию шаблона формы

Если вы хотите изменить шаблон формы, которая опубликована в библиотеке документов или в общей сетевой папке и не имеют рабочую копию шаблона формы, можно сохранить рабочую копию шаблона формы из места публикации на вашем компьютере.

Совет: Рекомендуется использовать программа контроля версий, таких как Microsoft Visual SourceSafe для управления рабочие копии шаблоны форм.

Сохраните копию шаблона формы из библиотеки документов с компьютером

  1. В веб-браузере откройте библиотеку документов, где публикации шаблона формы.

  2. В меню Параметры выберите пункт Параметры и нажмите кнопку Параметры библиотеки форм.

  3. В группе Общие параметры выберите пункт Дополнительные параметры.

  4. В разделе Шаблон документа нажмите кнопку Изменить шаблон.

    Шаблон формы будет открыт в приложении Microsoft Office InfoPath.

  5. В диалоговом окне Microsoft Office InfoPath нажмите кнопку Да.

  6. В меню Файл выберите пункт Сохранить как.

  7. В диалоговом окне Microsoft Office InfoPath нажмите кнопку ОК.

  8. В диалоговом окне Сохранить как перейдите туда, где вы хотите сохранить копию шаблона формы, а затем нажмите кнопку Сохранить.

Сохранить копию шаблона формы из общей сетевой папки на компьютере

  1. В меню файл выберите пункт Создание шаблона формы.

  2. В разделе Открытие шаблона формы нажмите кнопку На моем компьютере.

  3. Перейдите к общей сетевой папке опубликованный шаблон формы, щелкните шаблон формы и нажмите кнопку Открыть.

  4. В меню Файл выберите пункт Сохранить как.

  5. В диалоговом окне Microsoft Office InfoPath нажмите кнопку ОК.

  6. В диалоговом окне Сохранить как выберите расположение, отличного от оригинала место, где вы хотите сохранить рабочую копию шаблона формы публикации и нажмите кнопку Сохранить.

К началу страницы

Шаг 1: Публикация шаблона формы для новой библиотеки документов

  1. Откройте рабочую копию шаблона формы в режиме конструктора.

  2. В меню файл нажмите кнопку Опубликовать.

  3. В мастере публикации нажмите кнопку в SharePoint server или без службы InfoPath Forms Services и нажмите кнопку Далее.

  4. В поле Введите расположение сайта SharePoint или службы InfoPath Forms Services введите расположение, которое содержит библиотеку документов, который вы хотите переместить шаблона формы для сайта SharePoint и нажмите кнопку Далее.

  5. На следующей странице мастера выберите Библиотеку документов и нажмите кнопку Далее.

  6. Нажмите кнопку Создать новую библиотеку документов, а затем нажмите кнопку Далее.

  7. На следующей странице мастера введите имя и описание для новой библиотеки документов и нажмите кнопку Далее.

  8. Выбор полей в шаблон формы, которое будет отображаться как столбцы в представлении по умолчанию библиотеки документов.

    Инструкции

    1. Нажмите кнопку Добавить.

    2. Выберите поле, которое вы хотите добавить как столбец в библиотеке документов, а затем выполните одно из следующих действий:

      • Введите имя столбца в поле имя столбца.

      • Выберите столбец сайта в списке столбцов сайта группы, выберите имя в списке имя столбца и нажмите кнопку ОК.

        Примечание: Если вы выбрали повторяющееся поле для отображения данных в библиотеке документов, можно определить способ отображения поля в библиотеке документов, щелкнув значение в списке функция. Можно выбрать способ отображения первое значение в поле, последнее значение в поле или количество всех вхождений поля или объединить все значения.

    3. Нажмите кнопку ОК.

    Вы найдете ссылки на дополнительные сведения об отображении данных в столбцах в библиотеке документов в разделе Дополнительные сведения.

  9. Нажмите кнопку Далее.

  10. На следующей странице мастера проверьте правильность сведений и нажмите кнопку Опубликовать.

  11. Чтобы открыть библиотеку документов и тестирования в процессе заполнив форму, основанную на этом шаблоне формы, установите флажок Открыть эту библиотеку документов и нажмите кнопку Закрыть.

    Библиотека документов будет открыт в браузере. При нажатии кнопки Создать на панели инструментов списка, формы на основе этого шаблона формы будет открыт в Microsoft Office InfoPath.

После публикации шаблона формы в новую библиотеку документов, вы можете скопировать существующих форм, основанных на старой версии шаблона формы из старой библиотеки документов создать библиотеку документов. После завершения копирования существующих форм, можно связать существующих форм для новой версии шаблона формы. Если не указать существующих форм, пользователи не смогут открыть эти существующих форм.

К началу страницы

Шаг 2: Копирование и связать существующие формы

Предполагается, что оба библиотеки документов — на сервере, на котором работает Windows SharePoint Services 3.0.

  1. Откройте библиотеку документов старого веб-браузере.

  2. В меню Вид выберите Представление проводника.

  3. Нажмите и удерживайте нажатой клавишу CTRL, выделите каждую форму, которую требуется переместить и щелкните правой кнопкой мыши один из вариантов.

  4. В диалоговом окне Internet Explorer нажмите кнопку Да и выберите в контекстном меню команду Копировать.

  5. Откройте новую библиотеку документов.

  6. В разделе Выберите представление щелкните Представление проводника.

  7. Щелкните правой кнопкой мыши пустую область в окне папки.

  8. В диалоговом окне Internet Explorer нажмите кнопку Да и в контекстном меню выберите команду Вставить.

  9. В меню Вид выберите пункт Связать документы.

  10. В столбце " связать " установите флажок для каждой формы, на который должна указывать ссылка нового шаблона формы.

  11. На панели инструментов списка нажмите кнопку Связать выделенные документы.

После изменения связей существующих форм в новый шаблон формы, пользователей можно изменить существующие формы, которые были скопированы в новую библиотеку документов или заполните новых форм, основанных на шаблоне недавно опубликованную форму.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×