ПРОЕКТ: Создание, изменение и удаление объекта OLE

С помощью средств OLE можно включать в документы содержимое из других программ, таких как Microsoft Office Excel 2007, Microsoft Office PowerPoint 2007, Microsoft Office Word 2007 или Microsoft Office Outlook 2007.

Выберите действие

Обзор OLE

Связывание и внедрение содержимого из другой программы с помощью OLE

Изменение способа изображения объекта OLE

Изменение содержимого в программе OLE

Сообщение о невозможности редактирования при двойном щелчке в связанном или внедренном объекте

Примечание : Эта статья предлагается всеобщему вниманию для внесения комментариев. Все комментарии будут внимательно изучены и учтены при подготовке окончательной редакции статьи. Чтобы прислать свой отзыв, нажмите кнопку «Да» или «Нет» в конце статьи и напишите, что вам в ней понравилось, а что, по-вашему, следует изменить. Благодарим вас!

Обзор OLE

Назначение технологии OLE, поддерживаемой множеством различных программ, состоит в том, чтобы сделать материалы, созданные в одной программе, доступными в другой программе. Например, лист Excel 2007 можно вставить в презентацию PowerPoint 2007. Чтобы узнать, содержимое каких типов можно вставлять, нажмите кнопку Объект в группе Текст на вкладке Вставка. В списке Тип объекта будут перечислены только программы, установленные на данном компьютере и поддерживающие объекты OLE. Если нужной программы нет в этом списке, ее необходимо установить, прежде чем можно будет вставлять из нее содержимое.

К началу страницы

Сравнение связанных и внедренных объектов

При копировании данных между PowerPoint, Word и другими программами, поддерживающими OLE, например Excel, копию можно вставить либо как связанный объект, либо как внедренный объект. Связанные объекты отличаются от внедренных в первую очередь местом хранения данных и способом их обновления после вставки в конечный файл. Внедренные объекты хранятся в том документе, в который они вставлены, и не подлежат обновлению. Связанные объекты продолжают существовать как отдельные файлы и могут быть обновлены.

Связанные и внедренные объекты в документе

Связанные и внедренные объекты в документе

1. Внедренный объект не соединен с исходным файлом.

2. Связанный объект соединен с исходным файлом.

3. Связанный объект обновляется исходным файлом.

Дополнительные сведения о внедренных и связанных звуковых файлах в PowerPoint 2007 см. в статье Внедренные и связанные звуковые файлы в презентации.

К началу страницы

Когда используются связанные объекты

Если необходимо, чтобы содержимое конечный файл обновлялось при изменении данных в исходный файл, следует использовать связывание объектов.

В случае связанного объекта первоначальная информация остается в исходном файле. В конечном файле отображается представление связанного содержимого, но хранится в нем только расположение исходных данных (а также размер объекта, если это диаграмма Excel). Исходный файл должен оставаться доступным на компьютере или в сети, служа источником оригинальных данных.

Связанный объект может автоматически обновляться при изменении содержимого исходного файла. Например, если выделить абзац документа Word и вставить его в виде связанного объекта в презентацию PowerPoint, этот фрагмент может обновляться в PowerPoint при изменении абзаца в документе Word.

К началу страницы

Когда используются внедренные объекты

Если обновлять скопированные данные при их изменении в исходном файле не требуется, используйте внедренный объект. Версия источника полностью интегрируется в документ или презентацию. Если данные скопированы как внедренный объект, для конечного файла потребуется больше места на диске, чем если бы эти данные были связаны.

При открытии файла на другом компьютере внедренный объект можно будет просматривать, даже не имея доступа к исходным данным. Поскольку внедренный объект не имеет никаких связей с исходным файлом, объект не обновляется при изменении исходных данных.

К началу страницы

Связывание и внедрение содержимого из другой программы с помощью OLE

С документом можно связать или внедрить в него содержимое из другой программы.

Создание связи с содержимым из другой программы

Для Word 2007 или Outlook 2007

  1. Щелкните в том месте документа или сообщения электронной почты, куда следует поместить связанный объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Изображение ленты Word

  3. Перейдите на вкладку Создание из файла.

  4. Введите имя файла в поле Имя файла или нажмите кнопку Обзор для выбора файла из списка.

    Если выполнялся поиск файла, щелкните найденный файл и нажмите кнопку Вставить.

  5. Установите флажок Связь с файлом.

  6. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок В виде значка.

    • Чтобы отобразить объект в виде значка, установите флажок В виде значка.

      Чтобы изменить изображение значка или подпись к нему, которые используются по умолчанию, нажмите кнопку Сменить значок и затем щелкните нужный значок в списке Значок или введите подпись в поле Подпись.

Для PowerPoint 2007

  1. Щелкните в том месте слайда, куда следует поместить связанный объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Лента группы «Текст»

  3. Установите переключатель Создать из файла.

  4. Введите имя файла в поле Файл или нажмите кнопку Обзор для выбора файла из списка.

    Если выполнялся поиск файла, щелкните найденный файл и нажмите кнопку Вставить.

  5. Установите флажок Связать.

  6. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок Как значок.

    • Чтобы отобразить объект в виде значка, установите флажок Как значок.

      Чтобы изменить изображение значка или подпись к нему, которые используются по умолчанию, нажмите кнопку Значок и затем щелкните нужный значок в списке Значок или введите подпись в поле Надпись.

Примечание : Команда Объект не может использоваться для вставки рисунков и графики. Чтобы вставить рисунок или элемент графики, на вкладке Вставка в группе Иллюстрации нажмите кнопку Рисунок.

К началу страницы

Внедрение содержимого из другой программы

Для Word 2007 или Outlook 2007

  1. Щелкните в том месте документа или сообщения электронной почты, куда следует поместить внедренный объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Изображение ленты Excel

  3. Если документ еще не существует, откройте вкладку Новый. В списке Тип объекта выберите необходимый тип.

    Если документ уже существует, откройте вкладку Из файла. Введите имя файла в поле Имя файла или нажмите кнопку Обзор для выбора файла из списка.

  4. Снимите флажок Связь с файлом.

  5. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок В виде значка.

    • Чтобы отобразить объект в виде значка, установите флажок В виде значка. Чтобы изменить изображение значка или подпись к нему, которые используются по умолчанию, нажмите кнопку Сменить значок и затем щелкните нужный значок в списке Значок или введите подпись в поле Подпись.

Для PowerPoint 2007

  1. Щелкните в том месте слайда, куда следует поместить внедренный объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Изображение ленты Excel

  3. Если документ еще не существует, установите переключатель в положение Создать новый. В списке Тип объекта выберите необходимый тип.

    Если документ уже существует, установите переключатель в положение Создать из файла. Введите имя файла в поле Файл или нажмите кнопку Обзор для выбора файла из списка.

  4. Снимите флажок Связать.

  5. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок Как значок.

    • Чтобы отобразить объект в виде значка, установите флажок Как значок. Чтобы изменить изображение значка или подпись к нему, которые используются по умолчанию, нажмите кнопку Значок и затем щелкните нужный значок в списке Значок или введите подпись в поле Надпись.

К началу страницы

Связывание и внедрение фрагмента содержимого из другой программы

Для Word 2007 или Outlook 2007

  1. В программе, отличной от Word и Outlook, выделите данные, которые следует скопировать как связанный объект или внедренный объект.

  2. На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать.

    Изображение ленты Excel

  3. Перейдите в документ или сообщение электронной почты, куда требуется поместить данные, и щелкните в том месте, где их следует расположить.

  4. На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

  5. Выполните одно из следующих действий.

    • Чтобы вставить данные в виде связанного объекта, установите переключатель в положение Связать.

    • Чтобы вставить данные в виде внедренного объекта, установите переключатель в положение Вставить. В списке Как выберите пункт, в котором содержится слово «объект». Например, если данные были скопированы с листа Excel, выберите Лист Microsoft Office Excel (объект).

Для PowerPoint 2007

  1. В программе, отличной от PowerPoint, выделите данные, которые следует скопировать как связанный объект или внедренный объект.

  2. На вкладке Главная в группе Буфер обмена щелкните Копировать.

    Изображение ленты Excel

  3. Перейдите на слайд, на который требуется поместить данные, и щелкните в том месте, где их следует расположить.

  4. На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

  5. Выполните одно из следующих действий.

    • Чтобы вставить данные в виде связанного объекта, установите переключатель в положение Связать.

    • Чтобы вставить данные в виде внедренного объекта, установите переключатель в положение Вставить. В списке Как выберите пункт, в котором содержится слово «объект». Например, если данные были скопированы из документа Word, выберите Объект Документ Microsoft Office Word.

К началу страницы

Изменение способа изображения объекта OLE

связанный объект или внедренный объект можно отобразить в документе, на слайде или в сообщении электронной почты либо в том же виде, что и в программа-источник, либо в виде значка. Если документ или презентация будет просматриваться в интерактивном режиме, без вывода на печать, можно задать отображение объекта в виде значка. Тем самым место, занимаемое объектом на экране, сводится к минимуму. Для просмотра содержимого объекта достаточно будет дважды щелкнуть значок.

  1. Щелкните значок или объект правой кнопкой мыши, выделите пункт Объект тип объекта (например, Объект Документ) и выберите команду Преобразовать.

  2. Выполните одно из следующих действий.

    • Чтобы отобразить содержимое объекта, снимите флажок В виде значка.

    • Чтобы отобразить объект в виде значка, установите флажок В виде значка.

      Чтобы изменить изображение значка или подпись к нему, которые используются по умолчанию, нажмите кнопку Сменить значок и затем щелкните нужный значок в списке Значок или введите подпись в поле Подпись.

К началу страницы

Изменение содержимого в программе OLE

Работая в приложении Word, PowerPoint или Outlook, можно изменять содержимое, связанное или внедренное из другой программы.

Изменение связанного объекта в исходной программе

Для Word 2007 или Outlook 2007

  1. Щелкните значок или объект правой кнопкой мыши, выделите пункт Объект тип объекта (например, Связанный объект Worksheet) и выберите команду Связи.

  2. Нажмите кнопку Открыть источник.

  3. Внесите необходимые изменения в связанный объект.

Совет : Можно также заменить исходный файл, нажав после выбора команды Связи кнопку Сменить источник вместо кнопки Открыть источник. Найдите новый исходный файл и нажмите кнопку Открыть.

Для PowerPoint 2007

  1. Щелкните связанный объект на слайде.

  2. Нажмите кнопку Office Изображение кнопки Office , выделите команду Подготовить и выберите пункт Изменить ссылки на файлы.

    Если пункт Изменить ссылки на файлы не виден в списке, щелкните стрелку вниз под списком Подготовить документ к рассылке, чтобы прокрутить список до конца.

    Изображение меню подготовки

  3. В списке Связи выберите нужную связь и нажмите кнопку Открыть источник.

  4. Внесите необходимые изменения в связанный объект.

  5. Выйдите из программа-источник, чтобы вернуться к конечному файлу.

К началу страницы

Изменение внедренного объекта в исходной программе

Чтобы изменить внедренный объект, откройте его двойным щелчком и отредактируйте в исходной программе. Эта исходная программа (или другая программа, поддерживающая редактирование объекта) должна быть установлена на компьютере.

  1. Дважды щелкните внедренный объект, чтобы открыть его.

  2. Внесите в объект необходимые изменения.

  3. Если изменение объекта производится в том же окне в исходной программе, щелкните за пределами этого объекта, чтобы вернуться к конечный файл.

    Если внедренный объект редактируется в отдельном окне исходной программы, для возврата к конечному файлу выйдите из исходной программы.

Примечание :  Некоторые внедренные объекты, например видео- и звуковые клипы, при двойном щелчке не открываются в соответствующей программе, а начинаются воспроизводиться. Чтобы изменить такой внедренный объект, щелкните значок или объект правой кнопкой мыши, выделите пункт Объект тип объекта (например, Объект Media Clip) и выберите команду Изменить.

К началу страницы

Изменение внедренного объекта в программе, отличной от исходной

  1. Выделите внедренный объект, который требуется изменить.

  2. Щелкните значок или объект правой кнопкой мыши, выделите пункт Объект тип объекта (например, Объект Документ) и выберите команду Преобразовать.

  3. Выполните одно из следующих действий.

    • Чтобы преобразовать внедренный объект в тип, выбранный в списке, установите переключатель в положение преобразовать в.

    • Чтобы открыть внедренный объект в формате, выбранном в списке, без изменения типа внедренного объекта, установите переключатель в положение активизировать как.

К началу страницы

Сообщение о невозможности редактирования при двойном щелчке в связанном или внедренном объекте

Такое сообщение появляется, если не удается открыть исходный файл или программа-источник.

Убедитесь, что исходная программа доступна.     Если исходная программа не установлена на компьютере, преобразуйте объект в формат файла подходящей установленной программы.

Проверьте наличие свободной памяти.     Убедитесь, что памяти достаточно для запуска исходной программы. При необходимости закройте другие программы, чтобы освободить память.

Закройте все диалоговые окна.     Если исходная программа запущена, убедитесь, что у нее нет открытых диалоговых окон. Перейдите в исходную программу и закройте все открытые диалоговые окна.

Закройте исходный файл.     Если исходный файл является связанным объектом, убедитесь, что он не открыт другим пользователем.

Проверьте, не изменилось ли имя исходного файла.     Если исходный файл, который требуется изменить, является связанным объектом, убедитесь, что у него то же имя, которое было в момент создания связи, и он находится на прежнем месте. Чтобы изменить исходный файл, выполните следующие действия.

Для Word 2007 или Outlook 2007

  1. Щелкните значок или объект правой кнопкой мыши, выделите пункт Объект тип объекта (например, Связанный объект Worksheet) и выберите команду Связи.

  2. Нажмите кнопку Сменить источник.

  3. Найдите новый исходный файл и восстановите связь.

Для PowerPoint 2007

  1. Щелкните связанный объект на слайде.

  2. Нажмите кнопку Office Изображение кнопки Office , выделите команду Подготовить и выберите пункт Изменить ссылки на файлы.

    Если пункт Изменить ссылки на файлы не виден в списке, щелкните стрелку вниз под списком Подготовить документ к рассылке, чтобы прокрутить список до конца.

    Изображение меню подготовки

  3. В списке Связи выберите нужную связь и нажмите кнопку Изменить источник.

  4. Найдите новый исходный файл и восстановите связь.

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×