Отправление данных формы в сообщении электронной почты

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Чтобы разрешить пользователям отправлять данные формы в сообщении электронной почты, можно добавить дополнительное подключение отправления данных в шаблон формы. Для этого используйте постоянные значения, значения, основанные на данных формы, или формулы для указания адреса электронной почты, на который будет отправлена форма, тему сообщения электронной почты и имя формы. При необходимости можно также указать форму, появляющуюся в теле сообщения электронной почты или в качестве вложения.

При настройке шаблона формы для включения формы как вложения в сообщение электронной почты можно вложить шаблон формы в сообщение электронной почты. Включая форму и шаблон формы в качестве вложений в сообщение электронной почты, можно быть уверенным, что получатели этого сообщения смогут открыть форму в приложении InfoPath даже при отсутствии шаблона формы, сохраненного на компьютере. Чтобы открыть вложения, пользователи должны иметь установленное на компьютере приложение InfoPath.

Когда пользователи отправляют данные формы в сообщении электронной почты, приложение InfoPath создает сообщение электронной почты с данными формы и отправляет это сообщение получателям электронной почты, указанным при создании подключения отправления данных. Если пользователи, получившие заполненные формы, используют Microsoft Office Outlook 2007, они могут добавить папку в папку «Входящие» для хранения всех полученных форм InfoPath и настроить эту папку, чтобы отображать данные в формах в столбцах приложения Outlook.

После добавления подключения отправления данных настройте шаблон формы, чтобы разрешить пользователям отправлять данные формы. В результате, при открытии пользователями формы в приложении InfoPath автоматически добавляются кнопка Отправить на панель инструментов Стандартная и команда Отправить в меню Файл. Параметры отправки для шаблона формы можно также настроить следующими способами.

  • Изменить текст кнопки Отправить на панели инструментов Стандартная и команды Отправить в меню Файл.

  • Изменить сочетание клавиш для кнопки Отправить на панели инструментов Стандартная и команды Отправить в меню Файл.

  • Создать пользовательские сообщения для отображения отправления форм.

  • Указать, оставлять ли форму открытой, закрыть ее или открыть другую пустую форму после отправления этой.

К началу страницы

Добавление подключения данных, отправляющего данные

  1. В меню Сервис выберите команду Параметры отправки.

  2. В диалоговом окне Параметры отправки установите флажок Разрешить пользователям отправлять эту форму.

  3. Нажмите кнопку Отправить данные формы в одно место, а затем в списке выберите пункт Электронная почта.

  4. Нажмите кнопку Добавить.

  5. В мастере подключения данных в соответствующих окнах введите адреса электронной почты получателей, тему сообщения электронной почты, и любой необходимый вводный текст, а затем нажмите кнопку Далее.

    Совет : Можно указать поле или воспользоваться формулой, чтобы создать значение для каждого окна, за исключением окна Введение.

    Реализация

    1. Выберите пункт Вставить формулу Кнопка формулы .

    2. В диалоговом окне Вставка формулы выполните одно из следующих действий:

      • Чтобы использовать поле в формуле, щелкните Вставить поле или группу, выберите нужное поле в диалоговом окне Выбор поля или группы, а затем нажмите кнопку ОК.

      • Чтобы использовать функцию в формуле, щелкните Вставить функцию, выберите нужную функцию в диалоговом окне Вставка функции, а затем нажмите кнопку ОК.

        Совет : Если для функции необходимы параметры, выберите функцию в диалоговом окне Вставка функции, нажмите кнопку ОК, а затем в поле Формула диалогового окна Вставка формулы дважды щелкните добавленную функцию, а также поле или группу. Для получения дополнительных сведений о функциях см. ссылки в разделе См. также.

      • Для вставки в формулу значения или математического оператора в поле Формула введите значение или знак математической операции.

    Операция

    Символ

    Добавление

    +

    Вычитание

    -

    Умножение

    *

    Деление

    /

    • Примечание : Если в формуле используется оператор деления (/), следует убедиться, что до и после него стоят пробелы. Если пробелы отсутствуют, знак «/» может быть принят за разделитель шагов пути XPath, а не за оператор деления.

    • Для проверки формулы на правильность синтаксиса в диалоговом окне Вставка формулы щелкните кнопку Проверить формулу.

      Для получения дополнительных сведений о формулах см. ссылки в разделе См. также.

  6. На следующей странице мастера выполните одно из следующих действий:

    1. Для отображения формы в теле сообщения электронной почты нажмите кнопку Отправить только активное представление формы без вложений.

    2. Для отправки данных формы в качестве вложения в сообщение электронной почты нажмите кнопку Отправить данные формы как вложение, установите флажок Вложить шаблон формы, чтобы пользователи могли открывать форму, а затем введите имя формы в окне Имя вложения. Чтобы удостовериться в том, что каждая форма имеет уникальное имя, можно указать поле или воспользоваться формулой.

      Реализация

      1. Выберите пункт Вставить формулу Кнопка формулы .

      2. В диалоговом окне Вставка формулы выполните одно из следующих действий:

        • Чтобы использовать поле в формуле, щелкните Вставить поле или группу, выберите нужное поле в диалоговом окне Выбор поля или группы, а затем нажмите кнопку ОК.

        • Чтобы использовать функцию в формуле, щелкните Вставить функцию, выберите нужную функцию в диалоговом окне Вставка функции, а затем нажмите кнопку ОК.

          Совет : Если для функции необходимы параметры, выберите функцию в диалоговом окне Вставка функции, нажмите кнопку ОК, а затем в поле Формула диалогового окна Вставка формулы дважды щелкните добавленную функцию, а также поле или группу. Для получения дополнительных сведений о функциях см. ссылки в разделе См. также.

        • Для вставки в формулу значения или математического оператора в поле Формула введите значение или знак математической операции.

      Операция

      Символ

      Добавление

      +

      Вычитание

      -

      Умножение

      *

      Деление

      /

      • Примечание : Если в формуле используется оператор деления (/), следует убедиться, что до и после него стоят пробелы. Если пробелы отсутствуют, знак «/» может быть принят за разделитель шагов пути XPath, а не за оператор деления.

      • Для проверки формулы на правильность синтаксиса в диалоговом окне Вставка формулы щелкните кнопку Проверить формулу.

        Для получения дополнительных сведений о формулах см. ссылки в разделе См. также.

      Примечание : Получатели электронной почты с вложением данных формы должны иметь установленное приложение InfoPath на компьютере для открытия вложения.

  7. Нажмите кнопку Далее.

  8. На следующей странице мастера в поле Введите имя подключения данных введите описательное имя для этого подключения данных.

  9. Проверьте правильность введенных данных в разделе Сводка, а затем нажмите кнопку Готово.

    1. Чтобы изменить имя кнопка " Отправить ", которая появляется на стандартной панели инструментов и команды Отправить, которое отображается в меню файл при заполнении формы пользователями, введите новое имя в поле заголовок в диалоговом окне Параметры отправки.

      Совет : Если вы хотите назначить сочетание клавиш для этой кнопки и команды, введите амперсанд (&) перед символом, который вы хотите использовать в качестве сочетания клавиш. Например чтобы назначить сочетание клавиш ALT + B как сочетание клавиш для отправки кнопок и команд, введите су & Правка.

  10. Если не хотите, чтобы пользователи могут использовать команду Отправить или кнопка " Отправить " на панели инструментов Стандартная при заполнении формы, снимите флажок Показывать отправки в меню и панели инструментов кнопка "Отправить".

    1. По умолчанию после отправки формы InfoPath хранит открыть форму и отображает сообщение для указания был успешно отправить форму. Чтобы изменить поведение по умолчанию, нажмите кнопку Дополнительно, а затем выполните одно из следующих действий:

      • Чтобы закрыть форму или создать новую пустую форму после пользователь отправляет заполненной формы, выберите нужный вариант в списке после отправки.

      • Чтобы создать настраиваемое сообщение для указания был успешно отправить форму, установите флажок использовать настраиваемые сообщения и введите ваши сообщения в полях на успеха и в случае ошибки.

        Совет : Использовать сообщение в поле на сбой объясняющий, что делать, если они не могут отправить их формы. Например может предложить что пользователи сохранения формы и связаться с другим человеком дополнительную информацию.

      • Если вы не хотите отобразить сообщение после отправки формы, снимите флажок Показывать Успех и отказ сообщения.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×