Отправление данных в несколько расположений

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Можно создать шаблон формы таким образом, чтобы пользователи могли отправлять данные в несколько расположений при нажатии кнопки Отправка.

В этой статье:

Общие сведения

Шаг 1: Добавление подключений к данным submit

Шаг 2: Настройка шаблона формы, чтобы разрешить отправку

Обзор

Чтобы разрешить пользователям отправлять данные формы в несколько мест, необходимо добавить второе подключение данных в шаблон формы, которое отправляет эти сведения в каждое расположение, необходимое пользователям для отправки. После этого добавьте все подключения отправления данных, настройте шаблон формы, чтобы разрешить пользователям отправлять данные в несколько расположений, используя правило. Как результат, при заполнении пользователями формы в приложении InfoPath добавляются кнопка Отправка на панели инструментов Стандартная и команда Отправка в меню Файл. Приложение InfoPath отправляет данные формы по второму соединению отправления данных в порядке, указанном в правиле. Настроить правило для одновременного использования всех подключений отправления данных нельзя.

Чтобы разрешить пользователям отправлять данные формы, при настройке шаблона формы можно также произвести следующие настройки:

  • Изменить текст кнопки Отправить на панели инструментов Стандартная и команды Отправить в меню Файл.

  • Изменить сочетание клавиш для кнопки Отправить на панели инструментов Стандартная и команды Отправить в меню Файл.

  • Создать настраиваемые сообщения, отображаемые для пользователей при отправке ими форм.

  • Указать, оставить ли форму открытой, закрыть ли форму или открыть другую пустую форму после отправки этой.

К началу страницы

Шаг 1: добавление подключений отправления данных

Для настройки шаблона формы, позволяющего пользователям отправлять заполненные формы в несколько расположений, добавьте необходимые подключения отправления данных в шаблон формы. Добавить соединения данных можно для следующих расположений:

  • Веб-служба

  • Библиотека документа на сервере с работающей службой Microsoft Windows SharePoint Services

  • Сообщение электронной почты

    Примечание : Пользователи должны иметь установленное приложение Microsoft Office Outlook для отправления данных формы в сообщении электронной почты.

Следующие процедуры объясняют, как добавить подключения отправления данных в эти расположения.

Добавление подключения данных, отправляющего данные веб-службе

  1. В меню Сервис выберите пункт Подключения к данным.

  2. В диалоговом окне Подключения к данным нажмите кнопку Добавить.

  3. В мастере создания подключения данных выберите переключатель Создать новое подключение для, щелкните Отправка данных и нажмите кнопку Далее.

  4. На следующей странице мастера нажмите кнопку Веб-службе, а затем — кнопку Далее.

  5. На следующей странице мастера введите расположение веб-службы, куда пользователи будут отправлять формы, а затем нажмите кнопку Далее.

    Если необходимо найти сервер UDDI для веб-службы, нажмите кнопку Поиск в UDDI, введите сервер UDDI, который необходимо найти, укажите способ поиска — по провайдеру или предоставляемым службам, введите ключевое слово, а затем нажмите кнопку Поиск. Веб-службы, совпадающие с ключевым словом поиска, отобразятся в списке Результат поиска.

  6. На следующей странице мастера в списке Выберите операцию щелкните операцию веб-службы, которая получит данные формы, а затем нажмите кнопку Далее.

  7. На следующей странице мастера выполните одно из следующих действий:

    Отправка данных в поля или группы

    1. В списке Параметры выберите параметр веб-службы, который получит данные из формы.

    2. В группе Настройки параметра нажмите кнопку Поле или группа.

    3. Нажмите кнопку Изменить Изображение кнопки .

    4. В диалоговом окне Выбор поля или группы щелкните поле или группу, данные которых необходимо отправить, а затем нажмите кнопку ОК.

    5. В окне Включить нажмите кнопку Только текст и дочерние элементы, чтобы отправить только содержимое дочернего элемента поля или группы, или нажмите кнопку Поддерево XML, включая выбранный элемент, чтобы отправить содержимое и поля, и группы.

    Отправка всех данных в форме

    1. Установите флажок Вся форма (XML-документ, включая команды обработки).

    Отправить данные в виде строки

    1. Установите флажок Отправить данные как строку.

      Обычно этот флажок устанавливается перед отправкой данных с цифровой подписью. В большинстве случаев устанавливать этот флажок не нужно.

  8. Нажмите кнопку Далее.

  9. На следующей странице мастера в поле Введите имя подключения данных введите описательное имя для этого подключения данных.

  10. Проверьте правильность введенных данных в разделе Сводка, а затем нажмите кнопку Готово.

Добавление подключения данных, отправляющего данные в библиотеку документов

  1. В меню Сервис выберите пункт Подключения к данным.

  2. В диалоговом окне Подключения к данным нажмите кнопку Добавить.

  3. В мастере создания подключения данных выберите переключатель Создать новое подключение для, щелкните Отправка данных и нажмите кнопку Далее.

  4. На следующей странице мастера нажмите кнопку В библиотеку документов в узле SharePoint, а затем — кнопку Далее.

  5. На следующей странице мастера в окне Библиотека документа введите расположение библиотеки документов SharePoint.

  6. В окне Имя файла введите имя, которое будет использовано для идентификации формы в библиотеке документов. Чтобы удостовериться в том, что каждая форма имеет уникальное имя, можно воспользоваться формулой.

    Инструкции

    1. Выберите пункт Вставить формулу Кнопка формулы .

    2. В диалоговом окне Вставка формулы выполните одно из следующих действий:

      • Чтобы использовать поле в формуле, щелкните Вставить поле или группу, выберите нужное поле в диалоговом окне Выбор поля или группы, а затем нажмите кнопку ОК.

      • Чтобы использовать функцию в формуле, щелкните Вставить функцию, выберите нужную функцию в диалоговом окне Вставка функции, а затем нажмите кнопку ОК.

        Если для функции необходимы параметры, выберите функцию в диалоговом окне Вставка функции, нажмите кнопку ОК, а затем в поле Формула диалогового окна Вставка формулы дважды щелкните добавленную функцию, а также поле или группу. Для получения дополнительных сведений о функциях см. ссылки в разделе См. также.

      • Для вставки в формулу значения или математического оператора в поле Формула введите значение или знак математической операции.

    Операция

    Символ

    Добавление

    +

    Вычитание

    -

    Умножение

    *

    Деление

    /

    • Примечание : Если в формуле используется оператор деления (/), следует убедиться, что до и после него стоят пробелы. Если пробелы отсутствуют, знак «/» может быть принят за разделитель шагов пути XPath, а не за оператор деления.

    • Для проверки формулы на правильность синтаксиса в диалоговом окне Вставка формулы щелкните кнопку Проверить формулу.

      Для получения дополнительных сведений о формулах см. ссылки в разделе См. также.

  7. Чтобы в библиотеке документов перезаписать все существующие формы с одинаковыми именами, установите флажок Разрешить перезапись, если файл существует.

  8. Нажмите кнопку Далее.

  9. На следующей странице мастера в поле Введите имя подключения данных введите описательное имя для этого подключения данных.

  10. Проверьте правильность введенных данных в разделе Сводка, а затем нажмите кнопку Готово.

Добавление соединения данных, отправляющего данные в сообщении электронной почты

  1. В меню Сервис выберите пункт Подключения к данным.

  2. В диалоговом окне Подключения к данным нажмите кнопку Добавить.

  3. В мастере создания подключения данных выберите переключатель Создать новое подключение для, щелкните Отправка данных и нажмите кнопку Далее.

  4. На следующей странице мастера нажмите кнопку В виде сообщения электронной почты, а затем — кнопку Далее.

  5. На следующей странице мастера введите адрес получателя электронного сообщения, тему, появляющуюся в сообщении, и любой вводный текст в соответствующих окнах, а затем нажмите кнопку Далее. Использовать формулу можно в любом окне, за исключением окна Введение.

    Инструкции

    1. Выберите пункт Вставить формулу Кнопка формулы .

    2. В диалоговом окне Вставка формулы выполните одно из следующих действий:

      • Чтобы использовать поле в формуле, щелкните Вставить поле или группу, выберите нужное поле в диалоговом окне Выбор поля или группы, а затем нажмите кнопку ОК.

      • Чтобы использовать функцию в формуле, щелкните Вставить функцию, выберите нужную функцию в диалоговом окне Вставка функции, а затем нажмите кнопку ОК.

        Если для функции необходимы параметры, выберите функцию в диалоговом окне Вставка функции, нажмите кнопку ОК, а затем в поле Формула диалогового окна Вставка формулы дважды щелкните добавленную функцию, а также поле или группу. Для получения дополнительных сведений о функциях см. ссылки в разделе См. также.

      • Для вставки в формулу значения или математического оператора в поле Формула введите значение или знак математической операции.

    Операция

    Символ

    Добавление

    +

    Вычитание

    -

    Умножение

    *

    Деление

    /

    • Примечание : Если в формуле используется оператор деления (/), следует убедиться, что до и после него стоят пробелы. Если пробелы отсутствуют, знак «/» может быть принят за разделитель шагов пути XPath, а не за оператор деления.

    • Для проверки формулы на правильность синтаксиса в диалоговом окне Вставка формулы щелкните кнопку Проверить формулу.

      Для получения дополнительных сведений о формулах см. ссылки в разделе См. также.

  6. На следующей странице мастера выполните одно из следующих действий:

    1. Для отображения формы в теле сообщения электронной почты нажмите кнопку Отправить только активное представление формы без вложений.

    2. Для отправки данных формы в виде вложения в сообщение электронной почты, нажмите кнопку Отправка данных формы в виде вложения, установите флажок Присоединение шаблона формы, чтобы убедиться, что пользователи могут открыть форму и введите имя формы в поле Имя вложения. Можно также задать поле или использовать формулу, чтобы убедиться, что каждое имя формы является уникальным. Этот параметр доступен только доступных ли шаблон формы настроен для автоматически определять уровень безопасности настроен на уровень безопасности Ограниченные или полное доверие.

      Инструкции

      1. Выберите пункт Вставить формулу Кнопка формулы .

      2. В диалоговом окне Вставка формулы выполните одно из следующих действий:

        • Чтобы использовать поле в формуле, щелкните Вставить поле или группу, выберите нужное поле в диалоговом окне Выбор поля или группы, а затем нажмите кнопку ОК.

        • Чтобы использовать функцию в формуле, щелкните Вставить функцию, выберите нужную функцию в диалоговом окне Вставка функции, а затем нажмите кнопку ОК.

          Если для функции необходимы параметры, выберите функцию в диалоговом окне Вставка функции, нажмите кнопку ОК, а затем в поле Формула диалогового окна Вставка формулы дважды щелкните добавленную функцию, а также поле или группу. Для получения дополнительных сведений о функциях см. ссылки в разделе См. также.

        • Для вставки в формулу значения или математического оператора в поле Формула введите значение или знак математической операции.

      Операция

      Символ

      Добавление

      +

      Вычитание

      -

      Умножение

      *

      Деление

      /

      • Примечание : Если в формуле используется оператор деления (/), следует убедиться, что до и после него стоят пробелы. Если пробелы отсутствуют, знак «/» может быть принят за разделитель шагов пути XPath, а не за оператор деления.

      • Для проверки формулы на правильность синтаксиса в диалоговом окне Вставка формулы щелкните кнопку Проверить формулу.

        Для получения дополнительных сведений о формулах см. ссылки в разделе См. также.

      Получатели электронной почты с вложением данных формы должны иметь установленное приложение InfoPath на компьютере для открытия вложения.

  7. Нажмите кнопку Далее.

  8. На следующей странице мастера в поле Введите имя подключения данных введите описательное имя для этого подключения данных.

  9. Проверьте правильность введенных данных в разделе Сводка, а затем нажмите кнопку Готово.

К началу страницы

Шаг 2: настройка шаблона формы, разрешающая отправление

После добавления необходимых второстепенных подключений данных в шаблон формы настройте шаблон формы, чтобы разрешить пользователям отправлять данные формы. При этом приложение InfoPath добавляет команду Отправить в меню Файл и кнопку Отправить на панель инструментов Стандартная при заполнении пользователями формы. После этого можно настроить действия, происходящие при нажатии пользователем кнопки Отправить. В этом случае добавьте правило, по которому будут отправляться данные формы для каждого подключения отправления данных при нажатии кнопки Отправить на панели инструментов Стандартная или выборе команды Отправить в меню Файл.

В том же диалоговом окне можно настроить параметры отправления.

  1. В меню Сервис выберите команду Параметры отправки.

  2. В диалоговом окне Параметры отправки установите флажок Разрешить пользователям отправлять эту форму.

    Если этот флажок установлен, при заполнении пользователями формы на панель инструментов Стандартная будет добавлена кнопка Отправить, а в меню Файл — команда Отправить.

  3. Щелкните Выполнить пользовательское действие с использованием правил, а затем — пункт Правила.

  4. В диалоговом окне Правила отправки форм нажмите кнопку Добавить.

  5. Нажмите кнопку Добавить действие.

  6. В окне Действие нажмите кнопку Отправка с использованием подключения данных, щелкните необходимое соединение данных для этого отправления в списке Подключение данных, а затем нажмите кнопку ОК.

  7. Повторите шаги 5 и 6 для каждого соединения подключения данных, добавленного в шаблон формы.

  8. После добавления условий для всех соединений отправления данных в шаблоне формы дважды нажмите кнопку ОК.

    1. Чтобы изменить имя кнопки Отправить, которая отображается на панели инструментов Стандартная, и команды Отправить, которая выводится в меню Файл, когда пользователи заполняют форму, введите новое имя в поле Подпись в диалоговом окне Параметры отправки.

      Если вы хотите назначить сочетание клавиш для этой кнопки и команды, введите амперсанд (&) перед символом, который вы хотите использовать в качестве сочетания клавиш. Например чтобы назначить сочетание клавиш ALT + B как сочетание клавиш для отправки кнопок и команд, введите су & Правка.

  9. Чтобы при заполнении формы автора запретить пользователям применять команду Отправить или кнопку Отправить на панели инструментов Стандартная, снимите флажок Показать команду отправки в меню и кнопку отправки на панели инструментов.

    1. По умолчанию после отправки формы пользователями InfoPath оставляет форму открытой и отображает сообщение о том, была ли форма успешно отправлена. Чтобы изменить это стандартное действие, щелкните Дополнительно, а затем сделайте следующее:

      • Чтобы закрыть форму или создать новую пустую форму после отправки заполненной формы, выберите требуемый вариант в списке После отправки.

      • Чтобы создать сообщение, указывающее, была ли форма успешно отправлена, установите флажок Использовать настраиваемые сообщения, а затем введите свои сообщения в поля При успехе и При сбое.

        В сообщении При сбое укажите, что пользователям нужно делать, если им не удается отправить форму. Например, можно предложить им сохранить форму и связаться с кем-нибудь для получения дальнейших инструкций.

      • Если не требуется выводить сообщение после отправки формы, снимите флажок Показывать сообщения об успешном или неудачном завершении.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×