Отправка данных формы в библиотеку документов

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Хранить и упорядочить все формы пользователей можно в библиотеке документов на сервере с Microsoft Windows SharePoint Services. В библиотеке документов пользователи могут заполнять формы, созданные на основе шаблона формы, экспортировать данные из заполненных форм в Microsoft Office Excel 2003 или Microsoft Office Excel 2007 и объединять данные из нескольких форм в одной.

Чтобы разрешить пользователям отправлять формы, созданные на основе шаблона формы, в библиотеку документов, к шаблону формы, с помощью которого отправляются данные, можно добавить вспомогательное подключение данных. После добавления подключения можно настроить шаблон формы таким образом, чтобы пользователи имели возможность отправлять данные, включенные в формы, в библиотеку документов. В этом случае на панель инструментов Стандартная будет добавлена кнопка Отправить, а в меню Файл формы — команда Отправить. Параметры отправки для шаблона формы можно настроить следующими способами:

  • Изменить текст кнопки Отправить на панели инструментов Стандартная и команды Отправить в меню Файл.

  • Изменить сочетание клавиш для кнопки Отправить на панели инструментов Стандартная и команды Отправить в меню Файл.

  • Создать настраиваемые сообщения, отображаемые для пользователей при отправке ими форм.

  • Указать, оставить ли форму открытой, закрыть ли форму или открыть другую пустую форму после отправки этой формы.

Добавление подключения данных, отправляющего данные

  1. В меню Сервис выберите команду Параметры отправки.

  2. В диалоговом окне Параметры отправки установите флажок Разрешить пользователям отправлять эту форму.

  3. Щелкните Отправить данные формы в одно место, а затем в списке выберите Библиотека документов.

  4. Нажмите кнопку Добавить.

  5. В мастере создания подключения данных в поле Библиотека документов введите адрес библиотеки документов SharePoint.

  6. В поле Имя файла введите имя, которое будет идентифицировать форму в библиотеке документов.

    Совет : Чтобы гарантировать уникальность каждого имени формы, можно воспользоваться формулой.

    Реализация

    1. Выберите пункт Вставить формулу Кнопка формулы .

    2. В диалоговом окне Вставка формулы выполните одно из следующих действий:

      • Чтобы использовать поле в формуле, щелкните Вставить поле или группу, выберите нужное поле в диалоговом окне Выбор поля или группы, а затем нажмите кнопку ОК.

      • Чтобы использовать функцию в формуле, щелкните Вставить функцию, выберите нужную функцию в диалоговом окне Вставка функции, а затем нажмите кнопку ОК.

        Совет : Если для функции необходимы параметры, выберите функцию в диалоговом окне Вставка функции, нажмите кнопку ОК, а затем в поле Формула диалогового окна Вставка формулы дважды щелкните добавленную функцию, а также поле или группу. Для получения дополнительных сведений о функциях см. ссылки в разделе См. также.

      • Для вставки в формулу значения или математического оператора в поле Формула введите значение или знак математической операции.

    Операция

    Символ

    Добавление

    +

    Вычитание

    -

    Умножение

    *

    Деление

    /

    • Примечание : Если в формуле используется оператор деления (/), следует убедиться, что до и после него стоят пробелы. Если пробелы отсутствуют, знак «/» может быть принят за разделитель шагов пути XPath, а не за оператор деления.

    • Для проверки формулы на правильность синтаксиса в диалоговом окне Вставка формулы щелкните кнопку Проверить формулу.

      Для получения дополнительных сведений о формулах см. ссылки в разделе См. также.

  7. Чтобы в библиотеке документов перезаписать все существующие формы с одинаковыми именами, установите флажок Разрешить перезапись, если файл существует.

  8. Нажмите кнопку Далее.

  9. На следующей странице мастера в поле Введите имя подключения данных введите описательное имя для этого подключения данных.

  10. Проверьте правильность введенных данных в разделе Сводка, а затем нажмите кнопку Готово.

    1. Чтобы изменить имя кнопка " Отправить ", которая появляется на стандартной панели инструментов и команды Отправить, которое отображается в меню файл при заполнении формы пользователями, введите новое имя в поле заголовок в диалоговом окне Параметры отправки.

      Совет : Если вы хотите назначить сочетание клавиш для этой кнопки и команды, введите амперсанд (&) перед символом, который вы хотите использовать в качестве сочетания клавиш. Например чтобы назначить сочетание клавиш ALT + B как сочетание клавиш для отправки кнопок и команд, введите су & Правка.

  11. Если не хотите, чтобы пользователи могут использовать команду Отправить или кнопка " Отправить " на панели инструментов Стандартная при заполнении формы, снимите флажок Показывать отправки в меню и панели инструментов кнопка "Отправить".

    1. По умолчанию после отправки формы InfoPath хранит открыть форму и отображает сообщение для указания был успешно отправить форму. Чтобы изменить поведение по умолчанию, нажмите кнопку Дополнительно, а затем выполните одно из следующих действий:

      1. Чтобы закрыть форму или создать новую пустую форму после пользователь отправляет заполненной формы, выберите нужный вариант в списке после отправки.

      2. Чтобы создать настраиваемое сообщение для указания был успешно отправить форму, установите флажок использовать настраиваемые сообщения и введите ваши сообщения в полях на успеха и в случае ошибки.

        Совет : Использовать сообщение в поле на сбой объясняющий, что делать, если они не могут отправить их формы. Например может предложить что пользователи сохранения формы и связаться с другим человеком дополнительную информацию.

      3. Если вы не хотите отобразить сообщение после отправки формы, снимите флажок Показывать Успех и отказ сообщения.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×