Отображение размеров фигур в Visio

Отображение размеров фигур в Visio

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Чтобы узнать размеры фигуры, выделите ее и взгляните на строку состояния в нижней части окна Фигуры. Ширина, высота и угол поворота выводятся автоматически. Кроме того, вы можете воспользоваться одним из способов, описанных в этой статье.

Сведения об изменении размеров и углов фигуры в окне Размер и положение см. в статье Указание размеров с помощью окна "Размер и положение".

Отображение размеров на странице схемы

В стандартном выпуске Visio можно отображать размеры фигур с помощью полей, связанных с такими свойствами фигуры, как высота и ширина. Дополнительные сведения об использовании полей см. в статье Использование полей для отображения актуальной информации.

В профессиональном выпуске Visio для этой цели можно использовать фигуры размеров. Фигуры размеров показывают размер фигуры, к которой они приклеены, и автоматически обновляются при изменении ее размера.

Фигуры размеров включены в некоторые шаблоны. Набор элементов Размеры можно открыть в любом из них.

Чтобы открыть набор элементов размеры

  1. В окне Фигуры нажмите кнопку Дополнительные фигуры.

  2. Наведите указатель на элемент Дополнительные решения Visio и выберите Размеры (строительство) или Размеры (техника).

  3. Перетащите фигуру размера на фигуру, которую требуется измерить, и приклейте концы фигуры размера к точкам измерения.

Примечание : Чтобы изменить единицы измерения, щелкните правой кнопкой мыши фигуру размера и в контекстном меню выберите элемент Точность и единицы.

Фигура рабочего места с фигурами размеров

Пример

В приведенном ниже примере использования фигур размеров действия выполняются в профессиональном выпуске Visio.

Использование фигур размеров (пример)

  1. Откройте вкладку Файл, выберите Создать > Категории > Карты и планы этажей и дважды щелкните План дома.

  2. Щелкните название набора элементов Садовый участок и перетащите в документ фигуру Бетонная дорожка.

    Чтобы найти этот или другие наборы элементов, возможно, потребуется прокрутить список под заголовком Наборы элементов.

  3. Чтобы увеличить фигуру Бетонная дорожка, перетаскивайте маркеры на ней.

  4. Щелкните название набора элементов Размеры (строительство) и перетащите в документ фигуру Горизонтальный, разместив ее поверх дорожки.

    Если этого набора элементов в списке нет, выполните инструкции, приведенные в разделе Открытие набора элементов "Размеры".

  5. Перетащите правый маркер фигуры Горизонтальный на правый край дорожки таким образом, чтобы появился зеленый квадратик, указывающий на то, что фигуры связаны.

  6. Перетащите левый маркер фигуры По горизонтали на левый край дорожки.

  7. Поместите желтый ромб ( Управляющий маркер ), который находится справа от фигуры размера, над дорожкой таким образом, чтобы ее не загораживали размерные линии.

В этой статье

Просмотр ширины, высоты и угла поворота всей фигуры

Отображение ширины, высоты и угла поворота вложенной фигуры

Отображение ширины, высоты и угла поворота фигуры рядом с ней

Отображение размеров частей фигур

Просмотр ширины, высоты и угла поворота всей фигуры

  1. Выделите фигуру в документе.

  2. Чтобы узнать ширину, высоту и угол поворота фигуры, посмотрите на строку состояния.

Отображение ширины, высоты и угла поворота вложенной фигуры

Если вы хотите узнать размеры только некоторых фигур, вы можете быстро добавить поля измерения в фигуры, содержащие текстовые поля.

  1. Щелкните фигуру, к которой вы хотите добавить поля.

  2. На вкладке Вставка в группе Текст нажмите кнопку Поле.

  3. В диалоговом окне Поле в списке Категория выберите пункт Геометрия.

  4. В списке Имя поля выберите необходимое измерение.

    Совет : Для добавления единиц, таких как метры, нажмите кнопку Формат данных, а затем выберите значение в диалоговом окне Формат данных.

  5. Нажмите кнопку ОК.

  6. Повторите эти действия для каждого поля, которое вы хотите добавить.

    Совет : Чтобы отобразить высоту и ширину со знаком x между ними, вставьте первое поле в текстовое поле фигуры, введите пробел, x, еще один пробел, а затем вставьте второе поле.

К началу страницы

Отображение ширины, высоты и угла поворота фигуры рядом с ней

Примечание : Рисунки, связанные с данными, доступны только в Visio профессиональный и премиум.

Они позволяют быстро просмотреть высоту, ширину и угол поворота фигуры, а также другие сведения о ней. В этой статье объясняется, как показать размеры фигуры.

  1. На вкладке Данные в группе Отображение данных щелкните Рисунки, связанные с данными.

  2. Щелкните Создать рисунок, связанный с данными.

  3. В диалоговом окне Создание рисунка, связанного с данными нажмите кнопку Создать элемент.

  4. В диалоговом окне Создать элемент в списке Поле данных выберите Другие поля.

  5. В диалоговом окне Поле в списке Категория выберите пункт Геометрия.

  6. В списке Имя поля выберите необходимое измерение и нажмите кнопку ОК.

  7. В диалоговом окне Создать элемент в списке Отображение выберите Текст.

  8. В разделе Сведения в поле Метка введите название измерения (например, "Ширина" или "Высота") и нажмите кнопку ОК.

  9. Повторите эти действия для каждого измерения, которое вы хотите отобразить.

  10. В диалоговом окне Создание рисунка, связанного с данными нажмите кнопку ОК.

    Новый рисунок, связанный с данными, появится в коллекции Рисунки, связанные с данными в группе Доступные рисунки, связанные с данными.

  11. Выделите в документе фигуры, для которых вы хотите отобразить размеры, а затем в коллекции Рисунки, связанные с данными выберите рисунок, который вы создали.

Новый рисунок будет применен к выделенным фигурам.

К началу страницы

Отображение размеров частей фигур

Фигура рабочего места с фигурами размеров

Примечание : Фигуры размеров доступны только в Visio профессиональный и премиум.

С помощью фигур размеров можно измерять другие фигуры. Если приклеить фигуру размеров к фигуре, которую требуется измерить, в ней будут отображены соответствующие значения. Значения обновляются автоматически при изменении размеров.

Существует несколько фигур размеров, соответствующих различным измерениям. Чтобы ознакомиться с ними, просмотрите такие наборы элементов, как Размеры (техника).

Ниже показано, как использовать фигуру размеров для измерения дорожки на плане дома.

  1. Откройте вкладку Файл, выберите команду Создать и категорию Карты и планы этажей, а затем дважды щелкните элемент План дома.

  2. Щелкните название набора элементов Садовый участок и перетащите в документ фигуру Бетонная дорожка.

  3. Щелкните заголовок набора элементов Размеры (строительство) и перетащите в документ фигуру Размер по горизонтали, разместив ее над дорожкой.

  4. Перетащите правый маркер фигуры Размер по горизонтали на правый край дорожки таким образом, чтобы появился зеленый квадратик, указывающий на то, что фигуры связаны.

  5. Перетащите левый маркер фигуры По горизонтали на левый край дорожки.

  6. Поместите желтый ромб, который находится справа от фигуры размера, над дорожкой таким образом, чтобы ее не загораживали размерные линии.

Примечание : Чтобы изменить единицы измерения, щелкните правой кнопкой мыши фигуру размера и в контекстном меню выберите элемент Точность и единицы.

К началу страницы

В этой статье

Просмотр ширины, высоты и угла поворота всей фигуры

Просмотр площади или периметра фигуры

Отображение ширины, высоты и угла поворота вложенной фигуры

Отображение ширины, высоты и угла поворота фигуры рядом с ней

Отображение размеров частей фигур

Просмотр ширины, высоты и угла поворота всей фигуры

Строка состояния, в которой отображается ширина, высота и угол поворота выбранной фигуры.

  1. Выделите фигуру в документе.

  2. Чтобы узнать ширину, высоту и угол поворота фигуры, посмотрите на строку состояния.

Просмотр площади или периметра фигуры

Диалоговое окно «Площадь и периметр фигуры», в котором отображаются измерения выбранной фигуры.

Примечание : Диалоговое окно Площадь и периметр фигуры доступно только в Microsoft Office Visio профессиональный.

  1. Выделите фигуру в документе.

  2. В меню Сервис выберите Надстройки, щелкните Дополнительные решения Visio и выберите Площадь и периметр фигуры.

    Откроется диалоговое окно Площадь и периметр фигуры, в котором отображаются измерения фигуры.

  3. Чтобы просмотреть значения в других единицах, выберите нужную единицу измерения в поле Общая площадь или Общий периметр.

К началу страницы

Отображение ширины, высоты и угла поворота вложенной фигуры

Прямоугольник с измерением высоты и ширины фигуры, отображаемый в текстовом окне.

Если вы хотите узнать размеры только некоторых фигур, вы можете быстро добавить поля измерения в фигуры, содержащие текстовые поля. Если вы используете Office Visio Профессиональный 2007 и хотите отобразить измерения для большого количества фигур, можно сэкономить время, используя рисунки, связанные с данными, как описано в разделе Отображение ширины, высоты и угла поворота фигуры рядом с ней.

  1. Щелкните фигуру, к которой вы хотите добавить поля.

  2. В меню Вставка выберите команду Поле.

  3. В диалоговом окне Поле в списке Категория выберите пункт Геометрия.

    Диалоговое окно с полями, которые могут быть добавлены в текстовое поле фигуры.

  4. В списке Имя поля выберите необходимое измерение.

    Совет : Для добавления единиц, таких как метры, нажмите кнопку Формат данных, а затем выберите значение в диалоговом окне Формат данных.

  5. Нажмите кнопку ОК.

  6. Повторите шаги 2–5 для каждого поля, которое вы хотите добавить.

    Совет : Чтобы отобразить высоту и ширину со знаком x между ними, вставьте первое поле в текстовое поле фигуры, введите пробел, x, еще один пробел, а затем вставьте второе поле.

Примечание : Значения в полях обновляются автоматически при изменении размера фигуры.

К началу страницы

Отображение ширины, высоты и угла поворота фигуры рядом с ней

Фигура кустарника с указанием ширины, высоты и угла поворота в рисунке, связанном с данными.

Примечание : Рисунки, связанные с данными, доступны только в Office Visio Профессиональный 2007.

Они позволяют быстро просмотреть высоту, ширину и угол поворота фигуры, а также другие сведения о ней. В этой статье объясняется, как показать размеры фигуры. Сведения о том, как эффективно использовать рисунки, связанные с данными, см. в статье Использование рисунков, связанных с данными, для улучшения представления данных.

  1. В меню Данные выберите команду Показывать данные в фигурах.

  2. В области задач Рисунки, связанные с данными в разделе Создать рисунок, связанный с данными щелкните Создать рисунок, связанный с данными.

  3. В диалоговом окне Создание рисунка, связанного с данными щелкните Создать элемент и выберите Текст.

    Панель задач рисунков, связанных с данными, и диалоговое окно «Создание рисунка, связанного с данными».

    1. Область задач Рисунки, связанные с данными

    2. Команда Создать рисунок, связанный с данными

    3. Диалоговое окно Создание рисунка, связанного с данными с полем Создать элемент и командой Текст

  4. В диалоговом окне Новый текст в разделе Отображение в списке Поле данных выберите Другие поля.

  5. В диалоговом окне Поле в списке Категория выберите пункт Геометрия.

  6. В списке Имя поля выберите необходимое измерение и нажмите кнопку ОК.

    Диалоговое окно «Поле», показывающее поля, которые могут быть добавлены в рисунок, связанный с данными.

  7. В диалоговом окне Новый текст в разделе Сведения в поле Метка введите название измерения (например, "Ширина", "Высота" или "Угол") и нажмите кнопку ОК.

  8. Повторите действия 3–7 для каждого измерения, которое вы хотите отобразить.

  9. В диалоговом окне Создание рисунка, связанного с данными нажмите кнопку ОК.

    Новый рисунок, связанный с данными, появится в области задач Рисунки, связанные с данными в группе Применить рисунок, связанный с данными.

  10. Выделите в документе фигуры, для которых вы хотите отобразить размеры, а затем в области задач Рисунки, связанные с данными выберите рисунок, который вы создали.

Новый рисунок будет применен к выделенным фигурам.

Три фигуры дерева с применением недавно созданного рисунка, связанного с данными.

К началу страницы

Отображение размеров частей фигур

Фигура рабочего места с фигурами размеров

Примечание : Фигуры размеров поддерживаются только в Office Visio Профессиональный 2007.

С помощью фигур размеров можно измерять другие фигуры. Если приклеить фигуру размеров к фигуре, которую требуется измерить, в ней будут отображены соответствующие значения. Значения обновляются автоматически при изменении размеров.

Существует несколько фигур размеров, соответствующих различным измерениям. Чтобы ознакомиться с ними, просмотрите наборы элементов. На рисунке ниже показаны фигуры в наборе элементов Размеры (техника).

Трафарет «Размеры (строительство)».

Ниже показано, как использовать фигуру размеров для измерения рояля на плане дома.

  1. В меню Файл выберите команду Создать и категорию Карты и планы этажей, а затем щелкните План дома.

  2. Щелкните название набора элементов Мебель и перетащите в документ фигуру Рояль.

  3. Щелкните заголовок набора элементов Размеры (строительство) и перетащите в документ фигуру Размер по горизонтали, разместив ее над роялем.

    Фигура рояля с фигурой размера «По горизонтали» над ней.

  4. Перетащите правый маркер фигуры Размер по горизонтали на правый край рояля таким образом, чтобы появился зеленый квадратик, указывающий на то, что фигуры связаны.

    Фигура размера, соединенная с одним маркером фигуры рояля.

  5. Перетащите левый маркер фигуры Размер по горизонтали на левый край рояля.

    Фигура размера, соединенная с двумя маркерами фигуры рояля.

  6. Поместите желтый ромб, который находится справа от фигуры размера, над роялем таким образом, чтобы его не загораживали размерные линии.

    Фигура размера с удлиненными выносными линиями, соединенная с фигурой рояля.

Примечание : Чтобы изменить единицы измерения, щелкните правой кнопкой мыши фигуру размера и в контекстном меню выберите элемент Точность и единицы.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×