Основные сведения об отчетах в Access

Основные сведения об отчетах в Access

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью отчетов можно просматривать, форматировать и группировать информацию в базе данных Microsoft Access. Например, можно создать простой отчет в виде списка номеров телефонов всех контактов или сводный отчет по итогам продаж компании в разных регионах за разные периоды.

В этой статье представлен обзор отчетов в Access, сведения об основах создания отчета и использования функций сортировки, группирования и обобщения данных, а также о том, как предварительно просмотреть и напечатать отчет.

Примечание : Сведения в этой статье предназначены только для баз данных Access рабочего стола. Веб-приложения Access не поддерживает отчеты.

В этой статье

Обзор отчетов в Access

Создание отчета в Access

Добавление группировки, сортировки и итогов

Выделение данных с помощью условного форматирования

Настройка цвета и шрифтов

Добавление логотипа или фонового рисунка

Печать отчета

Обзор отчетов в Access

Возможности использования отчета

Отчет — это объект базы данных, удобный для представления ее информации с одной из следующих целей:

  • отображение или распространение сводки данных;

  • архивирование моментальных снимков данных;

  • предоставление сведений об отдельных записях;

  • создание надписей.

Составные части отчета

Можно создавать «несвязанные» отчеты, в которых данные не отображаются, но в этой статье мы рассмотрим отчет, связанный с источником данных (таблицей или запросом). Макет отчета разбит на разделы, которые можно просмотреть в режиме конструктора. Понимание принципов работы каждого раздела поможет создать лучшие отчеты. Например, от выбора раздела для размещения вычисляемого элемента управления зависит способ вычисления результата. Ниже перечислены типы разделов и указано назначение каждого из них:

Раздел

Отображение раздела при печати

Использование раздела

Заголовок отчета.

В начале отчета.

В заголовок включается информация, обычно помещаемая на обложке, например эмблема компании, название отчета или дата. Если в заголовке отчета помещен вычисляемый элемент управления, использующий статистическую функцию Sum, сумма рассчитывается для всего отчета. Заголовок отчета печатается перед верхним колонтитулом.

Верхний колонтитул.

Вверху каждой страницы.

Верхний колонтитул используется в тех случаях, когда нужно, чтобы название отчета повторялось на каждой странице.

Заголовок группы.

В начале каждой новой группы записей.

Используется для печати названия группы. Например, если отчет сгруппирован по изделиям, в заголовках групп можно указать их названия. Если поместить в заголовок группы вычисляемый элемент управления, использующий статистическую функцию Sum, сумма будет рассчитываться для текущей группы. Заголовок группы может состоять из нескольких разделов в зависимости от добавленных уровней группирования. Дополнительные сведения о создании верхних и нижних колонтитулов группы см. раздел «Добавление группирования, сортировки или итоговых данных».

Область данных.

Отображается один раз для каждой строки в источнике записей.

В нем размещаются элементы управления, составляющие основное содержание отчета.

Примечание группы.

В конце каждой группы записей.

Примечание группы можно использовать для печати сводной информации по группе. Нижний колонтитул группы может состоять из нескольких разделов в зависимости от добавленных уровней группирования.

Нижний колонтитул.

Внизу каждой страницы.

Используется для нумерации страниц и для печати постраничной информации.

Примечание отчета.

В конце отчета.

Примечание : В режиме конструктора примечание отчета отображается под нижним колонтитулом. Однако во всех остальных режимах (например, в режиме макета, при печати или предварительном просмотре) этот раздел помещается над нижним колонтитулом, сразу после примечания последней группы или строки области данных на последней странице.

Примечание отчета можно использовать для печати итогов и другой сводной информации по всему отчету.

Создать значимый отчет гораздо проще, если таблицы в базе данных имеют хорошо разработанные структуру и связи. Начальные сведения по планированию и разработке базы данных см. в статье Основные сведения о создании баз данных.

К началу страницы

Создание отчета в Access

Чтобы создать отчет для базы данных Access на компьютере, выполните следующие действия.

Действие 1. Выбор источника записей

Источником записей для отчета может быть таблица, именованный или внедренный запрос. Источник записей должен содержать все строки и столбцы данных, которые требуется отобразить в отчете.

  • Если нужные данные содержатся в существующей таблице или запросе, выделите эту таблицу или запрос в области навигации и перейдите к действию 2.

  • Если источник записей еще не создан, выполните одно из перечисленных ниже действий.

    • Перейдите к действию 2 и воспользуйтесь инструментом Пустой отчет;

      ИЛИ

    • создайте таблицы или запрос, которые будут содержать нужные данные, выберите их в области навигации и перейдите к действию 2.

Действие 2. Выбор инструмента отчета

Инструменты отчета расположены на вкладке Создать в группе Отчеты. В следующей таблице описаны такие параметры:

Средство

Описание

Отчет

Позволяет создать простой табличный отчет, содержащий все поля из источника записей, который выбран в области навигации.

Конструктор отчетов

Открывает в режиме конструктора пустой отчет, в который можно добавить необходимые поля и элементы управления.

Пустой отчет

Позволяет открыть пустой отчет в режиме макета и отобразить область задач «Список полей», из которой можно добавить поля в отчет.

Мастер отчетов

Служит для вызова пошагового мастера, с помощью которого можно задать поля, уровни группировки и сортировки и параметры макета.

Наклейки

Вызывает мастер, в котором можно выбрать стандартный или настраиваемый размер подписей, набор отображаемых полей и порядок их сортировки.

Действие 3. Создание отчета

  1. Для выбора требуемого инструмента нажмите соответствующую кнопку панели инструментов. После появления мастера следуйте всем его командам и на последней странице нажмите кнопку Готово.
    Access отображает отчет в режиме макета.

  2. Отформатируйте отчет, чтобы добиться желаемого внешнего вида.

    • Измените размер полей и подписей, выделяя их и перетаскивая края.

    • Расположите поля в нужном порядке, выделяя их (и соответствующие подписи, если они есть) и перетаскивая в нужное место.

    • Также можно, щелкая поля правой кнопкой мыши, с помощью команд контекстного меню объединять или разбивать ячейки, удалять и выделять поля и выполнять другие задачи форматирования.

      Кроме того, отчет можно сделать более привлекательным и удобным с помощью функций, описанных в разделах ниже.

К началу страницы

Добавление группировки, сортировки и итогов

Чтобы быстро добавить в отчет группировку, сортировку или итоги, щелкните правой кнопкой мыши поле, к которому необходимо применить соответствующую функцию, и выберите нужную команду в контекстном меню.

Кроме того, когда отчет открыт в режиме макета или конструктора, можно добавить эти функции с помощью области "Группировка, сортировка и итоги".

  1. Если область "Группировка, сортировка и итоги" не открыта, на вкладке Конструктор в группе Группировка и итоги выберите команду Группировка.

  2. Нажмите кнопку Добавить группировку или Добавить сортировку и выберите поле, по которому требуется сгруппировать или отсортировать данные.

  3. Чтобы задать дополнительные параметры или добавить итоги, в строке группировки или сортировки выберите команду Больше.

Более подробные сведения о группировке, сортировке и итогах см. в статье Создание отчета с группировкой или сводного отчета.

К началу страницы

Выделение данных с помощью условного форматирования

Доступ включает средства для выделения данных в отчете. Вы можете добавить правила условного форматирования для каждого элемента управления или группу элементов управления и отчетах клиента, вы также можете добавить гистограммы для сравнения данных.

Добавление условного форматирования к элементам управления:

  1. Щелкните отчет в области навигации правой кнопкой мыши и выберите пункт Режим макета.

  2. Выберите необходимые элементы управления и на вкладку Формат, в группе Форматирование элемента управления, нажмите кнопку Условное форматирование.

    Совет : Чтобы выбрать несколько элементов управления, щелкайте их, удерживая клавишу CTRL.

  3. В диалоговом окне Диспетчер правил условного форматирования выберите команду Создать правило.

  4. В диалоговом окне Новое правило форматирования выберите значение в поле Выберите тип правила.

    • Чтобы создать правило, которое будет проверяться отдельно для каждой записи, выберите вариант Проверьте значения в текущей записи или используйте выражение.

    • Чтобы создать правило для сравнения записей друг с другом с помощью гистограмм, выберите вариант Сравнить с другими записями.

  1. В поле Изменение описания правила укажите правило, которое будет применяться при форматировании, и тип форматирования, а затем нажмите кнопку ОК.

  2. Если нужно создать еще одно правило для этого элемента управления или группы элементов, повторите процедуру, начиная с действия 4.

К началу страницы

Настройка цвета и шрифтов

Для настройки цвета и шрифтов попробуйте параметр Тема приложения.

  1. Откройте отчет в режиме макета, щелкнув правой кнопкой мыши в области навигации и выбрав Макет Vросмотр.

  2. В пункте Работа с макетами отчетов на вкладке Конструктор выберите параметр Темы и наводите курсор на различные темы в галерее, чтобы предварительно просмотреть эффекты. Чтобы выбрать тему, щелкните ее и сохраните отчет.

  3. С помощью коллекций Цвета и Шрифты можно задать цвета и шрифты независимо друг от друга.


К началу страницы

Добавление логотипа или фонового рисунка

В отчет также можно добавить логотип или фоновый рисунок. При обновлении рисунка он автоматически обновляется в любом месте базы данных.

Добавление или удаление рисунка

  1. В области навигации щелкните отчет правой кнопкой мыши и выберите команду Макет.

  2. В отчете щелкните место, куда необходимо добавить рисунок, и на вкладке Конструктор в группе Колонтитулы выберите пункт Логотип.

  3. Перейдите к рисунку и нажмите кнопку Открыть. Access добавит рисунок в отчет.

  4. Чтобы удалить рисунок, щелкните его правой кнопкой мыши и выберите в контекстном меню пункт «Удалить».

Добавление фонового изображения

  1. В области навигации щелкните отчет правой кнопкой мыши и выберите команду Макет.

  2. На вкладке Формат в группе Фон нажмите кнопку Фоновый рисунок.

  3. Выберите рисунок из списка Коллекция изображений или нажмите кнопку Обзор, выберите рисунок и нажмите кнопку ОК.

К началу страницы

Предварительный просмотр и печать отчета

Предварительный просмотр отчета

  1. Щелкните правой кнопкой мыши имя отчета в области навигации и выберите команду Предварительный просмотр. Команды на вкладке Предварительный просмотр можно использовать, чтобы:

    • напечатать отчет;

    • изменить размер или макет страницы;

    • изменить масштаб или просмотреть сразу несколько страниц;

    • обновить данные в отчете;

    • экспортировать отчет в другой формат файла.

  2. Нажмите кнопку Закрыть режим предварительного просмотра

Печать отчета

Печать отчета без предварительного просмотра

  • Щелкните правой кнопкой мыши имя отчета в области навигации и выберите команду Печать. Отчет будет отправлен на принтер, используемый по умолчанию.

    Примечание : При выборе отчета в области навигации и выборе команды Печать на вкладке Файл можно установить дополнительные параметры печати (количество страниц и копий) и указать принтер.

    • Чтобы открыть диалоговое окно, в котором можно выбрать принтер, указать число копий и задать другие параметры, выберите команду Печать.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×