Общие сведения о подключении к данным и их импорте

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

В этой статье ссылка рассматриваются Импорт и подключения данных. Вы узнаете о задачах, таких как импорт, обновление, защита и управление данными.

В этой статье

Работа с подключений к внешним данным

Обновление данных

Импорт данных из источников данных

Повышение уровня безопасности доступ к данным

Вопросы о подключении к данным

Работа с подключениями к внешним данным

В приведенных ниже разделах описаны принципы работы подключений к внешним данным и представлены инструкции по их поиску, изменению, управлению ими и использованию с другими программами и пользователями.

К началу страницы

Принципы подключения к данным

Данные в книге Excel могут извлекаться из двух источников. Они могут храниться непосредственно в книге или во внешнем источнике данных, например в текстовом файле, базе данных или кубе OLAP. Этот внешний источник данных присоединяется к книге через подключение к данным, которое представляет собой набор сведений, описывающих порядок поиска источника данных, подключения и доступа к нему.

Главным преимуществом подключения к внешним данным является возможность их периодического анализа без многократного копирования в книгу, которое занимает много времени и не исключает ошибок. После подключения к внешним данным можно автоматически обновлять книги Microsoft Excel из исходного источника при каждом его обновлении.

Сведения о подключении хранятся в книге, однако их также можно сохранить в файле подключения (например, ODC-файле подключения к данным Office или DSN-файле имени источника данных).

Чтобы перенести внешние данные в Microsoft Excel, требуется доступ к данным. Если внешние источник данных, должны быть доступны не на локальном компьютере, вам потребуется обратиться к администратору базы данных пароль, разрешения пользователя или другие сведения о подключении. Если источник данных представляет собой база данных, убедитесь в том, что база данных не открыта в режиме монопольного доступа. Если источник данных в текстовый файл или электронную таблицу, убедитесь, что другой пользователь не открыт в режиме монопольного доступа.

Многим источникам данных для управления обменом данными между Excel, файлом подключения и источником также необходим драйвер ODBC или поставщик OLE DB.

На приведенной ниже схеме обобщены основные моменты подключения к данным.

Подключение к внешним источникам данных

1. существует различных источников данных, которые вы можете подключиться к: служб Analysis Services, SQL Server, Microsoft Access, другие OLAP и реляционных баз данных, электронных таблицах и текстовых файлов.

2. Многие источники данных имеют соответствующий драйвер ODBC или поставщик OLE DB.

3. файл подключения определяет все сведения, необходимые для доступа и извлечения данных из источника данных.

4. сведения о подключении копируются из файла подключения в книге, а можно легко изменять сведения о подключении.

5. Данные копируются в книгу, после чего их можно использовать так же, как и данные, которые хранятся непосредственно в ней.

К началу страницы

Поиск подключений

Найти файлы подключения можно с помощью диалогового окна Существующие подключения (на вкладке Данные в группе Внешние данные нажмите кнопку Существующие подключения). В этом окне доступны подключения указанных ниже типов.

  • Соединений в книге   

    В этом списке отображаются все подключения, доступные к книге. Он включает уже определенные подключения, подключения, созданные с помощью диалогового окна Выбор источника данных мастера подключения данных, а также подключения, ранее выбранные в этом же окне.

  • Файлы подключения на компьютере   

    Этот список создается на основе папки Мои источники данных, которая обычно хранится в папке Мои документы (Windows XP) или Документы (Windows Vista).

  • Файлы подключения к сети   

    В этот список могут входить указанные ниже элементы.

    • Набор папок в локальной сети, расположение которых можно указать в ходе развертывания групповых политик Microsoft Office.

    • службы Excel данные подключения библиотеки (ODC-ФАЙЛ) на сайте SharePoint Foundation. Дополнительные сведения о DCLs в разделе Публикация в службах Excel безопасно.

К началу страницы

Изменение свойств подключения

Приложение Excel можно использовать как редактор файлов для создания и редактирования подключений к внешним источникам данных, хранящимся в книге или в файле подключения. Если найти нужное подключение не удается, его можно создать. Для этого необходимо нажать кнопку Найти другие, чтобы вызвать диалоговое окно Выбор источника данных, а затем выбрать команду Создать источник, чтобы запустить мастер подключения данных.

После создания подключения можно использовать диалоговое окно Свойства подключения (на вкладке " данные " в группе Получение внешних данных нажмите кнопку Свойства.) для управления различные параметры для подключения к внешним источникам данных, а также использовать повторно использовать или изменить файлы подключения.

При использовании файла подключения для подключения к источнику данных приложение Excel копирует сведения о подключении в книгу. При изменении параметров в диалоговом окне Свойства подключения редактируются сведения о подключении, хранящиеся в текущей книге, а не исходный файл подключения к данным, имя которого определяет свойство Файл подключения на вкладке Определение. После изменения сведений о подключении (за исключением свойств Имя подключения и Описание подключения) ссылка на файл подключения будет удалена, а свойство Файл подключения — очищено.

Чтобы гарантировать, что файл подключения будет использоваться всегда при обновлении источника данных, установите флажок Всегда пытаться использовать этот файл для обновления данных на вкладке Определение. Этот флажок обеспечивает гарантирует, что обновления файла подключения распространяются на все книги, использующие этот файл (для него также необходимо установить это свойство).

К началу страницы

Управление подключениями

Управлять этими подключениями (создавать их, изменять и удалять) можно в диалоговом окне Подключения к книге (на вкладке Данные в группе Внешние данные нажмите кнопку Подключения). С помощью этого диалогового окна можно выполнять указанные ниже операции.

  • Создание, изменение, обновление и удаление подключений, используемых в книге.

  • Проверка внешнего источника данных. Это иногда требуется, если подключение было определено другим пользователем.

  • Указание мест использования подключений в текущей книге.

  • Анализ ошибок подключения к внешним данным.

  • Перенаправление соединения на другой сервер или источник данных или замена файла подключения для существующего подключения.

  • Создание файла подключения и обеспечение совместного доступа к нему.

К началу страницы

Совместное использование подключений

Файлы подключений особенно полезны при регулярном совместном использовании подключений, поскольку делают их более доступными, помогают защитить их и упрощают управление источниками данных. Оптимальный способ совместного использования файлов подключений предполагает, что они хранятся в защищенном и надежном месте (например, в сетевой папке или библиотеке SharePoint), в котором они доступны для чтения всем пользователям, а для изменения — лишь некоторым из них.

Использование ODC-файлов

Создать файл подключения к данным Office (ODC-файл) можно путем подключения к внешним данным с помощью диалогового окна Выбор источника данных или с помощью мастера подключения данных, позволяющего подключаться к новым источникам. В ODC-файле для хранения сведений о подключении используются настраиваемые HTML- и XML-теги. Содержимое этого файла можно легко просмотреть и изменить в приложении Excel.

Файлы подключений можно использовать совместно с другими людьми, предоставляя им такой же доступ к внешнему источнику данных. Другим пользователям для открытия файла подключения не нужно создавать источник данных, однако им может потребоваться установить драйвер ODBC или поставщик OLE DB, необходимый для доступа к внешним данным с их компьютеров.

ODC-файлы обеспечивают оптимальный способ подключения к данным и их совместного использования. Другие стандартные файлы подключений (DSN-, UDL-файлы и файлы запросов) можно легко преобразовать в ODC-файл. Для этого откройте файл подключения и в диалоговом окне Свойства подключения на вкладке Определение нажмите кнопку Экспорт файла подключения.

Использование файлов запросов

Файлы запросов — это текстовые файлы, содержащие сведения об источниках данных, включая имя сервера, на котором они расположены, и сведения о подключении, которые задаются при создании источника. Файлы запросов — это стандартный способ использования запросов совместно с другими пользователями Excel.

Использование файлов запросов .dqy    С помощью Microsoft Query для сохранения файлов .dqy, содержащих запросы для данных из реляционных баз данных и текстовых файлов. При открытии в Microsoft Query эти файлы можно просматривать данные, возвращаемые запросом и измените запрос, чтобы получить разные результаты. Можно сохранить для любого запроса, созданного, с помощью мастера запросов или непосредственно в Microsoft Query заново.

Использование файлов запросов .oqy    Вы можете сохранять файлы .oqy для подключения к данным в базе данных OLAP на сервере или в автономный файл куба (.cub). При использовании мастера подключения многомерные в Microsoft Query для создания источника данных для базы данных OLAP или куба самостоятельной создается автоматически. Поскольку баз данных OLAP не организованы в записи или таблицы, нельзя создать запросы или DKY-файлы в этих базы данных access.

Использование файлов запросов .rqy    Excel можно открывать файлы запросов в формате .rqy для поддержки драйверов источников данных OLE DB, использующих этот формат. Дополнительные сведения драйвер документации.

Использование файлов запросов .qry    Microsoft Query можно открывать и сохранять файлы запросов в формате QRY для использования с более ранними версиями Microsoft Query, не удается открыть файлы .dqy. Если у вас есть файл запроса в формате .qry, который вы хотите использовать в Excel, откройте файл в Microsoft Query и сохраните его как заново. Дополнительные сведения о сохранении файлов .dqy к справке Microsoft Query.

Использование IQY веб-запроса файлов    Excel можно открывать IQY-файлов Web запросов для извлечения данных из Интернета.

К началу страницы

Использование диапазонов и свойств внешних данных

Диапазон внешних данных (также называемый таблицей запроса) — это определенное имя или имя таблицы, которое задает расположение данных, загружаемых на лист. При подключении к внешним данным в Excel автоматически создается диапазон внешних данных. Единственным исключением из этого правила является подключение отчета сводной таблицы к источнику данных (диапазон внешних данных при этом не создается). В Excel можно настраивать форматирование и расположение диапазона внешних данных, а также использовать его в вычислениях, как и любые другие данные.

Приложение Excel автоматически присваивает имена диапазонам внешних данных в соответствии с указанными ниже правилами.

  • Внешним диапазонам данных из ODC-файлов присваиваются те же имена, что и соответствующим файлам.

  • Запрос на имя — это именованные диапазоны внешних данных из базы данных. По умолчанию запрос_из_источник — имя источника данных, которая использовалась для создания запроса.

  • Внешним диапазонам данных из текстовых файлов присваиваются имена соответствующих файлов.

  • С именем веб-страницы, из которого извлекается данных — это именованные диапазоны внешних данных из веб-запросы.

Если на листе есть несколько диапазонов внешних данных из одного источника, они нумеруются, например "МойТекст", "МойТекст_1", "МойТекст_2" и т. д.

Диапазон внешних данных имеет дополнительные свойства (не путайте их со свойствами подключения), которые можно использовать для управления данными (например, для сохранения форматирования ячеек и ширины столбцов). Свойства диапазона внешних данных можно изменить, нажав кнопку Свойства в группе Подключения на вкладке Данные и внеся все необходимые изменения в диалоговом окне Свойства внешнего диапазона данных или Свойства внешних данных.

Примечание : Если вы хотите поделиться сводку или отчет, который находится на основе внешних данных, можно предоставить другим пользователям книгу, содержащую диапазон внешних данных или можно создать шаблон отчета. шаблон отчета позволяет сохранить сводку или отчет без сохранения внешних данных, что файл меньшего размера. Внешние данные будут найдены при открытии шаблона отчета.

К началу страницы

Поддержка источников данных в Excel и службах Excel

Для подключения к разным источникам данных можно использовать различные объекты данных (например, диапазон внешних данных или отчет сводной таблицы), причем каждый такой объект допускает подключение к источникам определенного типа. Использовать и обновлять данные, к которым установлено подключение, можно в службах Excel, однако существуют дополнительные ограничения и способы их обхода, о которых необходимо помнить.

Объект данных Excel и поддержка источников данных

В приведенной ниже таблице указано, какие источники данных поддерживаются для каждого объекта данных в Excel.

Поддерживаемый источник данных

Excel
данные
объекта

Создает
внешних
данные
диапазон?

OLE
DB

ODBC

Текст
файла

HTML
файла

XML
файла

Общий доступ -
точки
списка

Мастер импорта текста

Да

Нет

Нет

Да

Нет

Нет

Нет

Отчет сводной таблицы
(не OLAP)

Нет

Да

Да

Да

Нет

Нет

Да

Отчет сводной таблицы
(OLAP)

Нет

Да

Нет

Нет

Нет

Нет

Нет

Таблица Excel

Да

Да

Да

Нет

Нет

Да

Да

Карта XML

Да

Нет

Нет

Нет

Нет

Да

Нет

Веб-запрос

Да

Нет

Нет

Нет

Да

Да

Нет

Мастер подключения данных

Да

Да

Да

Да

Да

Да

Да

Microsoft Query

Да

Нет

Да

Да

Нет

Нет

Нет

Примечание : Эти файлы (текстовый файл, импортированный с помощью мастера импорта текста, XML-файл, импортированный с помощью карты XML, и HTML- либо XML-файл, импортированный с помощью веб-запроса) не используют для подключения к источнику данных драйвер ODBC или поставщик OLE DB.

Службы Excel и поддержка источников данных

Если требуется отобразить книгу Excel в службах Excel (Excel в веб-браузере), можно подключиться к данным и обновить их, однако при этом необходимо использовать отчет сводной таблицы. Службы Excel не поддерживают диапазоны внешних данных, а это означает, что таблицы Excel, подключенные к источникам данных, веб-запросам, картам XML и приложению Microsoft Query, также не поддерживаются.

Однако это ограничение можно обойти, если подключиться к источнику данных с помощью сводной таблицы, а затем создать и расположить элементы сводной таблицы в виде плоской таблицы без уровней, групп и промежуточных итогов, чтобы отобразить все необходимые значения в строках и столбцах. Дополнительные сведения см. в разделе См. также.

К началу страницы

Принципы использования компонентов доступа к данным

Компоненты доступа к данным Microsoft (MDAC) 2,8 входит в состав Microsoft Windows Server 2003 и Windows XP с пакетом обновления 2. С MDAC можно подключиться к и использовать данные из различных источников реляционных и нереляционных данных. Вы можете подключить к различным источникам данных с помощью подключения ODBC (Open Database) драйверы или OLE DB поставщиков, которые являются встроенные и созданных корпорацией Майкрософт или разработанные различных третьими сторонами. При установке Microsoft Office на компьютер добавляются дополнительные драйверы ODBC и поставщиков OLE DB.

В системах Windows Vista и Windows 7 используются компоненты доступа к данным Windows DAC.

Чтобы увидеть полный список поставщиков OLE DB, установленных на компьютере, вызовите диалоговое окно Свойства связи с данными из файла связи с данными и откройте вкладку Поставщик.

Чтобы увидеть полный список поставщиков ODBC, установленных на компьютере, отобразите диалоговое окно Администратор баз данных ODBC и откройте вкладку Драйверы.

Для загрузки данных из источников, отличных от источников Майкрософт (включая другие виды баз данных ODBC и OLE DB), можно использовать драйверы ODBC и поставщики OLE DB других изготовителей. Для получения сведений об установке этих драйверов ODBC и поставщиков OLE DB обратитесь к документации по базе данных либо свяжитесь с ее поставщиком.

К началу страницы

Подключение к источникам данных с помощью ODBC

В приведеннных ниже технология ODBC описана более подробно.

Архитектура ODBC

В архитектуре ODBC приложение (например, Excel) подключается к диспетчеру драйверов ODBC, который, в свою очередь, использует конкретный драйвер ODBC (например, Microsoft SQL ODBC) для подключения к источнику данных (такому как база данных Microsoft SQL Server).

Определение сведений о подключении

Чтобы подключиться к источникам данных ODBC, выполните указанные ниже действия.

  1. Убедитесь, что на компьютере с источником данных установлен соответствующий драйвер ODBC.

  2. Определите имя источника данных (DSN) с помощью администратора источников данных ODBC, сохранив сведения о подключении в реестре или DSN-файле, либо с помощью строки подключения в Microsoft Visual Basic, которая передает сведения о подключении непосредственно диспетчеру драйверов ODBC.

    Чтобы определить источник данных в Windows Vista, нажмите кнопку Пуск и выберите пункт Панель управления. Щелкните ссылку Система и ее обслуживание, а затем — Администрирование. В Windows XP и Windows Server нажмите кнопку Пуск и выберите пункт Панель управления. Щелкните ссылку Производительность и обслуживание, а затем — Администрирование и выберите пункт Источники данных (ODBC). Чтобы получить дополнительные сведения о различных параметрах, нажмите кнопку Справка в соответствующем диалоговом окне.

Источники данных компьютера

Источники данных в компьютере хранение сведений о подключении в реестре на определенном компьютере, с именем пользовательские. Источники данных в компьютере можно использовать только на том компьютере, на котором они определены на. Существует два типа источников данных в компьютере — пользователь и система. Источники данных пользователя может использоваться текущим пользователем и видны только для этого пользователя. Системные источники данных можно использовать для всех пользователей на компьютере и видны всем пользователям на компьютере.

Источники данных компьютера особенно полезны, если требуется обеспечить дополнительную безопасность, поскольку они гарантируют, что просмотреть источник сможет только пользователь, который вошел в систему. Такой источник не может быть скопирован на другой компьютер удаленным пользователем.

Файловые источники данных

Файловые источники данных (также называемые DSN-файлами) хранят сведения о подключении не в реестре, а в текстовом файле, и обычно являются более гибкими, чем источники данных компьютера. Например, можно скопировать файловый источник данных на любой компьютер с подходящим драйвером ODBC, обеспечив приложению доступ к согласованным и точным данным со всех компьютеров. Кроме того, можно разместить файловый источник данных на сервере, организовать доступ к нему с нескольких компьютеров в сети и легко поддерживать правильность сведений о подключении в одном месте.

Файловый источник данных также может не поддерживать совместное использование. Такой источник данных находится на одном компьютере и указывает на источник данных компьютера. Файловые источники данных, не поддерживающие совместное использование, позволяют организовать доступ к существующим источникам данных компьютеров с помощью файловых источников.

К началу страницы

Подключение к источникам данных с помощью OLE DB

В приведенных ниже технология OLE DB описана более подробно.

Архитектура OLE DB

В архитектуре OLE DB приложение, обращающееся к данным, называется получателем данных (например, Excel), а программа, которая обеспечивает доступ к своим данных, — поставщиком баз данных (примером может служить поставщик Microsoft OLE DB для SQL Server).

Определение сведений о подключении

UDL-файл содержит сведения о подключении, с помощью которых получатель данных обращается к источнику данных через его поставщик OLE DB. Создать сведения о подключении можно одним из указанных ниже способов.

  • В мастере подключения данных воспользуйтесь диалоговым окном Свойства связи с данными для определения источника данных для поставщика OLE DB. Для получения дополнительных сведений обратитесь к разделу Импорт данных с помощью мастера подключения данных.

  • Создайте пустой текстовый файл с расширением UDL и откройте его для редактирования. Откроется диалоговое окно Свойства связи с данными.

К началу страницы

Обновление данных

При подключении к внешнему источнику данных также возможно выполнить операцию обновления для загрузки обновленной информации. После каждого обновления отображается самая последняя версия данных, включающая в себя все изменения, сделанные с момента последнего обновления.

На приведенном ниже рисунке показан базовый процесс обновления данных, подключенных к внешнему источнику.

Основной процесс обновления внешних данных

1. Операция обновления получает актуальные данные.

2. файл подключения определяет все сведения, необходимые для доступа к и получить данные из внешнего источника данных.

3. существует различных источников данных, которые можно обновлять: файлы OLAP, SQL Server, Access, OLE DB, ODBC, электронных таблицах и текст.

4. Актуальные данные добавляются в текущую книгу.

Приложение Excel поддерживает различные способы обновления импортированных данных, включая их обновление в момент открытия книги или автоматическое обновление через определенные интервалы времени. Пока выполняется обновление данных, можно продолжать работать с приложением Excel и проверять состояние процесса обновления.

Если к внешнему источнику данных требует пароль для получения доступа к данным, вы можете потребовать, что пароля при каждом обновлении диапазон внешних данных.

К началу страницы

Импорт данных из источников данных

В состав продуктов Windows XP, Windows Vista и Microsoft Office входят драйверы ODBC и поставщики OLE DB, с помощью которых можно загружать данные из таких стандартных источников, как Microsoft Access, HTML-файлы в Интернете, текстовые файлы, сервер Microsoft SQL Server, службы аналитики SQL Server и XML-файлы. С помощью мастера подключения данных и приложения Microsoft Query также можно обращаться к множеству других источников, для которых имеются подходящие поставщики OLE DB и драйверы ODBC. В число таких источников входят таблицы Excel, базы данных Microsoft FoxPro, dBASE, Paradox, Oracle и DB2.

К началу страницы

Импорт данных из базы данных Microsoft Access

Существует несколько способов обмена данными между приложениями Microsoft Access и Microsoft Excel.

  • Чтобы содержащиеся в Access данные переместить в Excel, можно скопировать данные таблицы Access и вставить их в лист Excel, подключить базу данных Access к листу Excel или экспортировать данные Access в лист Excel.

  • Чтобы содержащиеся в Excel данные переместить в Access, можно скопировать данные листа Excel и вставить их в таблицу Access, импортировать лист Excel в таблицу Access или связать лист Excel с таблицей Access.

Примечание : Импорт word имеет два значения между Excel и Access. В Excel для импорта означает сделать постоянное подключение к данным, которые могут быть обновлены. В Access Чтобы импортировать означает, что для загрузки данных в Access один раз, но без подключения к данным.

Работа в Excel с данными Access

Работая в книге Excel с данными Access, можно использовать функции анализа данных, построения диаграмм, гибкие средства размещения и представления данных и функции Excel, которых нет в Access.

Подключение к данным Access из Excel

Если нужно поработать с обновляемыми данными Access в Excel, можно создать подключение к базе данных Access и загрузить все данные из таблицы или запроса. Например, можно обновлять ежемесячный сводный бюджетный отчет в Excel, чтобы он содержал данные за текущий месяц.

Экспорт данных Access в Excel

С помощью мастера экспорта Access можно экспортировать на лист Excel объект базы данных Access (например, таблицу, запрос, форму) или выделенные записи. При экспорте данных из Access можно сохранить параметры этой операции для использования в будущем, а также задать расписание автоматического экспорта через заданные интервалы времени.

Ниже приведены часто встречающиеся ситуации, в которых нужно экспортировать в Excel данные Access:

  • Отдел или рабочая группа применяют для обработки данных и Access, и Excel. Данные хранятся в базах данных Access, а анализ данных и рассылка результатов анализа проводятся с помощью Excel. Обычно сотрудники экспортируют данные в Excel по мере необходимости, но нужно сделать этот процесс более эффективным.

  • Сотрудники привыкли работать с Access, но руководитель предпочитает просматривать отчеты в Excel. Сотрудникам приходится периодически копировать данные в Excel, и нужно автоматизировать этот процесс, чтобы экономить время.

Для получения дополнительных сведений об экспорте данных из Access в Excel см. справочную систему приложения Access.

Работа в Access с данными Excel

Работая в Access с данными Excel, можно использовать функции Access для управления данными, безопасностью и многопользовательскими возможностями. В Access есть много полезных функций, однако две из них особенно удобны при работе с данными Excel.

  • Отчеты    Если пользователь умеет создавать отчеты Access и хочет представить данные Excel в виде такого отчета, можно создать отчет Access. Например, можно создавать более сложные и гибкие отчеты, такие как итоговые отчеты, отчеты с группировкой, этикетки для распечатки и графические отчеты.

  • Формы    Если вы хотите использовать в форме для поиска или для отображения данных в Excel, можно создать форму Microsoft Access. Например можно создать форму Microsoft Access, чтобы отобразить поля в порядке, отличном от порядка столбцов на листе или просмотр длинных строк данных легче на один экран.

Дополнительные сведения о работе с формами и отчетами Access см. в справке Access.

Создание связи с данными Excel из Access

Диапазон в Excel можно связать с базой данных Access как таблицу. Это полезно, если данные из соответствующего диапазона и далее будут храниться в Excel, однако при этом необходимо обращаться к ним из Access. Такая связь устанавливается не из Excel, а из базы данных Access.

При установке связи с листом или именованным диапазоном Excel в приложении Access создается таблица, связанная с ячейками в файле источника. Изменения, вносимые в эти ячейки в Excel, отражаются в связанной с ними таблице. Однако в Access нельзя изменять содержимое этой таблицы. Все операции добавления, изменения и удаления данных выполняются в исходном файле Excel.

Ниже описаны типичные ситуации, в которых требуется установить связь из Access с данными на листе Excel.

  • Необходимо хранить данные на листах Excel, но при этом использовать эффективные функции запросов и отчетов Access.

  • В отделе или рабочей группе используется приложение Access, однако приходится также работать с внешними источниками данных, такими как листы Excel. Создавать копии внешних данных нецелесообразно, однако с данными необходимо работать в Access.

Дополнительные сведения о создании связи из Access с данными Excel см. в справке Access.

Импорт данных Excel в Access

Чтобы сохранить данные из Excel в базе данных Access, а затем продолжить работу с ними в Access, данные можно импортировать в Access. При импорте данных в приложение Access они сохраняются в новой или существующей таблице без изменения исходных данных в Excel. За одну операцию импорта можно импортировать только один лист данных. Чтобы импортировать данные с нескольких листов, повторите операцию импорта для каждого листа.

Далее описаны обычные ситуации, в которых производится импорт в Access данных Excel:

  • Опытному пользователю Excel требуется использовать Access для работы с данными. Для этого необходимо переместить данные из листов Excel в одну или несколько новых таблиц Access.

  • В отделе или рабочей группе используется Access, но иногда данные поступают в формате Excel, и их необходимо объединять с базами данных Access. Требуется выполнять импорт полученных листов Excel в базу данных.

  • Сотрудник обрабатывает данные с помощью Access, но получает от своих коллег еженедельные отчеты в виде книг Excel. Имеет смысл автоматизировать процесс импорта, чтобы каждую неделю в определенное время эти данные были импортированы в базы данных.

Для получения дополнительных сведений об импорте данных Excel в Access см. в справочной системе приложения Access.

К началу страницы

Импорт данных из Интернета

Веб-страницы часто содержат сведения, которые идеально подходят для анализа в Excel. Например, в Excel можно анализировать биржевые котировки, используя для этого данные, поступающие непосредственно с веб-страницы. В зависимости от конкретных требований можно загружать обновляемые данные (т. е. данные в Excel можно обновить актуальными сведениями с веб-страницы) либо сохранить на листе статические данные, загруженные с веб-страницы однократно.

С помощью веб-запроса можно загружать данные, которые хранятся в интрасети или в Интернете, например одну либо несколько таблиц или весь текст с веб-страницы, и анализировать их с использованием инструментов и возможностей Excel. Одним нажатием кнопки можно легко обновить данные актуальными сведениями с веб-страницы. Например, можно загружать и обновлять биржевые котировки с общедоступной веб-страницы либо таблицу с данными о продажах с веб-страницы компании.

Вы можете импортировать данные, рассчитанные на веб-страницы, используя диалоговое окно Нового веб-запроса. (На вкладке " данные " в группе Получение внешних данных нажмите кнопку Из Интернета ). Вам нужен доступ к World Wide Web через интрасети вашей организации или модемом на компьютере или в сети или соответствие HTML или XML-файлы, сохраненные на компьютере можно сделать запрос.

К началу страницы

Импорт текстовых файлов

С помощью Excel можно импортировать на лист данные из текстового файла (на вкладке Данные в группе Внешние данные нажмите кнопку Из текста). Мастер импорта текста изучит импортируемый текстовый файл и поможет подобрать подходящий способ импорта данных.

Импортировать данные в текстовый файл с помощью Excel можно двумя способами: можно открыть текстовый файл в Excel (при этом подключение к файлу не создается) либо импортировать его содержимое как диапазон внешних данных (в этом случае создается подключение к текстовому файлу).

Чаще всего используются два формата текстовых файлов:

  • текстовые файлы с разделителями (TXT), в которых для разделения полей текста обычно используется знак табуляции (код ASCII 009);

  • текстовые файлы с разделителями-запятыми (CSV), в которых в качестве разделителя полей текста обычно используется запятая (,).

Как в TXT-, так и CSV-файлах можно изменить знак разделителя (это может потребоваться для успешного импорта и экспорта).

К началу страницы

Импорт данных с сервера Microsoft SQL Server

Microsoft SQL Server — это полнофункциональная реляционная СУБД, предназначенная для создания корпоративных решений в области управления данными с высокими требованиями к производительности, доступности, масштабируемости и безопасности. В приложении Excel можно легко подключиться к базе данных Microsoft SQL Server (на вкладке Данные в группе Внешние данные выберите пункт Из других источников, а затем — С сервера SQL Server).

При подключении к базе данных Microsoft SQL Server мастер подключения данных включает три страницы, указанные ниже.

  • Страница 1: подключение к серверу базы данных    Эта страница укажите сервер базы данных и способ, которым вы выполните вход сервер.

  • Страница 2: Выбор базы данных и таблицы    Используйте этот запрос, содержащий данные, которые необходимо или страницы, таблицы и укажите имя базы данных.

  • Страница 3: сохранение данных файла и подключение    Используйте эту страницу, чтобы указать и описывают подключение файла и поиска для поиска файла фраз.

К началу страницы

Импорт данных из служб аналитики Microsoft SQL Server

Службы Analysis Services (компонент Microsoft SQL Server), которые поддерживает бизнес-аналитики и является основой интерактивной аналитической обработки (OLAP) аналитических систем, системы показателей ключевого индикатора производительности (KPI), интеллектуального анализа данных и отчетов, систем панели мониторинга. В Excel, вы можете легко подключиться к базе данных OLAP служб аналитики, используя поставщик OLAP. (На вкладке " данные " в группе Получение внешних данных нажмите кнопку Из других источников и выберите Из служб Analysis Services.) Поставщик OLAP — это набор программное обеспечение, которое предоставляет доступ к определенному типу баз данных OLAP. Драйвер источника данных и других клиентских программ, необходимый для подключения к базе данных, можно включить это программное обеспечение. Отчет сводной таблицы необходимо использовать для подключения к поставщику OLAP.

При отключении от источника данных OLAP, можно также перейти данных OLAP. автономный файл куба — это файл с расширением .cub, в которой хранится часть исходные данные из серверной базы данных OLAP. Чтобы продолжить вносить изменения отчетов сводных таблиц и сводных диаграмм, если сервер недоступен или при отключении от сети с помощью файла автономного куба.

При подключении к службам аналитики мастер подключения данных включает три страницы, указанные ниже.

  • Страница 1: подключение к серверу базы данных     Укажите сервер и способ, которым вы выполните вход на сервер базы данных с помощью этой страницы.

  • Страница 2: Выбор базы данных и таблицы    Используйте эту страницу для указания базы данных и куба.

  • Страница 3: сохранение данных файла и подключение    Используйте эту страницу, чтобы указать и описывают подключение файла и поиска для поиска файла фраз.

К началу страницы

Импорт XML-данных

Excel позволяет легко импортировать данные язык XML (Extensible Markup), который создается из других приложений и баз данных, сопоставление XML-элементов из XML-схемы с ячейками листа и экспорт обработанных данных XML для взаимодействия с другими приложениями и базами данных. Рассматривать эти новые возможности XML как превращение в генератор файла данных XML с помощью знакомого пользовательского интерфейса Excel.

Используя карты XML, можно легко добавлять, идентифицировать и извлекать определенные фрагменты бизнес-данных из документов Excel. Например, счет, содержащий имя и адрес покупателя, или отчет с финансовыми показателями за предыдущий квартал больше не будут обыкновенными статичными отчетами. Можно легко импортировать эти сведеня из баз данных и приложений, изменить их и экспортировать в эти же или другие базы данных и приложения.

Ключевые сценарии использования XML

Ниже приведены ключевые сценарии, для работы с которыми предназначены функциональные возможности XML.

  • Расширение функциональных возможностей существующих шаблонов Excel путем сопоставления XML-элементов с существующими ячейками. Это облегчает обмен XML-данными между источниками и шаблонами без необходимости переработки этих шаблонов.

  • Использование данных XML в качестве входных данных для существующих моделей вычислений путем сопоставления XML-элементов с существующими таблицами.

  • Импорт файлов XML-данных в новую рабочую книгу.

  • Импорт XML-данных из веб-службы в лист Excel.

  • Экспорт данных в сопоставленных ячейках в файлы XML-данных независимо от других данных в книге.

Основной процесс использования XML-данных в Excel

На приведенной ниже схеме показана совместная работа различных файлов и операций при использовании XML в Excel. В первом приближении этот процесс можно разбить на пять этапов.

Общие сведения о работе с данными XML в Excel

Выноска 1 Добавление в книгу файла схемы XML (XSD).

Выноска 2 Сопоставление элементов схемы XML с отдельными ячейками или XML-списков.

Выноска 3 Импорт файла данных XML (XML) и привязка XML-элементов к сопоставленным ячейкам.

Этап 4 Ввод данных, Перемещение сопоставленных ячеек и функциональных возможностей Excel при сохранении структуры и определений XML.

Выноска 5 Экспорт обработанных данных из сопоставленных ячеек в файл данных XML.

Использование данных XML

При импорте содержимого файла данных XML в имеющуюся в книге карту XML выполняется привязка данных из файла к карте XML, хранящейся в этой книге. Это означает, что каждый элемент данных в файле данных XML имеет соответствующий элемент в схеме XML, который был сопоставлен из файла схемы XML или из полученной схемы. Карта XML может содержать только одну привязку данных XML, и привязка данных XML связана со всеми сопоставлениями, которые были созданы на базе общей карты XML.

В диалоговом окне Свойства карты XML (на вкладке Разработчик в группе XML выберите пункт Свойства карты) есть три параметра (все они по умолчанию включены), с помощью которых можно управлять привязкой данных XML.

  • Проверять данные на соответствие схеме при импорте и экспорте    Определяет, если проверки данных Excel на соответствие схеме XML при импорте данных. Установите этот параметр, чтобы обеспечить соответствие XML-данных, импортируемых в схему XML.

  • Заменять существующие данные новыми    Определяет, если данные перезаписываются при импорте данных. Установите этот параметр, если требуется заменить текущих данных с новыми данными, например, когда актуальные данные содержатся в файле данных XML.

  • Добавлять новые данные в существующие XML-списки    Определяет, если содержимое источника данных добавляются в существующие данные на листе. Укажите этот параметр, например, объединение данных из нескольких так же, файлы данных XML в XML-списка, или не хотите перезаписывать содержимое ячейки, содержащей функцию.

К началу страницы

Импорт данных с помощью мастера подключения данных

Мастер подключения данных можно использовать для подключения к заданному внешнему источнику данных OLE DB или ODBC. Чтобы открыть мастер подключения данных, на вкладке Данные в группе Внешние данные выберите пункт Из других источников, а затем — Из мастера подключения данных.

Выбрав в мастере подключения в качестве источника вариант Дополнительно, можно просмотреть список доступных поставщиков OLE DB в диалоговом окне Свойства связи с данными. Кроме того, поставщик OLE DB драйверов ODBC (Майкрософт) также обеспечивает доступ к источникам данных ODBC. Чтобы получить дополнительные сведения об использовании каждой из вкладок в этом диалоговом окне, нажмите кнопку Справка в диалоговом окне Свойства связи с данными.

Чтобы задать сведения о подключении в диалоговом окне Свойства связи с данными, выполните указанные ниже действия.

  • Откройте вкладку Поставщик, выберите поставщик OLE DB и нажмите кнопку Далее. Появится вкладка Подключение, на которой можно указать сведения о подключении для данного поставщика OLE DB.

    Для каждого поставщика OLE DB нужно задать определенные сведения о подключении. Например, для поставщика OLE DB для SQL Server (Майкрософт) необходимо указать имя и расположение сервера, а также имя пользователя. Кроме того, можно задать дополнительные сведения, такие как пароль и параметр использования встроенной системы безопасности Microsoft Windows.

  • Откройте вкладку Дополнительно, чтобы указать дополнительные сведения, такие как параметры сети и разрешения на доступ.

  • Откройте вкладку Все, чтобы задать свойства инициализации для поставщика OLE DB.

Примечание : В мастере подключения данных нельзя выполнить фильтрацию или объединение данных.

К началу страницы

Импорт данных с помощью приложения Microsoft Query

Можно также использовать Microsoft Query для импорта данных. (На вкладке " данные " в группе Получение внешних данных нажмите кнопку Из других источников и нажмите кнопку Из Microsoft Query.) Настройка источников данных ODBC для извлечения данных с помощью Microsoft Query. В Microsoft Query можно использовать мастер запросов для создания простых запрос или расширенных условий в запросе можно использовать для создания более сложных запросов и сделайте следующее:

  • отфильтровать строки и столбцы перед загрузкой в Excel;

  • Создание запрос с параметрами.

  • отсортировать данные перед загрузкой в Excel;

  • соединить несколько таблиц.

Приложение Microsoft Query имеет простой интерфейс, который легко доступен из Excel и позволяет выполнять все указанные выше специализированные операции с запросами.

К началу страницы

Импорт данных программным образом и с использованием функций

Разработчикам предлагается несколько способов импорта данных в Excel.

  • С помощью Visual Basic для приложений для получения доступа к внешнему источнику данных. В зависимости от источника данных можно использовать объекты данных ActiveX и объекты доступа к данным для извлечения данных. Можно также определить строку подключения в коде, задающее сведения о подключении. С помощью строки подключения полезно, например, при необходимости старайтесь не запрашивать системным администраторам или пользователей, чтобы сначала создать файл подключения или для упрощения установки приложения.

  • При импорте данных из базы данных SQL Server можно воспользоваться собственным клиентом SQL — автономным программным интерфейсом доступа к данным, который используется при работе как с технологией OLE DB, так и с технологией ODBC. В нем поставщик OLE DB и драйвер ODBC для SQL объединены в одну собственную библиотеку динамической компоновки (DLL), которая содержит новые функции, отдельные и отличающиеся от функций технологии MDAC. С помощью собственного клиента SQL можно создавать новые приложения и совершенствовать уже существующие с применением новых возможностей SQL Server, таких как Multiple Active Result Sets (MARS), пользовательские типы и поддержка типа данных XML.

  • Функция ДРВ извлекает данные реального времени из программы, поддерживающей автоматизацию COM. ДРВ автоматизации надстройки COM необходимо будет создан и зарегистрирован на локальном компьютере.

  • Код SQL. Функция запрос обращается к внешнему источнику данных и выполняет запрос из листа. Код SQL. Затем запрос функция возвращает результат как формула массива без необходимости программирования макрос. Если эта функция недоступна, необходимо установить надстройку программы Microsoft Excel ODBC (XLODBC. XLA). Вы можете установить надстройку из Office.com.

Дополнительные сведения о программировании на языке Visual Basic для приложений см. в справке по Visual Basic.

К началу страницы

Защита доступа к данным

При подключении к внешнему источнику данных или их обновлении необходимо помнить о возможных проблемах с безопасностью, а также уметь их устранять. Для защиты данных пользуйтесь приведенными ниже рекомендациями и методиками.

К началу страницы

Хранение подключений к данным в надежном месте

Файлы подключения к данным часто содержат один или несколько запросов, используемых для обновления внешних данных. Заменив этот файл, злоумышленник может создать запрос для получения доступа к конфиденциальным данным и передать их другим пользователям либо причинить ущерб иным способом. Таким образом, важно убедиться в следующем:

  • создателю файла подключения можно доверять;

  • файл подключения защищен и хранится в надежном месте.

Для повышения безопасности можно запретить на компьютере подключение к внешним данным. Чтобы можно было подключаться к данным при открытии книги, необходимо разрешить подключение к данным с помощью панели центра управления безопасностью либо поместить книгу в надежное место. Дополнительные сведения см. по ссылкам в разделе См. также.

К началу страницы

Безопасность при использовании учетных данных

Для доступа к внешнему источнику данных обычно необходимы учетные данные (имя пользователя и пароль), применяемые при проверке подлинности пользователя. Необходимо гарантировать, что эти учетные данные передаются надежным и безопасным образом и что они недоступны другим пользователям.

Важно : Используйте надежные пароли, содержащие прописные и строчные буквы, числа и символы. Эти элементы не смешивать слабых пароли. Надежный пароль: Y6dh! et5. Слабых пароль: House27. Пароли должны быть 8 или более символов. Лучше фразу, которая использует более 14 символов. Важно, что вы помните пароль. Если вы забыли свой пароль, Microsoft нельзя восстановить. Хранение паролей, запишите в надежном месте вне сведения, которые помогают защитить.

Старайтесь не сохранять сведения для входа в систему при подключении к источникам данных. Эти сведения могут храниться в виде обычного текста в книге или файле подключения, что позволяет злоумышленникам использовать их для получения доступа к источнику данных.

По возможности используйте систему проверки подлинности Windows (доверительное соединение), которая подключается к серверу SQL Server с учетной записью пользователя Windows. При подключении с учетной записью Windows сервер SQL Server проверяет имя пользователя и пароль этой учетной записи по сведениям, хранящимся в операционной системе Windows. Прежде чем можно будет использовать проверку подлинности Windows, администратор сервера SQL Server должен настроить его для работы в соответствующем режиме. Если проверка подлинности Windows недоступна, старайтесь не хранить учетные данные пользователей в книге или файле подключения. Более безопасным будет требование, чтобы пользователь вводил эти данные каждый раз при входе.

К началу страницы

Безопасная публикация в службах Excel

При подключении к источнику данных в диалоговом окне Параметры проверки подлинности для служб Excel можно выбрать способ проверки подлинности для доступа к источнику в службах Excel. Выберите один из указанных ниже вариантов входа в источник данных.

  • Проверка подлинности Windows    Выберите данный вариант, чтобы использовать имя и пароль Windows для текущего пользователя. Этот способ является наиболее удобным, но он может отразиться на производительности при одновременной работе нескольких пользователей.

  • SSS    Выберите этот параметр для использования службы безопасного хранения и введите в текстовом поле Идентификатор SSS строка соответствующие идентификации. Администратор веб-сайтов можно настроить на сайте SharePoint с помощью службы безопасного хранения базы данных которых могут храниться имя пользователя и пароль. Этот метод может быть наиболее эффективно Если существует много пользователей.

  • Нет    Выберите этот параметр, чтобы сохранить в файле подключения имя пользователя и пароль.

Примечание : Проверка подлинности используется только в службах Excel, но не в приложении Microsoft Excel. Чтобы обеспечить доступ к одним и тем же данным при открытии книг как в приложении Excel, так и в службах Excel, установите те же параметры проверки подлинности в Excel.

Для повышения безопасности подключения, используйте данные подключения библиотеки (ODC-ФАЙЛ). ODC-ФАЙЛ — это особая библиотека документов SharePoint, которые могут быть определены как надежное расположение библиотеки, а, которая упрощает для хранения, secure, совместно использовать и управлять файлами ODC. Например администратор может потребоваться переместить базу данных из тестового сервера на сервер приложений или обновить запрос, который обращается к данным. С помощью одного ODC-файл, сохраненный в Получении администрирования эти сведения о подключении намного проще и доступа пользователей к данным наиболее удобно, поскольку все книги используют один и тот же файл подключения и операции обновления (ли на компьютере клиента и сервера) получает последние изменения на этот файл подключения. Даже можно настроить автоматическое обнаружение изменения подключения файла, а затем с помощью последнюю версию этого файла подключения SharePoint Server и клиентский компьютер пользователя. Дополнительные сведения читайте в статье справки центра администрирования Microsoft SharePoint Foundation 2010.

К началу страницы

Проблемы, связанные с подключением к данным

В приведенных ниже разделах описаны отдельные проблемы, которые могут возникнуть при подключении к внешним данным.

К началу страницы

Проблема: при попытке импортировать данные не хватает места на диске

Если при попытке подключения к внешним данным не хватает места на диске, попробуйте воспользоваться приведенными ниже рекомендациями.

Проверка и увеличение доступные места на диске    Чтобы освободить место на жестком диске, попробуйте очистки корзины, архивацию ненужных файлов и удалять их на жестком диске или удаление неиспользуемых компонентов Windows. Дополнительные сведения об освобождении места на жестком диске содержатся в справке Windows.

Методы, которые вы можете попробовать при ограничен места на диске    Если у вас есть только ограниченного объем свободного места на жестком диске, попробуйте сделать следующее:

Microsoft Query    Выполните одно или несколько из указанных ниже действий.

  • Упростить запроса.    Убедитесь, что включение таблицы и поля, которые необходимы для запроса. Если ваш запрос содержит ненужные таблицы или поля, удалите их из запроса, чтобы уменьшить размер файла временный запрос.

  • Установить используйте условия для уменьшения размера результат    Используйте условия для извлечения только определенных записей, а не получение всех записей из базы данных. Дополнительные сведения содержатся в справке Microsoft Query.

  • Установка максимального числа записи, возвращенные в запросе    Ограничение количества записей, которые возвращает запрос. В Microsoft Query нажмите кнопку Параметры в меню Правка, установите флажок ограничить количество возвращаемых записей в разделе Параметры пользователя и затем введите максимальное количество записей, чтобы вернуться в поле записи.

Мастера подключения данных    Несмотря на то, что не удается ограничить данных в мастере подключения данных, можно ограничить данные из источника данных, определив запрос в источнике данных. Если у вас нет возможности или разрешение на определение запроса в источнике данных, обратитесь к администратору данных.

К началу страницы

Проблема: что случилось с мастером кубов OLAP?

Мастера кубов OLAP в Microsoft Query, с помощью которого можно было создать куб OLAP из базы данных Jet, больше нет в Excel.

К началу страницы

Проблема: что случилось со службами извлечения данных?

Службы извлечения данных, появившиеся в пакете Microsoft Office 2003, использовали для доступа к веб-службам и запроса данных из различных источников универсальные файлы подключения к данным (UDCX-файлы).

В мастере подключения данных на странице приветствия мастера подключения данных можно выбрать параметры источника данных Microsoft Business Solutions или службы извлечения данных. Службы извлечения данных параметр позволяет выбрать две службы извлечения данных: списки служб Windows SharePoint Services, которая получает данные из списков и библиотек документов на сервере SharePoint Foundation и Microsoft SQL Server, который получает данные из Microsoft SQL Server 2000 или более поздней версии.

Хотя мастер подключения данных больше не поддерживает редактирование UDC-файлов подключения, в Excel по-прежнему поддерживаются существующие подключения с использованием служб извлечения данных и их обновление.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×