Общие сведения о подключении к данным и их импорте

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

В этой статье ссылка рассматриваются Импорт и подключения данных. Вы узнаете о ведением импорт, обновление, защита и управление данными в листах Excel 2007.

В этой статье

Работа с подключениями к внешним данным

Обновление данных

Импорт данных из источников данных

Защита доступа к данным

Проблемы, связанные с подключением к данным

Работа с подключениями к внешним данным

В следующих разделах подключений к внешним данным рабочий и как найти редактирования, управление и совместное использование сведений о соединении с другими приложениями и пользователей.

К началу страницы

Принципы подключения к данным

Данные в книге Excel могут поступать из двух разных местах. Могут храниться данные непосредственно в книге, или он может быть сохранен в внешнему источнику данных, например текстового файла, базы данных или в кубе интерактивной аналитической обработки (OLAP). Этот внешний источник данных подключения к книге через подключение к данным, которая представляет собой набор сведений, которые описано, как найти, выполните вход и получить доступ к внешнему источнику данных.

Подключение к внешним данным основного преимущество заключается в то, что может периодически анализ эти данные без копирования данных операция, которая может занять много времени, ошибкам несколько раз. После подключения к внешним данным, можно также автоматического обновления (или) к книгам Excel из исходного источника данных при каждом обновлении источника данных с новыми данными.

Сведения о подключении хранятся в книге, однако их также можно сохранить в файле подключения (например, ODC-файле подключения к данным Office или DSN-файле имени источника данных).

Чтобы перенести внешние данные в Microsoft Excel, требуется доступ к данным. Если внешние источник данных, должны быть доступны не на локальном компьютере, вам потребуется обратиться к администратору базы данных пароль, разрешение пользователя или другие сведения о подключении. Если источник данных представляет собой база данных, убедитесь в том, что база данных не открыта в режиме монопольного доступа. Если источник данных в текстовый файл или электронную таблицу, убедитесь, что другой пользователь не открыт в режиме монопольного доступа.

Многим источникам данных для управления обменом данными между Excel, файлом подключения и источником также необходим драйвер ODBC или поставщик OLE DB.

На приведенной ниже схеме обобщены основные моменты подключения к данным.

Подключение к внешним источникам данных

1. существует различных источников данных, которые вы можете подключиться к: служб Analysis Services, SQL Server, Microsoft Office Access, другие OLAP и реляционных баз данных, электронных таблицах и текстовых файлов.

2. Многие источники данных имеют соответствующий драйвер ODBC или поставщик OLE DB.

3. файл подключения определяет все сведения, необходимые для доступа и извлечения данных из источника данных.

4. сведения о подключении копируются из файла подключения в книге и текст можно редактировать.

5. Данные копируются в книгу, после чего их можно использовать так же, как и данные, которые хранятся непосредственно в ней.

К началу страницы

Поиск подключений

Найти файлы подключения можно с помощью диалогового окна Существующие подключения (на вкладке Данные в группе Внешние данные нажмите кнопку Существующие подключения). В этом окне доступны подключения указанных ниже типов.

  • Подключения в книге   

    Список всех текущих соединений в книге. Список создается из подключений, которые уже были определены, созданные с помощью диалогового окна Выбор источника данных в мастере подключения данных или подключения, которые ранее был выбран как подключение из этого диалогового окна.

  • Файлы подключений на компьютере   

    Этот список создается на основе папки Мои источники данных, которая обычно хранится в папке Мои документы (Windows XP) или Документы (Windows Vista).

  • Файлы подключений в сети   

    В этот список могут входить указанные ниже элементы.

    • Набор папок в локальной сети, расположение которых можно указать в ходе развертывания групповых политик Microsoft Office.

    • службы Excel данные подключения библиотеки (ODC-ФАЙЛ) на сайте Microsoft Office SharePoint Server 2007. Дополнительные сведения о DCLs просмотреть Опубликовать в службах Excel.

К началу страницы

Изменение свойств подключения

Приложение Excel можно использовать как редактор файлов для создания и редактирования подключений к внешним источникам данных, хранящимся в книге или в файле подключения. Если найти нужное подключение не удается, его можно создать. Для этого необходимо нажать кнопку Найти другие, чтобы вызвать диалоговое окно Выбор источника данных, а затем выбрать команду Создать источник, чтобы запустить мастер подключения данных.

После создания соединения, воспользуйтесь диалоговым окном Свойства подключения (на вкладке " данные " в группе Получение внешних данных нажмите кнопку Свойства.) для управления различные параметры для подключения к внешним источникам данных, а также использовать повторно использовать или изменить файлы подключения.

Если подключение к источнику данных с помощью файл подключения Excel копирует сведения о подключении из файла подключения в книгу Excel. Когда вы вносите изменения с помощью диалогового окна Свойства подключения, вы редактируете соединения данных, которые хранятся в текущей книге Excel и не исходного файла подключения к данным, которая используется для создания подключения, которое обозначается по имени файла, который отображается в свойстве Файл подключения на вкладке " Определение ". После изменения сведений о соединении (за исключением свойства Подключения имя и Описание подключения ) удаляется ссылка на файл подключения, снят свойства Файла подключения.

Чтобы гарантировать, что файл подключения будет использоваться всегда при обновлении источника данных, установите флажок Всегда пытаться использовать этот файл для обновления данных на вкладке Определение. Этот флажок обеспечивает гарантирует, что обновления файла подключения распространяются на все книги, использующие этот файл (для него также необходимо установить это свойство).

К началу страницы

Управление подключениями

С помощью диалоговом окне Подключения к книге , можно легко управлять эти подключения, включая создание, редактирование и удаление их. (На вкладке " данные " в группе Получение внешних данных нажмите кнопку подключения ). Это диалоговое окно можно использовать для выполнения следующих действий:

  • Создание, редактирование, обновление и удаление подключений, используемых в книге.

  • Проверка источников получения внешних данных (например, если подключение было задано другим пользователем).

  • Указание мест использования подключений в текущей книге.

  • Анализ ошибок подключения к внешним данным.

  • Перенаправление соединения на другой сервер или источник данных или замена файла подключения для существующего подключения.

  • Создание файла подключения и обеспечение совместного доступа к нему.

К началу страницы

Совместное использование подключений

Файлы подключения особенно полезны для совместным доступом на основе согласованность, что делает их более доступными, помогает повысить безопасность и Облегчение администрирования источника данных. Лучший способ общий доступ к файлам подключения является заключите их в безопасных и надежное расположение, например сетевую папку или в библиотеке SharePoint, где пользователи может прочитать файл, но только для назначенных пользователям можно изменить файл.

Использование ODC-файлов

Подключение к внешним данным в диалоговом окне Выбор источника данных или подключение к новым источникам данных с помощью мастера подключения данных можно создать файлы подключения к данным Office (ODC) (.odc). Настраиваемые теги HTML и XML использует ODC-файл для хранения сведений о подключении. Можно легко просматривать или изменять содержимое файла в Office Excel.

Файлы подключений можно использовать совместно с другими людьми, предоставляя им такой же доступ к внешнему источнику данных. Другим пользователям для открытия файла подключения не нужно создавать источник данных, однако им может потребоваться установить драйвер ODBC или поставщик OLE DB, необходимый для доступа к внешним данным с их компьютеров.

ODC-файлы обеспечивают оптимальный способ подключения к данным и их совместного использования. Другие стандартные файлы подключений (DSN-, UDL-файлы и файлы запросов) можно легко преобразовать в ODC-файл. Для этого откройте файл подключения и в диалоговом окне Свойства подключения на вкладке Определение нажмите кнопку Экспорт файла подключения.

Использование файлов запросов

Файлы запросов — это текстовые файлы, содержащие сведения об источниках данных, включая имя сервера, на котором они расположены, и сведения о подключении, которые задаются при создании источника. Файлы запросов — это стандартный способ использования запросов совместно с другими пользователями Excel.

Использование файлов запросов .dqy     С помощью Microsoft Query для сохранения файлов .dqy, содержащих запросы для данных из реляционных баз данных и текстовых файлов. При открытии эти файлы в Microsoft Query можно просматривать данные в запросе и выберите запрос на извлечение данных. Можно сохранить для любого запроса, созданного, с помощью мастера запросов или непосредственно в Microsoft Query заново.

Использование файлов запросов .oqy     Вы можете сохранять файлы .oqy для подключения к данным в базе данных OLAP на сервере или в автономный файл куба (.cub). При использовании мастера подключения многомерные в Microsoft Query для создания источника данных для базы данных OLAP или куба самостоятельной создается автоматически. Поскольку баз данных OLAP не организованы в записи или таблицы, нельзя создать запросы или DKY-файлы в этих базы данных access.

Использование файлов запросов .rqy     Excel можно открывать файлы запросов в формате .rqy для поддержки драйверов источников данных OLE DB, использующих этот формат. Дополнительные сведения драйвер документации.

Использование файлов запросов .qry     Microsoft Query можно открывать и сохранять файлы запросов в формате QRY для использования с более ранними версиями Microsoft Query, не удается открыть файлы .dqy. Если у вас есть файл запроса в формате .qry, который вы хотите использовать в Excel, откройте файл в Microsoft Query и сохраните его как заново. Дополнительные сведения о сохранении файлов .dqy к справке Microsoft Query.

Использование IQY веб-запроса файлов     Excel можно открывать IQY-файлов Web запросов для извлечения данных из Интернета.

К началу страницы

Использование диапазонов и свойств внешних данных

Диапазон внешних данных (также называемый таблицей запроса) — это определенное имя или имя таблицы, которое задает расположение данных, загружаемых на лист. При подключении к внешним данным в Excel автоматически создается диапазон внешних данных. Единственным исключением из этого правила является подключение отчета сводной таблицы к источнику данных (диапазон внешних данных при этом не создается). В Excel можно настраивать форматирование и расположение диапазона внешних данных, а также использовать его в вычислениях, как и любые другие данные.

Microsoft Excel автоматически именует диапазоны внешних данных следующим образом.

  • Внешним диапазонам данных из ODC-файлов присваиваются те же имена, что и соответствующим файлам.

  • Внешним диапазонам данных из баз данных присваиваются имена запросов. По умолчанию Query_from_source — имя источника данных, который был использован для создания запроса.

  • Диапазоны внешних данных из текстовых файлов называются по имени этих файлов, из веб-запросов — по имени веб-страницы.

  • Диапазоны внешних данных из веб-запросов именуются по имени веб-страницы, с которой были получены данные.

Если лист имеет несколько диапазонов внешних данных из одного источника, они нумеруются. Например MyText, MyText_1, MyText_2 и так далее.

Диапазон внешних данных имеет дополнительные свойства (не путайте их со свойствами подключения), которые можно использовать для управления данными (например, для сохранения форматирования ячеек и ширины столбцов). Свойства диапазона внешних данных можно изменить, нажав кнопку Свойства в группе Подключения на вкладке Данные и внеся все необходимые изменения в диалоговом окне Свойства внешнего диапазона данных или Свойства внешних данных.

Примечание : Если вы хотите поделиться сводку или отчет, который находится на основе внешних данных, можно предоставить другим пользователям книгу, содержащую диапазон внешних данных или можно создать шаблон отчета. шаблон отчета позволяет сохранить сводку или отчет без сохранения внешних данных, что файл меньшего размера. Внешние данные будут найдены при открытии шаблона отчета.

К началу страницы

Поддержка источников данных в Excel и службах Excel

Для подключения к разным источникам данных можно использовать различные объекты данных (например, диапазон внешних данных или отчет сводной таблицы), причем каждый такой объект допускает подключение к источникам определенного типа. Использовать и обновлять данные, к которым установлено подключение, можно в службах Excel, однако существуют дополнительные ограничения и способы их обхода, о которых необходимо помнить.

Объект данных Excel и поддержка источников данных

В приведенной ниже таблице указано, какие источники данных поддерживаются для каждого объекта данных в Excel.

Поддерживаемый источник данных

Объект
данных
Excel

Создается ли
диапазон
внешних
данных?

OLE
DB

ODBC

Текстовый
файл

HTML-
файл

XML-
файл

Список
Share
Point

Импорт текста

Да

Нет

Нет

Да

Нет

Нет

Нет

Отчет сводной таблицы
(не OLAP)

Нет

Да

Да

Да

Нет

Нет

Да

Отчет сводной таблицы
(OLAP)

Нет

Да

Нет

Нет

Нет

Нет

Нет

Таблица Excel

Да

Да

Да

Нет

Нет

Да

Да

XML-карта

Да

Нет

Нет

Нет

Нет

Да

Нет

Веб-запроса

Да

Нет

Нет

Нет

Да

Да

Нет

Мастер подключения данных

Да

Да

Да

Да

Да

Да

Да

База данных "Борей"

Да

Нет

Да

Да

Нет

Нет

Нет

Примечание : Текстовый файл импорта с помощью мастера импорта текста, XML-файл импорта с помощью карты XML и HTML или XML-файл импорта с помощью веб-запроса эти файлы не использовать поставщик OLE DB или драйвер ODBC для подключения к источнику данных.

Службы Excel и поддержка источников данных

Если вы хотите отобразить книгу Excel в службах Excel, можно подключиться к и обновление данных, но необходимо использовать отчет сводной таблицы. Службы Excel не поддерживает диапазоны внешних данных, то есть службы Excel не поддерживает подключения к источнику данных, веб-запроса, карты XML или Microsoft Query таблиц Microsoft Excel.

Однако можно обойти это ограничение с помощью сводной таблицы для подключения к источнику данных и нажмите оформление и макет сводной таблицы как двумерная таблица без уровни, группы и промежуточные итоги, чтобы все нежелательным строки и столбца значения отображаются. Дополнительные сведения узнать в статье отчета сводной таблицы, чтобы сделать внешняя таблица данных, доступных в службах Excel.

К началу страницы

Принципы использования компонентов доступа к данным MDAC

Компоненты доступа к данным Microsoft (MDAC) 2,8 входит в состав Microsoft Windows Server 2003, Windows Vista и Windows XP с пакетом обновления 2. С MDAC можно подключиться к и использовать данные из различных источников реляционных и нереляционных данных. Вы можете подключить к различным источникам данных с помощью подключения ODBC (Open Database) драйверы или OLE DB поставщиков, которые являются встроенные и созданных корпорацией Майкрософт или разработанные различных третьими сторонами. При установке Microsoft Office на компьютер добавляются дополнительные драйверы ODBC и поставщиков OLE DB.

Чтобы просмотреть полный список средств доступа OLE DB, установленных на компьютере, откройте диалоговое окно Свойства связи с данными из файла Data Link, а затем перейдите на вкладку Поставщик данных.

Чтобы увидеть полный список поставщиков ODBC, установленных на компьютере, отобразите диалоговое окно Администратор баз данных ODBC и откройте вкладку Драйверы.

Для загрузки данных из источников, отличных от источников Майкрософт (включая другие виды баз данных ODBC и OLE DB), можно использовать драйверы ODBC и поставщики OLE DB других изготовителей. Для получения сведений об установке этих драйверов ODBC и поставщиков OLE DB обратитесь к документации по базе данных либо свяжитесь с ее поставщиком.

К началу страницы

Подключение к источникам данных с помощью ODBC

В приведеннных ниже технология ODBC описана более подробно.

Архитектура ODBC

В архитектуре ODBC приложение (например, Excel) подключается к диспетчеру драйверов ODBC, который, в свою очередь, использует конкретный драйвер ODBC (например, Microsoft SQL ODBC) для подключения к источнику данных (такому как база данных Microsoft SQL Server).

Определение сведений о подключении

Чтобы подключиться к источникам данных ODBC, выполните указанные ниже действия.

  1. Убедитесь, что на компьютере с источником данных установлен соответствующий драйвер ODBC.

  2. Определите имя источника данных (DSN) с помощью администратора источников данных ODBC, сохранив сведения о подключении в реестре или DSN-файле, либо с помощью строки подключения в Microsoft Visual Basic, которая передает сведения о подключении непосредственно диспетчеру драйверов ODBC.

    Чтобы определить источник данных в Windows Vista, нажмите кнопку Пуск и выберите пункт Панель управления. Щелкните ссылку Система и ее обслуживание, а затем — Администрирование. В Windows XP и Windows Server нажмите кнопку Пуск и выберите пункт Панель управления. Щелкните ссылку Производительность и обслуживание, а затем — Администрирование и выберите пункт Источники данных (ODBC). Чтобы получить дополнительные сведения о различных параметрах, нажмите кнопку Справка в соответствующем диалоговом окне.

Машинные источники данных

Источники данных в компьютере хранение сведений о подключении в реестре на определенном компьютере, с именем пользовательские. Источники данных в компьютере можно использовать на компьютере, на которые они определены на. Существует два типа источников данных в компьютере — пользователь и система. Пользовательские источники данных можно использовать текущим пользователем и видны только для этого пользователя. Системные источники данных можно использовать для всех пользователей на компьютере и видны всем пользователям на компьютере.

Источники данных компьютера особенно полезны, если требуется обеспечить дополнительную безопасность, поскольку они гарантируют, что просмотреть источник сможет только пользователь, который вошел в систему. Такой источник не может быть скопирован на другой компьютер удаленным пользователем.

Файловые источники данных

Файловые источники данных (также называемые DSN-файлами) хранят сведения о подключении не в реестре, а в текстовом файле, и обычно являются более гибкими, чем источники данных компьютера. Например, можно скопировать файловый источник данных на любой компьютер с подходящим драйвером ODBC, обеспечив приложению доступ к согласованным и точным данным со всех компьютеров. Кроме того, можно разместить файловый источник данных на сервере, организовать доступ к нему с нескольких компьютеров в сети и легко поддерживать правильность сведений о подключении в одном месте.

Файловый источник данных также может быть непригоден для совместного использования. Такие источники данных располагаются на одном компьютере и указывают на машинные источники данных. Файловые источники данных, непригодные для совместного использования, можно использовать для доступа к существующим машинным источникам данных из файловых источников данных.

К началу страницы

Подключение к источникам данных с помощью OLE DB

В приведенных ниже технология OLE DB описана более подробно.

Архитектура OLE DB

В архитектуре OLE DB приложение, обращающееся к данным, называется получателем данных (например, Excel), а программа, которая обеспечивает доступ к своим данных, — поставщиком баз данных (примером может служить поставщик Microsoft OLE DB для SQL Server).

Определение сведений о подключении

UDL-файл содержит сведения о подключении, с помощью которых получатель данных обращается к источнику данных через его поставщик OLE DB. Создать сведения о подключении можно одним из указанных ниже способов.

  • В мастере подключения данных воспользуйтесь диалоговым окном Свойства связи с данными для определения источника данных для поставщика OLE DB. Дополнительные сведения читайте в статье Импорт данных с помощью мастера подключения данных.

  • Создайте пустой текстовый файл с типом файла .udl и выберите изменить файл, который отображает диалоговое окно Свойства связи с данными.

К началу страницы

Обновление данных

При подключении к внешнему источнику данных также возможно выполнить операцию обновления для загрузки обновленной информации. После каждого обновления отображается самая последняя версия данных, включающая в себя все изменения, сделанные с момента последнего обновления.

На следующей иллюстрации объясняется основной процесс обновления данных, подключенных к внешнему источнику данных.

Основной процесс обновления внешних данных

1. Операция обновления получает актуальные данные.

2. файл подключения определяет все сведения, необходимые для доступа к и получить данные из внешнего источника данных.

3. существует различных источников данных, которые можно обновлять: файлы OLAP, SQL Server, Access, OLE DB, ODBC, электронных таблицах и текст.

4. Актуальные данные добавляются в текущую книгу.

Приложение Excel поддерживает различные способы обновления импортированных данных, включая их обновление в момент открытия книги или автоматическое обновление через определенные интервалы времени. Пока выполняется обновление данных, можно продолжать работать с приложением Excel и проверять состояние процесса обновления.

Если к внешнему источнику данных требует пароль для получения доступа к данным, вы можете потребовать, что пароля при каждом обновлении диапазон внешних данных.

К началу страницы

Импорт данных из источников данных

Windows XP, Windows Vista и Microsoft Office будет ввести драйверы ODBC поставщики OLE DB, которые можно использовать для извлечения данных из следующих распространенных источников данных: Microsoft Office Access, HTML-файлов в Интернете, текстовые файлы, Microsoft SQL Server, Microsoft SQL Server Analysis Services и XML-файлы. С помощью мастера подключения данных и Microsoft Query, можно также перейти многих других источников данных, которые содержат соответствующие поставщики OLE DB и драйверы ODBC, а также другие Excel листы, Microsoft FoxPro, dBASE, Paradox, Oracle и DB2.

К началу страницы

Импорт данных из базы данных Microsoft Access

Существует несколько способов обмена данными между приложениями Microsoft Office Access и Microsoft Office Excel.

  • Чтобы содержащиеся в Access данные переместить в Excel, можно скопировать данные таблицы Access и вставить их в лист Excel, подключить базу данных Access к листу Excel или экспортировать данные Access в лист Excel.

  • Чтобы содержащиеся в Excel данные переместить в Access, можно скопировать данные листа Excel и вставить их в таблицу Access, импортировать лист Excel в таблицу Access или связать лист Excel с таблицей Access.

Примечание : Импорт word имеет два значения между Excel и Access. В Excel word импорта означает, что для создания постоянных подключения к данным, которые могут быть обновлены. В приложении Access Импорт word означает, что для загрузки данных в Access один раз, но без подключения к данным.

Работа в Excel с данными Access

Вы можете работать с доступа к данным в книге Excel, чтобы воспользоваться преимуществами функции для создания диаграмм, гибко упорядочение данных и макета или функции, которые недоступны в Access и анализ данных.

Подключение к данным Access из Excel

Если нужно поработать с обновляемыми данными Access в Excel, можно создать подключение к базе данных Access и загрузить все данные из таблицы или запроса. Например, можно обновлять ежемесячный сводный бюджетный отчет в Excel, чтобы он содержал данные за текущий месяц.

Экспорт данных Access в Excel

С помощью мастера экспорта в Access, вы можете экспортировать объект базы данных Access, например таблицы, запроса, формы или выбранных записей в представлении на листе Excel. При выполнении операции экспорта, можно сохранить сведения для использования в будущем и даже расписание операции экспорта автоматический запуск через заданные промежутки времени.

Ниже приведены часто встречающиеся ситуации, в которых нужно экспортировать в Excel данные Access:

  • Отдел или рабочая группа применяют для обработки данных и Access, и Excel. Данные хранятся в базах данных Access, а анализ данных и рассылка результатов анализа проводятся с помощью Excel. Обычно сотрудники экспортируют данные в Excel по мере необходимости, но нужно сделать этот процесс более эффективным.

  • Сотрудники привыкли работать с Access, но руководитель предпочитает просматривать отчеты в Excel. Сотрудникам приходится периодически копировать данные в Excel, и нужно автоматизировать этот процесс, чтобы экономить время.

Для получения дополнительных сведений об экспорте данных из Access в Excel см. справочную систему приложения Access.

Работа в Access с данными Excel

Работая в Access с данными Excel, можно использовать функции Access для управления данными, безопасностью и многопользовательскими возможностями. В Access есть много полезных функций, однако две из них особенно удобны при работе с данными Excel.

  • Отчеты     Если вы знакомы с разработкой доступа к отчетам и требуется для подведения итогов и упорядочения данных Excel в этом типе отчета, можно создать отчет Access. Например можно создать более гибкой отчеты, например группы и итоговые отчеты, печати наклеек и графические отчеты.

  • Формы     Если вы хотите использовать в форме для поиска или для отображения данных в Excel, можно создать форму Microsoft Access. Например можно создать форму Microsoft Access, чтобы отобразить поля в порядке, отличном от порядка столбцов на листе или просмотр длинных строк данных легче на один экран.

Дополнительные сведения о работе с формами и отчетами Access см. в справке Access.

Создание связи с данными Excel из Access

Вы можете связать диапазона Excel в базу данных Microsoft Access как таблицу. Используйте этот подход, если вы планируете продолжать Ведение диапазон в Excel, но также получить доступ к диапазону был доступен в приложении Access. Создать такую ссылку в базе данных Access, не из Excel.

При установлении связи с листом или именованным диапазоном Excel приложение Access создает новую таблицу, которая связана с ячейками в файле источника. Вносимые в эти ячейки в Excel изменения отражаются в связанной с ними таблице. Однако, из приложения Access невозможно вносить изменения в содержимое этой таблицы. При необходимости добавить, изменить или удалить данные необходимо делать это в исходном файле.

Далее описаны ситуации, в которых, как правило, нужно установить связь из Access с данными на листе Excel.

  • Требуется хранить данные в листах Excel, но иметь возможность использовать удобные функции запросов и отчетов Access.

  • В отделе или рабочей группе используется доступ, но данных из внешних источников, совместимые с в листы Excel. Вы не хотите сохранять копии внешних данных, но вы хотите иметь возможность работать с ним в приложении Access.

Дополнительные сведения о создании связи из Access с данными Excel см. в справке Access.

Импорт данных Excel в Access

Чтобы в базе данных Access сохранить содержащиеся в Excel данные, а затем продолжать работать с ними в приложении Access, данные можно импортировать. При импорте данных Access сохраняет их в новой или существующей таблице, не изменяя содержащихся в Excel данных. За одну операцию импорта можно импортировать только один лист данных. Чтобы импортировать данные из нескольких листов, необходимо повторить операцию импорта для каждого листа.

Далее описаны обычные ситуации, в которых производится импорт в Access данных Excel:

  • Опытному пользователю Excel требуется использовать Access для работы с данными. Для этого необходимо переместить данные из листов Excel в одну или несколько новых таблиц Access.

  • В отделе или рабочей группе используется Access, но иногда данные поступают в формате Excel, и их необходимо объединять с базами данных Access. Требуется выполнять импорт полученных листов Excel в базу данных.

  • Сотрудник обрабатывает данные с помощью Access, но получает от своих коллег еженедельные отчеты в виде книг Excel. Имеет смысл автоматизировать процесс импорта, чтобы каждую неделю в определенное время эти данные были импортированы в базы данных.

Для получения дополнительных сведений об импорте данных Excel в Access см. в справочной системе приложения Access.

К началу страницы

Импорт данных из Интернета

Веб-страницы часто содержат сведения, которые идеально подходят для анализа в Excel. Например, в Excel можно анализировать биржевые котировки, используя для этого данные, поступающие непосредственно с веб-страницы. В зависимости от конкретных требований можно загружать обновляемые данные (т. е. данные в Excel можно обновить актуальными сведениями с веб-страницы) либо сохранить на листе статические данные, загруженные с веб-страницы однократно.

С помощью веб-запроса можно загружать данные, которые хранятся в интрасети или в Интернете, например одну либо несколько таблиц или весь текст с веб-страницы, и анализировать их с использованием инструментов и возможностей Excel. Одним нажатием кнопки можно легко обновить данные актуальными сведениями с веб-страницы. Например, можно загружать и обновлять биржевые котировки с общедоступной веб-страницы либо таблицу с данными о продажах с веб-страницы компании.

Вы можете импортировать данные, рассчитанные на веб-страницы, используя диалоговое окно Нового веб-запроса. (На вкладке " данные " в группе Получение внешних данных нажмите кнопку Из Интернета ). Вам нужен доступ к World Wide Web через интрасети вашей организации или модемом на компьютере или в сети или соответствие локального HTML или XML-файлы можно сделать запрос.

К началу страницы

Импорт текстовых файлов

С помощью Excel можно импортировать на лист данные из текстового файла (на вкладке Данные в группе Внешние данные нажмите кнопку Из текста). Мастер импорта текста изучит импортируемый текстовый файл и поможет подобрать подходящий способ импорта данных.

Импортировать данные в текстовый файл с помощью Excel можно двумя способами: можно открыть текстовый файл в Excel (при этом подключение к файлу не создается) либо импортировать его содержимое как диапазон внешних данных (в этом случае создается подключение к текстовому файлу).

Чаще всего используются два формата текстовых файлов:

  • текстовые файлы с разделителями (TXT), в которых для разделения полей текста обычно используется знак табуляции (код ASCII 009);

  • текстовые файлы с разделителями-запятыми (CSV), в которых в качестве разделителя полей текста обычно используется запятая (,).

Как в TXT-, так и CSV-файлах можно изменить знак разделителя (это может потребоваться для успешного импорта и экспорта).

К началу страницы

Импорт данных с сервера Microsoft SQL Server

Microsoft SQL Server — это полнофункциональная реляционная СУБД, предназначенная для создания корпоративных решений в области управления данными с высокими требованиями к производительности, доступности, масштабируемости и безопасности. В приложении Excel можно легко подключиться к базе данных Microsoft SQL Server (на вкладке Данные в группе Внешние данные выберите пункт Из других источников, а затем — С сервера SQL Server).

При подключении к базе данных Microsoft SQL Server мастер подключения данных включает три страницы, указанные ниже.

  • Страница 1: подключение к серверу базы данных     Укажите сервер и способ, которым вы выполните вход на сервер базы данных с помощью этой страницы.

  • Страница 2: Выбор базы данных и таблицы    Используйте эту страницу для укажите имя базы данных и таблицы или запроса.

  • Страница 3: сохранение данных файла и подключение    Используйте эту страницу, чтобы указать и описания подключения файла и поиска для поиска файла фраз.

К началу страницы

Импорт данных из служб аналитики Microsoft SQL Server

Службы аналитики — это компонент сервера Microsoft SQL Server, поддерживающий возможности бизнес-аналитики и обеспечивающий платформу для систем аналитики OLAP, систем показателей ключевых показателей эффективности, глубинного анализа данных и систем отчетности, основанных на панелях мониторинга. В Excel можно легко подключиться к базе данных OLAP с помощью поставщика OLAP (на вкладке Данные в группе Внешние данные выберите пункт Из других источников, а затем — Из служб аналитики). Поставщик OLAP — это набор программного обеспечения, позволяющего обращаться к базам данных OLAP определенного типа. В состав этого программного обеспечения могут входить драйвер источника данных и другие клиентские программы, необходимые для подключения к базе данных. Для подключения к поставщику OLAP необходимо использовать отчет сводной таблицы.

При отключении от источника данных OLAP, можно также перейти данных OLAP. автономный файл куба — это файл с расширением .cub, в которой хранится часть исходные данные из серверной базы данных OLAP. Чтобы продолжить вносить изменения отчетов сводных таблиц и сводных диаграмм, если сервер недоступен или при отключении от сети с помощью файла автономного куба.

При подключении к Microsoft SQL Server Analysis Services, мастера подключения данных отображаются три страницы:

  • Страница 1: подключение к серверу базы данных     Укажите сервер и способ, которым вы выполните вход на сервер базы данных с помощью этой страницы.

  • Страница 2: Выбор базы данных и таблицы    Используйте эту страницу для указания базы данных и куба.

  • Страница 3: сохранение данных файла и подключение    Используйте эту страницу, чтобы указать и описания подключения файла и поиска для поиска файла фраз.

К началу страницы

Импорт XML-данных

Microsoft Office Excel позволяет легко импортировать данные язык XML (Extensible Markup), который создается из других приложений и баз данных, сопоставление XML-элементов из XML-схемы с ячейками листа и экспорт обработанных данных XML для взаимодействия с другими приложениями и базами данных. Рассматривать эти новые возможности XML как превращение в генератор файла данных XML с помощью знакомого пользовательского интерфейса Excel.

С помощью карты XML, можно легко добавлять, идентификации и выделять определенные части бизнес-данных из документов Microsoft Excel. Например счета, которая содержит имя и адрес клиента или отчет, содержащий финансовые результаты последнего квартала, больше не просто статические отчеты. Можно легко импортировать эти данные из баз данных и приложений, измените его и экспортировать его в то же или другой баз данных и приложений.

Ключевые сценарии использования XML

Ниже приведены ключевые сценарии, для работы с которыми предназначены функциональные возможности XML.

  • Расширение функциональных возможностей существующих шаблонов Excel путем сопоставления XML-элементов с существующими ячейками. Это облегчает обмен XML-данными между источниками и шаблонами без необходимости переработки этих шаблонов.

  • Использование данных XML в качестве входных данных для существующих моделей вычислений путем сопоставления XML-элементов с существующими таблицами.

  • Импорт файлов XML-данных в новую рабочую книгу.

  • Импорт XML-данных из веб-службы в лист Excel.

  • Экспорт данных в сопоставленных ячейках в файлы XML-данных независимо от других данных в книге.

Основной процесс использования XML-данных в Excel

На приведенной ниже схеме показана совместная работа различных файлов и операций при использовании XML в Excel. В первом приближении этот процесс можно разбить на пять этапов.

Общие сведения о работе с данными XML в Excel

Сноска 1 Добавление в книгу файла схемы XML (XSD).

Выноска 2 Сопоставление элементов схемы XML с отдельными ячейками или XML-списков.

Выноска 3 Импорт файла данных XML (XML) и привязка XML-элементов к сопоставленным ячейкам.

Этап 4 Ввод данных, Перемещение сопоставленных ячеек и функциональных возможностей Excel при сохранении структуры и определений XML.

Выноска 5 Экспорт обработанных данных из сопоставленных ячеек в файл данных XML.

Использование данных XML

При импорте содержимого файла данных XML в имеющуюся в книге карту XML выполняется привязка данных из файла к карте XML, хранящейся в этой книге. Это означает, что каждый элемент данных в файле данных XML имеет соответствующий элемент в схеме XML, который был сопоставлен из файла схемы XML или из полученной схемы. Карта XML может содержать только одну привязку данных XML, и привязка данных XML связана со всеми сопоставлениями, которые были созданы на базе общей карты XML.

Можно открыть диалоговое окно Свойства карты XML (на вкладке Разработчик в группе XML нажмите кнопку Свойства карты.), где существует три способа всю по умолчанию, которое можно задать, или снимите флажок, чтобы управлять привязка данных XML:

  • Проверять данные на соответствие схеме при импорте и экспорте    Определяет, если проверки данных Excel на соответствие схеме XML при импорте данных. Установите этот параметр, чтобы обеспечить соответствие XML-данных, импортируемых в схему XML.

  • Заменять существующие данные новыми    Определяет, если данные перезаписываются при импорте данных. Установите этот параметр, если требуется заменить текущих данных с новыми данными, например, когда актуальные данные содержатся в файле данных XML.

  • Добавлять новые данные в существующие XML-списки    Определяет, если содержимое источника данных добавляются в существующие данные на листе. Укажите этот параметр, например, объединение данных из нескольких так же, файлы данных XML в XML-списка, или не хотите перезаписывать содержимое ячейки, содержащей функцию.

К началу страницы

Импорт данных с помощью мастера подключения данных

В мастере подключения данных можно использовать для подключения к OLE DB и ODBC внешнего источника данных, уже было определено. Чтобы открыть мастера подключения данных, на вкладке " данные " в группе Получение внешних данных, нажмите кнопку Из других источников и выберите команду Из мастера подключения данных.

Выбрав в мастере подключения в качестве источника вариант Дополнительно, можно просмотреть список доступных поставщиков OLE DB в диалоговом окне Свойства связи с данными. Кроме того, поставщик OLE DB драйверов ODBC (Майкрософт) также обеспечивает доступ к источникам данных ODBC. Чтобы получить дополнительные сведения об использовании каждой из вкладок в этом диалоговом окне, нажмите кнопку Справка в диалоговом окне Свойства связи с данными.

Как правило чтобы определить сведения о подключении в диалоговом окне Свойства связи с данными, сделайте следующее:

  • Перейдите на вкладку Поставщик, выберите поставщика OLE DB и нажмите кнопку Далее, чтобы отобразить вкладку подключение для ввода конкретных сведений о подключении для этого поставщик OLE DB.

    Каждое средство доступа OLE DB определяет свои сведения о подключении. Например, Microsoft OLE DB Provider для SQL Server требует имени сервера, папки на сервере и имени пользователя; можно определить и дополнительные сведения, например пароль или режим использования интегрированных средств безопасности Microsoft Windows.

  • Перейдите на вкладку Дополнительно для предоставления дополнительных сведений, например о настройках сети и разрешениях на доступ.

  • Перейдите на вкладку Все, чтобы определить свойства инициализации для выбранного средства доступа OLE DB.

Примечание : В мастере подключения данных нельзя выполнить фильтрацию или объединение данных.

К началу страницы

Импорт данных с помощью приложения Microsoft Query

Можно также использовать Microsoft Query для импорта данных. (На вкладке " данные " в группе Получение внешних данных нажмите кнопку Из других источников и нажмите кнопку Из Microsoft Query.) Настройка источников данных ODBC для извлечения данных с помощью Microsoft Query. В Microsoft Query можно использовать мастер запросов для создания простых запрос или расширенных условий в запросе можно использовать для создания более сложных запросов и сделайте следующее:

  • фильтрацию строк и столбцов данных перед их перенесением в Microsoft Excel;

  • Создание запрос с параметрами.

  • сортировку данных перед их перенесением в Microsoft Excel;

  • объединение нескольких таблиц.

Microsoft Query обладает всеми необходимыми для выполнения этих специализированных задач свойствами.

К началу страницы

Импорт данных программным образом и с использованием функций

Разработчикам предлагается несколько способов импорта данных в Excel.

  • Для доступа к данным из внешнего источника можно использовать язык Visual Basic для приложений. В зависимости от вида источника данных для их загрузки можно воспользоваться объектами данных ActiveX либо объектами DAO. Кроме того, можно задать в коде строку подключения, содержащую сведения о подключении. Строка подключения может пригодиться, если, например, невозможно воспользоваться для создания файла подключения помощью администратора или других пользователей либо требуется упростить процедуру установки приложения.

  • При импорте данных из базы данных SQL Server, рассмотрите возможность использования собственного клиента SQL, наилучшим образом для доступа к данным автономное приложение программного интерфейса (API), используемый для OLE DB и ODBC. Он объединяет SQL поставщик OLE DB и драйвер ODBC SQL в один машинный, динамических библиотек (DLL) обеспечивая новые функции, которые, отличный от компонентов доступа к данным Microsoft (MDAC). С помощью собственного клиента SQL для создания новых приложений или повышения существующих приложений, которые можно использовать преимущества новых возможностей SQL Server 2005, таких как несколько активных результирующих наборов (MARS), пользовательская типов (пользовательского ТИПА) и XML поддержка типа данных.

  • Функция ДРВ загружает данные реального времени из программы, поддерживающей автоматизацию COM. Надстройка ДРВ автоматизации COM должна быть создана и зарегистрирована на локальном компьютере.

  • Код SQL. Функция запрос обращается к внешнему источнику данных и выполняет запрос из листа. SQL. Выберите запрос возвращает результат как формула массива без необходимости программирования макрос. Если эта функция недоступна, необходимо установить надстройку программы Microsoft Excel ODBC (XLODBC. XLA). Вы можете установить надстройку с Microsoft Office Online сайта.

Дополнительные сведения о программировании на языке Visual Basic для приложений см. в справке по Visual Basic.

К началу страницы

Защита доступа к данным

Когда подключение к внешнему источнику данных или обновление данных, важно следует помнить о возможных проблемах с безопасностью и можно делать о проблемах с безопасностью эти сведения. Используйте следующие правила и советы и рекомендации для защиты данных.

К началу страницы

Хранение подключений к данным в надежном месте

Файлы подключения к данным часто содержат один или несколько запросов, используемых для обновления внешних данных. Заменив этот файл, злоумышленник может создать запрос для получения доступа к конфиденциальным данным и передать их другим пользователям либо причинить ущерб иным способом. Таким образом, важно убедиться в следующем:

  • создателю файла подключения можно доверять;

  • Файл подключения безопасных и поступает из надежного расположения.

Для повышения безопасности подключений к внешним данным могут быть отключены на вашем компьютере. Для подключения к данным, при открытии книги, необходимо активировать подключений к данным с помощью панели Центр управления безопасностью или поместить книгу в надежном расположении. Дополнительные сведения читайте в статье Создание, удаление или изменение надежного расположения для файлов, Добавление, удаление или просмотр надежного издателяи просмотреть параметры безопасности в центре управления безопасностью.

К началу страницы

Безопасность при использовании учетных данных

Для доступа к внешнему источнику данных обычно необходимы учетные данные (имя пользователя и пароль), применяемые при проверке подлинности пользователя. Необходимо гарантировать, что эти учетные данные передаются надежным и безопасным образом и что они недоступны другим пользователям.

Используйте надежные пароли, состоящие из букв в верхнем и нижнем регистре, цифр и символов. В ненадежных паролях не используются сочетания таких элементов. Надежный пароль: Y6dh!et5. Ненадежный пароль: House27. Пароль должен состоять не менее чем из 8 знаков. Лучше всего использовать парольную фразу длиной не менее 14 знаков.

Очень важно запомнить пароль, поскольку восстановить его с помощью корпорации Майкрософт будет невозможно. Все записанные пароли следует хранить в надежном месте вдали от сведений, для защиты которых они предназначены.

Не сохраняйте учетные данные при подключении к источникам данных. Эта информация может храниться в книге и файл подключения как обычный текст и злоумышленникам есть доступ к информации для нарушения безопасности источника данных.

По возможности используйте проверку подлинности Windows (также называется доверительное соединение), который использует учетную запись пользователя Windows для подключения к серверу SQL Server. Когда пользователь подключается с помощью учетной записи пользователя Windows, SQL Server использует данные в операционной системе Windows для проверки имени пользователя и пароля. Прежде чем можно будет использовать проверку подлинности Windows, администратор сервера должен настроить SQL Server, чтобы использовать этот режим проверки подлинности. Если проверка подлинности Windows недоступна, не сохраняйте учетные данные пользователей. Безопаснее для пользователи должны вводить свои учетные данные при каждом входе в систему.

К началу страницы

Безопасная публикация в службах Excel

При подключении к источнику данных в диалоговом окне Параметры проверки подлинности для служб Excel можно выбрать способ проверки подлинности для доступа к источнику в службах Excel. Выберите один из указанных ниже вариантов входа в источник данных.

  • Проверка подлинности Windows    Выберите данный вариант, чтобы использовать имя и пароль Windows для текущего пользователя. Этот способ является наиболее удобным, но он может отразиться на производительности при одновременной работе нескольких пользователей.

  • Единый вход    Выберите этот параметр, чтобы использовать единый вход и введите в текстовом поле Код SSO строка соответствующие идентификации. Администратор веб-сайтов можно настроить на сайте SharePoint базы данных единого входа в систему с помощью которых могут храниться имя пользователя и пароль. Этот метод может быть наиболее эффективно Если существует много пользователей.

  • Нет.    Выберите этот вариант, чтобы сохранить имя пользователя и пароль в файле подключения.

Примечание : Проверка подлинности используется только в службах Excel, и не применяется в Microsoft Office Excel. Если необходимо обеспечить доступ к одним и тем же данным при открытии книг как в Excel, так и в службах Excel, установите те же параметры проверки подлинности в Excel.

Для повышения безопасности подключения, используйте данные подключения библиотеки (ODC-ФАЙЛ). ODC-ФАЙЛ — это особая библиотека документов SharePoint, которые могут быть определены как надежное расположение библиотеки, а, которая упрощает для хранения, secure, совместно использовать и управлять файлами ODC. Например администратор может потребоваться переместить базу данных из тестового сервера на сервер приложений или обновить запрос, который обращается к данным. С помощью одного ODC-файл, сохраненный в Получении администрирования эти сведения о подключении намного проще и доступа пользователей к данным наиболее удобно, поскольку все книги используют один и тот же файл подключения и операции обновления (ли на компьютере клиента и сервера) получает последние изменения на этот файл подключения. Даже можно настроить автоматическое обнаружение изменения подключения файла и использовать последнюю версию этого файла подключения Office SharePoint Server и клиентский компьютер пользователя. Дополнительные сведения читайте в статье справки центра администрирования Office SharePoint Server 2007.

К началу страницы

Проблемы, связанные с подключением к данным

В приведенных ниже разделах описаны отдельные проблемы, которые могут возникнуть при подключении к внешним данным.

К началу страницы

Проблема: при попытке импортировать данные не хватает места на диске

Если при попытке подключения к внешним данным не хватает места на диске, попробуйте воспользоваться приведенными ниже рекомендациями.

Проверка и увеличение доступные места на диске     Чтобы освободить место на жестком диске, попробуйте очистки корзины, архивацию ненужных файлов и удалять их на жестком диске или удаление неиспользуемых компонентов Windows. Дополнительные сведения об освобождении места на жестком диске содержатся в справке Windows.

Методы, которые вы можете попробовать при ограничен места на диске     Если у вас есть только ограниченного объем свободного места на жестком диске, попробуйте сделать следующее:

Microsoft Query    Выполните одно или несколько из указанных ниже действий.

  • Упростить запроса.     Убедитесь, что включение таблицы и поля, которые необходимы для запроса. Если ваш запрос содержит ненужные таблицы или поля, удалите их из запроса, чтобы уменьшить размер файла временный запрос.

  • Установить используйте условия для уменьшения размера результат     Используйте условия для извлечения только определенных записей, а не получение всех записей из базы данных. Дополнительные сведения содержатся в справке Microsoft Query.

  • Установка максимального числа записи, возвращенные в запросе     Ограничение количества записей, которые возвращает запрос. В Microsoft Query нажмите кнопку Параметры в меню Правка, установите флажок ограничить количество возвращаемых записей в разделе Параметры пользователя и затем введите максимальное количество записей, чтобы вернуться в поле записи.

Мастера подключения данных     Несмотря на то, что не удается ограничить данных в мастере подключения данных, можно ограничить данные из источника данных, определив запрос в источнике данных. Если у вас нет возможности или разрешение на определение запроса в источнике данных, обратитесь к администратору данных.

К началу страницы

Проблема: что случилось с мастером кубов OLAP?

Мастер куба OLAP в Microsoft Query, в котором он был создан в кубе OLAP из базы данных Jet, больше не доступен в Office Excel.

К началу страницы

Проблема: что случилось со службами извлечения данных?

Службы извлечения данных, появившиеся в пакете Microsoft Office 2003, использовали для доступа к веб-службам и запроса данных из различных источников универсальные файлы подключения к данным (UDCX-файлы).

В мастере подключения данных на странице приветствия мастера подключения данных можно выбрать параметры источника данных Microsoft Business Solutions или службы извлечения данных. Службы извлечения данных параметр позволяет выбрать две службы извлечения данных: списки служб Windows SharePoint Services, которая получает данные из списков и библиотек документов на сервере Windows SharePoint Services и Microsoft SQL Server, который получает данные из Microsoft SQL Server 2000 или более поздней версии.

Хотя мастер подключения данных больше не поддерживает редактирование UDC-файлов подключения, в Excel по-прежнему поддерживаются существующие подключения с использованием служб извлечения данных и их обновление.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×