Общие сведения об отчетах

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

При работе с базой данных для просмотра, форматирования и обобщения данных обычно используются отчеты. Например, можно создать отчет в виде списка с номерами телефонов всех контактов или сводный отчет с итогами продаж компании в разных регионах за разные периоды.

В этой статье представлен обзор отчетов в приложении Microsoft Access 2010, а также сведения о новых и изменившихся возможностях, связанных с ними. Кроме того, в статье содержатся инструкции по созданию отчетов, сортировке, группировке и обобщению данных, а также предварительному просмотру и печати отчетов.

Вы увидите, что намного проще создавать отчеты понятное, если у базы данных структуре хорошо спроектированный таблицы и связи. Общие сведения о планировании и проектировании базы данных читайте в статье Основные сведения о создании баз данных.

В этой статье

Общие сведения

Новые возможности

Создание нового отчета

Добавление группировки, сортировки и итогов

Выделение значений с помощью условного форматирования

Придание отчету профессионального внешнего вида с помощью тем

Добавление изображений

Предварительный просмотр и печать отчета

Общие сведения

Отчет — это объект базы данных, который используется для отображения и обобщения данных. С помощью отчетов можно распространять и архивировать мгновенные снимки данных в печатном виде, в виде PDF- или XPS-файлов и файлов других форматов.

Отчет по сотрудникам в режиме предварительного просмотра

Отчеты могут содержать подробные сведения об отдельных записях, сводные сведения о большой группе записей либо и то, и другое. Кроме того, отчеты Access также можно использовать при создании наклеек для списков рассылок и многого другого.

Можно создавать "свободные" отчеты, не отображающие никаких данных, однако в этой статье предполагается, что отчет привязан к некоторому источнику данных, например к таблице или запросу.

Клиентские отчеты и веб-отчеты

В приложении Access 2010 есть новая функция, позволяющая создавать веб-базы данных путем публикации баз данных Access на сервере SharePoint, на котором работают службы Access. Если имеется веб-база данных, отчеты Access можно отображать в браузере с помощью служб SQL Server Reporting Services. При таком преобразовании набор доступных функций в отчетах, отображаемых в браузере, будет несколько ограничен. Однако если не нужно отображать отчеты в браузере, можно использовать полный набор возможностей, предоставляемых конструктором отчетов Access.

Составные части отчета

В приложении Access конструктор отчетов разбит на разделы. В клиентской базе данных можно просмотреть отчет в режиме конструктора, чтобы увидеть его разделов. В макете Просмотр, разделы не очевидно, но они остались без изменений, а также можно выбрать с помощью раскрывающегося списка в группе " Выделение " на вкладке " Формат ". Создание полезных отчетов, необходимо понять, как работает в каждом разделе. Например раздел, в котором выбрано размещение вычисляемого элемента управления на определяет способ доступа вычисляет результаты. Ниже приведен Сводка типов разделов и их применения.

  • Заголовок отчета    В этом разделе печатается только один раз в начале отчета. Заголовок отчета с помощью узнать подробности, которые обычно может отображаться на титульной странице, такие как эмблему, название или дата. При наведении вычисляемого элемента управления, который используется агрегатную функцию сумм в заголовке отчета — вычисления суммы по всему отчету. Заголовок отчета печатается перед верхний колонтитул.

  • Верхний колонтитул    Этот раздел выводится в верхней части каждой страницы. Например с помощью верхний колонтитул повторите название отчета повторялось на каждой странице.

  • Заголовок группы    В этом разделе печатается в начале каждой новой группы записей. Заголовок группы используется для печати имя группы. В отчете, сгруппированные по продуктам, используйте заголовок группы для печати название продукта. При наведении вычисляемого элемента управления, который используется в заголовке группы агрегатную функцию сумм для текущей группы — сумму. В зависимости от количества уровней группировки добавления может иметь несколько разделов заголовок группы в отчете. Дополнительные сведения о создании группы верхние и нижние колонтитулы обратитесь к разделу Добавление группировки, сортировки и итогов.

  • Подробности    В этом разделе печатается один раз для каждой строки в источнике записей. Это размещаются элементы управления, составляющие основное содержание отчета.

  • Примечание группы    Этот раздел выводится в конце каждой группы записей. Примечание группы используется для печати сводные данные для группы. В зависимости от количества уровней группировки добавления может иметь несколько группы разделов нижнего колонтитула в отчете.

  • Нижний колонтитул.    Этот раздел выводится в конце каждой страницы. Используйте нижний колонтитул, номера страниц для печати или на странице сведений.

  • Примечание отчета    В этом разделе печатается только один раз в конце отчета. Используйте примечании отчета для печати итогов и другой сводной информации по всему отчету.

Примечание : В режиме конструктора нижний колонтитул отчета отображается под нижнего колонтитула. Однако во всех остальных представлениях (режим, например или при печати или предварительном просмотре отчета) нижний колонтитул отчета появляется над нижний колонтитул только после последней группе нижний колонтитул или детали строки на последней странице.

К началу документа

Новые возможности

Порядок создания отчета в приложении Access 2010 очень похож на соответствующую процедуру в версии Access 2007. Однако в Access 2010 имеются и некоторые новые возможности, связанные с отчетами.

  • Общие коллекция изображений    В Access 2010 теперь вложить изображение в базу данных и затем использовать изображение через несколько объектов. Обновление одно изображение обновляет это место, где используется в пределах всей базы данных.

  • Темы Office    В Access 2010 теперь можно использовать стандартные тем Microsoft Office применить профессионально разработанных наборы шрифтов и цветов сразу ко всем Access форм и отчетов.

  • Больше возможностей условного форматирования    Access 2010 включает более мощные инструменты для выделения данных в отчете. Можно добавить до 50 правила условного форматирования для каждого элемента управления или группу элементов управления, и в клиентских отчетов, вы можете добавить гистограммы для сравнения данных между записями.

  • Более гибкие макеты    Метод конструктор по умолчанию для отчетов в Access 2010 — поместить элементы управления в макете. Эти сетки справки выравнивание и легко изменять размер элементов управления и необходимые для любого отчеты, которые должны размещаться в браузере. Несмотря на то, что макеты сами не являются новые возможности Access 2010, существуют некоторые изменения способами, в котором они используются для перемещения, выравнивание и изменение размера элементов управления. Дополнительные сведения можно найти видео Знакомство с макетами форм и отчетов.

К началу документа

Создание отчета

Действие 1. Выбор источника записей

Источником записей для отчета может быть таблица, именованный или внедренный запрос. Источник записей должен содержать все строки и столбцы данных, которые требуется отобразить в отчете.

Дополнительные сведения о создании таблиц или запросов читайте в статьях Общие сведения о таблицах и Знакомство с запросами.

Дополнительные сведения о создании и выбрав источников записей читайте в статье Настройка источника записей для отчета.

Действие 2. Выбор инструмента отчета

Инструменты отчетов расположены на вкладке Создание ленты в группе Отчеты. В таблице ниже кратко описано их назначение.

Веб-совместимые отчеты

Отчеты, созданные с использованием этих инструментов, совместимы с функцией публикации в службах Access и могут быть отображены в браузере. Обратите внимание на то, что значки веб-совместимых объектов помечены изображением глобуса.

Изображение кнопки

Инструмент

Описание

Изображение кнопки

Отчет

Позволяет создать простой табличный отчет, содержащий все поля из источника записей, который выбран в области навигации.

Изображение кнопки

Пустой отчет.

Позволяет открыть пустой отчет в режиме макета и отобразить область задач "Список полей". При перетаскивании полей из этой области в отчет в приложении Access создается соответствующий запрос к источнику записей.

Дополнительные сведения о публикации для функции служб Access читайте в статье Создание базы данных Access для публикации в Интернете.

Клиентские отчеты

Отчеты, созданные с использованием этих инструментов, несовместимы с функцией публикации в службах Access. Если добавить клиентские отчеты в веб-базу данных, ее можно будет опубликовать, однако отчеты не будут доступны в браузере. При этом с ними можно будет работать, если открыть базу данных в приложении Access.

Изображение кнопки

Инструмент

Описание

Изображение кнопки

Отчет

Позволяет создать простой табличный отчет, содержащий все поля из источника записей, который выбран в области навигации.

Изображение кнопки

Конструктор отчетов

Открывает пустой отчет в конструкторе, где можно вставить в него необходимые поля и элементы управления.

Изображение кнопки

Пустой отчет.

Открывает пустой отчет в режиме макета и отображает область задач "Список полей". При перетаскивании в отчет полей из списка полей в приложении Access создается внедренный запрос, который сохраняется в свойстве отчета "Источник записей".

Изображение кнопки

Мастер отчетов

Пошаговый мастер, с помощью которого можно выбрать поля и задать уровни группировки и сортировки, а также параметры макета. Мастер создает отчет на основе выбранных пользователем параметров.

Изображение кнопки

наклейки

Вызывает мастер, в котором можно выбрать стандартный или настраиваемый размер подписей, набор отображаемых полей и порядок их сортировки. В результате мастер создает отчет с подписями на базе выбранных параметров.


Действие 3. Создание отчета

  1. Выберите нужный инструмент, нажав соответствующую кнопку. Если появится окно мастера, следуйте инструкциям в нем, а на последней странице нажмите кнопку Готово.

    Отчет будет открыт в приложении Access в режиме макета.

  2. Отформатируйте отчет, чтобы добиться желаемого внешнего вида, выполнив действия, указанные ниже.

    • Измените размер полей и подписей, выделяя их и перетаскивая края.

    • Расположите поля в нужном порядке, выделяя их (и соответствующие подписи, если они есть) и перетаскивая в нужное место.

    • Также можно, щелкая поля правой кнопкой мыши, с помощью команд контекстного меню объединять или разбивать ячейки, удалять и выделять поля и выполнять другие задачи форматирования.

      Кроме того, отчет можно сделать более привлекательным и удобным с помощью функций, описанных в разделах ниже.

К началу документа

Добавление группировки, сортировки и итогов

Чтобы быстро добавить в отчет группировку, сортировку или итоги, щелкните правой кнопкой мыши поле, к которому необходимо применить соответствующую функцию, и выберите нужную команду в контекстном меню.

Кроме того, когда отчет открыт в режиме макета или конструктора, можно добавить эти функции с помощью области "Группировка, сортировка и итоги".

  1. Если область "Группировка, сортировка и итоги" не открыта, на вкладке Конструктор в группе Группировка и итоги выберите команду Группировка.

  2. Нажмите кнопку Добавить группировку или Добавить сортировку и выберите поле, по которому требуется сгруппировать или отсортировать данные.

  3. Чтобы задать дополнительные параметры или добавить итоги, в строке группировки или сортировки выберите команду Больше.

Подробные сведения о Группировка, сортировка и итоги читайте в статье Создание группировкой или сводного отчета.

К началу документа

Выделение значений с помощью условного форматирования

В приложении Access 2010 предусмотрены более функциональные инструменты для выделения данных в отчетах. Для каждого элемента управления или их группы можно добавить до 50 правил условного форматирования, а в клиентских отчетах можно использовать гистограммы для сравнения данных из разных записей.

Добавление условного форматирования :

  1. Откройте отчет в режиме макета. Для этого щелкните его правой кнопкой мыши в области навигации и выберите команду Режим макета.

  2. Выделите все элементы управления, к которым требуется применить условное форматирование. Чтобы выбрать несколько элементов, удерживайте нажатой клавишу SHIFT или CTRL и щелкните нужные элементы.

  3. На вкладке Формат в группе Форматирование элемента управления выберите команду Условное форматирование.

    В приложении Access будет открыто диалоговое окно Диспетчер правил условного форматирования.

  4. В диалоговом окне Диспетчер правил условного форматирования выберите команду Создать правило.

  5. В диалоговом окне Новое правило форматирования выберите значение в поле Выберите тип правила.

    • Чтобы создать правило, которое будет проверяться отдельно для каждой записи, выберите вариант Проверьте значения в текущей записи или используйте выражение.

    • Чтобы создать правило для сравнения записей друг с другом с помощью гистограмм, выберите вариант Сравнить с другими записями.

Примечание :  Параметр Сравнить с другими записями недоступен в веб-базах данных.


  1. В поле Измените описание правила укажите правило, которое будет определять применение форматирования, а также форматирование, которое нужно применять при выполнении условий.

  2. Чтобы вернуться в диалоговое окно Диспетчер правил условного форматирования, нажмите кнопку ОК.

  3. Если нужно создать еще одно правило для этого элемента управления или группы элементов, повторите процедуру, начиная с действия 4. В противном случае нажмите кнопку ОК, чтобы закрыть диалоговое окно.

Дополнительные сведения о добавлении условного форматирования к отчету просмотреть видео Использование условного форматирования в отчетах.

К началу документа

Придание отчету профессионального внешнего вида с помощью тем

Теперь к базе данных Access можно применять темы Office 2010, что позволяет выдерживать общий стиль во всех документах Office.

Важно : Выбранная тема Office, шрифт или цвет применяется не только к текущему отчету, а ко всем формам и отчетам в базе данных.

  1. Откройте отчет в режиме макета, щелкнув правой кнопкой мыши в области навигации и выбрав Макет Vросмотр.

  2. На вкладке " Конструктор " в группе темы выберите тему, цвет или шрифт, который вы хотите:

    Изображение ленты

    • С помощью коллекции Темы можно одновременно задать цвета и шрифты в соответствии с готовой схемой.

    • С помощью коллекций Цвета и Шрифты можно задать цвета и шрифты независимо друг от друга.


Дополнительные сведения об использовании темы Office можно посмотреть видео сделать свой форм и отчетов Access более согласованные и резюме с помощью тем Office.

К началу документа

Добавление изображений

Изображения в приложении Access традиционно привязывались к отдельным элементам управления на формах и отчетах. Чтобы изменить часто используемое изображение, присутствующее на нескольких формах и отчетах, каждый соответствующий элемент управления приходилось обновлять вручную. В приложении Access 2010 можно прикрепить к базе данных изображение, а затем использовать его с несколькими объектами. Обновление одного изображения приводит к его обновлению в масштабах всей базы данных. Это очень полезно при работе с такими объектами, как эмблемы компаний и фоновые изображения, используемые во всей базе данных.

Добавление изображения

  1. В области навигации щелкните правой кнопкой мыши отчет, в который требуется добавить изображение, и выберите команду Режим макета.

  2. Щелкните то место отчета, где нужно поместить изображение.

  3. На вкладке Конструктор в группе Элементы управления нажмите кнопку Вставить изображение.

  4. Выполните одно из указанных ниже действий.

    • Использование существующего изображения    Если изображение, которое вы хотите уже находится в коллекции, щелкните его, чтобы добавить к отчету.

    • Загрузка новых изображения    В нижней части коллекции нажмите кнопку Обзор. В диалоговом окне Вставка рисунка перейдите к изображению, которую вы хотите использовать и нажмите кнопку Открыть.

      Выбранное изображение будет добавлено в отчет.

Добавление фонового изображения

Примечание :  Фоновые изображения невозможно добавить в веб-совместимые отчеты.

  1. В области навигации щелкните правой кнопкой мыши отчет, в который требуется добавить фоновое изображение, и выберите команду Режим макета.

  2. На вкладке Формат в группе Фон нажмите кнопку Фоновый рисунок.

  3. Выполните одно из указанных ниже действий.

    • Использование существующего изображения    Если изображение, которое вы хотите уже находится в коллекции, щелкните его, чтобы добавить к отчету.

    • Загрузка новых изображения    В нижней части коллекции нажмите кнопку Обзор. В диалоговом окне Вставка рисунка перейдите к изображению, которую вы хотите использовать и нажмите кнопку Открыть.

      Выбранное изображение будет добавлено в отчет.

К началу документа

Просмотр и печать отчета

Предварительный просмотр отчета

  1. Откройте отчет, который требуется просмотреть, или просто выберите его в области навигации.

  2. На вкладке Файл выберите команду Печать, а затем — Предварительный просмотр

    Отчет будет открыт в режиме предварительного просмотра. С помощью команд на вкладке Предварительный просмотр можно выполнить следующие действия:

    • напечатать отчет;

    • изменить размер или макет страницы;

    • изменить масштаб или просмотреть сразу несколько страниц;

    • обновить данные в отчете;

    • экспортировать отчет в другой формат файла.

  3. Чтобы вернуться в рабочую область базы данных, на вкладке Предварительный просмотр в группе Закрыть выберите команду Закрыть окно предварительного просмотра.

Печать отчета

Отчет можно вывести на печать не только из режима предварительного просмотра.

  1. Откройте отчет, который требуется распечатать, или просто выберите его в области навигации.

  2. На вкладке Файл выберите команду Печать.

    • Чтобы сразу отправить отчет на принтер по умолчанию, не настраивая его параметры, выберите команду Быстрая печать.

    • Чтобы открыть диалоговое окно, в котором можно выбрать принтер, указать число копий и задать другие параметры, выберите команду Печать.

К началу документа

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×