Обзор функций подключения данных в Microsoft Office Visio 2007.

Возможности Microsoft Office Visio 2007 не ограничиваются созданием схем и документов  — эта программа помогает упорядочивать, анализировать и наглядно представлять данные.

Каждая фигура в схеме Visio может использоваться для отображения разных наборов данных. На следующих иллюстрациях в каждой фигуре отображаются данные о продажах в разных регионах, что делает удобным сравнение результатов продаж по регионам за текущий год и за предыдущие годы.

Обозначение состояния с помощью флажков

Если данные, с которыми планируется работать, уже хранятся в книге или в таблице базы данных, их можно импортировать непосредственно в фигуры Office Visio, а не вводить вручную.

В этой статье

Какой способ рекомендуется использовать для подключения данных к схемам

Можно ли использовать для подключения к данным способ, который применялся в предыдущих версиях Visio

Следует ли всегда использовать функции канала передачи данных для подключения данных к схемам

Какой способ рекомендуется использовать для подключения данных к схемам

В программе Visio имеется несколько функций для подключения данных, но в большинстве случаев лучше подключать источники данных к схемам с помощью мастера выбора данных (в меню Данные выберите команду Импорт данных в фигуры). После завершения работы с мастером данные отображаются в окне Внешние данные. После добавления соединенных фигур в документ данные отображаются в фигурах. В Office Visio 2007 включен также набор рисунков, связанных с данными, из которых можно выбирать нужные и которые можно изменять.

Дополнительные сведения о канале передачи данных и функциях рисунков, связанных с данными, см. в следующих статьях:

В начало страницы

Можно ли использовать для подключения к данным способ, который применялся в предыдущих версиях Visio

Да. Функция канала передачи данных в Office Visio 2007 не заменяет никакие функции предыдущих версий Visio. По-прежнему можно использовать специальные решения для подключения к данным, а также две надстройки для подключения к базам данных.

Две надстройки для подключения к базам данных — мастер баз данных и команда Связь с базой данных ODBC. Для доступа к этим функциям в меню Сервис укажите команду Надстройки, затем укажите Дополнительные решения Visio и выберите Мастер баз данных или Связь с базой данных ODBC.

В некоторых шаблонах имеются также особые средства, которые можно использовать для подключения определенных типов данных к схемам или для создания схем из данных.

  • Шаблон «Организационная диаграмма».     Для подключения к данным Microsoft Exchange Server, Microsoft Office Excel, данным из текстовых файлов и из других совместимых с ODBC источников данных с целью создания организационной диаграммы используется мастер организационных диаграмм. В организационной диаграмме в меню Организационная диаграмма выберите команду Импорт данных организационной диаграммы. После создания организационной диаграммы можно настроить связь с другими внешними данными с помощью мастера выбора данных. Дополнительные сведения см. в статье Создание организационной диаграммы Visio.

  • Шаблон «Временная шкала».     Для подключения к данным Microsoft Office Project используется мастер импорта временной шкалы. В меню Данные укажите пункт Вставить решения для данных, а затем выберите Временная шкала. Дополнительные сведения см. в статье Импорт данных из приложения Project во временную шкалу Visio.

  • Шаблон «Календарь».     Для подключения к данным Microsoft Office Outlook используется мастер импорта данных Outlook. В меню Данные укажите пункт Вставить решения для данных, а затем выберите Календарь. Дополнительные сведения см. в статье Импорт встреч Outlook в календарь Visio.

  • Шаблон «Схема мозгового штурма».     В схеме мозгового штурма используйте команду Импорт данных в меню Мозговой штурм для подключения к файлам XML. Дополнительные сведения см. в статье Создание схемы мозгового штурма.

  • Шаблон «Диаграмма Ганта».     Для подключения к данным Office Project используется мастер импорта данных Project. В диаграмме Ганта в меню Диаграмма Ганта выберите команду Импорт. Дополнительные сведения см. в статье Импорт данных из приложения Project в диаграмму Ганта Visio.

  • Шаблон «Схема модели базы данных».     Для реконструирования баз данных, совместимых с ODBC, используется мастер реконструирования. В схеме модели базы данных в меню База данных выберите команду Реконструировать. В дополнение к мастерам, которые поставляются вместе с шаблонами, можно использовать мастер выбора данных для импорта дополнительных данных в схемы и для представления данных в этих схемах. Дополнительные сведения см. в статье Реконструирование существующей базы данных в модель базы данных.

В начало страницы

Следует ли всегда использовать функции канала передачи данных для подключения данных к схемам

В следующих сценариях описываются особые ситуации, в которых для работы с данными в схемах может потребоваться способ, не связанный с использованием мастера выбора данных:

  • Вы работаете со схемами, которые были созданы ранее с помощью мастера баз данных.

  • Требуется работать с двусторонним подключением данных с использованием мастера баз данных — например, если требуется, чтобы изменения данных в диаграмме Visio влияли на источник данных.

  • Выполняется создание схем, таких как временные шкалы, организационные диаграммы и календари, из данных — когда вся схема автоматически создается в Visio из источника данных.

  • Выполняется создание основных фигур в Visio из данных — когда фигуры автоматически создаются в Visio из источника данных.

  • Выполняется реконструирование базы данных с помощью мастера реконструирования, доступ к которому осуществляется через шаблон «Схема модели базы данных».

В начало страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×