Новый интерфейс инструментов "Скачать и преобразовать"

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

В Excel 2016 был реализован набор полезных инструментов под названием "Скачать и преобразовать". Эти средства, основанные на технологии Power Query, позволяют легко подключать, объединять и преобразовывать данные, полученные из различных источников. В этом учебнике изложены основы работы с такими функциями.

Мы рады сообщить о важных изменениях набора "Скачать и преобразовать", которые были реализованы в мартовском обновлении Office 365. Мы расширили возможности импорта данных в Excel и изменили расположение кнопок на вкладке "Данные", чтобы использовать инструменты "Скачать и преобразовать" было еще проще.

Параметры "Скачать и преобразовать" на вкладке "Данные"

Вы по достоинству оцените интегрированные и современные возможности импорта и преобразования данных в Excel. Вы сможете легко получать данные из различных популярных источников, включая файлы, базы данных, службы Azure и веб-службы. Кроме того, вы сможете преобразовывать такие данные, сортируя их, изменяя их типы, выполняя с ними статистические вычисления, разделяя столбцы и т. д. Экономьте свое время благодаря новым соединителям и простым преобразованиям.

Обратите внимание, что новый интерфейс заменяет старые мастеры, которые были доступны в разделе Данные > Получение внешних данных. Однако при желании вы можете продолжать пользоваться ими. См.: Как восстановить старую функцию "Получение внешних данных?"

Примечание : Эта функция доступна в Excel, только если у вас есть подписка на Office 365. Если это так, убедитесь, что у вас установлена последняя версия Office.

Как получить данные из популярных источников, например CSV-файлов или Интернета?

Пользователи, импортирующие данные, предпочитают использовать кнопки для самых популярных соединителей, расположенные на ленте. В этом обновлении мы постарались учесть это и не нарушать привычный вам образ работы. Теперь вы найдете в разделе "Скачать и преобразовать" вкладки "Данные" следующие три популярных соединителя: Из текстового/CSV-файла, Из Интернета и Из таблицы/диапазона.

Из текстового/CSV-файла

С помощью этого соединителя можно легко импортировать данные из текстовых файлов (TXT), файлов данных с разделителями-запятыми (CSV) и файлов с форматированным текстом (PRN). Этот современный соединитель основан на технологии Power Query и заменяет устаревший мастер "Из текста".

Чтобы начать импорт данных с помощью нового соединителя, щелкните Данные > Из текстового/CSV-файла, выберите исходный файл и нажмите кнопку ОК. Новый соединитель Из текстового/CSV-файла проанализирует структуру входного файла и автоматически применит подходящие параметры импорта. Он может разбить столбцы по разделителю, преобразовать первую строку в заголовки столбцов и т. д.

Параметры "Из текста" для инструментов "Скачать и преобразовать"

Если вас не устраивает то, что вы видите в окне предварительного просмотра, можно настроить основные параметры импорта, такие как источник файлов, разделитель или логика определения типа данных. Окно предварительного просмотра обновляется с учетом выбранных настроек.

Затем вы можете нажать кнопку Загрузить, чтобы добавить данные непосредственно на лист, или щелкнуть стрелку рядом с этой кнопкой, чтобы загрузить их в модель данных. Если вы хотите применить к данным дополнительные преобразования в редакторе запросов, нажмите кнопку Изменить.

Из Интернета

С помощью этого соединителя вы можете извлекать данные из HTML-страниц. Этот соединитель также основан на технологии Power Query. Он заменяет устаревший мастер "Из Интернета".

Чтобы использовать его, выберите Данные > Из Интернета, укажите URL-адрес целевой страницы и нажмите кнопку ОК. В диалоговом окне "Навигатор" появится список всех таблиц на странице. Вы можете работать с веб-страницей в режиме таблицы или в веб-представлении. В режиме таблицы щелкните имя таблицы слева, и ее данные будут показаны в правой части экрана. В веб-представлении вы можете щелкнуть таблицу в списке "Навигатор" или в области предварительного просмотра. Вы любом из представлений можно выбрать несколько таблиц.

Параметры "Из Интернета" для инструментов "Скачать и преобразовать"

Из таблицы/диапазона

С помощью этого соединителя можно создать запрос, связанный с таблицей или именованным диапазоном на листе Excel. Затем вы можете уточнить данные и применить дополнительные преобразования к ним в окне редактора запросов.

Параметры "Из таблицы" для инструментов "Скачать и преобразовать"

Как импортировать данные из дополнительных источников, таких как XML-файл или Microsoft SQL Server?

Вы можете создать запрос для импорта данных из такого источника, как база данных Microsoft Access или веб-канал OData, а также сразу импортировать данные из нескольких текстовых файлов в папке.

При выборе команд Данные > Получение данных появляется раскрывающееся меню с доступными источниками данных. Источники разделены на категории, включая файлы, такие как книги Excel, XML-файлы или папки, базы данных, например SQL Server или Oracle, службы Azure (HDInsight или хранилище BLOB-объектов), веб-службы, например список SharePoint Online или Salesforce, и другие источники, такие как OData или ODBC.

Перечень доступных соединителей постоянно растет.

Параметры "Из базы данных" для инструментов "Скачать и преобразовать"

В этом обновлении мы также удалили следующие устаревшие мастеры, которые раньше были доступны в разделе "Получение внешних данных" на вкладке "Данные": "Из Access", "Из Интернета", "Из текста", "С сервера SQL Server", "Из веб-канала данных ODATA", "Из импорта данных XML" и "Из мастера подключения к данным". Если вам по какой-либо причине требуется использовать один из них, обратитесь к разделу Как восстановить старую функцию "Получение внешних данных?"

Однако в новом интерфейсе сохранены два популярных и довольно уникальных мастера: Из служб аналитики и Из Microsoft Query. Их можно найти в разделах Данные > Из базы данных и Данные > Из других источников нового интерфейса.

Как подготовить и преобразовать данные с помощью инструментов "Скачать и преобразовать"?

Подготовка и преобразование данных с помощью функции Скачать и преобразовать является важным этапом для их анализа. Вы можете удалить столбцы, отфильтровать строки, изменить типы данных в столбцах, заменить значения и т. д. Для этого используется специальное окно редактора запросов, в котором выполняются и отображаются все преобразования данных.

Откройте вкладку Данные на ленте, нажмите кнопку Получить данные, подключитесь к нужному источнику (например, файлу или базе данных) с помощью одного из доступных соединителей, а затем просмотрите данные в окне Навигатор.

Навигатор для инструментов "Скачать и преобразовать"

После этого выберите таблицы, которые вы хотите импортировать, и нажмите кнопку Изменить, чтобы открыть окно редактора запросов.

Редактор запросов "Скачать и преобразовать"

Используйте различные команды, доступные на ленте в окне редактора запросов. Вы можете преобразовывать данные, сортируя и фильтруя их, изменяя их типы, разделяя и объединяя столбцы, выполняя с ними статистические вычисления и т. д.

Все шаги преобразования, которые применяются к данным, записываются и сохраняются как часть запроса. Записанные преобразования можно просмотреть и настроить в разделе ПРИМЕНЕННЫЕ ШАГИ в редакторе запросов. Они повторно применяются к данным при каждом обновлении запроса.

Как импортировать данные из недавно использовавшихся источников, файлов подключения к базе данных Office (ODC), других подключений к книгам или таблиц?

Часто импорт данных выполняется путем получения данных из недавно использовавшихся источников. Зачастую пользователи подключаются к одним и тем же источникам для импорта данных.

Чтобы создать запрос на основе одного из недавно использовавшихся источников, щелкните Данные > Последние источники. Затем вы можете просмотреть источники, к которым подключались недавно, выбрать один из них и нажать кнопку Подключить, чтобы продолжить импорт.

Область недавних источников "Скачать и преобразовать"

Другим популярным сценарием является импорт данных из существующих подключений или таблиц в книге. Например, вам может потребоваться создать сводную таблицу на основе раннее созданного подключения к книге или импортировать данные из источника с помощью файла подключения к базе данных Office (ODC), который был определен вашим коллегой.

Теперь вы сможете экспортировать любые определения запросов в ODC-файл, а затем использовать его в различных книгах и делиться им с коллегами. Чтобы экспортировать определение запроса в ODC-файл, щелкните запрос правой кнопкой мыши на боковой панели навигации Запросы и подключения и выберите Экспортировать файл подключения. Созданный ODC-файл будет содержать определение запроса со всеми зависимостями, а также инструкции по подключению к источнику данных и шаги преобразования, применяемые к данным. Кроме того, определение запроса можно экспортировать через диалоговое окно Свойства запроса, которое можно открыть, выбрав Свойства в контекстном меню запроса.

После получения ODC-файла вы сможете использовать его и импортировать определение запроса в книгу. Чтобы импортировать данные, используя механизм ODC, щелкните Данные> Существующие подключения. Откроется диалоговое окно Существующие соединения, и вы сможете выполнить импорт из доступных ODC-файлов, существующих подключений к книгам или таблиц.

Выбор из существующих подключений или запросов

Если вам необходимо создать ODC-файл, который будет использоваться в другом приложении, например Visio и Excel 2013 или более ранних версий, это можно сделать с помощью соединителей Из базы данных SQL Server, Из базы данных Microsoft Access, Из веб-канала данных ODATA, Из служб аналитики, Из Microsoft Query или устаревшего мастера подключения к данным. Важно помнить, что при использовании ODC-файлов из другого приложения это приложение будет использовать только инструкции по подключению из ODC и не будет включать шаги преобразования, которые могли содержаться в исходном запросе. Если вам нужно восстановить устаревшие соединители "Из Access", "С сервера SQL Server" и "Из веб-канала данных ODATA", см.: Как восстановить старую функцию "Получение внешних данных?"

Как управлять существующими запросами и подключениями к книгам?

Инструменты "Скачать и преобразовать" в Excel 2016 поддерживали две методологии импорта данных: В новом методе Скачать и преобразовать использовались запросы (подключения к книгам применялись в фоновом режиме для обновления и загрузки их элементов). Второй метод был устаревшим и использовал подключения к книге. Управление запросами и подключениями к книгам выполнялось отдельно. Управление запросами осуществлялось с помощью особой области "Запросы", а подключениями — в диалоговом окне "Подключения к книге". Это приводило наших клиентов в замешательство.

В этом обновлении мы решили данную проблему. Теперь можно управлять запросами и подключениями на специальной боковой панели навигации Запросы и подключения. Чтобы открыть ее, нажмите кнопку Запросы и подключения на вкладке Данные.

Область "Запросы и подключения" инструментов "Скачать и преобразовать"

Щелкнув вкладку Запросы в верхней части панели, можно просмотреть и настроить запросы в книге. Щелкните запрос правой кнопкой мыши, чтобы выполнить с ним дополнительные действия. Например, вы можете обновить данные, возвращаемые запросом из источника, скопировать и вставить запрос, изменить преобразования запроса в редакторе запросов и т. д.

Кроме того, мы упростили управление запросом и его подключением, представив новое диалоговое окно Свойства запроса. Теперь при создании запроса в книге автоматически создается объект подключения, связанный с этим запросом. В то время как задачей запроса является подключение к источнику данных и применение к ним преобразований, подключение определяет, куда загружаются данные (например, на лист или в модель данных), а также задает параметры обновления данных, возвращаемых запросом, например его частоту. В новом диалоговом окне Свойства запроса вы можете легко управлять всеми свойствами запроса, например его именем или инструкциями по преобразованию, а также свойствами подключения, например параметрами обновления. Чтобы открыть новое диалоговое окно Свойства запроса, щелкните Свойства в контекстном меню запроса на боковой панели навигации Запросы и подключения.

Вкладка Подключения в верхней части панели позволяет просматривать и настраивать старые подключения в книге, связанные с одним из таких устаревших мастеров, как Из текста, Из служб аналитики и Из Microsoft Query. Щелкните подключение правой кнопкой мыши, чтобы открыть контекстное меню. В нем вы сможете выполнить дополнительные действия, например обновить данные из источника, удалить подключение или настроить его свойства, используя хорошо знакомое диалоговое окно Свойства подключения.

Как восстановить старую функцию "Получение внешних данных?"

В новом интерфейсе "Скачать и преобразовать" доступно больше соединителей и возможностей преобразования, чем в устаревших мастерах. Однако существуют ситуации, когда может потребоваться один из старых мастеров импорта данных. Например, вам может быть нужно сохранить учетные данные для источника как часть книги. (Обратите внимание на то, что этот метод не соответствует современным стандартам безопасности и поэтому не поддерживается новыми инструментами.)

Для доступа к устаревшим соединителям можно настроить ленту. Кроме того, можно добавить старые мастеры импорта данных в раскрывающееся меню Данные > Получить данные, используя новые настройки в диалоговом окне "Параметры Excel".

Выберите Файл > Параметры > Данные > Отображение мастеров импорта данных прежних версий и выберите нужные мастеры:

Восстановление устаревших параметров "Скачать и преобразовать"

Откройте раскрывающееся меню Данные > Получить данные и запустите один из выбранных устаревших мастеров в соответствующей категории:

Параметры устаревшего меню "Скачать и преобразовать"

Дополнительные сведения об инструментах "Скачать и преобразовать"

Если вы хотите узнать больше о средствах Скачать и преобразовать, обратитесь к справке по Microsoft Power Query для Excel.

Нужна дополнительная помощь?

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×