Начало работы с SharePoint Designer 2010

Microsoft SharePoint Designer 2010 представляет собой программу для создания веб-страниц и приложений, которая используется для проектирования, разработки и настройки веб-страниц на базе SharePoint Foundation 2010 и Microsoft SharePoint Server 2010. С помощью программы SharePoint Designer 2010 можно создавать информативные веб-страницы, разрабатывать эффективные решения для поддержки рабочих процессов и настраивать внешний вид и функции сайта.

Ниже приведены ссылки на статьи, видеоматериалы и другие обучающие ресурсы, содержащие дополнительные сведения о программе SharePoint Designer 2010. Воспользуйтесь описанными ниже процедурами, чтобы узнать об основных задачах, выполняемых в программе SharePoint Designer 2010.

Эмблема "Приступая к работе"

Что требуется

Раздел

Для тех, кто хочет узнать об изменениях    

Узнайте о новых возможностях данной версии, а также о том, как извлечь из них максимальную пользу.

Новые возможности SharePoint Designer 2010

Ищете меню и команды версии 2007?    

Ознакомьтесь с таблицей команд меню и панелей инструментов версии 2007 и узнайте об их новых расположениях с помощью данного журнала сопоставлений.

Руководства по сопоставлению для приложений Microsoft Office

Впервые используете программу SharePoint Designer?    

Узнайте, для чего нужна программа SharePoint Designer 2010 и как наиболее эффективно использовать ее в своей организации.

Введение в SharePoint Designer 2010

Вам и вашим коллегам требуется обучение?    

Повысьте производительность при работе с данной версией, пройдя программу обучения работе с SharePoint Designer 2010.

Обучение Microsoft Office

Основные задачи в SharePoint Designer 2010

Открытие и сохранение сайтов SharePoint

Создание списков, библиотек и подключений к источникам данных

Создание настраиваемых представлений и форм

Создание настраиваемых рабочих процессов

Разработка страниц сайта, главных страниц и макетов страниц

Сохранение в виде шаблона

Открытие и сохранение сайтов SharePoint

В программе SharePoint Designer 2010 можно открывать существующие на сервере сайты SharePoint и настраивать их, а также создавать новые на основе шаблонов SharePoint либо новые пустые сайты, чтобы разработать их с нуля.

Открытие сайтов

Чтобы открыть существующий сайт, щелкните вкладку Файл, выберите команду Сайты, а затем выполните одно из приведенных ниже действий.

  • Чтобы просмотреть доступные сайты на данном сервере, выберите команду Открыть сайт.

  • Щелкните элемент Настроить мой сайт, чтобы открыть и настроить свой сайт.

  • В меню Последние сайты выберите сайт, над которым ранее уже выполнялась работа.

Создание сайтов

Чтобы создать сайт, щелкните вкладку Файл, выберите элемент Сайты, а затем выполните одно из перечисленных ниже действий.

  • Чтобы создать пустой сайт SharePoint, выберите команду Новый пустой веб-сайт.

  • Чтобы создать сайт в составе уже существующего, выберите команду Добавить дочерний сайт на мой сайт.

  • В разделе Шаблоны сайтов выберите шаблон SharePoint, на основе которого требуется создать сайт.

Примечание : Открыть и создать сайты можно не только в программе SharePoint Designer 2010, но и в браузере, а затем открыть его в SharePoint Designer 2010, используя ссылки, доступные в меню Действия сайта, на ленте, а также в других расположениях в SharePoint.

К началу страницы

Создание списков, библиотек и подключений к источникам данных

В программе SharePoint Designer 2010 можно создавать списки и библиотеки, которые обычно служат источниками данных для сайтов SharePoint. Кроме того, можно создавать подключения к XML-файлам, внешним базам данных и веб-службам.

Списки и библиотеки SharePoint

Чтобы создать список или библиотеку SharePoint, щелкните на панели Навигация элемент Списки и библиотеки, а затем на вкладке Списки и библиотеки выберите один из перечисленных ниже параметров.

  • Чтобы с нуля создать пустой список, выберите команду Настраиваемый список.

  • Чтобы создать список на основе шаблона списка SharePoint, выберите команду Список SharePoint.

  • Чтобы создать библиотеку на основе шаблона библиотеки SharePoint, выберите команду Библиотека документов.

  • Чтобы создать внешний список на основе внешнего типа контента, выберите команду Внешний список. (Сведения о внешних типах контента приведены ниже.)

  • Чтобы создать список на основе импортированной электронной таблицы, выберите команду Список из электронной таблицы.

Подключения к источникам данных

Чтобы создать подключение к источнику данных, щелкните на панели Навигация элемент Источники данных, а затем на вкладке Источники данных выберите один из перечисленных ниже параметров.

  • Чтобы создать подключение к нескольким источникам данных, выберите команду Связанный источник данных.

  • Чтобы создать подключение к базе данных, поддерживающей протокол OLE DB или ODBC, выберите команду Подключение к базе данных.

  • Чтобы создать подключение к веб-службе XML с помощью протокола SOAP, выберите команду Подключение службы SOAP.

  • Чтобы создать подключение к серверному скрипту с помощью службы REST, выберите команду Подключение к службе REST.

  • Чтобы создать подключение к XML-файлу источника, выберите команду Подключение к XML-файлу.

Внешние типы контента

С помощью внешних типов контента можно подключиться к внешним источникам бизнес-данных и интегрировать эти источники с сайтом SharePoint и поддерживаемыми клиентскими приложениями. После создания внешнего типа контента можно создать внешние списки, позволяющие пользователям работать с данными так, как если бы это был список или библиотека SharePoint.

Чтобы создать внешний тип контента, выполните указанные ниже действия.

  1. На панели Навигация щелкните элемент Внешние типы контента.

  2. На вкладке Внешние типы контента щелкните элемент Внешний тип контента, а затем создайте для этого внешнего типа контента операции, поля и т. д.

К началу страницы

Создание настраиваемых представлений и форм

В программе SharePoint Designer 2010 для источников данных можно создавать настраиваемые представления и формы, выполняющие функции интерфейса для чтения и записи данных в них.

Представления

Представление является динамически настраиваемым отображением источника данных, которое можно добавить на любую страницу SharePoint. В программе SharePoint Designer 2010 можно создавать представления списков (использующие веб-часть представления списка XSLT) и представления данных (использующие веб-часть формы данных). Чтобы создать представление списка или данных, выполните одно из приведенных ниже действий.

  • На панели Навигация щелкните элемент Списки и библиотеки, выберите список, для которого требуется создать представление, а затем на вкладке Параметры списка щелкните элемент Представление списка.

    Примечание : Будет создано представление, связанное со списком или библиотекой. В результате пользователи будут видеть представление и смогут настраивать его с помощью группы элементов Управление представлениями на ленте SharePoint.

  • На панели Навигация щелкните элемент Страницы сайта, измените страницу, на которой требуется создать представление, щелкните вкладку Вставка, выберите команду Представление данных, а затем выберите список или библиотеку SharePoint, которая будет использована для создания этого представления.

Формы

Форма является настраиваемым отображением источника данных, которое можно использовать для отправки или обратной записи в источник данных. В программе SharePoint Designer 2010 можно создавать формы списков и формы данных (и те, и другие используют веб-часть формы данных). Чтобы создать форму списка или данных, выполните одно из перечисленных ниже действий.

  • На панели Навигация выберите команду Списки и библиотеки, выберите список, для которого требуется создать форму, а затем на вкладке Параметры списка щелкните элемент Форма списка.

  • На панели Навигация щелкните элемент Страницы сайта, измените страницу, на которой требуется создать форму, щелкните вкладку Вставка, выберите команду Создать форму элемента, Изменить форму элемента или Отобразить форму элемента, а затем выберите источник данных, который будет использован для создания формы.

Примечание : Кроме инструментов конструктора форм, доступных в программе SharePoint Designer 2010, для создания и настройки форм SharePoint можно использовать программу Microsoft InfoPath 2010.

К началу страницы

Создание настраиваемых рабочих процессов

В программе SharePoint Designer 2010 можно управлять бизнес-процессами с помощью рабочих процессов с широкими возможностями для настройки. Рабочие процессы можно использовать для управления процессами приложений, а также процессами совместной работы пользователей. При создании рабочих процессов доступен ряд параметров.

Создание рабочих процессов в SharePoint Designer 2010

Рабочий процесс можно создать на основе списка или библиотеки SharePoint; можно создать рабочий процесс с возможностью повторного использования и применять его к любым спискам или библиотекам. Кроме того, можно создать рабочий процесс сайта, который будет работать на уровне сайта.

Чтобы создать такие рабочие процессы, щелкните на панели Навигация элемент Рабочие процессы, а затем на вкладке Рабочие процессы выполните одно из перечисленных ниже действий.

  • Выберите команду Рабочий процесс списка и выберите список, с которым требуется связать рабочий процесс.

  • Чтобы создать рабочий процесс с возможностью повторного использования, который можно связать с любым списком или библиотекой, выберите команду Рабочий процесс для повторного использования.

  • Чтобы создать рабочий процесс, который может применяться на уровне сайта, выберите команду Рабочий процесс сайта.

После создания рабочего процесса структурируйте в нем условия, действия и шаги с помощью конструктора рабочих процессов.

Импорт рабочих процессов из программы Microsoft Visio 2010

Помимо создания рабочих процессов в SharePoint Designer 2010, можно импортировать рабочий процесс, созданный в программе Microsoft Visio 2010 с помощью имеющихся в ней шаблонов и наборов элементов.

Чтобы импортировать рабочий процесс, щелкните на панели Навигация элемент Рабочие процессы, а затем на вкладке Рабочие процессы выполните указанные ниже действия.

  1. Выберите команду Импорт из Visio, а затем найдите требуемую файловую систему или библиотеку документов SharePoint для файла Visio Workflow Interchange (VWI).

  2. Свяжите рабочий процесс со списком или сделайте его процессом с возможностью повторного использования и нажмите кнопку Готово.

  3. Приступайте к настройке рабочего процесса в SharePoint Designer.

К началу страницы

Разработка страниц сайта, главных страниц и макетов страниц

В программе SharePoint Designer 2010 можно создавать и настраивать страницы сайтов, главные страницы и макеты страниц. Несмотря на то что каждый из этих видов страниц предназначен для определенной цели, способы их редактирования общие. Можно добавлять и удалять текст, изображения, ссылки, таблицы, веб-части, элементы управления сервером и т. д. Для главных страниц и макетов страниц можно применять определения и таблицы стилей с целью настройки внешнего вида и обеспечения удобства использования сайта или добавить фирменную символику, чтобы привести его в соответствие с корпоративным стилем.

Страницы сайта

Чтобы создать страницу сайта, щелкните на панели Навигация элемент Страницы сайта, а затем на вкладке Страницы выполните одно из перечисленных ниже действий.

  • Выберите команду Страница «Веб-части», чтобы создать страницу, имеющую веб-части заголовка и основной зоны и, кроме того, связанную с главной страницей сайта.

  • Чтобы создать пустую страницу сайта, не связанную с главной страницей, выберите команду Страница, а затем — пункт ASPX или HTML.

Главные страницы

  • На панели Навигация щелкните элемент Главные страницы, а затем на вкладке Главные страницы щелкните элемент Пустая главная страница.

Макеты страниц

  • На панели Навигация щелкните элемент Макеты страниц, а затем на вкладке Макеты страниц щелкните элемент Новый макет страницы и выберите группу типов контента и имя, на основе которых будет создан макет страницы.

Примечание : По умолчанию главные страницы и макеты страниц отключены для всех пользователей, кроме администраторов семейства сайтов. Если в программе SharePoint Designer 2010 недоступен параметр для просмотра или изменения главных страниц или макетов страниц, обратитесь к администратору сайта с просьбой о включении этих параметров.

К началу страницы

Сохранение объекта как шаблона

По завершении настройки сайта можно сохранить сайт или его параметры как шаблон, чтобы другие сотрудники организации могли использовать этот шаблон для создания списков, представлений, рабочих процессов, страниц сайтов и т. д.

Кроме того, шаблон можно использовать в будущем для настройки сайта в другой среде или при помощи других пользователей, например в браузере или в программе Microsoft Visual Studio.

Найдите команду Сохранить как шаблон в программе SharePoint Designer 2010, чтобы воспользоваться преимуществами этих функций.

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×