НЕ (функция НЕ)

Используйте логическую функциюНЕ, если вы хотите убедиться, что одно значение не равно другому.

Пример

Примеры использования НЕ для изменения значения на противоположное.  Например: =НЕ(1+1=2)

Функция НЕ меняет значение своего аргумента на обратное.

Обычно функция НЕ используется для расширения возможностей других функций, выполняющих логическую проверку. Например, функция ЕСЛИ выполняет логическую проверку и возвращает одно значение, если при проверке получается значение ИСТИНА, и другое значение, если при проверке получается значение ЛОЖЬ. Использование функции НЕ в качестве аргумента "лог_выражение" функции ЕСЛИ позволяет проверять несколько различных условий вместо одного.

Синтаксис

НЕ(логическое_значение)

Аргументы функции НЕ описаны ниже.

  • Логическое_значение    Обязательный. Значение или выражение, принимающее значение ИСТИНА или ЛОЖЬ.

Примечания

Если аргумент "логическое_значение" имеет значение ЛОЖЬ, функция НЕ возвращает значение ИСТИНА; если он имеет значение ИСТИНА, функция НЕ возвращает значение ЛОЖЬ.

Примеры

Ниже представлено несколько общих примеров использования функции НЕ как отдельно, так и в сочетании с функциями ЕСЛИ, И и ИЛИ.

Примеры использования НЕ с функциями ЕСЛИ, И и ИЛИ


Формула

Описание

=НЕ(A2>100)

A2 НЕ больше 100

=ЕСЛИ(И(НЕ(A2>1);НЕ(A2<100));A2;"Значение вне допустимого диапазона.")

50 больше 1 (ИСТИНА) И меньше 100 (ИСТИНА), поэтому НЕ изменяет оба аргумента на ЛОЖЬ. Для И требуется, чтобы оба аргумента имели значение ИСТИНА, поэтому возвращается результат ЛОЖЬ.

=ЕСЛИ(ИЛИ(НЕ(A3<0);НЕ(A3>50)); A3; "Значение вне интервала.")

100 не меньше 0 (ЛОЖЬ) и больше чем 50 (ИСТИНА), поэтому НЕ меняет значения на ИСТИНА и ЛОЖЬ. Для ИЛИ требуется, чтобы один аргумент имел значение ИСТИНА, поэтому возвращается результат ИСТИНА.

Расчет комиссионных

Ниже приводится решение довольно распространенной задачи: с помощью функций НЕ, ЕСЛИ и И определяется, заработал ли торговый сотрудник премию.

Пример вычисления премии с продаж при помощи функций ЕСЛИ, И и НЕ.  Формула в ячейке E14: "=ЕСЛИ(И(НЕ(B14<$B$7);НЕ(C14<$B$5));B14*$B$8;0)"
  • =ЕСЛИ(И(НЕ(B14<$B$7);НЕ(C14<$B$5));B14*$B$6;0)ЕСЛИ общие продажи НЕ меньше целевых И число договоров НЕ меньше целевого, общие продажи умножаются на процент премии. В противном случае возвращается значение 0.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Видео: расширенное применение функции ЕСЛИ

Использование вложенных функций в формуле

Функция ЕСЛИ

Функция И

Функция ИЛИ

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах в Excel 2016

Сочетания клавиш в Excel 2016 для Windows

Сочетания клавиш в Excel 2016 для Mac

Логические функции (справка)

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×