Макет элементов интерфейса Windows XP

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью шаблона Интерфейс пользователя Windows XP создаются макеты пользовательских интерфейсов с фигурами, разработанными в соответствии с руководствами Microsoft Windows XP. Фигуры включают элементы, часто используемые в интерфейсах, например пустую форму для основы окна приложения, страницы мастера, фигуры панели инструментов и меню, фигуры элементов управления.

Чтобы все элементы из макет окна сложного приложения или диалоговое окно со вкладками простое окно сообщения или одну кнопку можно использовать эти фигуры.

Предполагаемое действие

Создание отдельного диалогового окна

Создание диалогового окна с вкладками

Создание окна приложения

Создание панелей инструментов и меню

Создание отдельного диалогового окна

  1. Из набора элементов Окна и диалоговые окна перетащите на страницу документа фигуру Пустая форма.

  2. Выделив фигуру, введите заголовок для диалогового окна.

  3. Перетащите фигуру Кнопки Windows в правую часть заголовка и выберите тип кнопки. Обычно представлены кнопки «Справка» и «Закрыть», расположенные слева направо.

  4. В нижний правый угол фигуры Пустая форма добавьте кнопки команд, например ОК, Отмена и Применить.

    how

    1. Из набора элементов Общие элементы управления перетащите фигуры Кнопка в нижнюю правую часть фигуры Пустая форма.

    2. Выделите каждую кнопку и введите имя элемента управления.

  5. Перетащите соответствующие элементы управления в фигуру Пустая форма. Щелкните правой кнопкой мыши фигуры, чтобы выбрать соответствующие параметры.

    Чтобы получить справочные сведения об определенной фигуре элемента управления, щелкните правой кнопкой мыши эту фигуру и нажмите кнопку Справка.

    Если собственный текст в фигуре Пустая форма создается с помощью инструмента Текст, отформатируйте текст, используя шрифт «Tahoma» и размер шрифта, равный 8 пунктам.

  6. Объедините команды в логические группы.

  7. Чтобы визуально разделить группы, перетащите фигуры Группа и Линия группы на фигуру Пустая форма.

    Для выравнивания элементов управления воспользуйтесь направляющими.

    Диалоговое окно Печать, расположенное под меню Файл, является хорошим примером диалогового окна, в котором представлено большинство наиболее общих элементов управления.

К началу страницы

Создание диалогового окна с вкладками

  1. Из набора элементов Окна и диалоговые окна перетащите на страницу документа фигуру Пустая форма.

  2. Выделив фигуру, введите заголовок для диалогового окна.

  3. Перетащите фигуру Кнопки Windows в правую часть заголовка и выберите тип кнопки. Обычно представлены кнопки Справка и Закрыть, расположенные слева направо.

  4. В нижний правый угол фигуры Пустая форма добавьте кнопки команд, например ОК, Отмена и Применить.

    how

    1. Из набора элементов Общие элементы управления перетащите фигуры Кнопка в нижнюю правую часть фигуры Пустая форма.

    2. Выделите каждую кнопку и введите имя элемента управления.

  5. Перетащите фигуру Начальная вкладка на фигуру Пустая форма и приведите ее размер в соответствие с внутренним размером формы, оставив место для вкладок.

  6. Перетащите фигуру Дополнительные вкладки и приклейте ее к верхней части фигуры Начальная вкладка.

  7. Выделив фигуру Дополнительные вкладки, введите имя вкладки.

  8. Повторяйте шаги 6 и 7 для каждой вкладки, приклеивая вкладки друг к другу таким же образом, как и к фигуре Начальная вкладка.

  9. Щелкните правой кнопкой мыши вкладку, которую требуется отобразить на переднем плане, выберите команду Отображаемая вкладка, а для других вкладок выберите параметр Скрытая вкладка.

  10. Перетащите соответствующие элементы управления в фигуру Пустая форма. Щелкните правой кнопкой мыши фигуры, чтобы выбрать соответствующие параметры.

    Чтобы получить справочные сведения об определенной фигуре элемента управления, щелкните правой кнопкой мыши эту фигуру и нажмите кнопку Справка.

    Если собственный текст в фигуре Пустая форма создается с помощью инструмента Текст, отформатируйте текст, используя шрифт «Tahoma» и размер шрифта, равный 8 пунктам.

  11. Объедините команды в логические группы.

  12. Чтобы визуально разделить группы, перетащите фигуры Группа и Линия группы на фигуру Пустая форма.

    Для выравнивания элементов управления воспользуйтесь направляющими.

    Диалоговое окно Параметры страницы, расположенное под меню Файл, является хорошим примером диалогового окна, в котором представлено большинство наиболее общих элементов управления.

К началу страницы

Создание окна приложения

  1. Из набора элементов Окна и диалоговые окна перетащите на страницу документа фигуру Пустая форма.

  2. Выделив фигуру, введите заголовок для окна приложения.

  3. Чтобы в строку заголовка слева от текста добавить значок, щелкните правой кнопкой мыши фигуру Пустая форма и установите флажок Место для значка.

  4. Перетащите фигуру Кнопки Windows в правую часть заголовка и выберите тип кнопки. Имеется три кнопки, расположенные справа налево: Свернуть, Развернуть или Восстановить и Закрыть.

  5. Из набора элементов Панели инструментов и меню перетащите фигуру Строка меню на фигуру Пустая форма, приклейте ее к нижней части заголовка, а затем добавьте элементы меню.

    how

    1. Перетащите фигуру Пункт главного меню на страницу и приклейте ее к левому краю фигуры Строка меню.

      Слева от первого элемента меню можно расположить значок.

    2. Выделив фигуру, введите имя. Если элементу меню назначено сочетание клавиш, подчеркните соответствующую букву.

    3. При необходимости повторите шаги 1 и 2.

      Чтобы получить справочные сведения о фигуре, щелкните ее правой кнопкой мыши, а затем выберите команду Справка.

      Чтобы скрыть точки соединения Изображение точки соединения — синий значок «X» , в меню Вид выберите команду Точки соединения.

      Ширина всех элементов столбца должна соответствовать самому широкому элементу.

    Чтобы отобразить точки захвата с левой стороны строки меню, щелкните правой кнопкой мыши фигуру и снимите флажок Закрепить строку меню.

  6. Из набора элементов Панели инструментов и меню перетащите фигуру Панель инструментов на фигуру Пустая форма, приклейте ее к нижней части строки меню, а затем добавьте кнопки панели инструментов.

    how

    1. Перетащите одну из фигур Кнопки панели инструментов на страницу и приклейте ее к левому краю фигуры Панель инструментов.

    2. В диалоговом окне Данные фигуры выберите нужный тип кнопки. Если позднее кнопку потребуется изменить, щелкните правой кнопкой мыши фигуру и выберите команду Тип кнопки, чтобы открыть диалоговое окно Данные фигуры.

    3. При необходимости перетащите дополнительные фигуры Кнопки панели инструментов и Разделитель кнопок и приклейте их друг к другу.

      Чтобы получить справочные сведения о фигуре, щелкните ее правой кнопкой мыши, а затем выберите команду Справка.

      Чтобы скрыть точки соединения Изображение точки соединения — синий значок «X» , в меню Вид выберите команду Точки соединения.

    Чтобы отобразить точки захвата с левой стороны панели инструментов, щелкните правой кнопкой мыши фигуру и снимите флажок Закрепить панель инструментов.

  7. Из набора элементов Общие элементы управления при необходимости перетащите горизонтальные и вертикальные полосы прокрутки вправо или вниз фигуры Пустая форма.

  8. Щелкните правой кнопкой мыши полосы прокрутки и выберите команду Размер бегунка, чтобы указать, насколько можно прокрутить сведения в окне.

    Чтобы задать отображение меньшей части документа, установите небольшой размер ползунка. Чтобы задать отображение большей части документа, установите большой размер ползунка.

  9. Перетащите фигуру Строка состояния в нижнюю часть окна приложения и выполните соответствующее форматирование.

    how

    1. Перетащите фигуру Разделитель строки состояния на страницу документа и приклейте ее к управляющему маркеру Управляющий маркер фигуры Строка состояния.

      Управляющие маркеры предоставляют пространство для приклеивания фигуры Разделитель строки состояния к фигуре Строка состоянияили к другой фигуре Разделитель строки состояния.

      Если фигура Разделитель строки состояния не отображается после ее приклеивания к фигуре Строка состояния, выделите фигуру Строка состояния, в меню Фигура выберите команду Порядок, а затем — команду Переместить назад.

    2. Перетащите фигуру Маркер изменения размеров окна к правому краю индикатора состояния, чтобы указать, что в данный момент размер окна можно изменить.

К началу страницы

Создание панелей инструментов и меню

Фигуры Windows XP можно использовать для создания основных меню, раскрывающихся меню и панелей инструментов.

Создание меню

  1. Из набора элементов Панели инструментов и меню перетащите на страницу документа фигуру Строка меню. Чтобы отобразить точки захвата с левой стороны строки меню, щелкните правой кнопкой мыши эту фигуру и снимите флажок Закрепить строку меню.

  2. Перетащите фигуру Пункт главного меню и приклейте ее к левому краю фигуры Строка меню.

    Совет : Слева от первого элемента меню можно расположить значок.

  3. Выделив фигуру, введите имя. Если элементу меню назначено сочетание клавиш, подчеркните соответствующую букву.

  4. При необходимости повторите шаги 2 и 3.

    Чтобы получить справочные сведения о фигуре, щелкните ее правой кнопкой мыши, а затем выберите команду Справка.

    Чтобы скрыть точки соединения Изображение точки соединения — синий значок «X» , в меню Вид выберите команду Точки соединения.

    Ширина всех элементов столбца должна соответствовать самому широкому элементу.

Создание раскрывающегося меню

  1. Перетащите фигуру Пункт главного меню на страницу документа.

  2. Выделив фигуру, введите имя. Если элементу меню назначено сочетание клавиш, подчеркните соответствующую букву.

  3. Перетащите фигуру Пункт раскрывающегося меню, приклейте ее к нижней части фигуры Пункт главного меню и введите имя.

  4. Повторите шаг 3 для всех элементов раскрывающегося меню в столбце.

  5. Измените размер всех фигур Пункт раскрывающегося меню в соответствии с шириной самой широкой фигуры.

  6. Щелкните правой кнопкой мыши каждую фигуру Пункт раскрывающегося меню, выберите команду Свойства пункта меню и соответствующие параметры.

    Чтобы получить справочные сведения о фигуре, щелкните ее правой кнопкой мыши, а затем выберите команду Справка.

    Чтобы скрыть точки соединения Изображение точки соединения — синий значок «X» , в меню Вид выберите команду Точки соединения.

Создание панели инструментов

  1. Из набора элементов Панели инструментов и меню перетащите на страницу документа фигуру Панель инструментов. Чтобы отобразить точки захвата с левой стороны панели инструментов, щелкните правой кнопкой мыши фигуру и снимите флажок Закрепить панель инструментов.

  2. Перетащите фигуру Кнопки панели инструментов и приклейте ее к левому краю фигуры Панель инструментов.

  3. В диалоговом окне Данные фигуры выберите нужный тип кнопки. Если позднее кнопку потребуется изменить, щелкните правой кнопкой мыши фигуру и выберите команду Тип кнопки, чтобы открыть диалоговое окно Данные фигуры.

  4. При необходимости перетащите дополнительные фигуры Кнопки панели управления и Разделитель кнопки и приклейте их друг к другу.

    Чтобы получить справочные сведения о фигуре, щелкните ее правой кнопкой мыши, а затем выберите команду Справка.

    Чтобы скрыть точки соединения Изображение точки соединения — синий значок «X» , в меню Вид выберите команду Точки соединения.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×