Копирование формулы путем перетаскивания маркера заполнения в Excel 2016 для Mac

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью маркера заполнения можно быстро копировать формулы в смежные ячейки.

Маркер заполнения

При перетаскивании маркера в другие ячейки Excel показывает разные результаты для каждой ячейки.

Копирование формулы с помощью маркера заполнения

  1. Выделите ячейку, которая содержит формулу для заполнения смежных ячеек.

  2. Поместите курсор в правый нижний угол, чтобы он принял вид знака плюс (+). Например:

    Курсор на маркере заполнения

  3. Перетащите маркер заполнения вниз, вверх или по ячейкам, которые нужно заполнить. В этом примере мы перетаскиваем маркер заполнения вниз.

    Курсор, перетаскивающий вниз маркер заполнения

  4. Когда вы отпустите маркер, формула будет автоматически применена к другим ячейкам.

    Показаны значения для заполненных ячеек

  5. Чтобы изменить способ заполнения ячеек, нажмите кнопку Параметры автозаполнения  Кнопка "Параметры автозаполнения" , которая появляется после перетаскивания, и выберите нужный вариант.

Дополнительные сведения о копировании формул см. в статье Копирование и вставка формулы в другую ячейку или на другой лист.

Советы : 

  • Можно также нажать клавиши CONTROL+D, чтобы заполнить формулой ячейки вниз по столбцу. Выделите ячейку с нужной формулой, а затем выделите ячейки под ней и нажмите клавиши CONTROL+D.

  • Можно также нажать клавиши CONTROL+R, чтобы заполнить формулой ячейки вправо по строке. Выделите ячейку с нужной формулой, а затем выделите ячейки справа от нее и нажмите клавиши CONTROL+R.

Если заполнение не работает

Иногда заполнение ячеек не работает так, как вы ожидаете. Поэтому важно проверить ссылки на ячейки в первой ячейке.

Ссылки на ячейки — это просто указатели на другие ячейки. Например, пусть первая ячейка содержит такую формулу:


=СУММ(A1;B1)


A1 и B1 — относительные ссылки. Это значит, что при заполнении формулы вниз по ячейкам ссылки будут пошагово изменяться с A1; B1 на A2; B2 и т. д. Например:

=СУММ(A1;B1)

=СУММ(A2;B2)

=СУММ(A3;B3)

Бывают случаи, когда вам не нужно, чтобы ссылки на другие ячейки изменялись. Например, вы хотите, чтобы первая ссылка A1 оставалась фиксированной, а B1 изменялась при перетаскивании маркера заполнения. В этом случае необходимо в первой ссылке ввести знаки доллара, например: =СУММ($A$1;B1). Знаки доллара вынуждают Excel сохранять ссылку на A1 при заполнении других ячеек. Это может выглядеть таким образом:

=СУММ($A$1;B1)

=СУММ($A$1;B2)

=СУММ($A$1;B3)

Ссылки со знаками доллара ($) называются абсолютными. При заполнении ячеек вниз ссылка на A1 остается фиксированной, но ссылку B1 приложение Excel изменяет на B2 и B3.

Есть проблемы с отображением маркера заполнения?

Если маркер не отображается, возможно, он скрыт. Чтобы отобразить его, выполните указанные ниже действия.

  1. В меню Excel выберите пункт Параметры.

  2. Щелкните Правка.

  3. В разделе Параметры правки установите флажок Включить маркер заполнения и перетаскивание ячеек.

Если в книге не включено автоматическое вычисление, результаты формул не будут обновляться при заполнении ячеек. При необходимости его можно включить следующим образом:

  1. В меню Excel выберите пункт Параметры.

  2. Щелкните Вычисление.

  3. В разделе Параметры вычисления должен быть выбран параметр Автоматически.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×