Как исправить ошибки в формулах в Excel 2016 для Mac

Будь то ошибки #ЗНАЧ!, #ИМЯ! или проблема с функцией ВПР, указанные ниже сведения помогут вам устранить неполадки.

ВПР

Если при использовании функции ВПР возникают ошибки или неожиданные результаты, скачайте краткий справочник по устранению неполадок с функцией ВПР.

Ошибка #ЗНАЧ!

Эта проблема обычно связана с наличием числовых и текстовых значений. Дополнительные сведения см. в разделе Исправление ошибки #ЗНАЧ!.

Ошибка #ИМЯ!

Убедитесь в том, что вы правильно ввели имена, что текст заключен в кавычки, а имена листов — в одиночные кавычки ('). О других причинах ошибки и способах ее устранения можно узнать из раздела Ошибка #ЗНАЧ!.

Ошибка #ЧИСЛО!

Эта ошибка может возникнуть, если вы ввели лишние символы в формуле. Например, не вводите в формуле 1000 р. Вместо этого нужно вводить 1000. О других причинах ошибки и способах ее устранения можно узнать из раздела Ошибка #ЧИСЛО!.

Ошибка #Н/Д

Когда формула не может найти значение, на которую указывает ссылка, возвращается ошибка #Н/Д. Дополнительные сведения см. в разделе Исправление ошибки #Н/Д.

Ошибка #ССЫЛКА!

Эта ошибка возникает в Excel, если формула содержит недопустимую ссылку на ячейку. Дополнительные сведения см. в разделе Исправление ошибки #ССЫЛКА!.

Ошибка #ДЕЛ/0!

Эта ошибка возникает, когда число делится на ноль (0) или если формула ссылается на пустую ячейку или ячейку, содержащую 0. Дополнительные сведения см. в разделе Ошибка #ДЕЛ/0!.

Ссылки на другие листы и книги

Если вам нужно указать ссылку на другой лист, введите ! после его имени, а затем — координаты ячейки или диапазона ячеек. Если имя листа содержит пробелы, заключите его в апострофы. Например: =СУММ('отчет о продажах'!A1:A8).

Если вы указываете ссылку на другую внешнюю книгу,

  • заключите имя книги в квадратные скобки ([]).

  • Затем введите полный путь к файлу.

  • Заключите его в апострофы (в начале пути и после имени листа перед восклицательным знаком).

    Например: =СУММ('/Пользователи/ваше_имя/Рабочий_стол/[Q2 Operations.xlsx]Продажи'!A1:A8).

Другие простые способы устранения проблем

  • Начинайте ввод формул со знака равенства (=). Пример: =СУММ(A1:A8)

  • Для умножения чисел используйте символ *, а не X. Пример: =A1*A8

  • Следите за соответствием открывающих и закрывающих скобок, чтобы они были парными. В этом примере две пары: =ЕСЛИ(40>50;СУММ(G2:G5);0)

  • Введите все обязательные аргументы. В этом вам поможет построитель формул. Начните вводить формулу с имени функции и нажмите сочетание клавиш CONTROL+A, чтобы открыть построитель формул.

  • Текст в формулах следует заключать в кавычки. Пример: =ЕСЛИ(A2>B2;"Превышение бюджета";"ОК")

  • Измените тип данных для ячейки, на которую дана ссылка. Нажмите COMMAND +1, а затем выберите параметр Числовой.

Примечания : 

  • Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

  • Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала. Вместе с другими участниками сообщества Майкрософт вы можете улучшить эту статью с помощью Community Translation Framework (CTF). Просто наведите указатель мыши на предложение в статье и выберите команду "УЛУЧШИТЬ ПЕРЕВОД" в мини-приложении CTF. Для получения дополнительных сведений о CTF щелкните здесь. Используя CTF, вы соглашаетесь с нашими условиями предоставления услуг.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×