Как использовать вычисляемые столбцы в таблице Excel

Как использовать вычисляемые столбцы в таблице Excel

Вычисляемые столбцы в таблицах Excel упрощают ввод формул. Формула, введенная в одну ячейку столбца, автоматически распространяется на его остальную часть. При этом не приходится использовать заполнение или копирование. Это позволяет сэкономить время, особенно при наличии множества строк. То же самое происходит при изменении формулы: изменение также распространяется на все остальные ячейки вычисляемого столбца.

Примечание : Снимки экрана в этой статье получены в Excel 2016. Если вы используете другую версию, интерфейс может немного отличаться, но функции будут такими же.

Создание вычисляемого столбца

  1. Создайте таблицу. Если вы не знакомы с таблицами Excel, см. статью Общие сведения о таблицах Excel.

  2. Вставьте в таблицу новый столбец. Введите данные в столбец справа от таблицы, и Excel автоматически расширит ее. В этом примере мы создали новый столбец, введя "Итог" в ячейке D1.

    Добавление нового столбца путем ввода данных в пустой столбец справа от существующей таблицы

    Советы : 

    • Вы также можете добавить столбец на вкладке Главная. Просто щелкните стрелку на кнопке Вставить и выберите команду Вставить столбцы таблицы слева.

    • Чтобы добавить столбец, на вкладке "Главная" щелкните стрелку на кнопке "Вставить" и выберите команду "Вставить столбцы таблицы слева".

  3. Введите нужную формулу и нажмите клавишу ВВОД.

    Добавление формулы в ячейку таблицы, которая будет автоматически заполнена в других ячейках для создания вычисляемого столбца

    В этом случае мы ввели =СУММ(, а затем выбрали столбцы Кв1 и Кв2. В результате Excel создал следующую формулу: =СУММ(Таблица1[@[Кв1]:[Кв2]]). Такие формулы называются формулами со структурированными ссылками, и их можно использовать только в таблицах Excel. Структурированные ссылки позволяют использовать одну и ту же формулу в каждой строке. Обычная формула Excel выглядела бы как =СУММ(B2:C2), и ее было бы необходимо добавить в остальные ячейки путем копирования и вставки или заполнения.

    Дополнительные сведения о структурированных ссылках см. в статье Использование структурированных ссылок в таблицах Excel.

  4. При нажатии клавиши ВВОД формула будет автоматически применена ко всем ячейкам столбца, которые находятся сверху и снизу от активной ячейки. Для каждой строки используется одна и та же формула, но поскольку это структурированная ссылка, Excel знает, на что она ссылается в каждой строке.

    Пример формулы, которая использовалась для создания вычисляемого столбца в таблице

Примечания : 

  • При копировании формулы во все ячейки пустого столбца или заполнении его формулой он также становится вычисляемым.

  • Если ввести или переместить формулу в столбец, уже содержащий данные, это не приведет к автоматическому созданию вычисляемого столбца. Однако отобразится кнопка Параметры автозамены, с помощью которой можно перезаписать данные и создать вычисляемый столбец.

    Команда для перезаписи существующих формул в вычисляемом столбце, когда одна формула отличается от остальных

  • При вводе новой формулы, которая отличается от существующих в вычисляемом столбце, она будет автоматически применена к столбцу. Вы можете отменить обновление и оставить только одну новую формулу, используя кнопку Параметры автозамены. Обычно не рекомендуется этого делать, так как столбец может прекратить автоматически обновляться из-за того, что при добавлении новых строк будет неясно, какую формулу нужно к ним применять.

    Команда для отмены вычисляемого столбца после ввода формулы

  • Если вы ввели или скопировали формулу в ячейку пустого столбца и не хотите использовать новый вычисляемый столбец, нажмите Отменить Изображение кнопки два раза. Вы также можете дважды нажать клавиши CTRL+Z.

В вычисляемый столбец можно включать формулы, отличающиеся от формулы столбца. Ячейки с такими формулами становятся исключениями и выделяются в таблице. Это позволяет выявлять и устранять несоответствия, возникшие по ошибке.

Уведомление о несогласованной формуле в таблице Excel

Примечание : Исключения вычисляемого столбца возникают в результате следующих операций.

  • При вводе в ячейку вычисляемого столбца данных, отличных от формулы.

  • Ввод формулы в ячейку вычисляемого столбца и нажатие кнопки Отменить Изображение кнопки на панели быстрого доступа.

  • Ввод новой формулы в вычисляемый столбец, который уже содержит одно или несколько исключений.

  • При копировании в вычисляемый столбец данных, которые не соответствуют формуле вычисляемого столбца.

    Примечание : Если скопированные данные содержат формулу, она заменяет данные в вычисляемом столбце.

  • При удалении формулы из одной или нескольких ячеек вычисляемого столбца.

    Примечание : В этом случае исключение не помечается.

  • При удалении или перемещении ячейки в другую область листа, на которую ссылается одна из строк вычисляемого столбца.

Уведомление об ошибке отображается только в том случае, если включена фоновая проверка ошибок. Если вы не видите сообщение об ошибке, откройте Файл > Параметры > Формулы и убедитесь, что флажок Включить фоновую проверку ошибок установлен.

  • Если вы используете Excel 2007, нажмите кнопку Office Кнопка Office 2007 и выберите Параметры Excel > Формулы.

  • Если вы используете Mac, в строке меню Excel выберите Параметры > Формулы и списки > Поиск ошибок.

Параметр автоматического заполнения формул для создания вычисляемых столбцов в таблице Excel по умолчанию включен. Если не нужно, чтобы приложение Excel создавало вычисляемые столбцы при вводе формул в столбцы таблицы, можно выключить параметр заполнения формул. Если вы не хотите выключать этот параметр, но не всегда при работе с таблицей хотите создавать вычисляемые столбцы, в этом случае можно прекратить автоматическое создание вычисляемых столбцов.

  • Включение и выключение вычисляемых столбцов

    1. На вкладке Файл нажмите кнопку Параметры.

      Если вы используете Excel 2007, нажмите кнопку Office Кнопка Office 2007 и выберите Параметры Excel.

    2. Выберите категорию Правописание.

    3. В разделе Параметры автозамены нажмите кнопку Параметры автозамены

    4. Откройте вкладку Автоформат при вводе.

    5. В разделе Автоматически в ходе работы установите или снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы включить или выключить этот параметр.

      Отключите вычисляемые столбцы путем выбора параметров "Файл" > "Средства проверки правописания" > "Параметры автозамены" и снятия флажка "Создать вычисляемые столбцы, заполнив таблицы формулами".

      Совет :  Вы можете также щелкнуть кнопку Параметры автозамены, которая отобразится в столбце таблицы после ввода формулы. Нажмите кнопку Параметры автозамены, а затем снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы отключить этот параметр.

    Если вы используете Mac, выберите Excel в главном меню, а затем щелкните Параметры > Формулы и списки > Таблицы и фильтры > Автоматически заполнять формулы.

  • Прекращение автоматического создания вычисляемых столбцов

    После ввода в столбец таблицы первой формулы нажмите отобразившуюся кнопку Параметры автозамены, а затем выберите Не создавать вычисляемые столбцы автоматически.

Вычисляемые поля можно также создавать в сводных таблицах. При этом Excel будет применять созданную формулу ко всему столбцу. Подробнее о вычислении значений в сводных таблицах...

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Общие сведения о таблицах Excel

Форматирование таблицы Excel

Изменение размера таблицы путем добавления или удаления строк и столбцов

Данные итогов в таблице Excel

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×