Как вычислять среднее значение ряда чисел

Как вычислять среднее значение ряда чисел

Рассмотрим ситуацию, когда необходимо найти среднее количество дней для выполнения этапа работ в проекте или вычислить среднюю температуру в определенный день за 10 лет. Существует несколько способов вычисления среднего значения для ряда чисел.

Функция СРЗНАЧ вычисляет центральную тенденцию, представляющую собой место в центре ряда чисел в статистическом распределении. Далее перечислены наиболее общие характеристики центральной тенденции.

  • Среднее значение     — это значение, которое является средним арифметическим, т. е. вычисляется сложением набора чисел с последующим делением полученной суммы на их количество. Например, средним значением для чисел 2, 3, 3, 5, 7 и 10 будет 5 (результат деления суммы этих чисел, равной 30, на их количество, равное 6).

  • Медиана     — число, которое является серединой множества чисел: половина чисел имеют значения большие, чем медиана, а половина чисел — меньшие. Например, медианой для чисел 2, 3, 3, 5, 7 и 10 будет 4.

  • Мода     — число, наиболее часто встречающееся в данном множестве чисел. Например, модой для чисел 2, 3, 3, 5, 7 и 10 будет 3.

При симметричном распределении множества чисел все три значения центральной тенденции будут совпадать. При смещенном распределении множества чисел значения могут быть разными.

Вычисление среднего значения ячеек, расположенных непрерывно в одной строке или одном столбце

  1. Выделите ячейку снизу или справа от чисел, среднее значение которых требуется найти.

  2. На вкладке Главная в группе Редактирование щелкните стрелку рядом с кнопкой Изображение кнопки Автосумма, выберите пункт Среднее, а затем нажмите клавишу ВВОД.

Вычисление среднего значения ячеек, расположенных вразброс

Для выполнения этой задачи используйте функцию СРЗНАЧ.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание : Не выделяйте заголовки строк и столбцов.

    Выделение примера из справки

    Выделение примера из справки

  3. Нажмите клавиши CTRL+C

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

  5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

1

2

3

4

5

6

7

A

Данные

10

7

9

27

0

4

Формула

Описание (результат)

=СРЗНАЧ(A2:A7)

Вычисление среднего значения всех чисел списка (9,5)

=СРЗНАЧ(A2:A4;A7)

Вычисление среднего значения трех первых и последнего чисел списка (7,5)

=СРЗНАЧ(A2:A7;"<>0")

Вычисление среднего значения всех чисел списка, кроме нулевых, таких как в ячейке A6 (11,4)

Вычисление среднего взвешенного значения

Для выполнения этой задачи используйте функции СУММПРОИЗВ и СУММ.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание : Не выделяйте заголовки строк и столбцов.

    Выделение примера из справки

    Выделение примера из справки

  3. Нажмите клавиши CTRL+C

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

  5. Для переключения между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите сочетание клавиш CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости нажмите кнопку Показать формулы.

Данный пример вычисляет среднюю цену, уплаченную за единицу товара, в ходе трех покупок, когда приобреталось различное количество товара по различным ценам за единицу товара.

1

2

3

4

A

B

Цена единицы товара

Количество единиц товара

20

500

25

750

35

200

Формула

Описание (результат)

=СУММПРОИЗВ(A2:A4;B2:B4)/СУММ(B2:B4)

Деление общей стоимости всех трех покупок на общее количество приобретенных единиц товара (24,66)

Вычисление среднего значения всех чисел, кроме нулевых (0)

Для выполнения этой задачи используйте функции СРЗНАЧ и ЕСЛИ.

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Создайте пустую книгу или лист.

  2. Выделите пример в разделе справки.

    Примечание : Не выделяйте заголовки строк и столбцов.

    Выделение примера из справки

    Выделение примера из справки

  3. Нажмите клавиши CTRL+C

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

  5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

1

2

3

4

5

6

7

A

Данные

10

7

9

27

0

4

Формула

Описание (результат)

=СРЗНАЧЕСЛИ(A2:A7;"<>0")

Вычисление среднего значения всех чисел списка, кроме нулевых, таких как в ячейке A6 (11,4)

См. также

СРЗНАЧ

СРЗНАЧЕСЛИ

СУММ

СУММПРОИЗВ

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×