Исправление ошибки #ССЫЛКА!

Исправление ошибки #ССЫЛКА!

Ошибка #ССЫЛКА! указывает на то, что формула ссылается на недопустимую ячейку. Чаще всего это происходит потому, что формула ссылается на ячейки, которые были удалены или заменены другими данными.

Пример ошибки #ССЫЛКА! из-за удаления столбца

В следующем примере в столбце E используется формула =СУММ(B2;C2;D2).

Если в формуле используются явные ссылки на ячейки, например =СУММ(B2;C2;D2), то удаление столбца может вызывать ошибку #ССЫЛКА!.

Если удалить столбец B, C или D, произойдет ошибка #ССЫЛКА!. В этом случае мы удалим столбец C ("Продажи за 2007 г."), и формула теперь будет иметь вид =СУММ(B2;#ССЫЛКА!;C2). Если при использовании подобных явных ссылок на ячейки (то есть ссылок на отдельные ячейки через точку с запятой) удалить строку или столбец, на которые указывает ссылка, программе Excel не удастся исправить эту проблему и она вернет ошибку #ССЫЛКА!. Это главная причина, по которой использовать явные ссылки на ячейки в функциях не рекомендуется.

Пример ошибки #ССЫЛКА! из-за удаления столбца.

Решение

  • Если вы случайно удалили строки или столбцы, вы можете немедленно нажать кнопку "Отменить" на панели быстрого доступа (или нажать клавиши CTRL+Z), чтобы восстановить их.

  • Измените формулу так, чтобы она ссылалась на диапазон, а не на отдельные ячейки, например =СУММ(B2:D2). Теперь можно удалить любой столбец в диапазоне суммирования, и Excel автоматически скорректирует формулу. Чтобы вычислить сумму значений в строках, также можно использовать формулу =СУММ(B2:B5).

Пример функции ВПР с неправильными ссылками на диапазоны

В следующем примере функция =ВПР(A8;A2:D5;5;ЛОЖЬ) вернет ошибку #ССЫЛКА!, так как она выполняет поиск возвращаемого значения в столбце 5, но указан диапазон A:D, который содержит только 4 столбца.

Пример формулы ВПР с неправильным диапазоном.  Формула имеет вид =ВПР(A8;A2:D5;5;ЛОЖЬ).  Пятого столбца в диапазоне ВПР нет, поэтому значение 5 вызывает ошибку #ССЫЛКА!.

Решение

Расширьте диапазон или уменьшите значение столбца для поиска так, чтобы он попадал в указанный диапазон. Формулы =ВПР(A8;A2:E5;5;ЛОЖЬ) будет работать правильно, так же как и формула =ВПР(A8;A2:D5;4;ЛОЖЬ).

Пример функции ИНДЕКС с неправильной ссылкой на строку или столбец

В этом примере формула =ИНДЕКС(B2:E5;5;5) возвращает ошибку #ССЫЛКА!, так как диапазон в ней содержит 4 строки и 4 столбца, а запрашивается значение ячейки в пятой строке и пятом столбце.

Пример формулы ИНДЕКС с недопустимой ссылкой на диапазон.  Формула имеет вид =ИНДЕКС(B2:E5;5;5), но диапазон содержит всего 4 строки и 4 столбца.

Решение

Измените ссылки на строки и столбцы так, чтобы они попадали в диапазон поиска функции ИНДЕКС. Формула =ИНДЕКС(B2:E5;4;4) вернет правильный результат.

Пример ссылки на закрытую книгу с использованием функции ДВССЫЛ

В следующем примере функция INDIRECT пытается сослаться на закрытую книгу, что приводит к ошибке #ССЫЛКА!.

Пример ошибки #ССЫЛКА! из-за использования функции ДВССЫЛ для ссылки на закрытую книгу.

Решение

Откройте книгу, на которую указывает ссылка

Проблемы с OLE и DDE

Если вы использовали ссылку OLE и она возвращает ошибку #ССЫЛКА!, запустите программу, которая вызывает ссылку.

Примечание. OLE — это технология, которая используется для обмена информацией между приложениями.

Если вы используете раздел DDE, который возвращает ошибку #ССЫЛКА!, убедитесь в том, что вы ссылаетесь на правильный раздел.

Примечание. DDE — это протокол, принятый для обмена данными между приложениями на основе Microsoft Windows.

Проблемы с макросами

Если макрос вызывает функцию, которая ссылается на ячейку выше, а ячейка с функцией находится в первой строке, будет возвращена ошибка #ССЫЛКА!, так как такой ячейки не существует. Проверьте функцию и убедитесь в том, что ее аргументы ссылаются на допустимые ячейки или диапазоны ячеек. Для этого может потребоваться отредактировать макрос в редакторе Visual Basic.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах с помощью функции проверки ошибок

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×