Исправление ошибки #ССЫЛКА!

Исправление ошибки #ССЫЛКА!

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

#REF! ошибки отображается, если формула ссылается на ячейку, которая не является допустимым. Чаще всего это происходит, когда ячейки, которые были ссылаются формулы получить удалены или вставлены поверх.

Пример ошибки #ССЫЛКА! из-за удаления столбца

В следующем примере в столбце E используется формула =СУММ(B2;C2;D2).

Если в формуле используются явные ссылки на ячейки, например =СУММ(B2;C2;D2), то удаление столбца может вызывать ошибку #ССЫЛКА!.

Если вы удалите столбец B, C и D она приведет #REF! Ошибка. В этом случае будет удален столбец C (2007 продажи), а теперь содержит формулу текст =SUM(B2,#REF!,C2). Когда использовать прямые ссылки на ячейки следующим образом (там, где каждая ячейка ссылаться по отдельности, разделенных запятыми) и удаление указанной строки или столбца, Microsoft Excel не может разрешить имена, чтобы он возвращал #REF! Ошибка. Это основной причины, почему прямые ссылки на ячейки в функции не рекомендуется использовать.

Пример ошибки #ССЫЛКА! из-за удаления столбца.

Решение

  • Если вы случайно удалили строки или столбцы, вы можете немедленно нажать кнопку "Отменить" на панели быстрого доступа (или нажать клавиши CTRL+Z), чтобы восстановить их.

  • Измените формулу так, чтобы он использовал ссылкой на диапазон вместо отдельных ячеек, например =SUM(B2:D2). Теперь можно удалить любой столбец в диапазоне сумм и Excel будет автоматически настроить формулу. Можно также использовать =SUM(B2:B5) для суммирования строк.

Пример функции ВПР с неправильными ссылками на диапазоны

В следующем примере функция =ВПР(A8;A2:D5;5;ЛОЖЬ) вернет ошибку #ССЫЛКА!, так как она выполняет поиск возвращаемого значения в столбце 5, но указан диапазон A:D, который содержит только 4 столбца.

Пример формулы ВПР с неправильным диапазоном.  Формула имеет вид =ВПР(A8;A2:D5;5;ЛОЖЬ).  Пятого столбца в диапазоне ВПР нет, поэтому значение 5 вызывает ошибку #ССЫЛКА!.

Решение

Настройка диапазона, чтобы увеличить или уменьшить искомое значение столбца в соответствии с диапазоном ссылку. Диапазон допустимой ссылкой, о том, как будет =VLOOKUP(a8,a2:E5,5,false)= VLOOKUP(A8,A2:D5,4,FALSE).

Пример функции ИНДЕКС с неправильной ссылкой на строку или столбец

В этом примере формула =ИНДЕКС(B2:E5;5;5) возвращает ошибку #ССЫЛКА!, так как диапазон в ней содержит 4 строки и 4 столбца, а запрашивается значение ячейки в пятой строке и пятом столбце.

Пример формулы ИНДЕКС с недопустимой ссылкой на диапазон.  Формула имеет вид =ИНДЕКС(B2:E5;5;5), но диапазон содержит всего 4 строки и 4 столбца.

Решение

Настройте строки или столбца ссылки так, чтобы они находятся внутри диапазона ИНДЕКСА поиска. =Index(B2:E5,4,4) вернет допустимый результат.

Пример ссылки на закрытую книгу с использованием функции ДВССЫЛ

В следующем примере функция INDIRECT пытается сослаться на закрытую книгу, что приводит к ошибке #ССЫЛКА!.

Пример ошибки #ССЫЛКА! из-за использования функции ДВССЫЛ для ссылки на закрытую книгу.

Решение

Откройте книгу, на которую указывает ссылка

Вопросы OLE

Если вы использовали ссылку OLE и она возвращает ошибку #ССЫЛКА!, запустите программу, которая вызывает ссылку.

Примечание. OLE — это технология, которая используется для обмена информацией между приложениями.

Проблемы с DDE

Если вы использовали раздел динамического обмена данными (DDE), которое возвращает #REF! Ошибка, первый флажок чтобы убедиться, что вы ссылки на правильный раздел. Если по-прежнему получаете #REF! Проверьте Параметры центра управления безопасностью для внешнего содержимого, как описано в, ошибка Блокирование и разблокирование внешнего содержимого в документах Office.

Примечание: Динамического обмена данными (DDE)— это традиционные протокол для обмена данными между программами Microsoft под управлением Windows.

Проблемы с макросами

Если макрос вводит функцию листа, на который ссылается на ячейку выше функции и ячейку, содержащую функцию находится в строке 1, функция возвратит #REF! так как нет ячеек выше строки 1. Установите флажок функции для просмотра, если аргумент ссылается на ячейку или диапазон ячеек, который не является допустимым. Это может потребоваться изменение макроса в Visual Basic редактор (VBE) вступили в такой ситуации в учетную запись.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах с помощью функции проверки ошибок

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×