Исправление ошибки #ЗНАЧ! в функциях СЧЁТЕСЛИ и СЧЁТЕСЛИМН

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

В этом разделе перечислены распространенные причины ошибки #ЗНАЧ! в функциях СЧЁТЕСЛИ и СЧЁТЕСЛИМН.

Проблема: формула ссылается на ячейки в закрытой книге

Если функция СЧЁТЕСЛИ или СЧЁТЕСЛИМН ссылается на ячейку или диапазон в закрытой книге, это приводит к ошибке #ЗНАЧ!

Примечание. Это известная проблема с рядом других функций Excel, в том числе СУММЕСЛИ, СУММЕСЛИМН и СЧИТАТЬПУСТОТЫ. Дополнительные сведения см. в статье Функции СУММЕСЛИ, СЧЁТЕСЛИ и СЧИТАТЬПУСТОТЫ возвращают ошибку #ЗНАЧ!

Решение: Откройте связанную книгу, указанную в формуле, и нажмите клавишу F9, чтобы обновить формулу.

Также можно обойти эту проблему, используя функции СУММ и ЕСЛИ вместе в формуле массива. Дополнительные сведения см. в статье Функции СУММЕСЛИ, СЧЁТЕСЛИ и СЧИТАТЬПУСТОТЫ возвращают ошибку #ЗНАЧ!

Проблема: длина строки превышает 255 символов

Решение: Сократите строку, если это возможно. Если сократить строку нельзя, используйте функцию СЦЕПИТЬ или оператор-амперсанд (&), чтобы разделить значение на несколько строк. Пример:

  • =СЧЁТЕСЛИ(B2:B12;"длинная строка"&"еще одна длинная строка")

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СЧЁТЕСЛИ

Функция СЧЁТЕСЛИМН

Функция ЕСЛИ — вложенные формулы и типовые ошибки

Просмотр видео о функциях Advanced если

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×