Исправление ошибки #ЗНАЧ! в функциях СУММЕСЛИ и СУММЕСЛИМН

В этом разделе перечислены распространенные причины ошибки #ЗНАЧ! в функциях СУММЕСЛИ и СУММЕСЛИМН и способы их устранения.

Проблема: формула ссылается на ячейки в закрытой книге

Если функция СУММЕСЛИ или СУММЕСЛИМН ссылается на ячейку или диапазон в закрытой книге, это приводит к ошибке #ЗНАЧ!.

Примечание. Это известная проблема с рядом других функций Excel, в том числе СЧЁТЕСЛИ, СЧЁТЕСЛИМН и СЧИТАТЬПУСТОТЫ. Дополнительные сведения см. в статье Функции СУММЕСЛИ, СЧЁТЕСЛИ и СЧИТАТЬПУСТОТЫ возвращают ошибку #ЗНАЧ!.

Решение: Откройте книгу, указанную в формуле, и нажмите клавишу F9, чтобы обновить формулу.

Также можно обойти эту проблему, используя функции СУММ и ЕСЛИ вместе в формуле массива. Дополнительные сведения см. в статье Функции СУММЕСЛИ, СЧЁТЕСЛИ и СЧИТАТЬПУСТОТЫ возвращают ошибку #ЗНАЧ!.

Проблема: длина строки условия превышает 255 символов

Функции СУММЕСЛИ и СУММЕСЛИМН возвращают неправильные результаты, если они используются для сопоставления строк длиннее 255 символов.

Решение: Сократите строку, если это возможно. Если сократить строку нельзя, используйте функцию СЦЕПИТЬ или оператор-амперсанд (&), чтобы разделить значение на несколько строк. Например:

=СУММЕСЛИ(B2:B12;"длинная строка"&"еще одна длинная строка")

Проблема: в функции СУММЕСЛИМН аргумент диапазон_условия не совпадает с аргументом диапазон_суммирования.

Аргументы диапазонов в функции СУММЕСЛИМН должны совпадать. Это означает, что в аргументах диапазон_условия и диапазон_суммирования должно указываться одинаковое количество строк и столбцов.

В приведенном ниже примере формула должна возвращать итоговое значение ежедневных продаж яблок в Омске. Однако аргумент диапазон_суммирования (C2:C10) не соответствует количеству строк и столбцов в аргументах диапазон условия (A2:A12 и B2:B12). Использование синтаксиса =СУММЕСЛИМН(C2:C10;A2:A12;A14;B2:B12;B14) приведет к ошибке #ЗНАЧ!.

Неправильная формула: =СУММЕСЛИМН(C2:C10;A2:A12;A14;B2:B12;B14), где C2:C10 необходимо изменить на C2:C12
В функции СУММЕСЛИМН аргумент диапазон_условия должен совпадать с аргументом диапазон_суммирования

Решение: В приведенном примере измените диапазон_суммирования на C2:C12 и выполните формулу повторно.

Примечание :  В функции СУММЕСЛИ можно использовать диапазоны разного размера.

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященного Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СУММЕСЛИ

Функция СУММЕСЛИМН

Видеоролики об усложненных функциях ЕСЛИ

Обзор формул в Excel

Как избежать появления неработающих формул

Исправление распространенных ошибок в формулах с помощью функции проверки ошибок

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×