Исправление ошибки #ЗНАЧ! в функциях ИНДЕКС и ПОИСКПОЗ

В этой статье описываются распространенные ситуации, в которых может возникнуть ошибка #ЗНАЧ! при использовании функций ИНДЕКС и ПОИСКПОЗ вместе в формуле. Одной из наиболее распространенных причин использования функций ИНДЕКС и ПОИСКПОЗ в сочетании друг с другом является необходимость найти значение в случае, когда функция ВПР неприменима, например, если длина искомого значения превышает 255 символов.

Проблема: формула не была введена как массив

Если вы используете ИНДЕКС как формулу массива вместе с функцией ПОИСКПОЗ для извлечения значения, вам необходимо преобразовать формулу в формулу массива. В противном случае возникнет ошибка #ЗНАЧ!.

Решение: Сочетание функций ИНДЕКС и ПОИСКПОЗ следует использовать как формулу массива, то есть нужно нажать клавиши CTRL+SHIFT+ВВОД. При этом формула будет автоматически заключена в фигурные скобки {}. Если вы попытаетесь ввести их вручную, Excel отобразит формулу как текст.

Если при использовании функций ИНДЕКС и ПОИСКПОЗ длина искомого значения превышает 255 символов, его необходимо вводить как формулу массива.  В ячейке F3 содержится формула =ИНДЕКС(B2:B4;ПОИСКПОЗ(ИСТИНА;A2:A4=F2;0);0), которая вводится путем нажатия клавиш CTRL+SHIFT+ВВОД
Сочетание функций ИНДЕКС и ПОИСКПОЗ следует использовать как формулу массива

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященного Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция ИНДЕКС

Функция ПОИСКПОЗ

Поиск значений с помощью функций ВПР, ИНДЕКС и ПОИСКПОЗ

Обзор формул в Excel

Как избежать появления неработающих формул

Исправление распространенных ошибок в формулах с помощью функции проверки ошибок

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×