Исправление ошибки #ЗНАЧ! в функции СЦЕПИТЬ

Важно : В Excel 2016, Excel Mobile и Excel Online функция СЦЕПИТЬ заменена функцией СЦЕП. Функция СЦЕПИТЬ пока еще доступна для обратной совместимости, однако рекомендуем использовать вместо нее функцию СЦЕП, так как ее возможности шире.

Одной из наиболее распространенных ситуаций возникновения ошибки #ЗНАЧ! при использовании функции СЦЕПИТЬ является попытка сформировать строку, которая включает в себя ссылку на ячейку с ошибкой, например #ЗНАЧ!.

В приведенном ниже примере мы хотим сцепить ячейки D2, E2 и F2, но в ячейке E2 имеется ошибка #ЗНАЧ!.

Ошибка #ЗНАЧ! в функции СЦЕПИТЬ

Ошибка в ячейке E2 приводит к тому, что функция выводит ошибку #ЗНАЧ!. Чтобы формула работала правильно, необходимо заменить ошибочное значение на допустимое. Можно создать формулу, проверяющую наличие ошибок в ссылках на ячейки и в случае их обнаружения выводящую текстовую строку с заменой ошибки на 0 (вместо 0 можно указать собственный текст, но его следует заключить в кавычки, например "Ваш текст").

Следующая формула будет работать правильно:

=ЕСЛИ(ЕОШИБКА(E2);СЦЕПИТЬ(D2;" ";0;" ";F2))

Использование функций ЕСЛИ и ЕОШИБКА для сцепления строк в качестве обходного пути при возникновении ошибки #ЗНАЧ!

Как это работает? Функция ЕСЛИ использует функцию ЕСЛИОШИБКА для определения наличия ошибки в ячейке E2. В случае обнаружения ошибки функция СЦЕПИТЬ объединяет значения ячеек D2, E2 и F2 (ошибка заменяется на 0) и выводит получившуюся текстовую строку. Обратите внимание на то, что для разделения значений в формуле используются пробелы (" ").

Исправление ошибки #VALUE! в функции СЦЕПИТЬ в Excel 2003 и более ранних версиях

Если ошибка #ЗНАЧ! возникает в Office Excel 2003 или более ранних версиях, необходимо отключить параметр "вычисления по правилам 1-2-3" в Excel. Чтобы устранить проблему, выполните инструкции в статье Ошибка #ЗНАЧ! при сцеплении ячеек.

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященного Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СЦЕПИТЬ

Функция СЦЕП

Обзор формул в Excel

Как избежать появления неработающих формул

Исправление распространенных ошибок в формулах с помощью функции проверки ошибок

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×