Исправление ошибки #ЗНАЧ! в функции СУММПРОИЗВ

В этой статье рассматриваются распространенные ситуации, в которых при работе с функцией СУММПРОИЗВ возникает ошибка #ЗНАЧ!.

Проблема: массивы имеют разный размер

Все массивы должны иметь одинаковый размер. В противном случае возникает ошибка #ЗНАЧ! Например, если Массив 1 указывает на диапазон из трех строк и двух столбцов, то Массив 2 должен указывать на аналогичный диапазон.

Функция СУММПРОИЗВ в следующей формуле вызывает ошибку: =СУММПРОИЗВ(D2:D13;E2:E10). Адрес ячейки E10 следует поменять E13, чтобы он соответствовал адресу в первом диапазоне.
  • =СУММПРОИЗВ(D2:D13;E2:E10)

Эта формула вызовет ошибку, так как диапазоны, указанные в функции, содержат разное количество строк (13 в первом диапазоне, но только 10 во втором).

Решение: Измените формулу так, чтобы оба диапазона имели одинаковые номера первых и последних строк:

  • =СУММПРОИЗВ(D2:D13;E2:E13)

После этого вычислите формулу повторно.

Чтобы устранить ошибку функции СУММПРОИЗВ, исправьте ошибку #ЗНАЧ! в данных.

Проблема: одна или несколько ячеек в диапазоне содержат текст

Если одна или несколько ячеек в диапазоне, на который ссылается функция, содержат текст или имеют текстовый тип данных, возникнет ошибка #ЗНАЧ! Текст может быть результатом вычисления другой формулы или неправильного форматирования ячейки.

Формула в ячейке E15 вызывает ошибку #ЗНАЧ! из-за ошибки #ЗНАЧ! в столбце E.

Решение: Проверьте наличие ячеек, содержащих текст или отформатированных как текстовые, и выберите правильный тип данных.

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященного Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СУММПРОИЗВ

Обзор формул в Excel

Как избежать появления неработающих формул

Исправление распространенных ошибок в формулах с помощью функции проверки ошибок

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×