Исправление ошибки #ЗНАЧ! в функции СРЗНАЧ или СУММ

Если функция СРЗНАЧ или СУММ ссылается на ячейки, содержащие ошибки #ЗНАЧ!, формула также вызовет ошибку #ЗНАЧ!.

Ошибка #ЗНАЧ! в функции СРЗНАЧ

Чтобы не учитывать ошибки, мы создадим формулу, пропускающую ошибочные значения в диапазоне и рассчитывающую среднее для остальных значений.

Чтобы решить эту проблему, мы используем функцию СРЗНАЧ в сочетании с функциями ЕСЛИ и ЕОШИБКА для определения наличия ошибок в указанном диапазоне. В данном конкретном случае требуется формула массива:

=СРЗНАЧ(ЕСЛИ(ЕОШИБКА(B2:D2);"";B2:D2))

Примечание : Это формула массива, которую нужно вводить с помощью клавиш CTRL+SHIFT+ВВОД. Excel автоматически заключит формулу в фигурные скобки {}. Если вы попытаетесь ввести их вручную, Excel отобразит формулу как текст.

Функция массива в СРЗНАЧ для исправления ошибки #ЗНАЧ!

Примечание : Приведенная выше формула будет работать не только в случае ошибок #ЗНАЧ!, но и в случае ошибок #Н/Д, #ПУСТО!, #ДЕЛ/0! и других.

Таким же образом можно использовать функцию СУММ:

=СУММ(ЕСЛИ(ЕОШИБКА(B2:D2);"";B2:D2))

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященного Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СРЗНАЧ

Функция СУММ

Обзор формул в Excel

Как избежать появления неработающих формул

Исправление распространенных ошибок в формулах с помощью функции проверки ошибок

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×