Office

Исправление ошибки #ЗНАЧ! в функции СРЗНАЧ или СУММ

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Если "среднее" или "сумма" ссылаются на ячейки, которые содержат #VALUE! ошибки формулы могут привести к #VALUEу! Ссылки формул на данные в этом диапазоне будут возвращать ошибку "#ССЫЛКА!".

Ошибка #ЗНАЧ! в функции СРЗНАЧ

Чтобы не учитывать ошибки, мы создадим формулу, пропускающую ошибочные значения в диапазоне и рассчитывающую среднее для остальных значений.

Чтобы решить эту проблему, мы используем функцию СРЗНАЧ в сочетании с функциями ЕСЛИ и ЕОШИБКА для определения наличия ошибок в указанном диапазоне. В данном конкретном случае требуется формула массива:

=СРЗНАЧ(ЕСЛИ(ЕОШИБКА(B2:D2);"";B2:D2))

Это формула массива. Поэтому нужно нажать клавишу Ввод (только в том случае, если вы используете Office365) или CTRL + SHIFT + ВВОД в формуле.

Примечание: Если у вас установлена текущая версия Office 365, вы можете просто ввести формулу в выходную ячейку, а затем нажать клавишу Ввод , чтобы подтвердить формулу как формулу динамических массивов. В противном случае необходимо ввести формулу в качестве устаревшей формулы массива, сначала выбрав выходную ячейку, введя формулу в выходную ячейку, а затем нажав клавиши CTRL + SHIFT + ВВОД , чтобы подтвердить его. В начале и конце формулы Excel вставляет фигурные скобки. Дополнительные сведения о формулах массива см. в статье Использование формул массива: рекомендации и примеры.

Функция массив в среднем для разрешения #VALUE! ошибки

Примечание: Приведенная выше формула будет работать не только в случае ошибок #ЗНАЧ!, но и в случае ошибок #Н/Д, #ПУСТО!, #ДЕЛ/0! и других.

Таким же образом можно использовать функцию СУММ:

=СУММ(ЕСЛИ(ЕОШИБКА(B2:D2);"";B2:D2))

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Исправление ошибки #ЗНАЧ!

Функция СРЗНАЧ

Функция сумм

Общие сведения о формулах в Excel

Обнаружение ошибок в формулах

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×