Исправление ошибки #ДЕЛ/0!

Ошибка #ДЕЛ/0! возникает в Microsoft Excel, когда число делится на ноль (0). Это происходит, если вы вводите простую формулу, например =5/0, или если формула ссылается на ячейку с 0 или пустую ячейку, как показано на этом рисунке.

Примеры формул, вызывающих ошибку #ДЕЛ/0!

Есть несколько способов исправления этой ошибки.

  • Убедитесь в том, что делитель в функции или формуле не равен нулю и соответствующая ячейка не пуста.

  • Измените ссылку в формуле, чтобы она указывала на ячейку, не содержащую ноль (0) или пустое значение.

  • Введите в ячейку, которая используется в формуле в качестве делителя, значение #Н/Д, чтобы изменить результат формулы на #Н/Д, указывая на недоступность делителя.

Часто ошибки #ДЕЛ/0! нельзя избежать, поскольку ожидается, что вы или другой пользователь введете значение. В этом случае нужно сделать так, чтобы сообщение об ошибке не отображалось. Добиться этого можно несколькими способами.

Оценка знаменателя на наличие нуля или пустого значения

Самый простой способ избавиться от ошибки #ДЕЛ/0! — воспользоваться функцией ЕСЛИ для оценки знаменателя. Если он равен нулю или пустой, в результате вычислений можно отображать значение "0" или не выводить ничего. В противном случае будет вычислен результат формулы.

Например, если ошибка возникает в формуле =A2/A3, можно заменить ее формулой =ЕСЛИ(A3;A2/A3;0), чтобы возвращать 0, или формулой =ЕСЛИ(A3;A2/A3;""), чтобы возвращать пустую строку. Также можно выводить произвольное сообщение. Пример: =ЕСЛИ(A3;A2/A3;"Ожидается значение."). В первой приведенной здесь формуле также можно использовать функцию ЧАСТНОЕ: =ЕСЛИ(A3;ЧАСТНОЕ(A2;A3);0)ЕСЛИ в ячейке A3 указано значение, возвращается результат формулы, в противном случае возвращается ноль.

Примеры разрешения ошибок #ДЕЛ/0!

Использование функции ЕСЛИОШИБКА для подавления ошибки #ДЕЛ/0!

Вы также можете избежать ошибки, вложив операцию деления в функцию ЕСЛИОШИБКА. Так, для расчета отношения A2/A3 будет использоваться формула =ЕСЛИОШИБКА(A2/A3;0): если вычисление по формуле вызывает ошибку, возвращается значение "0", в противном случае — результат вычисления.

В версиях до Excel 2007 можно использовать синтаксис ЕСЛИ(ЕОШИБКА()): =ЕСЛИ(ЕОШИБКА(A2/A3);0;A2/A3) (см. статью Функции Е).

Примечание. При использовании функции ЕСЛИОШИБКА или синтаксиса ЕСЛИ(ЕОШИБКА()) подавляются любые возможные ошибки, а не только #ДЕЛ/0!. Перед использованием различных способов исключения ошибок следует проверить работоспособность формулы. В противном случае вы можете не заметить, что формула не работает нужным образом.

Совет :  Если в Microsoft Excel включена проверка ошибок, нажмите кнопку Значок кнопки рядом с ячейкой, в которой показана ошибка. Выберите пункт Показать этапы вычисления, если он отобразится, а затем выберите подходящее решение.

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Функция ЕСЛИ

ЕСЛИОШИБКА (функция ЕСЛИОШИБКА)

Функции Е

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах в Excel 2016

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×