Исправление недействительных связей с данными

Если в книге есть связь с данными в книге или другом файле, которые были перемещены, можно исправить ее, обновив путь к исходный файл. Если не удается найти документ, с которым была изначально создана связь, или отсутствует доступ к нему, можно отключить автоматические обновления или удалить связь, чтобы она не обновлялась в Excel.

Важно : связанный объект — это не то же, что и гиперссылки. Описанную ниже процедуру нельзя применять для исправления неработающих ссылок. Дополнительные сведения о гиперссылках см. в статье Создание, изменение и удаление гиперссылки

Выполните одно из перечисленных ниже действий.

Исправление недействительной связи

Внимание : Это действие невозможно отменить. Перед началом процедуры рекомендуется сохранить резервную копию книги.

  1. Откройте книгу, содержащую неработающую ссылку

  2. В меню Правка выберите пункт Связи.

    Отсутствие команды Связи означает, что книга не содержит связей

  3. В поле Исходный файл щелкните неработающую ссылку, которую требуется исправить

    Примечание : Чтобы исправить несколько ссылок, щелкните их, удерживая нажатой клавишу COMMAND .

  4. Нажмите кнопку Изменить источник.

  5. Выполните одно из указанных ниже действий.

Чтобы

Выполните указанные ниже действия

Исправление недействительной связи на лист в другой книге

В диалоговом окне Открыть найдите книгу и нажмите кнопку Изменить.

Исправление недействительной связи на книгу или другой документ Office

Укажите новое имя или расположение документа в текстовом поле Изменить связи на и нажмите кнопку ОК.

Отключение автоматического обновления связанных данных

  1. Откройте книгу, содержащую неработающую ссылку

  2. В меню Правка выберите пункт Связи.

    Отсутствие команды Связи означает, что книга не содержит связей

  3. В поле Исходный файл щелкните неработающую ссылку, которую требуется исправить

    Примечание : Чтобы исправить несколько ссылок, щелкните их, удерживая нажатой клавишу COMMAND .

  4. Установите переключатель Вручную.

Удаление недействительной связи

При разрыве связи все формулы, которые ссылаются на исходный файл, преобразуются в текущие значения. Например, если формула =СУММ([Бюджет.xls]Годовой!C10:C25) дает результат 45, после разрыва связи она будет преобразована в 45.

  1. Откройте книгу, содержащую неработающую ссылку

  2. В меню Правка выберите пункт Связи.

    Отсутствие команды Связи означает, что книга не содержит связей

  3. В диалоговом окне Исходный файл щелкните недействительную связь, которую требуется удалить.

    Примечание : Чтобы удалить несколько связей, щелкните их, удерживая нажатой клавишу COMMAND .

  4. Нажмите кнопку Разорвать связь.

См. также

Импорт данных из файла в формате CSV, HTML или текстового файла

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×