Использование Excel 2013 для создания отчета Project Online

Использование Excel 2013 для создания отчета Project Online

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Microsoft Excel 2013 позволяет подключаться к данным Project Online и на их основе создавать отчеты. Вы можете сохранять отчеты в библиотеке Project Online и затем просматривать их в браузере с помощью Excel Online.

Важно :  Прежде чем выполнить изложенные в этой статье шаги, важно, чтобы вы сначала предоставили доступ для создания отчетов в Project Online. Это одноразовое действие, которое позволит вашим отчетам обновляться в Excel Online.

В этой статье описано, как с помощью Excel 2013 подключиться к данным Project Online и отобразить список проектов в отчете сводной таблицы. С помощью Excel 2013 и подключения OData к данным Project Online можно решать гораздо более сложные задачи, но начать лучше с простого примера.

В данной статье описаны указанные ниже этапы.

Этап 1. Создание подключения к данным Project Online в Excel 2013

Первым делом нужно создать в Excel 2013 подключение, указывающее на данные Project Online.

Ниже описано, как создать подключение.

  1. В Excel 2013 выберите пункты Файл > Создать > Пустая книга.

  2. На вкладке Данные в группе Получение внешних данных выберите Из других источников > Из веб-канала данных OData.

  3. В разделе 1. Расположение веб-канала данных в поле Ссылка или файл введите адрес веб-сайта (URL-адрес) своего экземпляра Project Web App и добавьте после него /_api/ProjectData/.

    Например, если ваше приложение Project Web App расположено по адресу https://contoso.sharepoint.com/sites/pwa, введите https://contoso.sharepoint.com/sites/pwa/_api/ProjectData/ в поле Ссылка или файл.

  4. Выполните вход с учетными данными Microsoft Office 365.

  5. В диалоговом окне Мастер подключения к данным установите флажок рядом с надписью Проекты и нажмите кнопку Далее.

  6. На этапе Сохраните файл подключения данных и завершите работу нажмите кнопку Готово.

  7. В диалоговом окне Импорт данных выберите пункт Отчет сводной таблицы и нажмите кнопку ОК.

Вот и все. Теперь вы подключены к данным Project Online.

Этап 2. Выбор данных, включаемых в отчет

Теперь нужно в разделе Проекты выбрать данные, которые должны быть включены в отчет, и создать сам отчет. В этом очень простом примере мы выберем две точки данных: имена проектов и имена ответственных за них.

Чтобы создать простой отчет сводной таблицы, выполните указанные ниже действия.

  1. На панели Поля сводной таблицы в правой части окна Excel 2013 установите флажки Имя проекта и Ответственный за проект.

  2. Настройте отчет сводной таблицы с помощью параметров на вкладках Анализ и Конструктор в разделе Работа со сводными таблицами ленты.

Этап 3. Сохранение отчета в Project Online

Созданный отчет нужно сохранить в Project Online, чтобы его можно было использовать в Excel Online.

Чтобы сохранить отчет сводной таблицы в Project Online, выполните указанные ниже действия.

  1. В Excel 2013 откройте вкладку Файл.

  2. Нажмите кнопку Сохранить как, выберите пункт SharePoint и нажмите кнопку Обзор.

  3. В верхней части экрана в строке, где указано текущее расположение, щелкните URL-адрес правой кнопкой мыши и выберите пункт Изменить адрес.

  4. Введите URL-адрес сайта Project Web App в поле расположения и нажмите клавишу ВВОД.

    Например, введите https://contoso.sharepoint.com/sites/pwa и нажмите клавишу ВВОД.

  5. Дважды щелкните библиотеку Отчеты PWA.

  6. Дважды щелкните папку Английский (США).

  7. Введите имя нового отчета в поле Имя файла и нажмите кнопку Сохранить.

После сохранения отчета в библиотеке "Отчеты PWA" Project Online закройте его в Excel 2013. Теперь можно перейти к отчету в веб-браузере и открыть его в Project Online.

Этап 4. Открытие отчета в Project Online

После сохранения отчета в Project Online можно перейти в библиотеку "Отчеты PWA" и открыть отчет через Excel Online. Так можно просмотреть отчет с последними данными проекта на любом устройстве с доступом к Project Online.

Чтобы открыть отчет в Excel Online, выполните указанные ниже действия.

  1. В Project Web App нажмите кнопку Отчеты на панели быстрого запуска.

  2. Выберите пункт Английский (США).

  3. Щелкните имя отчета, чтобы открыть его в Excel Online.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×