Office

Использование функций и вложенных функций в формулах Excel

Функции представляют собой заранее определенные формулы, выполняющие вычисления над заданными величинами — аргументами — в определенном порядке или по определенной схеме. С помощью функций можно выполнять как простые, так и сложные вычисления. Все функции Excel можно увидеть на вкладке "Формулы".

Вкладка "Формулы" на ленте Excel
  • Синтаксис функций Excel

    Приведенный ниже пример функции ОКРУГЛ, округляющий число в ячейке A10, демонстрирует синтаксис функции.

    Структура функции

    1. Структура. Структура функции начинается со знака равенства (=), за которым следуют имя функции, открывающая скобка, список аргументов, разделенных точками с запятой, и закрывающая скобка.

    2. Имя функции. Чтобы просмотреть весь список доступных функций, щелкните по ячейке и нажмите сочетание клавиш SHIFT + F3. После этого откроется диалоговое окно Вставка функции.

    Формулы Excel: диалоговое окно для вставки функции

    3. Аргументы. Существуют различные типы аргументов: числа, текст, логические значения (ИСТИНА и ЛОЖЬ), массивы, значения ошибок (например, #Н/Д) или ссылки на ячейки. Используемый аргумент должен возвращать допустимое для него значение. В качестве аргументов также могут выступать константы, формулы и другие функции.

    4. Всплывающая подсказка аргумента. При вводе функции появляется всплывающая подсказка с синтаксисом и аргументами. Например, всплывающая подсказка появляется, если ввести выражение =ОКРУГЛ(. Всплывающие подсказки отображаются только для встроенных функций.

    Примечание: Имена функций необязательно вводить заглавными буквами, например =ОКРУГЛ. Excel автоматически применит нужный регистр, как только вы нажмете клавишу ВВОД. Имя функции, написанное с ошибкой, например =СУММА(A1:A10) вместо =СУММ(A1:A10), вернет ошибку #ИМЯ?.

  • Ввод функций Excel

    Диалоговое окно Вставка функции облегчает ввод формул, содержащих функцию. При выборе функции в окне Вставка функции Excel запускает мастер функций. В нем перечислены имя функции, все ее аргументы, описание функции и каждого аргумента, текущее значение функции и текущий результат всей формулы.

    Мастер функций Excel

    С помощью автозаполнения можно упростить создание и редактирование формул, уменьшив количество опечаток и синтаксических ошибок. Как только вы вводите знак равенства (=) и начинаете писать имя функции, Excel отображает динамический раскрывающийся список доступных функций, аргументов и имен, совпадающий с введенными символами. Просто выберите подходящий элемент, и Excel сам введет его за вас.

    Автозаполнение формулы Excel

  • Вложение функций Excel

    В некоторых случаях может потребоваться использовать функцию в качестве одного из аргументов другой функции. Например, в приведенной ниже формуле для сравнения результата со значением 50 используется вложенная функция СРЗНАЧ.

    Вложенные функции

    1. Функции СРЗНАЧ и СУММ вложены в функцию ЕСЛИ.

    Допустимые типы вычисляемых значений   . Вложенная функция, используемая в качестве аргумента, должна возвращать соответствующий этому аргументу тип данных. Например, если аргумент должен быть логическим, т. е. иметь значение ИСТИНА либо ЛОЖЬ, вложенная функция также должна возвращать логическое значение (ИСТИНА или ЛОЖЬ). В противном случае Excel выдаст ошибку «#ЗНАЧ!».

    Предельное количество уровней вложенности функций   . В формулах можно использовать до семи уровней вложенных функций. Если функция Б является аргументом функции А, функция Б находится на втором уровне вложенности. Например, в приведенном выше примере функции СРЗНАЧ и СУММ являются функциями второго уровня, поскольку обе они — аргументы функции ЕСЛИ. Функция, вложенная в качестве аргумента в функцию СРЗНАЧ, будет функцией третьего уровня, и т. д.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×