Использование функций И и ИЛИ для проверки сочетания условий

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Если нужно найти данные, соответствующие нескольким условиям, например товары, проданные с апреля по январь, или объем продаж Екатерины, можно использовать функции И и ИЛИ вместе, например:

Использование функций И и ИЛИ в одной формуле

В этой формуле выполняет вложение функции внутри функции или поиск между 1 апреля 2011 и 1 января 2012 г., проданных единиц или любой единицы проданы Сергей. Вы увидите, что она возвращает значение True , Сергей проданных единиц товара, а также единиц, проданных времен и Сергей во время даты, указанные в формуле.

Ниже приведена формула, которую можно скопировать и вставить. Если вы хотите поэкспериментировать с ней в книге-примере, см. конец статьи.

=ИЛИ(И(C2>ДАТА(30,4,2011),C2<ДАТА(1,1,2012)),B2="Катерина")

Давайте обсудим формулу подробнее. Функция ИЛИ принимает набор аргументов (элементов данных) и проверяет их истинность. В данной формуле первым аргументом является функция И, в которую вложена функция ДАТА. Вторым аргументом является значение "Екатерина". Прочитать формулу можно следующим образом: "проверить, продан ли товар после 30 апреля 2011 г. и до 1 января 2012 г. или продан ли он Екатериной".

Функция И также возвращает значение ИСТИНА или ЛОЖЬ. В большинстве случаев ее используют для расширения возможностей других функций, таких как ИЛИ и ЕСЛИ. В данном примере функция ИЛИ не нашла бы правильные даты без функции И.

Использование функций И и ИЛИ с функцией ЕСЛИ

Функции И и ИЛИ можно использовать с функцией ЕСЛИ.

Функции И и ИЛИ, вложенные в функцию ЕСЛИ

В этом примере сотрудник не получает премию, если он не продал товаров хотя бы на 125 тыс. рублей или же на 100 тыс. руб, если он работает в южном регионе, где объем рынка меньше.

=ЕСЛИ(ИЛИ(C4>=125000;И(B4="Южный";C4>=100000))=ИСТИНА;C4*0,12;"Премия не положена")

Рассмотрим формулу. Функции ЕСЛИ для правильной работы нужны три элемента данных (аргумента). Первый — логическое выражение, второй — значение, отображаемое, если результатом выражения является ИСТИНА, и третий — значение, отображаемое, если результатом выражения является ЛОЖЬ. В данном примере логическим выражением является функция ИЛИ со всеми вложенными в нее элементами. Формулу можно прочитать следующим образом: "если значение больше или равно 125 000 или же 100 000 при условии, что значение в столбце C — "Южный", умножить значение на процент премии, равный 0,12, в противном случае отобразить слова "Премия не положена".

К началу страницы

Образец данных

Если вы хотите работать с примерами в этой статье, скопируйте приведенную ниже таблицу в ячейку A1 свою таблицу. Не забудьте выделяется вся таблица, включая строки заголовков.


Продавец

Регион

Продажи

Формула и результат

Гладких

Восточный

87925

= Если (или (C2 > = 125000; И (B2 = «Южный»; C2 > = 100000)) = ИСТИНА, C2 * 0, 12; "Премия не положена")

Ильина

Север

100000

= Если (или (C3 > = 125000; И (B3 = «Южный»; C3 > = 100000)) = ИСТИНА, C3 * 0, 12; "Премия не положена")

Песоцкий

Западный

145000

=ЕСЛИ(ИЛИ(C4>=125000;И(B4="Южный";C4>=100000))=ИСТИНА;C4*0,12;"Премия не положена")

Корепин

Юг

200750

= Если (или (C5 > = 125000; И (B5 C5 = «Южный» > = 100000)) = ИСТИНА, C5 * 0, 12; "Премия не положена")

Климов

Юг

178650

= Если (или (C6 > = 125000; И (B6 C6 = «Южный» > = 100000)) = ИСТИНА, C6 * 0, 12; "Премия не положена")

Thomas

Север

99555

= Если (или (C7 > = 125000; И (B7 C7 = «Южный» > = 100000)) = ИСТИНА, C7 * 0, 12; "Премия не положена")

Keever

Восточный

147000

= Если (или (C8 > = 125000; И (B8 C8 = «Южный» > = 100000)) = ИСТИНА, C8 * 0, 12; "Премия не положена")

Cassazza

Север

213450

= Если (или (C9 > = 125000; И (B9 C9 = «Южный» > = 100000)) = ИСТИНА, C9 * 0, 12; "Премия не положена")

Brownlee

Юг

122680

= Если (или (C10 > = 125000; И (B10 C10 = «Южный» > = 100000)) = ИСТИНА, C10 * 0, 12; "Премия не положена")

Smithberg

Западный

92500

= Если (или (C11 > = 125000; И (B11 C11 = «Южный» > = 100000)) = ИСТИНА, C11 * 0, 12; "Премия не положена")

Benson

Восточный

88350

= Если (или (C12 > = 125000; И (B12 C12 = «Южный» > = 100000)) = ИСТИНА, C12 * 0, 12; "Премия не положена")

Чтение

Западный

102500

= Если (или (C13 > = 125000; И (B13 C13 = «Южный» > = 100000)) = ИСТИНА, C13 * 0, 12; "Премия не положена")

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×